none
SPS2013: Asset Library - 'PeopleInMedia' does not exist

    Frage

  • Hello,

    i have created a new "Asset" Library.

    If i want to modify the current view (Thumbnails / All Assets) i get a error.

    The diag file logs the following error:
    "Application error when access /_layouts/15/ViewEdit.aspx, Error=Column 'PeopleInMedia' does not exist. It may have been deleted by another user."

    Does anybody has seen this?


    Dienstag, 28. Mai 2013 06:47

Alle Antworten

  • There is an out of box "People In Video" field in my Asset library, its from the out of box Video content type. The internal name for this field is PeopleInMedia. Could you please whether the field is there on your site?
    Mittwoch, 29. Mai 2013 07:53
    Moderator
  • Nope, this field does not exist.

    Do have to activate a feature for getting this field?

    SPS 2013 Enterprise environment. The sitecollection uses the Enterprise Wiki (Publishing Site) as base template.

    Freitag, 14. Juni 2013 09:25
  • I had the same problem.. and found the solution on this page..

    Just enabled a site collection feature - "Advanced media and vídeo" .. Then recreated the media library.

    then got it to work.


    Vinicius Paluch

    Donnerstag, 26. September 2013 18:21
  • Does "Advanced media and video" feature refers to "Video and Rich Media" feature?. As I can not see any site collection feature with a name "Advanced media and video".

    Also is there any way to resolve this issue without recreating the asset library instance.

    I have migrated a site which was built in SPS 2010 to SPS 2013 using Database attach approach. After this migration I am facing the same issue but I don't have an option to recreate the instance. I would prefer to fix the existing migrated Asset Library.

    Please help.

    Samstag, 14. Dezember 2013 19:48
  • What licence are you using? 

    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Samstag, 14. Dezember 2013 22:16
    Beantworter
  • Standard Version

    Also, after activating this feature, when I upload a video file, it has started throwing error "File Not Found". Stack trace is like this

    Application error when access /_layouts/15/Upload.aspx, Error=The system cannot find the file specified. (Exception from HRESULT: 0x80070002) 

    at Microsoft.SharePoint.Library.SPRequestInternalClass.GetFileAndFolderProperties(String bstrUrl, String bstrStartUrl, ListDocsFlags ListDocsFlags, Boolean bThrowException, Int32& phrStatus, Object& pvarFiles, Object& pvarDirs, UInt32& pdwNumberOfFiles, UInt32& pdwNumberOfDirs)   

    at Microsoft.SharePoint.Library.SPRequest.GetFileAndFolderProperties(String bstrUrl, String bstrStartUrl, ListDocsFlags ListDocsFlags, Boolean bThrowException, Int32& phrStatus, Object& pvarFiles, Object& pvarDirs, UInt32& pdwNumberOfFiles, UInt32& pdwNumberOfDirs)   

    at Microsoft.SharePoint.SPWeb.GetFileOrFolderProperties(String strUrl, ListDocsFlags listDocsFlags, Boolean throwException, SPBasePermissions& permMask)   

    at Microsoft.SharePoint.SPFile.PropertiesCore(Boolean throwException)   

    at Microsoft.SharePoint.SPFile.get_Length()   

    at Microsoft.SharePoint.ApplicationPages.UploadPage.OnSubmit(Object o, EventArgs e)   

    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)  

    at Microsoft.SharePoint.Library.SPRequestInternalClass.GetFileAndFolderProperties(String bstrUrl, String bstrStartUrl, ListDocsFlags ListDocsFlags, Boolean bThrowException, Int32& phrStatus, Object& pvarFiles, Object& pvarDirs, UInt32& pdwNumberOfFiles, UInt32& pdwNumberOfDirs)   

    at Microsoft.SharePoint.Library.SPRequest.GetFileAndFolderProperties(String bstrUrl, String bstrStartUrl, ListDocsFlags ListDocsFlags, Boolean bThrowException, Int32& phrStatus, Object& pvarFiles, Object& pvarDirs, UInt32& pdwNumberOfFiles, UInt32& pdwNumberOfDirs)   

    at Microsoft.SharePoint.SPWeb.GetFileOrFolderProperties(String strUrl, ListDocsFlags listDocsFlags, Boolean throwException, SPBasePermissions& permMask)   

    at Microsoft.SharePoint.SPFile.PropertiesCore(Boolean throwException)   

    at Microsoft.SharePoint.SPFile.get_Length()   

    at Microsoft.SharePoint.ApplicationPages.UploadPage.OnSubmit(Object o, EventArgs e)   

    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    • Bearbeitet VinayAgarwal Mittwoch, 18. Dezember 2013 12:44 changed text
    Montag, 16. Dezember 2013 09:36
  • Thanks a ton Vinicius, this worked activating the Rich Media and Video site collection feature resolved this error for me.

    VBM

    Montag, 10. November 2014 22:41
  • Yes, the problem should be solved after activating feature on site collection.

    Additionaly, if you need to make your existin library work, you can add this field (PeopleInVideo) to the library... and another 10 fields... 

    By the way, all the fields will appear on your site collection after activating feature "Advanced media and vídeo", But all of them would be hidden, So to heal your existing media library, you need to change that property to false and then add those fields to the library.

    Donnerstag, 17. Mai 2018 20:11