none
Can't start "Windows Deployment Services" Service

    Frage

  • I have a Windows 2003 Server that has WDS SP1 installed.  The Windows
    Deployment Services Server Service isn't started and when I try to
    start it I get a message that says:

    Windows could not start the Widows Deployment Services Server on Local
    Computer.  For more information, review the System Event Log.  If this
    is a non-Microsoft service, contact the service vendor, and refer to
    server-specific error code 2310.

    Event viewer lists Event ID 257 and this:

    An error occurred while trying to start the Windows Deployment Services
    server.

     Error Information: 0x906

      When I go to the actual WDS application, my server isn't listed.  If
    I try and add it, I get a message that says "The Windows Deployment
    Services configuration is corrupt.  Would you like to add it anyway?"
    If I say yes, the server is added, but it has a red x through it.

    I thought about removing WDS and then re-installing it, but it listed a
    number of programs that might fail if I did that.

    What should I do?
    Freitag, 29. Dezember 2006 01:09

Alle Antworten

  • Is TFTP running?  If not start it and then try again to start the WDS service.
    Sonntag, 31. Dezember 2006 17:49
  • Still i am npot able to start the service and gives same error
    Mittwoch, 24. Januar 2007 05:07
  • well i could able to fix the problem with domain login since

    Windows Deployment Services uses Active Directory as a database for storing configuration information. Additionally, WDS can link physical booting computers to logical computer objects stored in AD. The binlsvc.dll provider provides this integration and must contact AD in order to be functional.

    The error you are receiving generally indicates that you have a networking configuration problem on your server that is causing the domain to be unreachable. I would start by checking your DNS settings - ensure that all NICs in your machine are pointing to local DNS servers (and not internet / external DNS servers), ensure that your domain suffix actually matches that of the domain, etc...

    A good tool to help troubleshoot is netdiag.exe (run this with the /v switch, e.g. 'netdiag.exe /v') available when you install the support tools from the \Tools folder of your Server 2003 installation media.

    Mittwoch, 24. Januar 2007 05:22
  • You may want to uninstall WDS and then reinstall it.  Ensure you reboot the machine before you reinstall.
    Mittwoch, 24. Januar 2007 13:41
  • Also make sure you don't have Norton Ghost on that machine, as it will disable WDS.
    Montag, 29. Januar 2007 20:47
  • Are the WDS server and domain controller in different dns namespaces?

    If so then make sure you specify the dns suffix search order for the primary adaptor. I got stuck with that one for hours :)

    Also make sure you can do a simple ldap query to the domain controller, I had a problem where the machine object corrupted so it couldn't read AD and so wouldn't start WDS. Dropped it and rejoined it to the domain and it was fine.
    Montag, 19. Februar 2007 14:57
  • Hi Vijay,

     

    you information was really helpful. now i am able to resolve the issue.though still i unable to start the WDS Services but still my purpose is solved . my WDS is working perfectely.

     

    Thanks

    manoj

     

     

     

     

     

    Montag, 14. Januar 2008 12:21
  • Kath,

    Who ever you are, you are the greatest. I had the same issue and I was also losing connection to my DC intermittenly. My domain suffix had a typo and i was sourcing an external DNS. Life is good again.

     

     

    Thanks,

     

    Duggan

    Freitag, 16. Juli 2010 18:27
  • hey. i have the same problem. I have tried the things listed on this blog. however, i still get the same message. my server is windows 2008.  i already have a server created in wds with images loaded and such.  since, wds won't start when i go to services and try to start it, will the server that i created still pxe boot? thanks

    Donnerstag, 12. August 2010 14:01
  • I am also facing the same issue on win 2008 R2 server. Also I have tried 399215_intl_x64_zip patch for the same but no luck for me.Please let me know if you have any salutation for it.
    Amol Maindarkar
    Dienstag, 7. Juni 2011 13:03
  • 0x906 is NERR_NetNameNotFound, which generally means that the REMINST share on the machine was removed somehow. WDS requires this share to be present on the server in order to function. You can most likely fix this by unintializing the server and re-initializing it, which will recreate the share. From a command prompt, run:

    wdsutil /uninitialize-server

    wdsutil /initialize-server /reminst:[PATH_TO_REMOTEINSTALL_DIRECTORY]

    • Als Antwort vorgeschlagen cwhite_remar Donnerstag, 15. September 2011 22:57
    Montag, 27. Juni 2011 22:50
  • Aaron you are the best this solution worked for me. Thank you!
    Mittwoch, 9. November 2011 22:26
  • As above this solution (by Aaron Tyler) worked a treat for me - had this problem after doing a system restore.
    Donnerstag, 24. November 2011 09:42
  • 0x906 is NERR_NetNameNotFound, which generally means that the REMINST share on the machine was removed somehow. WDS requires this share to be present on the server in order to function. You can most likely fix this by unintializing the server and re-initializing it, which will recreate the share. From a command prompt, run:

    wdsutil /uninitialize-server

    wdsutil /initialize-server /reminst:[PATH_TO_REMOTEINSTALL_DIRECTORY]


        You are simply the best. Thank you and be blessed.
    • Als Antwort vorgeschlagen Tiago Toledo Donnerstag, 26. März 2015 20:37
    Dienstag, 28. Februar 2012 17:35
  • Hey gangs,

    My problem is not the same but similar with WDS not working.

    Here is my scenario: 

    I have WDS installed in large server farm enterprise. The DHCP and DNS are hosted by other servers and the WDS just joined the domain. After setting up the server, I cannot change anything from the PXE boot tab or any other tabs when you right click on the WDS server name and select properties. I received an access denied. I cannot boot any client to connect to the WDS server. When I boot the client, it initialized and received an IP address but would not boot to the WDS boot manager where to select the actual boot file.

    I have set port 66 and 67 in the DHCP server manager with the IP and name of the WDS server as suggested by Microsoft if the WDS server is not the actual DHCP and DNS, and the Domain controller. Any idea why am I receiving the "Access denied" and what else am I missing here? 

    Or What is the requirement settings for WDS when it is not the actual AD, DHCP and DNS server itself? I really need to have this thing working and I have been looking everywhere without success. I have it working like a champ in a test lab but, it is a Domain controller, DHCP and DNS itselt, not member server.

    Any help will be helpful and welcome!!!

    Thanks

    Himrod


    SHimrod


    • Bearbeitet Himrod Donnerstag, 3. Mai 2012 02:49
    Donnerstag, 3. Mai 2012 02:47
  • Thanks, my problem was exactly that:

    ..................The error you are receiving generally indicates that you have a networking configuration problem on your server that is causing the domain to be unreachable...............


    They exchanged the Firewall and forgot to unlock the doors. After review and release back to work.

    Thank you.
    ________________

    Moura



    Donnerstag, 10. Mai 2012 15:37
  • Aaron Tyler. You`re the man ! Worked for me :)
    Dienstag, 18. Dezember 2012 08:54
  • Aron Thank you!
    Your dead on. Who delete my share?!
    Freitag, 4. Januar 2013 20:33
  • I had the same problem. Ran the services manager as administrator it then started successfully. 
    • Bearbeitet Josh Doolan Sonntag, 17. Februar 2013 01:37
    Sonntag, 17. Februar 2013 01:37
  • Thank you good sir for giving the information Microsoft's software lacks.  Appalling that you're told the service is corrupt rather than being simply told the configured share is missing, want to configure a new one?  You can't even change it in the UI if everything is working.  Poor design that.
    Donnerstag, 2. Mai 2013 17:10
  • Thank you all for posting, Aron for your help I almost uninstall and re-install WDS. My WDS is on a virtual server and the share was by taken away sometime back only notice know when trying to install a new client.

    You safe me lots of time.

    All the best!

    Mittwoch, 27. November 2013 04:31
  • Aaron you are the best this solution worked for me. Thank you!
    Donnerstag, 6. November 2014 11:25
  • Funcionou perfeito. Muito obrigado!

    Tiago Toledo A essência do conhecimento consiste em aplicá-lo, uma vez possuído.

    Donnerstag, 26. März 2015 20:37
  • Thanks Aaron, this solved the problem on my WDS server !!

    Freitag, 6. Januar 2017 17:11
  • Thank you!
    Montag, 15. Mai 2017 19:03