none
Kalender im Internet freigeben. RRS feed

  • Frage

  • Hallo alle zusammen,

    Ich habe ein kleines Problem bei der Veröffentlichung von Kalendern im Internet.

    Kurz zur Situation:

    Ich habe eine Migration von Exchange 2003 (SBS) auf einen 2008er R2 durchgeführt.
    Es wurde alles ohne Probleme übertragen, bei einer hoffentlichen Kleinigkeit stehe ich aber auf dem Schlauch.

    Ein Kalender soll im Internet freigebenen werden, damit von extern darauf zugegriffen werden kann.
    Hier habe ich das Problem das ich den Kalender nicht veröffentlicht bekomme.

    Ich habe mich im OWA angemeldet und über Kalender -> Freigeben -> Diesen Kalender im Internet veröffentlichen ausgewählt.
    Nun bekomme ich bei der Veröffentlichung des Kalenders die folgende Fehlermeldung

    Für die Kalenderveröffentlichung über das virtuelle /owa-Verzeichnis steht keine externe URL zur Verfügung.

    Ich hab den IIS in Verdacht, habe aber keine Idee wie ich an das Problem rangehen kann.
    Ich hoffe es hat vielleicht jemand von euch eine passende Idee

    Sollten euch noch Infos fehlen sagt Bescheid!


    Grüße Marcel
    Mittwoch, 22. Juli 2015 09:56

Antworten

  • Änderungen an den virtuellen Verzeichnissen werden im AD gespeichert, das kann schon mal ein wenig dauern (hängt immer von der Auslastung, den Einstellungen der Exchange-Dienste, usw. ab).

    Funzt denn der Aufruf des Kalenders von extern?


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 22. Juli 2015 11:03

Alle Antworten

  • Hi Marcel,

    Punkt 1: einen Exchange 2008 R2 gibt es nicht. Meinst Du evtl. einen SBS 2011 (wo Exchange 2010 drauf läuft) oder einen Server 2008 R2, auf dem Du WELCHE Version von Exchange installiert hast?

    Die Fehlermeldung besagt, dass Du das virtuelle OWA-Verzeichnis keine externe URL (z.B. https://mail.contoso.com/owa) definiert hast. Für jedes (oder fast jedes) virtuelle Verzeichnis kann sowohl eine interne als auch eine externe URL konfiguriert werden, wobei die internen bei der Installation automatisch eingerichtet werden, die externen jedoch nicht (nicht jeder will seinen Exchange ins Internet hängen).

    Je nachdem, welche Exchange-Version Du hast, sind die Schritte in der GUI dazu etwas unterschiedlich. Nimm daher lieber die Exchange Management Shell (Powershell):

    Get-OWAVirtualDirectory | Set-OWAVirtualDirectory -ExternalUrl <URL, unter der Dein Exchange von außen erreichbar ist, z.B. https://mail.contoso.com/owa>


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 22. Juli 2015 10:13
  • Stimmt, du hast recht ich habe mich vertippt :D

    Es ist ein Exchange 2010 auf einem Server 2008R2 :P

    Wenn ich in der Shell Get-OWAVirtualDirectory eintippe bekomme ich eine Ausgabe zurück
    die wie folgt aussieht:

    Name                                  Server            OwaVersion
    --------                                ---------            ----------------

    owa (default web site)      W8R2-EX       Exchange2010

    Bedeutet es nicht das es dieses virtuelle Verzeichnis nicht schon gibt
    Wenn ich den Befehl nun eingebe erzeugt er einen neuen Eintrag oder wird der vorhandene Überschrieben?

    Danke für die schnelle Rückmeldung 

    Mittwoch, 22. Juli 2015 10:27
  • Hi,

    ja, das virtuelle Verzeichnis an sich existiert, das wird bei der Installation angelegt. Wie ich aber schon sagte, wird standardmäßig nur die interne URL vorkonfiguriert, bei Dir fehlt nun noch die externe URL. Um Dir diese Konfiguration anzeigen zu lassen, musst Du folgendes eingeben:

    Get-OWAVirtualDirectory | fl Name,InternalUrl,ExternalUrl

    Da wirst Du sehen, dass für "ExternalUrl" nichts ausgegeben wird. Für sämtliche Parameter:

    Get-OWAVirtualDirectory | fl


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 22. Juli 2015 10:31
  • Ok das habe ich verstanden und auch so in die Shell eingetippt.

    Bei der Konfiguration der externen URL für das OWA habe ich die Meldung bekommen das ich die entsprechende Änderung für das virtuelle ECP-Verzeichnis auf der selben Webseite vornehmen soll.

    Dazu habe ich den befehl dann angepasst und die externe URL für das virtuelle ECP-Verzeichnis ebenfalls eingetragen.

    Get-ECPVirtualDirectory | Set-ECPVirtualDirectory -ExternalUrl

    Wenn ich mich nun über das OWA anmelde bekomme ich den selben Fehler wie vorher.

    Habe ich etwas falsch gemacht?!

    EDIT: Es scheint wohl ein paar Minuten gedauert zu haben bis die Einstellungen angenommen wurden. Zumindest bekomme ich bisher keine Fehlermeldung bei der Veröffentlichung.


    • Bearbeitet rel0adme Mittwoch, 22. Juli 2015 10:59
    Mittwoch, 22. Juli 2015 10:57
  • Änderungen an den virtuellen Verzeichnissen werden im AD gespeichert, das kann schon mal ein wenig dauern (hängt immer von der Auslastung, den Einstellungen der Exchange-Dienste, usw. ab).

    Funzt denn der Aufruf des Kalenders von extern?


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 22. Juli 2015 11:03
  • Danke für den Hinweis mit dem Cross-Posting *grrrr*

    http://www.msxforum.de/community/index.php/Thread/15283-Kalender-im-Internet-freigeben/

    Ich habe dir bei mir geantwortet, wenn du das so machst, klappt das auch.

    :-o


    Gruß Norbert

    Mittwoch, 22. Juli 2015 11:17
    Moderator
  • Änderungen an den virtuellen Verzeichnissen werden im AD gespeichert, das kann schon mal ein wenig dauern (hängt immer von der Auslastung, den Einstellungen der Exchange-Dienste, usw. ab).

    Funzt denn der Aufruf des Kalenders von extern?


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Ich danke VIELMALS!!

    Ich konnte den Kalender nun veröffentlichen und alle funktioniert ohne Probleme.

    Grüße!

    Mittwoch, 22. Juli 2015 13:46
  • Moin,

    dann musst du jetzt nur noch die Beiträge als hilfreich markieren und den Thread als erledigt setzen.

    ;)


    Gruß Norbert

    Mittwoch, 22. Juli 2015 15:08
    Moderator