none
Exchange Server 2010 SP3 - Fehler bei Überprüfung der Organisation RRS feed

  • Frage

  • Hallo zusammen,

    ich habe auf einem Exchange Server 2010 SP2 ein Problem beim installieren des SP3.

    Beim Prüfen der Organisation kommt es zu folgendem Fehler:

    Setup kann den Domänencontroller 'DC.dom.local' nicht verwenden, weil ein Eintrag zum außer Kraft setzen in der Registrierung festgelegt ist. Führen Sie Setup erneut aus, und geben Sie '/DomainController:DC2.dom.local' an.Mit

    Mit dem Schalter /DomainController ändert sich der Fehler leider nicht.

    Bin ein wenig ratlos bei der Lösung des Problems. Vielleicht hatte den schonmal jmd. und kann weiterhelfen.

    Vielen Dank! :)

    Donnerstag, 6. Februar 2014 07:50

Antworten

  • Hallo Robert,

    nach deinem Hinweis und noch ein wenig Recherche habe ich den Fehler glaube ich beheben können. Der Server braucht noch einen Neustart. Wenns dann klappt werde ich den Beitrag als gelöst markieren.

    Zur Lösung:

    Über Get-ExchangeServer –Identity <server_name> -Status | FL konnte ich sehen das der DC statisch eingetragen war ebenso wie der ConfigDC und der GC.

    Über Set-ExchangeServer -Identity <server_name> -StaticDomainControllers $Null

    Set-ExchangeServer -Identity <server_name> -StaticConfigDomainControllers $Null

    und

    Set-ExchangeServer -Identity <server_name> -StaticGlobaclCatalogs $Null

    stehen nun beide DCs und GCs drin. Die Vorrausprüfung des SPs zeigt jetzt nurnoch als Fehler einen ausstehenden Neustart.

    Wie es zu diesem statischen Eintrag kommt ist mir nicht klar. Die Installation des Exchange ist aber auch nicht von mir. Daher einige unbekannte.

    • Als Antwort markiert DominikM Donnerstag, 6. Februar 2014 16:14
    Donnerstag, 6. Februar 2014 16:13
  • Die Regkeys wären auch bei 2010 noch aktuell und es darf sie eben NICHT geben - das ist das wichtige.

    Bitte such mal im Eventlog des Exchange nach Event 2080 der Quelle MSExchange ADAccess und poste die Ausgabe hier. Das Event sollte eigentlich alle 15 Minuten auftauchen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert DominikM Donnerstag, 6. Februar 2014 16:14
    Donnerstag, 6. Februar 2014 15:45

Alle Antworten

  • Moin,

    schau Dir mal bitte diesen Artikel an:

    http://support.microsoft.com/kb/250570/en-us

    Prüfe die darin beschriebenen Stellen, ob da ein statischer DC oder GC eingetragen ist. Wenn ja, dann versuch bitte unbedingt herauszubekommen, warum. Eventuell hat das bei Euch einen Grund.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 6. Februar 2014 13:32
  • Hallo Robert,

    erstmal danke für den Link. Diesen Artikel habe ich schon überflogen aber nicht wirklich beachtet, da er sich auf Exchange 2000 bezieht. Den Registry-Key zu MSExchangeDSAccess hat der Server garnicht. Ist dies der Fehler? Sollte der key angelegt werden?

    Eins ist mir noch auffällig:

    Unter Exchange-Konsole -> Serverkonfiguration -> Clientzugriff -> Rechtsklick auf Server "Eigenschaften" -> Systemeinstellungen

    Dort steht bei den Verwendeten DCs und GCs jeweils nur DC1 drin. DC2 fehlt komplett. Ich vermute das hier der Fehler begraben liegt, da DC2 auch alle FSMO-Rollen hat. Aber wo kommen diese Angaben her, bzw. lassen sich ändern?

    • Bearbeitet DominikM Donnerstag, 6. Februar 2014 15:27
    Donnerstag, 6. Februar 2014 15:05
  • Die Regkeys wären auch bei 2010 noch aktuell und es darf sie eben NICHT geben - das ist das wichtige.

    Bitte such mal im Eventlog des Exchange nach Event 2080 der Quelle MSExchange ADAccess und poste die Ausgabe hier. Das Event sollte eigentlich alle 15 Minuten auftauchen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert DominikM Donnerstag, 6. Februar 2014 16:14
    Donnerstag, 6. Februar 2014 15:45
  • Hallo Robert,

    nach deinem Hinweis und noch ein wenig Recherche habe ich den Fehler glaube ich beheben können. Der Server braucht noch einen Neustart. Wenns dann klappt werde ich den Beitrag als gelöst markieren.

    Zur Lösung:

    Über Get-ExchangeServer –Identity <server_name> -Status | FL konnte ich sehen das der DC statisch eingetragen war ebenso wie der ConfigDC und der GC.

    Über Set-ExchangeServer -Identity <server_name> -StaticDomainControllers $Null

    Set-ExchangeServer -Identity <server_name> -StaticConfigDomainControllers $Null

    und

    Set-ExchangeServer -Identity <server_name> -StaticGlobaclCatalogs $Null

    stehen nun beide DCs und GCs drin. Die Vorrausprüfung des SPs zeigt jetzt nurnoch als Fehler einen ausstehenden Neustart.

    Wie es zu diesem statischen Eintrag kommt ist mir nicht klar. Die Installation des Exchange ist aber auch nicht von mir. Daher einige unbekannte.

    • Als Antwort markiert DominikM Donnerstag, 6. Februar 2014 16:14
    Donnerstag, 6. Februar 2014 16:13
  • Interessant und dank für die Info. Bei der Einstellung hätte ich eine andere Fehlermeldung erwartet.

    Berichte mal, ob es das war.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 6. Februar 2014 16:26
  • Danke Dominik für die Lösung! Genau das Problem hatte ich heute auch. Wie auch immer die statischen Einträge da rein kamen... :-/

    Gruß Rocco

    Freitag, 10. April 2015 17:07