none
SCCM Installations Problem RRS feed

  • Frage

  • Hallo,

    ich bin gerade dabei die neuste Version (SCCM 2016) in einer Testumgebung zu installieren.

    Die Testumgebung besteht aus folgende VMs:

    - DC (Domaincontroller)

    - SQL (SQL-Server 2016)

    - CM (SCCM-Server 2016)

    Problem:

    Bei der Installation des SCCM Servers werden die DB-Daten abgefragt. Dies funktioniert einwandfrei.

    Im nächsten Schritt schlägt er mir die Pfade zur SQL Server-Datendatei sowie SQL Server-Protokolldatei vor

    (C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\DATA\), die er vom SQL-Server ausliest.

    Wenn ich auf weiter klicke, dann kommt es zu folgender Fehlermeldung:

    Der Pfad ist nicht vorhanden. Wählen Sie einen gültigen Pfad aus

    Der Pfad ist aber auf dem SQL-Server vorhanden.

    Hat jemand eine Idee?

    Auf dem SQL-Server ist der Benutzer DB-Owner

    Dienstag, 6. Dezember 2016 08:50

Antworten

Alle Antworten

  • "SCCM 2016" gibt es nicht. Entweder System Center Configuration Manager 2012 oder System Center Configuration Manager Current Branch 16xx.

    Ein separater SQL-Server ist machbar, aber nur für große Umgebungen empfohlen. Ansonsten ist SQL lokal besser.

    Haben denn der installierende Account und der Computeraccount des ConfigMgr-Servers Admin- und sysadmin-Berechtigungen auf dem SQL-Server? Was steht in C:\ConfigMgrSetup.log für eine Fehlermeldung?


    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 6. Dezember 2016 10:53
    Beantworter
  • Hallo,

    ja, die haben sysadmin-Rechte auf die DB

    Das ist komisch, dass er die Pfade nicht findet, obwohl die vorhanden sind.

    Mehr steht nicht in der Log

    Log:

    aCWmi::Connect(): ConnectServer(Namespace) failed. - 0x80070005~  $$<Configuration Manager Setup><12-06-2016 13:08:38.737-60><thread=2052 (0x804)>
    CWmiRegistry::WmiOpen: Failed to connect to remote WMI repository on machine SQL01.cm-center.de  $$<Configuration Manager Setup><12-06-2016 13:08:38.737-60><thread=2052 (0x804)>
    Failed to connect HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\SQL registry key for reading on SQL Server [SQL01.cm-center.de].  $$<Configuration Manager Setup><12-06-2016 13:09:00.872-60><thread=2052 (0x804)>
    WARNING: failed to retrieve port number for SQL01.cm-center.de.  $$<Configuration Manager Setup><12-06-2016 13:09:00.888-60><thread=2052 (0x804)>
    WARNING: failed to retrieve port number for SQL01.cm-center.de.  $$<Configuration Manager Setup><12-06-2016 13:09:00.888-60><thread=2052 (0x804)>
    INFO: Registered type SQL01.CM-CENTER.DE MASTER for SQL01.cm-center.de master  $$<Configuration Manager Setup><12-06-2016 13:09:00.903-60><thread=2052 (0x804)>
    INFO: Registered type SMS Master for SQL01.cm-center.de master  $$<Configuration Manager Setup><12-06-2016 13:09:00.903-60><thread=2052 (0x804)>
    INFO: Registered type SQL01.CM-CENTER.DE CM_STR for SQL01.cm-center.de CM_STR  $$<Configuration Manager Setup><12-06-2016 13:09:00.903-60><thread=2052 (0x804)>
    INFO: Registered type SMS ACCESS for SQL01.cm-center.de CM_STR  $$<Configuration Manager Setup><12-06-2016 13:09:00.919-60><thread=2052 (0x804)>
    INFO: SQL Server version detected is 13.0, 13.0.4001.0 (SP1).~  $$<Configuration Manager Setup><12-06-2016 13:09:01.385-60><thread=2052 (0x804)>
    INFO: Return code:0, Major:13, Minor:0, BuildNum:4001  $$<Configuration Manager Setup><12-06-2016 13:09:01.385-60><thread=2052 (0x804)>

    Dienstag, 6. Dezember 2016 12:11
  • Und das Log endet genau an dem Punkt oder kommt noch mehr?

    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 6. Dezember 2016 12:40
    Beantworter
  • das endet genau an dem Punkt
    Dienstag, 6. Dezember 2016 12:45
  • die Dienste auf dem SQL-Server laufen unter einem AD-Account sqlsvc.

    Der SCCMMan ist ein AD-Benutzer, der sysadmin-Rechte auf die DB CM_STR hat.

    Dienstag, 6. Dezember 2016 12:48
  • hat sich erledigt. ich hab sql 2014 installiert. damit geht es jetzt

    scheint vermutlich an sql 2016 zu liegen

    Dienstag, 6. Dezember 2016 14:26
  • hat sich erledigt. ich hab sql 2014 installiert. damit geht es jetzt

    scheint vermutlich an sql 2016 zu liegen


    Nicht zwingend. Kommt auf die Version von ConfigMgr an.

    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 6. Dezember 2016 14:44
    Beantworter