none
Internet Explorer 10 Deployment unter Windows 7 schlägt fehl RRS feed

  • Frage

  • Guten Morgen Community,

    ich versuche nun schon seit längerem im Unternehmen den Rollout des Internet Explorer 10 vorzubereiten. Leider erfolglos.

    Die Infrastruktur besteht momentan aus Windows 7 x64 SP1 Clients, Active Directory unter Server 2003 und Member-Servern 2003 bis 2012. Es werden als Client durchgängig Notebooks von DELL eingesetzt.

    Auf einem repräsentativen Test Client der die Standard Software des Unternehmens enthält und vollständig über Windows Update aktualisiert ist, lässt sich Internet Explorer 10 nicht installieren. Weder manuell (Download aus Microsofts Download Center und von windows.com) noch automatisiert über Windows Update.

    Was ich mittlerweile weiß: Die Installation funktioniert wenn ich den Client neuinstalliere. Soll heißen: Nur Betriebssystem und aktualisiert über Windows Update. In dieser konstellation kann ich Internet Explorer 10 manuell installieren. Installiere ich den Client neu mit Betriebssystem + Standard Software und aktualisiere diesen anschließend über Windows Update schlägt das Setup des IE10 fehl. (Ich erhalte zwar die Meldung "Internet Explorer 10 ist jetzt installiert" nach einem Neustart werden die Änderungen aber wieder rückgängig gemacht.)

    Mein Verdacht lag aus diesem Grund an der installierten Software, diese habe ich nun deinstalliert, leider ist das Endergebnis immer noch das gleiche. Entweder wurde nicht alles sauber deinstalliert oder eine der installierten Applikationen hat ein Update mitgebracht, das noch auf dem System ist und für das Fehlschlagen der IE10 Installation verantwortlich ist.

    Ich würde mich freuen eure Tipps & Anregungen bzw. eure Erfahrung mit Internet Explorer 10 zu lesen.

    Vielen Dank und einen schönen Tag.

    Freitag, 17. Mai 2013 06:37

Alle Antworten

  • Welches sind denn diese deinstallierten "Standard-Programme"?
     
    Ist nicht klar, ob die Bemerkung "Die Installation funktioniert wenn ich
    den Client neuinstalliere" sich auf manuelle Installation bezieht oder
    auch Deployment. Eben exakt der normal verteilte Client nur vor der
    Applikation der Software?
     
    Im Windows-Verzeichnis finden sich diverse ie10* Log-Dateien, die
    weiterhelfen könnten, das Problem einzugrenzen.
     
     

    IEFAQ: http://iefaq.info
    Freitag, 24. Mai 2013 22:05
  • Guten Morgen,

    entschuldige, das war vielleicht etwas unverständlich ausgedrückt.

    In folgenden Konstellationen funktioniert die Installation des IE10:

    1. Installation des Client manuell von der CD und anschließendes aktualisieren über unseren internen WSUS
    2. Installation des Client automatisch über unsere Softwareverteilung und anschließendes aktualisieren über unseren internen WSUS

    In diesen beiden Fallen werden also nur das Betriebssystem und die verfügbaren Updates Installiert. Sobald ich aber die im Unternehmen eingesetzte Software installiere schlägt die Installation des IE10 fehl. Auch wenn ich diese Applikationen wieder deinstalliere bleibt irgendetwas auf dem System zurück, das die Installation des IE10 verhindert.

    Die besagten Applikationen sind: Java Runtime (x86 und x64), FastStone Capture, 7-Zip, TeamViewer, Adobe Reader, XenApp online Plugin, Notepad++, ProCall, PDFCreator, Lync, Office, Net 4, SyncToy, TeraCopy, CRM Outlook Client, 1E9, Visio Viewer, Documents Core Pack, DNE Update, Adobe Flash Player, TrendMicro
    WorryFree Business Security

    Das IE10_main.log sieht so aus:

    00:00.000: ====================================================================
    00:00.187: Started: 2013/06/03 (Y/M/D) 09:49:14.821 (local)
    00:00.250: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.359: Command line: "D:\IE10-Windows6.1-x64-de-de.exe" 
    00:00.562: INFO:    Setup installer for Internet Explorer: 10.0.9200.16521
    00:02.278: INFO:    Previous version of Internet Explorer: 9.0.8112.16483
    00:02.309: INFO:    Checking if iexplore.exe's current version is between 10.0.8100.0...
    00:02.356: INFO:    ...and 10.1.0.0...
    00:02.527: INFO:    Maximum version on which to run IEAK branding is: 10.1.0.0...
    00:02.652: INFO:    iexplore.exe version check success. Install can proceed.
    00:02.777: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:02.933: INFO:    Trying to extract ID: SetupDownloadList.txt (0) as "SetupDownloadList.txt"
    00:03.073: INFO:    Trying to extract ID: HardwareBlockingList.xml (0) as "HardwareBlockingList.xml"
    00:03.136: INFO:    Trying to extract ID: 7006 (0) as "IE10-neutral.Extracted.cab"
    00:08.440: INFO:    Trying to extract ID: 7010 (1031) as "IE10_amd64_DEU.cab"
    00:08.736: INFO:    Extracted DEU language pack to C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_DEU.cab.
    00:08.830: INFO:    Trying to extract ID: 5501 (1031) as "Spelling_de.msu"
    00:09.157: INFO:    Extracted Spelling dictionary for de to C:\Windows\TEMP\IE1EE06.tmp\Spelling_de.msu.
    00:09.204: INFO:    Trying to extract ID: 5502 (1031) as "Hyphenation_de.msu"
    00:09.438: INFO:    Extracted Hyphenation dictionary for de to C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_de.msu.
    00:09.485: INFO:    Trying to extract ID: 5501 (1033) as "Spelling_en.msu"
    00:09.766: INFO:    Extracted Spelling dictionary for en to C:\Windows\TEMP\IE1EE06.tmp\Spelling_en.msu.
    00:09.813: INFO:    Trying to extract ID: 5502 (1033) as "Hyphenation_en.msu"
    00:10.078: INFO:    Extracted Hyphenation dictionary for en to C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_en.msu.
    00:10.125: INFO:    Trying to extract ID: 7128 (1031) as "IE10-support.cab"
    00:12.043: INFO:    PauseOrResumeAUThread: Successfully paused Automatic Updates.
    00:14.305: INFO:    Updated Download list, Hardware Blocking list, and no reboot policy files successfully downloaded and extracted for use.
    00:14.461: INFO:    Launched program to check hardware: "C:\Windows\TEMP\IE1EE06.tmp\IE10-SUPPORT\IEXPLORE.EXE" /CheckHardware "C:\Windows\TEMP\IE1EE06.tmp\IE10-support\HardwareBlockingList.xml"
    00:17.020: INFO:    Graphics Device Information: NVIDIA Quadro NVS 160M
    00:17.051: INFO:    Hardware support check succeeded. Installation will continue.
    00:17.098: INFO:    Windows 7 operating system detected.
    00:17.113: INFO:    Service pack major: 1
    00:17.129: INFO:    Service pack minor: 0
    00:17.160: INFO:    Service pack name:  Service Pack 1
    00:17.347: WARNING: Checking version for C:\Windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll.  The file does not exist.
    00:17.425: INFO:    Version Check for (KB2639308) of C:\Windows\System32\Ntoskrnl.exe: 6.1.7601.18113 >= 6.1.7601.17727 (True)
    00:17.503: INFO:    Version Check for (KB2533623) of C:\Windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18015 >= 6.1.7601.17617 (True)
    00:17.644: INFO:    Version Check for (KB2731771) of C:\Windows\System32\kernel32.dll: 6.1.7601.18015 >= 6.1.7601.17932 (True)
    00:17.691: INFO:    Checking for correct version of C:\Windows\Fonts\segoeui.ttf.
    00:17.722: INFO:    Version Check for (KB2786081) of C:\Windows\System32\taskhost.exe: 6.1.7601.18010 >= 6.1.7601.18010 (True)
    00:33.400: INFO:    Download for KB2670838 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=272391 -> KB2670838_amd64.CAB.
    00:33.478: INFO:    Download for de-DE IE10_amd64 pack initiated. Downloading http://download.microsoft.com/download/7/F/C/7FCD6AE3-E4D4-48A7-A034-A4873F006058/de-de/amd64fre/Win6.1/cab/Windows6.1-KB2718695-x64.cab -> C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_de-DE.cab.
    00:43.930: INFO:    Waiting for 1 prerequisite downloads.
    00:43.992: INFO:    Prerequisite download processes have completed. Starting Installation of 1 prerequisites.
    00:44.133: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\KB2670838_amd64.CAB /quiet /norestart
    02:24.067: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\KB2670838_amd64.CAB /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    02:24.145: INFO:    The neutral pack was successfully downloaded from the internet. Installation will continue using the downloaded package.
    02:24.270: INFO:    No reboot logic message NrApiStart(0), lParam=0x03762758 returned 0x00000000.
    02:27.343: INFO:    No reboot logic message NrApiScan(1), lParam=0x00000001 returned 0x00000000.
    02:27.374: INFO:    No reboot logic message NrApiStartInstall(4), lParam=0x00000001 returned 0x00000014.
    02:27.437: INFO:    Installing with the downloaded package. C:\Windows\TEMP\IE1EE06.tmp\IE10-neutral.Downloaded.cab
    02:27.468: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10-neutral.Downloaded.cab /quiet /norestart
    03:40.648: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10-neutral.Downloaded.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    03:40.695: INFO:    Setting registry to check if Internet Explorer is the default browser on first run: SUCCESS.
    03:40.710: INFO:    Preparing to install DEU using C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_DEU.cab
    03:40.757: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_DEU.cab /quiet /norestart
    04:41.894: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_DEU.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    04:41.941: INFO:    Preparing to install Spelling_de.msu using C:\Windows\TEMP\IE1EE06.tmp\Spelling_de.msu
    04:42.471: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Spelling_de\Windows6.2-KB2764916-x86.cab /quiet /norestart
    05:29.661: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Spelling_de\Windows6.2-KB2764916-x86.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    05:29.693: INFO:    Preparing to install Hyphenation_de.msu using C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_de.msu
    05:30.207: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_de\Windows6.2-KB2764913-x86.cab /quiet /norestart
    06:13.685: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_de\Windows6.2-KB2764913-x86.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    06:13.716: INFO:    Preparing to install Spelling_en.msu using C:\Windows\TEMP\IE1EE06.tmp\Spelling_en.msu
    06:14.293: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Spelling_en\Windows6.2-KB2764916-x86.cab /quiet /norestart
    06:57.022: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Spelling_en\Windows6.2-KB2764916-x86.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    06:57.053: INFO:    Preparing to install Hyphenation_en.msu using C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_en.msu
    06:57.584: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_en\Windows6.2-KB2764913-x86.cab /quiet /norestart
    07:38.861: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\Hyphenation_en\Windows6.2-KB2764913-x86.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    07:38.908: INFO:    Download for IE10_amd64_de-DE.cab Language Pack succeeded. Filename: C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_de-DE.cab
    07:38.924: INFO:    Preparing to install IE10_amd64_de-DE.cab using C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_de-DE.cab
    07:38.971: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_de-DE.cab /quiet /norestart
    07:50.000: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1EE06.tmp\IE10_amd64_de-DE.cab /quiet /norestart' exited with exit code 0x00000BC2 (3010)
    07:50.031: INFO:    No reboot logic message NrApiInstallDone(7), lParam=0x00000bc2 returned 0x00000000.
    07:50.062: INFO:    No reboot logic message NrApiStartFinish(11), lParam=0x00000000 returned 0x00000000.
    07:50.125: INFO:    No reboot logic message NrApiFinish(12), lParam=0x00000000 returned 0x00000016.
    07:50.156: INFO:    Verifying that the Internet Explorer Optional Component is enabled.
    07:53.978: INFO:    PauseOrResumeAUThread: Successfully resumed Automatic Updates.
    07:54.072: INFO:    Setup exit code: 0x00000BC2 (3010) - Installation Succeeded. Reboot required.
    07:54.228: INFO:    Cleaning up temporary files in: C:\Windows\TEMP\IE1EE06.tmp
    07:54.415: INFO:    Unable to remove directory C:\Windows\TEMP\IE1EE06.tmp, marking for deletion on reboot.
    07:54.508: INFO:    Rebooting computer...
    07:54.571: INFO:    Released Internet Explorer Installer Mutex

    Eingesetzte Hardware sind verschiedene DELL Latitude Modelle, z.B. E6400, E6500, E6420

    Ich bin dankbar über jeden Hinweis.

    Dienstag, 11. Juni 2013 06:32
  • Teste mal ohne Installation dieser Sicherheitsprogramme (zwei soweit ich
    sehe).
     
     

    IEFAQ: http://iefaq.info
    Donnerstag, 13. Juni 2013 11:45
  • Entschuldigt die Verzögerung, ich war jetzt eine Woche nicht im Office.

    Die neueste Erkenntnis ist, dass sich der Internet Explorer 10 installieren lässt wenn folgende Applikationen nicht installiert sind: PCVisit ProfiSupport, Cisco VPN Client, FileZilla, mRemoteNG, Passwordsafe, InLoox, VMware Workstation.

    Im nächsten Schritt versuche ich nun herauszufinden welche dieser sieben Applikationen nun verantwortlich für das Fehlschlagen der IE10 Installation ist.

    Gruß

    Dienstag, 25. Juni 2013 13:58
  • Verdächtig sind grundsätzlich die Programme, die einen Dienst oder eine wie auch immer geartete Autostart Datei mitbringen, denn dann hst du einen Process, der die Installation u.U. blockiert.



    Tschö
    Mark Heitbrink - MVP Windows Server - Group Policy
    Homepage: www.gruppenrichtlinien.de - deutsch
    GPO Tool: www.reg2xml.com - Registry Export File Converter

    Dienstag, 25. Juni 2013 14:08
  • Guter Tipp.

    Von diesen sieben Applikationen installiert VMware Workstation und der Cisco VPN Client einen Dienst. Der Test Client wird gerade neu installiert. Ich werde zunächst die oben genannten Applikationen die keinen Dienst mitbringen installieren und anschließend testen wie sich das Setup des IE10 verhält.

    Gruß

    Dienstag, 25. Juni 2013 14:21
  • Folgende Applikationen installiert: PCVisit, FileZilla, mRemoteNG, Passwordsafe, InLoox

    Ergebnis: IE10 Setup schlägt fehl

    Ich hätte nicht erwartet, dass es eine dieser Applikationen ist .... Nunja ich suche weiter und lass es euch wissen.

    Gruß

    Dienstag, 25. Juni 2013 15:39
  • Das Thema hat sich erstmal erledigt. Auch mit Hilfe des Microsoft Support konnte das Problem nicht gelöst werden. Mögicherweise schafft das über WSUS veröffentlichte Update-Rollup abhilfe.

    Danke für eure Unterstützung.

    Mittwoch, 9. Oktober 2013 09:55