none
RemoteApp - läuft lokal, über Bereitstellung fehlen Daten RRS feed

  • Frage

  • Hallo liebe Community,

    ich stelle über einen Windows Server 2016 RemoteApps bereit. Habe eine eigene Sammlung dafür eingerichtet, etc. Grundsätzlich funktioniert die Bereitstellung, es laufen soweit alle Applikationen - bis auf eine.

    Dabei handelt es sich um den Aufruf eines ERP-Systems. Damit das Programm grundsätzlich läuft muss auf Laufwerk C in einem bestimmten Verzeichnis eine Datei liegen, die die Verbindungsinformationen zu einer Oracle-Datenbank beinhaltet. So weit so gut. Auf dem Terminalserver läuft die Anwendung ohne Probleme. Wenn ich die App Bereitstelle, funktioniert auch der Aufruf auf den Clients bis zu dem Punkt wo auf die Datenbank zugegriffen wird. Als Clients werden Windows 10 Pro 20h2 mit aktuellen Updates verwendet. 

    Im Ereignislog des Servers (Anwendungsprotokolle) ist leider ebenso wenig zu finden wie auf dem lokalen System. Gut, verstehe ich auch, die Meldung erscheint ja auch in einer MessageBox: "ORA-12154: TNS: Angegebener Connect Identifier konnte nicht aufgelöst werden." Die Datei habe ich auch bereits lokal auf mein System unter dem selben Pfad wie auf dem Server kopiert.

    Leider kenne ich die Hintergründe rum um die RemoteApps zu wenig um mir nun selbst weiterhelfen zu können. Habt ihr eine Idee, wie ich meiner Lösung näher komme?

    Mittwoch, 13. Januar 2021 16:29

Antworten

  • Moin,

    zu rekapitulieren:

    • Du hast einen Account, der Admin auf dem TS ist und die Berechtigung auf die RemoteApp hat
    • Meldest Du dich mit diesem Account am RDP-Desktop des TS an, läuft die Anwendung
    • Startest Du mit diesem gleichen Account die RemoteApp, kommt die zitierte Meldung 12154

    Soweit richtig?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert -BeZ- Donnerstag, 14. Januar 2021 06:39
    Donnerstag, 14. Januar 2021 05:59

Alle Antworten

  • Die Remote-App läuft weiterhin auf dem Server, wird aber wie eine lokale App dargestellt. D.h., alles was die App benötigt muss auf dem Server bereitgestellt werden. Dort findest du i.Ü. dann auch die Fehlerlogs, wenn die App welche erstellt.

    Bei Remote-App handelt es sich nicht um eine Click-Once-Bereitstellung!

    Mittwoch, 13. Januar 2021 19:14
  • Moin,

    zu rekapitulieren:

    • Du hast einen Account, der Admin auf dem TS ist und die Berechtigung auf die RemoteApp hat
    • Meldest Du dich mit diesem Account am RDP-Desktop des TS an, läuft die Anwendung
    • Startest Du mit diesem gleichen Account die RemoteApp, kommt die zitierte Meldung 12154

    Soweit richtig?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert -BeZ- Donnerstag, 14. Januar 2021 06:39
    Donnerstag, 14. Januar 2021 05:59
  • Vielen Dank für eure Rückmeldungen! Das Programm läuft auf alle Fälle wenn ich als Admin direkt auf dem Server angemeldet bin. Wenn ich mit MEINEM Account lokal auf dem Server anmelde erhalte ich die selbe Meldung wie die, als ich es als RemoteApp gestartet habe. Das ist schonmal hervorragend, da ich nun ganz normal den Support des Programms anrufen kann.

    Vielen Dank Evgenij Smirnovd da hätte selbst auch drauf kommen können - bin ich gestern aber nicht... 

    Ich sage jetzt einfach mal, dass mein Problem gelöst ist

    Donnerstag, 14. Januar 2021 06:39
  • Dann hast du u.U. nur ein Berechtigungsproblem auf den Dateistandort der Oracle-Verbindungskonfiguration.
    Dies kann u.U. auch das gesamte Verzeichnis des Oracle-Treibers betreffen.
    Donnerstag, 14. Januar 2021 09:06