none
Server 2008 als Domäncontroller / Netzwerkerkennung lässt sich nicht einschalten RRS feed

  • Frage

  • Bei unserem DC (SRV 2008)lässt sich die Netzwerkerkennung nicht einschalten. Jedesmal wenn ich einschalte und schließe erscheint "Benutzerdefiniert"
    Kann keine andern Rechner W3K oder XP-Clients sehen und umgekeht auch nicht. Aber der Ping und die Namensauflösung funktioniert.

    Kennt jemand dasProblem bzw. die Lösung hierzu?
    Mittwoch, 24. Juni 2009 13:13

Antworten

  • Hallo Miteinander,

    ich hatte das gleiche Probelemm mit dem DC.

    Versucht mal folgende Dienste zu starten:

    sc start dnscache
    sc start fdrespub
    sc start ssdpsrv
    sc start upnphost

    danach gings

    wäre super wenn Ihr hier ein feedback postet

    Grüsse Henning Renz
    Sonntag, 13. Dezember 2009 19:04

Alle Antworten


  • Hi Lucky,

    >Kennt jemand dasProblem bzw. die Lösung hierzu?
    Kennen = Ja
    Lösung = Nein, in heterogenen Umgebungen - meiner Erfahrung nach ( in 8 unterschiedlichen Kundennetzwerken)
    Altes/Neues Browsingproblem (Jetzt wegen Topolgieerkennung IPV6 & Co bei neueren Systemen)
    Manchmal hilft es den WINS zu reaktivieren.

    Gruß Ralph Andreas Altermann
    Mittwoch, 24. Juni 2009 14:56
  • *lach* Da bin ich schon froh das ich nicht der einzige bin!!!

    Habe natürlich etwas weiter rumprobiert, dabei ist mir aufgefallen dass das genannte Problem  nur in der Verbindung mit Domäne und DC auftritt. Der Witz dabei ist ich kann mittels Netzlaufwerk darauf zugreifen. Kommt mir irgendwie vor wie Autofahren im Nebel!!!

    Installierte einen Server 2008 ohne ihn in die Domäne einzubinden, also nur in einer Arbeitsgruppe stehen lassen. dann sehe ich alle anderen Rechner also W3K, XP (Sp3),Server 2008.

    Daraus schließe ich das irgendeine GPO, sei es Domain oder Domain Controller, die da irgendwie Einfluss nimmt.

    Das Problem und die Abhilfe müsste doch auch MS bekannt sein!!

    Gibt es inzwischen eine Lösung, googlen brachtre da ja nichts!!

    Ciao Hans
    Samstag, 27. Juni 2009 10:24
  • Mit RSOP.MSC auf dem DC kannst Du die GPO-Einstellungen sehen, die ankommen. Evtl. findest Du ja was dabei. Hast Du IPV6 deaktiviert?
    Winfried
    Samstag, 27. Juni 2009 11:04
  • Hallo guten Morgen,

    nein explizit habe ich IP6 nicht ausgeschalten bzw. deaktiviert. Allerdings habe ich es auch nicht konfiguriert.
    Wie schaltet man IP6 endgültig aus?

    Das mit RSOP.msc muss ich noch ausprobieren.

    Servus Hans
    Montag, 29. Juni 2009 06:41
  • Hi Lucky,

    an IPV6 liegt es nicht unbedingt und auf längerfristige Sicht würde ich IPV6 mitlaufen lassen.
    IPV6 konfiguriert sich standardmäßig erst einmal selbst automatisch.
    Gruß Ralph Andreas Altermann
    Montag, 29. Juni 2009 11:05
  • Hallo zusammen

    Bin zufällig über den Computer Browser Service Abschnitt in diesem Artikel gestolpert (leider nur auf Englisch). Evtl. ist das die Erklärung für dieses Verhalten.

    Viele Grüße
    Andrei
    Mittwoch, 8. Juli 2009 08:22
    Moderator
  • Computer Browser Service

    Habe mir den Artikel angesehen bzw. durchgelesen und den wesentlich bzw relevanten Part hier reinkopiert.
    Habe den Browserdienst unter Dienst auf automatisch gestellt.
    Muss sagen bei mir hat es keine Veränderung gebracht, aber vielleicht klappt es ja bei einem anderen hier.
    Habe auch RSOP.msc ausprobierrt und mir den darauf geöffneten Richtliniensatz angesehen, keine neuen ERkenntnisse!!

    Ich befürchte, dass dies ein Bug von MS ist.

    DC sieht keine andere Arbeitsgruppe bzw. Domäne. XP-Rechner mit SP 3(ist neuer als der Patch zum download) sehen ihre Domäne und ihren DC nicht. Netzwerkkennung ist nicht einschaltbar, es erscheint ein "Benutzerdefiniert" was auch immer dies heißen mag. Zum testen war die Firewall ausgeschalten, nicht das die evtl. auch noch mitmischt.

    Also mir fällt momentan nichts mehr relevantes ein.

    Hat hier inzwischen jemand an Erkenntnis hinzugewonnen?

    Wenn das MS-Technet Forum schon keine Antwort bzw. Lösung hat wer dann!!

    MS scheint sich nicht darum zu kümmern, beim googlen kommt das Problem massig vor aber keine Lösung hierzu.

    Aber die Hoffnug sirbt bekanntlich zuletzt
    Ciao Lucky


    Windows Server 2008 sets the startup state of the Computer Browser service to disabled by default for a new installation of Windows Server and when upgrading an existing server to Windows Server 2008. The Computer Browser service helps maintain an updated list of domains, workgroups, and server computers on the network and supplies this list to client computers upon request. For detailed information about Computer Browser service operation, see Appendix C - Computer Browser Service.

    The default startup state of the Computer Browser service on computers running Windows Server 2008 can cause problems for a domain controller in the primary domain controller flexible single master operations (PDC FSMO) role. For computer browsing, a computer in the PDC FSMO role centrally collects and distributes information about domains, workgroups, and computers for multi-subnet networks. If the computer in the PDC FSMO role is not running the Computer Browser service, computer browse lists across the network will contain only domains, workgroups, and computers on the local subnet. To prevent this problem, configure the startup type for the Computer Browser service for Automatic on the computer in the PDC FSMO role and then start Computer Browser service. You can do this from the Services snap-in or at an elevated command prompt with the following commands:

    sc config browser start= auto

    sc start browser

    Because the Computer Browser service relies on file and printer sharing, you will also need to turn on File and Printer Sharing in the Network and Sharing Center. Alternatively, move the PDC FSMO role to another domain controller that has the Computer Browser service started and configured for automatic startup and File and Printer Sharing turned on in the Network and Sharing Center.

    Additionally, if the only server computer on a subnet is running Windows Server 2008, client computers will become the local browse server on the subnets. As client computers are started and are shut down, the role of the local browse server will pass from one client computer to another, possibly resulting in an inconsistent display of domains, workgroups, and computers. To prevent this problem, on the computer running Windows Server 2008, turn on file and printer sharing, configure the startup type for the Computer Browser service for Automatic, and then start the Computer Browser service.

    Sonntag, 19. Juli 2009 09:38
  • Hallo LuckyMchn

    ist die Datei- und Druckerfreigabe im Netzwerk- und Freigabecenter -> Erweiterterte Einstellungen auf den DC eingeschaltet? Netzwerkerkennung auch?

    Gruß
    Andrei
    Dienstag, 28. Juli 2009 08:39
    Moderator
  • Hallo Andrei,

    klar habe ich die eingeschaltet. Auffällig ist nur, wie oben schon beschrieben, wenn ich die Netzwerkkennung im Freigabecenter ausschalte nimmt der DC das auch an. und es bleibt bei aus.
    Schalte ich hingegen die Netzwerkkennung ein, dann bleibt es nicht bei ein sondern es wird ein benutzerdefiniert daraus.

    Wie ist es den bei Dir bzw. bei Euch wenn ihr auf einen DC die Netzwerkkennung aus- bzw. einschaltet??

    Gruß
    Lucky
    Mittwoch, 29. Juli 2009 09:33
  • Hallo Lucky

    in meiner virtuellen Umgebung, bleibt es auch bei Benutzerdefiniert, allerdings erscheinen da alle Maschinen (unter diesen ein W2k3 SP2 auch). Der DC ist ein W2k8 SP1 und alle Maschinen befinden sich im selben Subnetz.

    Ich denke, dass es am besten ist wenn ich kurz erkläre wie die Netzwerkerkennung läuft. Evtl. hilft das dein Problem leichter zu erkennen.

    Der Client sucht nach benachbarten Computern indem er einen Broadcast Request in den lokalen Subnetz rausschickt. Der Master Browser für das lokale Subnetz empfängt diesen und sendet eine Liste mit dem Backup Browsern zurück. Der Klient bekommt dann die entsprechende Liste von einem der Backup Browsers.

    In einer Domäne Umgebung, jedes Subnetz muss ein Master Browser zugeteilt haben und die Domäne einen Domain Master Browser (der PDC). Der Domain Master Browser ist zuständig für das Verwalten der verschiedenen Subnetz Listen von den individuellen Master Browsern.

    Die Voraussetzungen für eine funktionierende Umgebung:

    1. Jedes Subnetz hat wenigstens eine Maschine mit den Computer Browser Dienst aktiviert, damit diese die Master Browser Role zugewiesen bekommt.

    2. NetBIOS über TCP/IP sollte auf allen Maschinen eingeschaltet sein.

    3. NetBIOS über TCP/IP / Alle Discovery Protokolle und der Computer Browser Dienst auf dem PDC sind eingeschaltet.

    4. Die 137, 138 und 139 TCP/UDP Ports sind in der Umgebung freigeschaltet.

    Mehrere Infos im unteren KB Artikeln:

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;188001

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;188305

    die browstat Utility sollte in den \Support\Tools Ornder auf dem Installations Medium zu finden sein oder per Download vom unteren Link zu finden sein:

    http://www.microsoft.com/downloads/details.aspx?FamilyId=49AE8576-9BB9-4126-9761-BA8011FABF38&displaylang=de

    Hoffe, dass es dir weiterhilft.

    Gruß
    Andrei
    Mittwoch, 29. Juli 2009 10:58
    Moderator
  • Hallo Lucky,

    in der Windows Online Hilfe steht:

    Benutzerdefiniert
    In diesem gemischten Status sind einige Einstellungen im Zusammenhang mit der Netzwerkermittlung aktiviert, jedoch nicht alle. Beispielsweise kann die Netzwerkermittlung aktiviert sein, aber Sie oder der Systemadministrator haben möglicherweise eine Firewallausnahme deaktiviert, die sich auf die Netzwerkermittlung auswirkt.

    und wenn Du nun mal in der erweiterten FW nachsiehst, dann ist zB. die Netzwerkerkennung für 'Öffentlich' deaktiviert, auch wenn Du sie pauschal im Netzwerkcenter
    einschaltest. Also ist diese Verhalten "by design" und "Benutzerdefiniert" die richtige Einstellung bzw. Benennung.


    Gruß Ralph Andreas Altermann
    Mittwoch, 29. Juli 2009 14:05
  • Hallo Zusammen,

    ich weiß nicht, ob das Problem noch aktuell ist. Hatte aber gerade einen ähnlichen Fall:

    Hatte einen Windows 7 PC als Teil eines SBS 2008 Donänennetzwerkes neu installiert (alte Inst. war fehlerhaft, der Rechner war aber zuvor bereits Mitglied der Domäne). Die automatische Zuweisung in die Domäne über http://connect funzte zuerst nicht, daher habe ich den Rechner manuell über Computer - Eigenschaften - Einstellungen für Computernamen, Domänen und Arbeitsgruppe in die Domäne gebracht. Auf dem DC war der Computer zuvor schon angelegt.

    Alle Domänenfunktionen waren vorhanden. Allerdings konnte ich über Netzwerk keine anderen Computer sehen, mit dem Hinweis, dass die Dateifreigabe, etc. nicht aktiviert sei. (Die Computer konnte ich allerdings manuell über Browser mit \\IP-Adresse ansprechen) Über die Einstellungen wurden meine Aktivierungen immer wieder zurückgesetzt (liegt wohl an einer DC Rechte- und Rollenthematik).

    Nun habe ich erneut http://connect ausprobiert, und diesmal klappte es. danach konnte ich die Netzwerkfreigaben aktivieren und jetzt läuft's. 

    Gruß

    Heiko Schnoelzer
    Donnerstag, 10. Dezember 2009 10:07
  • Hallo Miteinander,

    ich hatte das gleiche Probelemm mit dem DC.

    Versucht mal folgende Dienste zu starten:

    sc start dnscache
    sc start fdrespub
    sc start ssdpsrv
    sc start upnphost

    danach gings

    wäre super wenn Ihr hier ein feedback postet

    Grüsse Henning Renz
    Sonntag, 13. Dezember 2009 19:04
  • Hallo Miteinander,

    ich hatte das gleiche Probelemm mit dem DC.

    Versucht mal folgende Dienste zu starten:

    sc start dnscache
    sc start fdrespub
    sc start ssdpsrv
    sc start upnphost

    danach gings

    wäre super wenn Ihr hier ein feedback postet

    Grüsse Henning Renz

    Gerne, bei mir hat es damit funktioniert.
    W2008R2 X64....

    Wobei die Dienste ssdpsrv und upnphost deaktiviert waren.

    Gruss

    Jörg Dassler
    Mittwoch, 20. Januar 2010 11:57
  • Hallo Miteinander,

    ich hatte das gleiche Probelemm mit dem DC.

    Versucht mal folgende Dienste zu starten:

    sc start dnscache
    sc start fdrespub
    sc start ssdpsrv
    sc start upnphost

    danach gings

    wäre super wenn Ihr hier ein feedback postet

    Grüsse Henning Renz

    Gerne, bei mir hat es damit funktioniert.
    W2008R2 X64....

    Wobei die Dienste ssdpsrv und upnphost deaktiviert waren.

    Gruss

    Jörg Dassler

    stimmt bei mir waren auch beide dienste deaktiviert. nach aktivierung funktionierte das einschalten der netzwerkerkennung.

    System W2008R2 x64

    lg Wolfgang Blechinger
    Donnerstag, 11. Februar 2010 19:17
  • Hallo,

    einen Hinweis zur Lösung des Problem, dass sich die Netzwerkerkennung auf einem Server nicht einschalten lässt, sondern immer wieder auf "benutzerdefiniert" springt, liefert der Server selbst, wenn man im "Netzwerk- und Freigabecenter" oben auf "Gesamtübersicht zeigen" klickt.

    Dann meldet Windows "Die Erstellung einer Netzwerkübersicht ist in Domänennetzwerken standardmäßig deaktiviert. Der Netzwerkadministrator kann eine Gruppenrichtlinie verwenden, um die Erstellung von Netzwerkübersichten zu aktivieren."

    Guckst Du hier --->    http://blogs.msdn.com/wndp/archive/2006/11/03/enable_5F00_vista_5F00_network_5F00_map.aspx


    Alfred

    Montag, 15. Februar 2010 12:14
  • Hallo Henning

    DC mit Server 2008 R2

    Danach ging es dann auch bei meinem DC.

    Danke und Grüsse Mamozu

    Dienstag, 13. April 2010 18:27
  • Hallo,

     

    sehr interessante Diskussion hier und der Grund warum ich nach solch einer Lösung suche ist, da ich einen Streaming Client habe welcher einfach den DC (der die Freigabe für die Media Dateien hat) nicht gefunden werden kann. Darauf ist mir später aufgefallen, dass der DC (2008 Std R2) auch nicht aus der Netzwerkumgebung eines 2003 Std SP2 sichtbar ist. Ich habe nun den Trick versucht, all die genannten Dienste hier in der Diskussion zu starten was aber nicht wirklich hilft.

     

    Was ich hier noch anmerken möchte ist, dass ich noch einen 2008 Std R2 Mitgliedsserver in der gleichen Domäne habe (kein DC) welcher ohne irgendwelche weiteren Einstellungen (die meisten der hier im Threat genannten Dienste sind dort (standardmäßig) deaktiviert) ohne weiteres vom 2003 Server wie auch vom Streaming Client gefunden wird. Ich habe die Dienste und auch die IPv4 Einstellungen verglichen und es gibt keinen Unterschied.

     

    Auch mit rsop.msc konnte ich nichts außergewöhnliches feststellen.

     

    Verwunderlich für mich ist nur das beide 2008 R2 Server der eine davon DC und keine weiteren Einstellungen vorgenommen haben unterschiedlich reagieren.

    Wäre schön, wenn von euch schon bis dato etwas näheres in Erfahrung bringen konnte.

    Denke ich werde die Dienste wieder auf ihre Standardeinstellungen bringen, da sie absolut nichts getan hat. Der andere 2008 R2 Server wird auch mit den Diensten gestoppt gefunden. DNSclient ist von Haus aus aktiviert und den werde ich auch laufen lassen.

     

    Schöne Grüße

     

    Robert

    Sonntag, 27. Juni 2010 11:54
  • Hallo,

    bei mir hat es auch unter Windows Server 2008 R2 64bit funktioniert.

    Dienstag, 8. Februar 2011 21:30
  • Um auch mal etwas beizusteuern: der Dienst "fdrespub" ist die "Funktionssuche-Ressourcenveröffentlichung" in der Diensteliste. Diese stand bei mir auf "manuell". Aktiviert den als automatischen Start und Eure Probleme sollten gelöst sein!

     

    Hat mich nur nen Samstag gekostet...

    Sonntag, 27. Februar 2011 14:07
  • Hatte gleiches Problem...

    Lösung: (mit Vorbehalt - bei mir hast funktioniert) Serverseitig - Netzwerk- und Freigabecenter öffnen > Erweiterte Freigabeeinstellungen ändern > Netzwerkerkennung deaktivieren und neu aktivieren.

    Den gleichen Vorgang auf dem Client durchführen. Nach kurzer Verzögerung sollten die Rechner in der Netzwerkumgebung sichtbar sein.

     

     

    Dienstag, 17. Mai 2011 13:07
  • Hatte auch das Problem.

    FDResPub starten und schon funktioniert es :-)

    Anzeigename des Dienstes " Funktionssuche-Ressourcenveröffentlichung"  - Super Name... lach - auf automatisch stellen.

    • Als Antwort vorgeschlagen Andreas Sturma Dienstag, 5. November 2013 09:01
    Mittwoch, 3. August 2011 18:12
  • Hammer geht jetzt auch bei mir danke
    Dienstag, 16. Juli 2013 10:49
  • Hallo,

    danke für diesen Beitrag.

    Der Dienst Funktionssuche-Resourcenveröffentlichung hat mich etliche Nerven gekostet.

    Jetzt sieht sich der 2008r2 wieder selbst und ist auch von den Clients wieder in er Netzwerkumgebung zu sehen.

    Ist das out of the box so, wenn ja habe ich in etlichen Lektüren wichtige Seiten überspringen.

    Danke nochmal

    Gruß Andreas


    Andreas Sturma


    Dienstag, 5. November 2013 09:05