none
MOSS2010 - Serverfehler bei Link in der Globalen Navigation RRS feed

  • Frage

  • Hallo,

    ich habe folgendes Problem:

    Wenn ich bei einer Websitesammlung unter "Aussehen und Verhalten" unter "Navigation" bei der "Globalen Navigation" ein Hyperlink hinzufüge, der das Format /websites/seitenname/SitePages/Homepage.aspx hat, gibt es beim Speichern ein Serverfehler. Gebe ich den Hyperlink als http://server/websites/seitenname/SitePages/Homepage.aspx ein, gibt es kein Fehler beim Speichern. Änder ich das "websites" in irgendetwas anderes ab, gibt es auch kein Fehler. Weiterhin besteht dieses Problem nur in einer Websitesammlung und deswegen bin ich etwas ratlos.

    Hat jemand eine Idee?

    Danke und Gruß

    Uwe

    Freitag, 29. Juli 2011 07:17

Antworten

Alle Antworten

  • Hallo Uwe,

    kannst Du bitte die genaue Fehlermeldung, die beim Speichern gibt, hier posten?

    Grüß,

    Alex

    Montag, 1. August 2011 12:01
  • Hallo Alex,

    sobal ich den Hyperlink konfiguriert habe und auf der Seite Navigationseinstellungen auf OK klicke, bekomme ich folgende Meldung:

    Fehler

    Datei nicht gefunden.

     

    Führen Sie die Problembehandlung mit Microsoft SharePoint Foundation aus.

    Korrelations-ID: 812edf27-9a01-46e4-b5e4-581f10929400

    Datum und Uhrzeit: 01.08.2011 16:14:27

    Zurück zur Website Zurück zur Website
    Gruß
    Uwe
    Montag, 1. August 2011 14:16
  • Hallo Uwe,

    Sagt mir bitte, ob das Link im Browser funktioniert.

    Wenn es dort funktioniert, aber im Seite Navigationseinstellungen kannst du den Hyperlink nicht speichern, dann musst du Alternate Access Mappings bearbeiten.

    Eine Alternative wäre es zuerst den vollen Name des Servers im Seite Navigationseinstellungen zu schreiben:

    Beispiel: http://server.domain.com:port/websites/seitenname/SitePages/Homepage.aspx

    Grüße,

    Alex

    Dienstag, 2. August 2011 07:58
  • Hallo Alex,

    Zur Fehlerumgehung gebe ich die Links zurzeit so an:

    http://server/websites/GB2.0.0.0/SitePages/Homepage.aspx oder http://server/websites/GB2.0.0.0

    Diese Eingaben kann ich speichern. Der Fehler taucht nur auf, wenn der Link z.B. /websites/GB2.0.0.0 oder /websites/GB2.0.0 ist oder /websites/GB2.0 Wenn ich irgendein Schrott eingebe, wie z.B. /website/GB2.0.0.0 kann ich Speicher, auch bei /websites/GB2

    Irgendwie scheint ein Problem in der Kombination mit /websites/ und dem GB2.0.0.0 zu sein. Allerdings nur bei einer Websitesammlung innerhalb eine Webanwendung. Bei anderen Websitesammlungen innerhalb der gleichen Webanwendung besteht dieses Problem nicht. Gebe ich bei einer anderen Websitesammlung den Link /websites/GB2.0.0.0 an, kann ich speichern.

    Sehr eigenartig...

    Gruß

    Uwe

    Dienstag, 2. August 2011 12:01
  • Hallo Uwe,

     

    Von was ich sehen kann, haben wir die folgende Situation:

     

    Es geht:

     

    http://server/websites/GB2.0.0.0/SitePages/Homepage.aspx

    http://server/websites/GB2.0.0.0

    ..................../websites/GB2

    ..................../website/GB2.0.0.0

     

     

    Es geht nicht:

    ............./websites/GB2.0.0.0

    ............./websites/GB2.0.0

    ............./websites/GB2.0

    ............./websites/GB2.0.0.0 geht nicht mit aktueller Websitesammlung

     

     

    Also, was eigentlich nicht korrekt ist, ist die Kombination:

    ...................- s/GB2.0 -............

     

    Wenn du diese Kombination hast, ob du eine "/" am Ende einträgst, kannst du speichern?

    Ich kann nur an einer URL Parse Problem denken, aber das würde in alle Websitesammlungen auftreten.

     

    Viele Grüße,

    Alex

    Donnerstag, 11. August 2011 10:30
  • Hallo Alex,

    ich habe jetzt noch einmal viele Varianten ausprobiert:

    folgendes URL Format kann gespeichert werden:
    http://server/websites/GB2.0.0.0/SitePages/Homepage.aspx
    http://server/websites/GB2.0.0.0/
    http://server/websites/GB2.0.0.0
    ...also alles, was mit http://server beginnt.
    Folgende kurze URL Formate können auch gespeichert werden:
    /website/GB2.0.0.0 (diese URL gibt es nicht)
    /websites/schrott.irgendwas (diese URL gibt es nicht)
    /websites/GB2
    /websites/GB20.0 (diese URL gibt es nicht)
    /websites/GF2.0.0 (diese URL gibt es nicht)
    /websites/GB1.0.0.0

    folgendes URL Format kann nicht gespeichert werden:
    /websites/GB2.0.0.0/SitePages/Homepage.aspx
    /websites/GB2.0.0.0/
    /websites/GB2.0.0.0
    /websites/GB2.schrott

    Fazit: es gibt immer ein Fehler, wenn die kurze URL mit /websites/GB2. beginnt. Die fehlerhafte Websitesammlung selber hat die URL http://server/websites/GB2

    Ich habe jetzt mal Websitesammlungen wie http://server/websites/GB1 oder http://server/websites/GB3 angelegt. Dort lässt sich das gleiche Verhalten feststellen, wenn die kurze URL bei der GB1 Website mit /websites/GB1. und bei GB3 mit /websites/GB3. beginnt.

    Ist es denn möglich, eine Websitesammlung von http://server/websites/GB2.0.0.0 in http://server/websites/GB2000 umzubenennen? So könnte ich das Problem zumindest umgeben.

    Gruß

    Uwe

    Freitag, 12. August 2011 08:09
  • Hallo Uwe,

     

    Schau Dir bitte folgende Links an, und vergiss nicht, zuerst der Backup zu machen !

     

    1.Technet SP DE Forum - SharePoint 2010 Websitesammlung umbennen

    2.Technet SP EN Forum - Wie kann man eine Websitesammlung umbennen

    3.External Blog - Websitesammlung URL Änderung

    4.External Blog - SharePoint 2010: Site URL Umbenennung  

     

    Viele Grüße,

    Alex

    • Als Antwort vorgeschlagen Alex Pitulice Freitag, 12. August 2011 09:00
    • Als Antwort markiert Uwe Bockstette Freitag, 12. August 2011 13:57
    Freitag, 12. August 2011 08:59
  • Hallo Alex,

    ich habe das Problem mit Backup/Restore gelöst bzw. umgangen und die Websites umbenannt (z.B. GB2 in GB-2).

    Danke und Gruß

    Uwe

    • Als Antwort markiert Alex Pitulice Dienstag, 16. August 2011 08:12
    Freitag, 12. August 2011 13:56
  • Hallo Uwe,

    Gern geschehen und ein schönes Wochenende !

    Gruss,

    Alex 

    Freitag, 12. August 2011 14:03