none
Probleme mit Benutzer-Profil & Outlook-Pfad bei Rechner-Wechsel RRS feed

  • Frage

  • Hallo,

    erstmal eine frohes neues Jahr euch allen :)

    So, wir haben bei uns ein kleines Netzwerk mit einem Windows 2012 als Server.
    Dabei arbeiten wir mit server-gespeicherten Profilen, so das sich jeder Nutzer an jedem Rechner einloggen kann und seine Arbeitsumgebung mitnimmt.

    Nachdem jetzt aber ein Nutzer den Rechner gewechselt hat, gab es ein Problem mit Outlook.

    "Die Outlook-Datendatei kann nicht konfiguriert werden.
    C\USers\USERNAME.MEINE-FIRMA\AppData\Local\Microsoft\Outlook\user@meine-firma.de.ost"

    Und damit funktioniert dann Outlook logischerweise nicht.

    Ich habe mir dann mal den alten Rechner genauer angeschaut.

    Dort gibt es unter Benutzer:

    USERNAME
    USERNAME.MEINE-FIRMA

    Er ist also doppelt da. Die einfache Variante, ohne angehängtes "MEINE-FIRMA" stammt noch aus der Zeit des alten Linux Netztes.
    Deswegen hat Windows bei der ersten Anmeldung des neuen Benutzers auch einen neuen Ordner erstellt.
    Da "USERNAME" schon belegt war hat er "USERNAME.MEINE-FIRMA" gewählt, richtig?
    Und in diesem Ordner ist auch das Outlook-Profil, bzw. geht Outlook davon aus.

    Bei dem neuen Rechner gibt es keinen alten Account gleichen Names, deshalb hat der Benutzer dort nur das Verzeichnis

    USERNAME

    Ergo kann Outlook seine Profil-Dateien nicht finden.

    Wie kann ich das Problem lösen?

    Weiß bitte jemand Rat?

    Sonntag, 1. Januar 2017 11:33

Antworten

  • Moin,

    eine direkte Lösung kann ich nicht anbieten, aber vier Ansätze:

    1. Mach auf den neuen Rechner dasselbe wie auf den alten - leg lokale Benutzer an, damit der Pfad passt. Schmeiß anschließend die Profile weg und lass sie bei der Anmeldung neu erstellen.
    2. Schmeiß die OST-Dateien weg (Cache mode aus und wieder an) und lass sie von Outlook im richtigen Pfad neu anlegen.
    3. Bearbeite den Pfad in der Registry des MAPI-Profils. Da es kein String ist, sondern als REG_BINARY kodiert, ist es zwar keine Triviale, aber machbare Übung.
    4. Mach einen Symbolic Link von USER.DOMAIN auf USER (es tut mir gerade in den Fingern weh, das zu schreiben - nur der Vollständigkeit halber. ;-) )

    Da es sich a. um ein kleines Netzwerk handelt, und die User vermutlich b. nicht mehr zurück auf die alten Rechner roamen müssen, nehme ich an, dass Variante 2. praktikabel ist.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    • Als Antwort markiert derMausbiber Montag, 2. Januar 2017 21:12
    Montag, 2. Januar 2017 10:43

Alle Antworten

  • Moin,

    eine direkte Lösung kann ich nicht anbieten, aber vier Ansätze:

    1. Mach auf den neuen Rechner dasselbe wie auf den alten - leg lokale Benutzer an, damit der Pfad passt. Schmeiß anschließend die Profile weg und lass sie bei der Anmeldung neu erstellen.
    2. Schmeiß die OST-Dateien weg (Cache mode aus und wieder an) und lass sie von Outlook im richtigen Pfad neu anlegen.
    3. Bearbeite den Pfad in der Registry des MAPI-Profils. Da es kein String ist, sondern als REG_BINARY kodiert, ist es zwar keine Triviale, aber machbare Übung.
    4. Mach einen Symbolic Link von USER.DOMAIN auf USER (es tut mir gerade in den Fingern weh, das zu schreiben - nur der Vollständigkeit halber. ;-) )

    Da es sich a. um ein kleines Netzwerk handelt, und die User vermutlich b. nicht mehr zurück auf die alten Rechner roamen müssen, nehme ich an, dass Variante 2. praktikabel ist.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    • Als Antwort markiert derMausbiber Montag, 2. Januar 2017 21:12
    Montag, 2. Januar 2017 10:43
  • Habe Variante 1 genommen, ging schnell und alles geht wieder.

    Danke.

    Montag, 2. Januar 2017 21:12