none
Exchange 2013 max Mailgröße per IMAP

    Frage

  • Hallo,

    ich befinde mich aktuell in der Einführung von Exchange 2013 bei einem Kunden. Während der Migration der User und PCs in die Domäne nutzen wir IMAP für die Mailmigration. Exchange lässt aber keine Mails größer 10 MB zu. Für Exchange 2010 und 2010 SP1 fand ich diese Seite http://www.hv23.net/2010/03/change-exchange-2010-maximum-imap-message-append-size/

    Hier ist u.a. ein Parameter für SP1 beschrieben:

    <add key=”MaxReceiveSize” value=”102400000″/> in die Microsoft.Exchange.Imap4.exe.config einfügen.

    Leider scheint das mit 2013 nicht mehr zu funktionieren. Selbst wenn ich den Tippfehler in dem obigen Parameter anpasse (Leerzeichen vor dem / fehlt), kann ich danach nicht mehr den IMAP4 Backend Service starten.

    Jemand eine Idee wie das bei einem Exchang 2013 zu lösen ist?

    Donnerstag, 18. April 2013 12:39

Antworten

  • Moin,

    habe den dritten Key bei mir ausprobiert, funktioniert problemlos.

    Hast Du die vier "hübschen" Anführungszeichen gegen normale SHIFT+2 ausgetauscht?

    Ob er allerdings die erforderliche Wirkung hat, kann ich Dir nicht sagen. Ich (und meine Kunden auf mein anraten) setzen noch kein Ex 2013 ein - und IMAP i.d.R. auch nicht.

    BTW: Der Key verschwindet übrigens wieder mit JEDEM Exchange-CU. Eine der "Verbesserungen" bei Ex 2013. :(


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Freitag, 19. April 2013 08:04

Alle Antworten

  • Hab leider das gleiche Problem. Kann irgendwer helfen? Viele Grüße Florian
    Donnerstag, 18. April 2013 19:26
  • Moin,

    habe den dritten Key bei mir ausprobiert, funktioniert problemlos.

    Hast Du die vier "hübschen" Anführungszeichen gegen normale SHIFT+2 ausgetauscht?

    Ob er allerdings die erforderliche Wirkung hat, kann ich Dir nicht sagen. Ich (und meine Kunden auf mein anraten) setzen noch kein Ex 2013 ein - und IMAP i.d.R. auch nicht.

    BTW: Der Key verschwindet übrigens wieder mit JEDEM Exchange-CU. Eine der "Verbesserungen" bei Ex 2013. :(


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Freitag, 19. April 2013 08:04
  • Jupp.... ist mir ja fast unangenehm... das Erste wo ich sonst drauf achte... ;)

    Also noch einmal: Der von mir gepostete Eintrag, nur eben mit Anführugnszeichen von SHIFT + 2 funktioniert.

    Das wäre dann wie folgt für 10MB (Standardwert, wenn nicht gesetzt):

    <add key="MaxReceiveSize" value="102400000" />

    Freitag, 19. April 2013 08:15
  • Hallo Sebastian,

    geht es bei dir wirklich? Meine appSettings habe ich dir mal angehängt. Ich kann nach wie vor keine Email größer 10 MB über ImapSync transferieren. Ist da noch etwas falsch?

    Viele Grüße und Danke!

    Florian

      <appSettings>
        <add key="MaxIoThreadsPerCPU" value="0" />
        <add key="MaxMimeBufferPoolPerCPU" value="100" />
        <add key="ConnectionCacheSize" value="250" />
        <add key="TemporaryStoragePath" value = "C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\PopImap\Temp" />
        <add key="MaxReceiveSize" value="102400000" />

        <add key="ThrottlingTimeoutInSeconds" value="60"/>
        <add key="MaxFailedLoginAttempts" value="4"/>
        <add key="UidCacheSize" value="30"/>

        <!-- Config file for tracing -->
        <add key="ExInMemoryTraceConfiguration" value="C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\PopImap\IMAP4-EnabledInMemoryTraces.Config" />

        <!-- Budget action maximum elapsed times before logging. Use 4 days in minutes. -->
        <add key="Connection_MaxTimeInMinutes" value="5760"/>

        <!-- Black hole protection -->
        <add key="BlackHole.DatabaseConcurrencyLimit" value="15"/>
        <add key="BlackHole.Enabled" value="true"/>
        <add key="BlackHole.StatisticsEnabled" value="true"/>
        <add key="BlackHole.QuarantineLogThreshold" value="60"/> <!-- seconds -->
      </appSettings>

    Freitag, 19. April 2013 12:19
  • Hey Florian,

    das ist bei dir korrekt. Auch das es 10 MB sind ist korrekt...

    102400000 umgerechnet sind 10 MB, häng eine Null mehr mit ran und du landest bei 100MB ;)

    Freitag, 19. April 2013 12:22
  • Also bei mir geht es immer noch nicht :(

    Vielleicht liegt es auch an ImapSync (wir wollen gerade von MDaemon auf Exchange 2013 wechseln) Ich bekomme diesen Fehler

    - msg INBOX/2520 {12261216} couldn't append  (Subject:[Re: =?UTF-8?B?TGlxdWlkaXTDpHRzcGxhbiBLYXRlayBHbWJI?=]) to folder INBOX: Error sending 'APPEND INBOX (\Seen) "12-Apr-2013 13:36:17 +0200" {12261216}': * BYE Connection closed. 14; 52 BAD Command Argument Error. 11

    Und dieses Bad Command Argument Error. 11 bedeutet dass diese Email größer ist als die zugelassene Größe

    Freitag, 19. April 2013 14:13
  • Die Dienste von IMAP hast du nach der Änderung neu gestartet?

    Versuchst du denn wie ich Mails aus einem Ordner des alten Mailservers auf den Exchange zu bringen, oder wie ist die Konstellation? Wie verhält es sich denn, wenn du einfach deinen Mailclient an den Exchange per IMAP anbindest und dort eine Mail >10MB versenden willst?

    Freitag, 19. April 2013 14:16
  • Ja die hab ich neu gestartet.

    Ich hab gerade versucht eine Email mit 18 MB von Outlook 2010 auf den Exchange 2013 per Drag and Drop zu ziehen und bekomme dann denn Fehler Command Argument Error.11.

    Freitag, 19. April 2013 14:55
  • Und sind die anderen Einträge auch gesetzt? Ob in dem Post fehlen sie jedenfalls. Ausprobieren!


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Freitag, 19. April 2013 15:01
  • Hallo Robert,

    danke für deine Beteiligung.

    Hab nun mal alle drei Schlüssel eingefügt und den Server neu gestartet, aber es geht trotzdem nicht :(

    Freitag, 19. April 2013 15:16
  • Bei mir war die Lösung unter Nachrichtenfluss Sendeconnectors Einstellungen für den Organisationstransport die Grenzwerte neu zu setzen. Wahrscheinlich aber in der Kombination mit dem Ändern der Config auf dem Exchange Server.

    Viele Grüße

    Florian

    Freitag, 19. April 2013 15:40
  • Wir gehen natürlich schon aus, dass die anderen Grenzwerte alle schon angehoben sind und hier nur noch IMAP zu machen ist.

    Es gibt Grenzwerte:
     - für die Organisation
     - für jeden Connector
     - für das Postfach (als Ausnahmen zu den beiden oben)

    Außerdem gibt es Einstellungen bei:
     - OWA
     - EWS (Mac Outlook)
     - EAS
     - POP3

    Diese wären alle zu prüfen und anzupassen, wenn man wirklich an jeder Stelle, bei jedem Client und in jedem Protokoll eine Änderung von 10 MB haben will.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Samstag, 20. April 2013 08:07