none
Exchange Hybrid: Mailversand über Exchange Online RRS feed

  • Frage

  • Hallo,

    ich würde gerne in einem Exchange Hybrid Setup meinen On-Premise Exchange dazu bewegen, dass er ausgehende Mails nicht über seinen eigenen Smarthost, sondern über Exchange Online verschickt. Leider klappt das nicht so, wie ich mir das gedacht habe.

    Zum Hintergrund:

    Das Hybrid Setup besteht und funktioniert schon seit Monaten. Bisher ist es aber so, dass Benutzer, die im Exchange Online angemeldet sind, über Exchange Online versenden. Benutzer, die auf der On-Premise Maschine sind, versenden noch über einen angebundenen externen SmartHost.

    Der Mailfluss zwischen beiden Exchangeservern funktioniert erst mal problemlos. Durch den HybridWizard wurden auch alle Connectoren erfolgreich angelegt.

    Auf dem On Premise Server gibt es zwei wesentliche Sendeconnectoren:

    Einmal der EX->Internet der alle Mails (Adressraum *) an den Smarthost weiter leitet.

    Zusätzlich gibt es noch den vom Wizard angelegten "Outbound to Office 365" Connector. Dieser steht aktuell auf Adressraum "domain.de" (hab aber auch schon * getestet) und leitet weiter an domain.mail.protection.outlook.com - war aber bisher auch immer deaktiviert, dennoch hat soweit alles funktioniert.

    Sobald ich jetzt den Sendeconnector "EX->Internet" deaktiviere, läuft mir die Warteschlange des "Outbound to Office 365" voll. Erstaunlicherweise nicht nur mit ausgehenden Mails, sondern auch mit Mails, die der lokale Exchange dem Exchange Online zustellen will. (Der MX läuft auf eine lokale Firewall, die alle eingehenden Mails erst mal an den On-Premise Exchange zustellt, bevor der diese an, sofern die Benutzer im Office365 sind, an den Exchange Online weiter gibt).

    Das kommt mir allesetwas merkwürdig vor und ich verstehe die Logik dahinter nicht.

    Kann mir das jemand erklären und einen Tip geben, wie ich den On-Premise Exchange dazu bringe, seine Mails alle über Exchange online zu verschicken?

    Danke und beste Grüße

    Dennis

    ---------------------------

    AddressSpaces                : {SMTP:*;1}
    AuthenticationCredential     : System.Management.Automation.PSCredential
    CloudServicesMailEnabled     : False
    DNSRoutingEnabled            : False
    DomainSecureEnabled          : False
    Enabled                      : True
    ForceHELO                    : False
    Fqdn                         :
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : SERVER2019
    Identity                     : EX2013 -> Internet
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 35 MB (36,700,160 bytes)
    Name                         : EX2013 -> Internet
    Port                         : 25
    ProtocolLoggingLevel         : None
    RequireOorg                  : False
    RequireTLS                   : False
    SmartHostAuthMechanism       : BasicAuth
    SmartHosts                   : {[123.123.123.123]}
    SmartHostsString             : [123.123.123.123]
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNABC)
    SourceTransportServers       : {SERVER2019}
    TlsAuthLevel                 :
    TlsCertificateName           :
    TlsDomain                    :
    UseExternalDNSServersEnabled : False


    AddressSpaces                : {SMTP:domain.de;1}
    AuthenticationCredential     :
    CloudServicesMailEnabled     : True
    Comment                      :
    ConnectedDomains             : {}
    ConnectionInactivityTimeOut  : 00:10:00
    DNSRoutingEnabled            : True
    DomainSecureEnabled          : False
    Enabled                      : False
    ErrorPolicies                : Default
    ForceHELO                    : False
    Fqdn                         : mail.domain.de
    FrontendProxyEnabled         : False
    HomeMTA                      : Microsoft MTA
    HomeMtaServerId              : SERVER2019
    Identity                     : Outbound to Office 365
    IgnoreSTARTTLS               : False
    IsScopedConnector            : False
    IsSmtpConnector              : True
    MaxMessageSize               : 35 MB (36,700,160 bytes)
    Name                         : Outbound to Office 365
    Port                         : 25
    ProtocolLoggingLevel         : Verbose
    RequireOorg                  : False
    RequireTLS                   : True
    SmartHostAuthMechanism       : None
    SmartHosts                   : {}
    SmartHostsString             :
    SmtpMaxMessagesPerConnection : 20
    SourceIPAddress              : 0.0.0.0
    SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNABC)
    SourceTransportServers       : {SERVER2019}
    TlsAuthLevel                 : DomainValidation
    TlsCertificateName           : <I>CN=Sectigo RSA Domain Validation Secure Server CA, O=Sectigo Limited, L=Salford,
                                   S=Greater Manchester, C=GB<S>CN=*.domain.de, OU=Domain Control Validated
    TlsDomain                    : mail.protection.outlook.com
    UseExternalDNSServersEnabled : False

    Donnerstag, 20. August 2020 14:23

Antworten

  • Hallo Dennis,

    Wenn Du die ausgehenden E-Mails über Exchange Online Protection weiterleiten möchtest, brauchst Du einen neuen Sendeconnector, der die anderen Domänen zur EOP und zum Internet weiterleiten wird. Sieh Dir für weitere Informationen diesen Blogeintrag an:
    Outbound Email Via Exchange Online Protection When Using Hybrid Exchange Online

    Gruß,
    Dimitar

    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    • Als Antwort markiert Dennis_K5121 Mittwoch, 26. August 2020 05:32
    Freitag, 21. August 2020 14:06
    Moderator

Alle Antworten

  • Hallo Dennis,

    Wenn Du die ausgehenden E-Mails über Exchange Online Protection weiterleiten möchtest, brauchst Du einen neuen Sendeconnector, der die anderen Domänen zur EOP und zum Internet weiterleiten wird. Sieh Dir für weitere Informationen diesen Blogeintrag an:
    Outbound Email Via Exchange Online Protection When Using Hybrid Exchange Online

    Gruß,
    Dimitar

    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    • Als Antwort markiert Dennis_K5121 Mittwoch, 26. August 2020 05:32
    Freitag, 21. August 2020 14:06
    Moderator
  • Vielen Dank Dimitar, das war genau das, was ich gesucht habe!
    Mittwoch, 26. August 2020 05:33