none
AppV 5: Connection Group Version ID

    Frage

  • Hi everybody,

    I try to wrote a script for a connection group and there's no problem for the GroupID in the xml but where i can found the VersionID for this group or how can i creat a new one?

    Thanks!


    Mittwoch, 8. Mai 2013 21:22

Antworten

Alle Antworten

  • See this article: http://stealthpuppy.com/code/creating-app-v-5-0-connection-groups-with-powershell/


    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Donnerstag, 9. Mai 2013 06:25
    Moderator
  • Hello,

    Get-appvclientconnectiongroup will show you the versionid

    You can set a new one within the XML-file

    This article explains the process and talks about the XML-file;

    http://blogs.technet.com/b/appv/archive/2012/11/06/deploying-connection-groups-app-v-5-0.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Donnerstag, 9. Mai 2013 06:47
  • Thanks Aaron, i have tried you're script but when i my command line is complete, i receive error about the display name and -FilePath is not recognzie and it's finished whit failed to save connection group definition file. Could you help me?

    Thanks

    Freitag, 10. Mai 2013 14:05
  • Znack, the problem is in the Application manager Console on my server. If i create 3 connection group only one will be add in the client.
    Freitag, 10. Mai 2013 14:45
  • Have you specified an order and priority? 
    Samstag, 11. Mai 2013 09:29
  • Hello,

    I am just failing to understand what the issue is and what you are doing, is there any reason you can not explain this in more simple terms and give an idea of what you are doing?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sonntag, 12. Mai 2013 19:02
  • Hi,

    Ok i will try to explain in other words.

    I have a management console on a 2008 server for all of my applications and groups. I have three groups in the console. When i sync on my client it's only publish one group. So i have try to add the two others manually on the client. But when i create the xml on the client, everything failed when i lauch the command line on powershell. I made my xml like Aaron showin on his website and still failing. But when i create the xml i think i have a problem to link the VersionID but i'm not pretty sure. Maybe you have another way to resolve my problem.

    Thanks! 

    Montag, 13. Mai 2013 13:20
  • Hello,

    For the first issue I would raise a call with Microsoft.

    It seems that you have an issue with the App-V Management Server and try to avoid resolving that and instead want to focus on a standalone deployment - is that correct?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Montag, 13. Mai 2013 15:26
  • yes i try to find an alternative ton management server to have all of my group on the client.
    Montag, 13. Mai 2013 16:45
  • Hello,

    Can you perhaps share exactly what commands you have been using to workaround the issue?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Dienstag, 14. Mai 2013 11:41
  • Add-AppvCLientConnectionGroup -Path \test2.xml and i receive this error :

    Add-AppvClientConnectionGroup : Application Virtualization Service failed to 
    complete requested operation. 
    Operation attempted: Add AppV Connection Group. 
    AppV Error Code: 0600000008. 
    Error module: Catalog. Internal error detail: 8A90160600000008. 
    Please consult AppV Client Event Log for more details.
    Au caractère Ligne:1 : 1
    + Add-AppvClientConnectionGroup -Path C:\Users\lessarda\Desktop\test2.xml
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult : (:) [Add-AppvClientConnectionGroup], C 
       lientException
        + FullyQualifiedErrorId : AddConnectionGroupError,Microsoft.AppV.AppvClientPower 
       Shell.AddAppvClientConnectionGroup

    Dienstag, 14. Mai 2013 13:24
  • Hello,

    Whats the content of of the xml-file?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Dienstag, 14. Mai 2013 13:39
  • <?xml version="1.0" encoding="UTF-8" ?>
    <appv:AppConnectionGroup
    xmlns="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
    xmlns:appv="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
    AppConnectionGroupId="99ea0ecb-6661-4ee6-a47e-65768c88e70d"
    VersionId="6badb2b7-922e-4277-8b19-22acc6e57d7d"
    Priority="2"
    DisplayName="Group1">
    <appv:Packages>
    <appv:Package DisplayName="Package1" PackageId="e3bdbdb1-6040-47af-b1ef-5538d6246c1c" VersionId="d75f1843-7f78-4c66-8636-ab801daf16c7" />
    <appv:Package DisplayName="Package2" PackageId="d35708fb-bb40-4d14-b08e-b0b5d856dc6e" VersionId="e403141b-3511-40f4-b4b5-7ef8d46ca9f0" />
    </appv:Packages>
    </appv:AppConnectionGroup>
    Dienstag, 14. Mai 2013 14:13
  • Hello,

    Does those two packages exist - with those packageids and versionids?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Dienstag, 14. Mai 2013 15:05
  • yes!
    Dienstag, 14. Mai 2013 15:11
  • Hello,

    Perhaps if you re-read this guide - and share what commands you use;

    http://stealthpuppy.com/code/creating-app-v-5-0-connection-groups-with-powershell/

    Otherwise, I would validate your XML against this guide;

    http://www.applepie.se/app-v-5-standalone-and-connection-groups


    Nicke Källén | The Knack| Twitter: @Znackattack

    Dienstag, 14. Mai 2013 21:00
  • Hi,

    I have try the same definition file as Aaron had made at the top of the page and i make it workable for me, no success.

    I have try his script for new-appvconnectiongroupfile the script work fine but when i try to write the command line, i receive an error of powershell not unterstand -package section so no success

    .I have try the second webpage and when i try the command Add-AppvClientConnectionGroup -Path 'c:\media\freemind.xml' | Enable-AppvClientConnectionGroup –Global.

    with my own XML File, i received the same error about the service failed to complete requested operation.



    Mittwoch, 15. Mai 2013 14:52
  • Hello,

    I am really confused - it seems that you left out a lot of stuff from your explanation? Any reason you can simply not share your entire process with a lot more detail than you previously have been sharing?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Mittwoch, 15. Mai 2013 16:56
  • Hi,

    No reason to give more detail so there is everything i do.

    1 - I made the full installation of App-V Management Server 

    2 - I import all of my apps i need to publish link to Connection Group on the Management Server

    3 - I'm going on my client to add all packages and Connection Group that i've created before, so i add-AppvPublishingServer and sync my server

    4- On my client, only one connection group was publish. First Issues

    5- I trying to create my connection group as standalone

    6- Create a xml file

    <?xml version="1.0" encoding="UTF-8" ?>
    <appv:AppConnectionGroup
    xmlns="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
    xmlns:appv="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
    AppConnectionGroupId="99ea0ecb-6661-4ee6-a47e-65768c88e70d"
    VersionId="6badb2b7-922e-4277-8b19-22acc6e57d7d"
    Priority="2"
    DisplayName="Group1">
    <appv:Packages>
    <appv:Package DisplayName="Package1" PackageId="e3bdbdb1-6040-47af-b1ef-5538d6246c1c" VersionId="d75f1843-7f78-4c66-8636-ab801daf16c7" />
    <appv:Package DisplayName="Package2" PackageId="d35708fb-bb40-4d14-b08e-b0b5d856dc6e" VersionId="e403141b-3511-40f4-b4b5-7ef8d46ca9f0" />
    </appv:Packages>
    </appv:AppConnectionGroup>
    

    7- Add-AppvClientConnectionGroup -Path 'C:\users\lessarda\Desktop\test2.xml' | Enable-AppvClientConnectionGroup –Global

    8- Error code 

    Add-AppvClientConnectionGroup : Application Virtualization Service failed to 
    complete requested operation. 
    Operation attempted: Add AppV Connection Group. 
    AppV Error Code: 0600000008. 
    Error module: Catalog. Internal error detail: 8A90160600000008. 
    Please consult AppV Client Event Log for more details.
    Au caractère Ligne:1 : 1
    + Add-AppvClientConnectionGroup -Path 'C:\users\lessarda\Desktop\test2.xml' | Enab 
    ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult : (:) [Add-AppvClientConnectionGroup], C 
       lientException
        + FullyQualifiedErrorId : AddConnectionGroupError,Microsoft.AppV.AppvClientPower 
       Shell.AddAppvClientConnectionGroup

    It his what i made from the beggining.

    Hope this is a better explanation and easiest to understand my problem

    But thanks to try to help me with that!

     
    Mittwoch, 15. Mai 2013 18:15
  • Hello,

    How did you create the XML-file? Manually?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Mittwoch, 15. Mai 2013 19:59
  • Hi,

    Yes i have taked the code on Aaron website. 

    Donnerstag, 16. Mai 2013 12:52
  • Hello,

    What was the command you used to create the file?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Donnerstag, 16. Mai 2013 14:01
  • Hi, 

    I have tryed to create file manualy with a new blank file. And i also tryed the code from Aaron website to use

    New-AppvConnectionGroupFile but when i use this command, i received an error about the displayname can't be define so no success with these both option.

    Donnerstag, 16. Mai 2013 14:55
  • Hello,

    So, what does the full-command line you are attempting to use look like?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Donnerstag, 16. Mai 2013 16:20
  • Hi,

    I retryed the command of Aaron website and now it's work pretty well! Thanks!!! 

    But do you have an idea about my first issue of my App-V Management Server show me only 1 group on my client when i have 3 created on the server?

    Donnerstag, 16. Mai 2013 17:02
  • Hello,

    Unfortunately no, but you haven't shared anything about the steps you take. You seem to be reluctant to share how you perform steps..


    Nicke Källén | The Knack| Twitter: @Znackattack

    Donnerstag, 16. Mai 2013 18:59
  • No i have gived all step few message before.

    1 - I made the full installation of App-V Management Server 

    2 - I import all of my apps i need to publish link to Connection Group on the Management Server

    3 - I'm going on my client to add all packages and Connection Group that i've created before, so i add-AppvPublishingServer and sync my server

    4- On my client, only one connection group was publish. 

    Donnerstag, 16. Mai 2013 19:05
  • Hello,

    According to your steps - there is only one connection group. I would say - the behavior is what I would expect.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Donnerstag, 16. Mai 2013 19:22
  • Hi,

    I miss to tell i created 3 connections groups with different package in each groups, give the AD access to each packages and groups, and everything i imported and created are made in the management webpage. Then i'm going on my client and i do this command in powershell -

    Add-AppvPublishingServer -Name win2k8r2x-64-en-pu -URL http://win2k8r2-x64-en:6768 | Sync-AppvPublishingServer -Global

    So only one groups are imported on 3 groups have created before in the management.

    I hope my explanation is clearly better!

    Thanks!

    Freitag, 17. Mai 2013 13:35
  • Hello,

    Does the connection groups have the same ID or different ID?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Freitag, 17. Mai 2013 20:34
  • Different ID, but i found something!! On my Management server i can give the good priority to all of my groups but when i check the xml webpage of my publishing server, the priority of my 3 groups still at 0. This could be a problem about my issue?? But did you hav seen this problem before??
    Dienstag, 21. Mai 2013 13:28
  • Hello,

    I suggest that you report it to Microsoft


    Nicke Källén | The Knack| Twitter: @Znackattack

    Mittwoch, 22. Mai 2013 08:26
  • ok i will do that. Where i can do it?
    Mittwoch, 22. Mai 2013 13:39
  • Hello,

    Click "Contact support" on this page,

    http://support.microsoft.com

    Usually - your company has their own contact points within Microsoft - I would only use the above if there are no contact-points already


    Nicke Källén | The Knack| Twitter: @Znackattack

    Mittwoch, 22. Mai 2013 13:47
  • open c:\programdata\Appv

    Package ID = top folder

    Version ID = sub folder

    Donnerstag, 27. März 2014 01:02
  • about the priorities: actually there are two priorities: One controls the 'overlay' behaviour _inside_ a connection group (result: the order in which the individual packages are listed in the CG XML), the other is the 'outer' prio that determine, which CG will be used if an application is part of several CGs.

    AFAIK you can only set the 'inner' prio with the management console; to modify the 'outer' prio, you'd need powershell.

    AND the App-V 5 Management Server needs SP1 HF1 (I think) to support reading those changed priorities and submitting them to the Publishing Server.


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Freitag, 28. März 2014 11:09
    Moderator
  • I get this error 0600000008 if not all of the packages inside the connection group are published (either for user or system). Maybe you want to check that one first with a

    get-appvclientpackage -all

    Mittwoch, 14. Dezember 2016 18:16