none
HyperV Windows 2012 mit Broadcom Netzwerkkarte extrem langsam RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    wir haben uns einen neuen Dell PE 720 Server gekauft. Dieser hat eine Broadcom NetExtreme Quadport Gigabit Netzwerkkarte onboard + eine PCI Express Intel Quadport Netzwerkkarte eingebaut

    Alle Gastsysteme (Windows 2008r2) die an den Broadcom Anschlüssen hängen sind sehr langsam beim kopieren einer Datei über Netzwerk (max. 3MB/sec). Stelle ich beim einem Gastsystem in den HyperVeinstellungen auf die Intel Netzwerkkarte um, habe ich fast 90MB/sec.

    Die neueste Firmware und die neueste Netzwerktreiber sind installiert. 

    Ein Broadcom Netzwerkinterface habe ich für die Remotedesktopverbindung eingerichtet. Kopiere ich direkt vom HyperVServer (nicht in einem Gast) eine Datei, komme ich auch auf die 90MB/sec.

    Bei dem gleichen Broadcom Netzwerinterface unter einem Gast komme ich nur auf 3MB/sec.

    Im Internet habe ich gefunden, dass man Large Send Offload und Checksum am HyperV Server ausschalten soll. Das habe ich gemacht, aber leider keinen Erfolg gehabt.

    Habt Ihr vielleicht noch eine Idee.

    Herzlichen Dank im Voraus.

    Heinz

    Dienstag, 8. Januar 2013 19:49

Alle Antworten

  • Hallo zusammen,

    ich bin ein Stückchen weiter gekommen. Ich habe bei HyperV den virtuellen Switch für eine Netzwerkkarte gelöscht und diesen neu angelegt. Beim Anlegen habe ich dann SR-IOV (Single-Root I/O Virtualization) aktiviert.

    Jetzt läuft es in der gleichen Geschwindigkeit wie die Intel Netwerkkarte bei der diese Option nicht aktiv ist.

    Macht es Sinn mit dieser Funktion auch die Intel Karte auszustatten.

    Was macht dieses Feature genau?

    Danke im Voraus.

    Heinz

    Mittwoch, 9. Januar 2013 08:49
  • Hallo,

    hier ist ein ausgezeichneter Artikel zum SR-IOV: http://blogs.technet.com/b/jhoward/archive/2012/03/12/everything-you-wanted-to-know-about-sr-iov-in-hyper-v-part-1.aspx


    Guido Over
    MCITP Server Administrator 2008
    MCITP Enterprise Administrator 2008
    MCSA Windows Server 2008
    MCSA Windows Server 2012

    Mittwoch, 9. Januar 2013 09:07
  • Hallo zusammen,

    leider habe ich mich zu früh gefreut. Immer wenn der HyperV Server neugestartet wird. Ist das Netzwerk wieder über die Broadcom Netzwerkkarte extrem langsam. Entferne ich den Virtuellen Switch und lege diesen neu mit SR-IOV an, funktioniert es wieder.

    Allerdings wird beim Status im HyperV Manager angezeigt das bei Netzwerkkarte: Herabgestuft (SR-IOV)

    Habt Ihr vielleicht noch eine Idee. So dass ich die Broadcom Netzwerkkkarte ganz normal verwenden kann.

    Danke.

    Heinz

    Montag, 14. Januar 2013 09:14
  • Ich habe hier das selbe Problem allerdings mit einem Server 2008R2 Ent mit aktivierter HyperV Rolle als Host.

    Leider haben wir nur die Quadport Nic deshalb kann ich nicht sagen, ob es mit einer anderen Nic schneller ist.

    Wenn ich den Virtuellen Switch lösche und neu anlege habe ich die Option(SR-IOV) nicht allerdings wird das Netzwerk dann etwas schneller...

    Braucht ihr noch Infos ?

    Danke schon mal...


    • Bearbeitet Jirikus Montag, 14. Januar 2013 14:48
    Montag, 14. Januar 2013 14:41
  • Nach einigem gesuche, herumprobieren, testen... etc...

    Bei mir hat folgendes geholfen:
    Die Bios Einstellungen C1E und CState unter System Profile Settings deaktivieren.

    Montag, 14. Januar 2013 16:50
  • Hallo zusammen,

    ich hatte genau das gleiche Problem wie Ihr mit dem 720. Dies liegt an den Treibern von Broadcom. Da es derzeit aber noch keinen neueren geprüften von Dell gibt, bleibt nichts anderes übrig als folgendes HowTo zu befolgen: http://de.community.dell.com/techcenter/os-applications/w/wiki/930.schlechte-performance-mit-broadcom-netzwerkkarten-nach-der-konfiguration-eines-virtuellen-switch-in-hyper-v.aspx

    Das Deaktivieren dieses Parameters hat bei mir DAUERHAFT zum beheben des Fehlers geführt. Die SRIOV Einstellung ist somit nicht notwendig und der Fehler bleibt auch nach einem Neustart behoben. Hilft nur noch abwarten auf eine neue TreiberVersion, die von Dell genehmigt ist :-)

    Gruß

    Dittsche

    PS: die BIOS Einstellungen bezüglich C1E und CState sind schon standardmäßig deaktiviert...
    Donnerstag, 13. Juni 2013 12:06