none
Excel 2003 - abhängiger Mittelwert RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe eine Tabelle, in der aus einer Spalte der Mittelwert einer Wartezeit errechnet werden soll. In der Spalte danach taucht aber ab und zu ein W für Wunschtermin auf. Diese Wartezeiten sollen nicht berücksichtigt werden.

    Ich dachte an ein konstrukt wie das hier: =MITTELWERT(WENN(E4:E14="";E4:E14)) [strg-shift-enter), aber das liefert 0 als Ergebnis.

    Wie komme ich zu einem funktionierenden Ergebnis (echte Tabelle viel länger als Beispiel).

    Danke
    Uwe

    Mittwoch, 3. November 2010 06:32

Alle Antworten

  • Hi Uwe,

    probier es sonst auf dieser Formel:
    =SUMMEWENN(C2:C6;"<>W";B2:B6)/ANZAHL(B2:B6)

    Viele Grüße
    Christian

    Donnerstag, 4. November 2010 21:28
  • Hallo Uwe

    konnte Christians Antwort weiterhelfen?

    Gruß,
    Andrei

    Montag, 29. November 2010 11:49
    Moderator
  • Sorry, hat gedauert bis ich dazu wieder kam ;)

    hat einen Fehler:

    Ich hab mal 6 Praxiszahlen in der Tabelle. 18, 18, 6, 6, 6, 6. Der Mittelwert ist 10, nach der formel von Christian ebenfalls. 60 / 6 Werte

    Wenn ich nun in eine beliebige 6er "W-Zelle" (also das Feld in der Spalte dahinter) das W setze, dies ist also ein Wunschtermin und die Wartezeit soll nicht berücksichtigt werden, dann ist der Mittelwert rechnerisch 10,8. (54 / 5 Werte)

    Die Formel gibt aber 9 aus. (54 / 6 Werte)

    Setze ich noch ein W hinter eine 6, will also zweimal eine 6 unberücksichtigt lassen kriege ich MW 12 (48/4 Werte), die Formel gibt 8 aus (48/6 Werte).

    Ich will sowohl den Wert als auch den Zähler aussparen. Was kann ich noch anpassen?

     

    Danke, Uwe

     

    edit: MITTELWERTWENN wäre die Lösung, scheint es aber erst ab Excel 2007 zu geben, ich hab dort Excel 2003.

    Montag, 3. Januar 2011 13:49
  • Hallo Uwe,

    angenommen deine Werte stehen im Bereich A1:A6 (18, 18, 6, 6, 6, 6) und die Ws werden in dem Bereich B1:B6 eingetragen, dann lautet für Excel 2007/2010 die Formel:

    =MITTELWERTWENNS(A1:A6;B1:B6;"")

    Für Excel 2003 lautet die Formel:

    =SUMMENPRODUKT((B1:B6="")*A1:A6)/SUMMENPRODUKT(--(B1:B6=""))

     

    Mit freundlichem Gruß aus der Rattenfängerstadt Hameln


    Frank Arendt-Theilen
    (www.at-exceltraining.de)


    Ist deine Frage mit diesem Beitrag beantwortet, markiere sie für alle Mitleser als Antwort . (Du kannst auch mehrere Beiträge als Antwort markieren)

    Dienstag, 1. Februar 2011 09:11
  • Später Nachtrag:

    wir sind dann seinerzeit auf Excel 2007 an dem betreffenden Arbeitsplatz umgestiegen. Dort geht es mit
    =MITTELWERTWENN(I3:I1000;"<>w";H3:H2000)
    völlig problemlos.

    Wenn ich das jetzt über den Konverter in excel 2003 öffne wird daraus
    =_xlfn.AVERAGEIF(I3:I1000;"<>w";H3:H2000)
    Das angezeigte Ergebnus stimmt zwar, aber nur bis ich in der Tabelle was eingebe, dann ist es sofort kaputt.

    Jedenfalls heisst die Lösung hier wirklich Update ;)

    Donnerstag, 5. April 2012 06:59