none
forceaccountselection Outlook 2010 RRS feed

  • Frage

  • Hallo,

    ich habe folgendes Problem:

    Wir haben mehere Benutzer die im Exchange über mehere Postfächer verfügen bzw mailen können. Unser Support, der eine externe Mailadresse hat mit den er mit Kunden Korrespondieren soll lautet z.B. *** Die E-Mail-Adresse wurde aus Datenschutzgründen entfernt. ***. Der Mitarbeiter hat aber auch noch eine personenbezogene Mailadresse als z.B. *** Die E-Mail-Adresse wurde aus Datenschutzgründen entfernt. ***.

    Damit der Mitarbeiter nicht aus versehen mit seiner persönlichen Mailadresse den Kunden anmailt, sollte er vor dem senden der Mail das Konto auswählen über das er senden möchte.

    Nun gibt es einen Registrykey den man setzten kann damit diese Abfrage hochkommt:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Options]
    "forceaccountselection"=dword:00000001

    Ich habe auch schon die Gruppenrichtlinien ins ADS Impoortiert und entsprechend konfiguriert. Leider Ohne Erfolg. Es wird immer über das Standartpostfach gesendet.....

    Unsere Umgebung:
    Windows 2008 Domäne
    Client: Windows 7 64bit
    Office 2010 SP1 32bit

    Kann mir jemand sagen warum das nicht funktioniert?

    Grüße

    Daniel
    Dienstag, 15. Mai 2012 09:31

Antworten

  • Hallo Robert,

    folgendes habe ich nun rausbekommen:-)

    Fur die von mir gesuchte Funktion war es vollkommen falsch wie ich Outlook konfiguriert habe. So wie es aussieht muss Automapping aus sein, was irgendwie blöd gemacht ist. Aber egal.

    Dann darf man aber auch nicht das zusätzliche Konto über die Option "Zusätzlich diese Postfächer öffnen" hinzufügen in der eigenen Postfachkonfiguration.Hier möchte ich nochmal sagen das ich bis jetzt gar keine andere Möglichkeit kannte Postfächer hinzuzufügen!

    Man muss das zusätzliche Postfach über "Datei" -> "Informationen" -> da gibt es eine dropdownlistbox mit dem derzeitigen eigenen Postfach und darunter gibt es ein Button "Neues Konto"! Darüber muss man das "Konto hinzufügen". Dann klappt auch der Schalter mit dem Erzwingen der Auswahl des Absenderpostfaches.

    Warum hat man denn nun noch eine dritte Auswahl ein Postfach hinzu zufügen? Meinst du das mit "Ein echtes Exchange Konto" hinzufügen Robert?

    Ich dachte die ganze Zeit ein zusätzliches Postafch aufmachen reicht. Wo liegt da denn jetzt der Unterschied?

    Gruß

    Daniel

    Nachtrag: Nur so kann man auch die beiden Postfächer wie zwei getrennte Postfächer nutzen. Wenn ich jetzt im zweiten Postfach eine Mail sende, landen auch die gesendeten Mails in gesendete Objekte des zweiten Postfachs und nicht mehr immer im ersten....

    Noch ein Nachtrag: Jetzt benötige ich auch den Schalter nicht mehr, da Outlook immer automatisch den richtigen account benutzt!

    OH MANNN

    Mittwoch, 16. Mai 2012 12:45

Alle Antworten

  • Moin,

    geht der Key bei Dir lokal? Bei mir schon.

    Wie genau sind die Konten eingebunden? Das scheint auf den ersten Blick nicht mit Automapping-Konten zu gehen, kann ich aber nciht intensiv testen.

    Allerdings verstehe ich gar nicht, dass es da ein Problem gibt. Outlook gibt doch den richtigen Absender automatisch vor, wenn der Cursor im richtigen Postfach steht, bzw. auf eine Mail geantwortet wird (dann scheint der Key eh nicht zu greifen). Eventuell muss man die Mitarbeiter noch ein wenig schulen oder Outlook ist doch nicht das beste Werkzeug für einen komplizierten Workflow.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Dienstag, 15. Mai 2012 14:41
  • Hallo Robert,

    nein der Key funktioniert bei mir lokal eben nicht. Ich habe ihn einmal per GPO eingetragen, ich kann auch sehen wie er beim gpupdate /force erstellt wird, aber greifen tut er dann nicht. Du hast recht, wenn man auf eine Mail antwortet nimmt er den richtigen Account. Erstellt man eine neue mail nimmt er den Standartaccount. Irgenwie sagt jeder das dieser Schlüssel funktioniert, bei mir eben nicht und ich verstehe es nicht. Naja, ein komplizierte Workflow sieht ein wenig anders aus..:-) In allen Anleitungen die ich gefunden habe steht drin, das Outlook so einen eben vor dem Senden den Account auswählen lässt. Ich meine sogar das sich MS Seiten darunter befunden haben.

    *Die Haare ausreis*

    Ich weiß nicht mehr weiter....

    Gruß

    Daniel

    Dienstag, 15. Mai 2012 14:55
  • Hi Daniel Koelbl,

    Die Haare ausreis

    Ich weiß nicht mehr weiter....

    Es wäre natürlich interessant zu wissen, wie die Accounts in Outlook eingebunden sind und ob es zum Beispiel bei neuen Emails funktioniert oder nur beim weiterleiten nicht:
    "Replies and Forwards always use the account the message arrived on"

    Hier gibt es noch ein paar weitere Hinweise und andere Workarounds:
    http://www.slipstick.com/outlook/2010/multiple-accounts-and-the-default-account/
    http://www.msoutlook.info/question/477


    Viele Grüße
    Christian

    Mittwoch, 16. Mai 2012 05:03
    Moderator
  • Hallo Christian,

    vielen Dank für deine Antwort! :-)

    Die Accounts sind folgendermaßen eingebunden. Das Primäre Postfach ist das personifizierte Postfach also M.Mustermann@domain.de. Zusätzlich hat der Benutzer über Exchange "Vollzugriff" und "Senden als..." Berechtigungen auf ein zusätzliches Konto z.B. Support@domain.de. Das Konto wird dem StandartPostfach über die Einstellung  "Zusätzlich diese Postfächer öffnen" hinzugefügt.(Warum kann man in Outlook 2010 schon vor dem hinzufügen des zusätzlichen Kontos die Ordnerstruktur sehen und aufs Postfach zugreifen? In 2007 war das anders) Aber das ist eine andere Frage)

    Stehe ich in dem Posteingang des hinzugefügten Postfaches (Support@domain.de) und erstelle eine neue Mail, so wird der Absender des Standartaccounts eingetragen, hier also M.Mustermann@domain.de.

    Beantworte ich aus dem Posteingang des Postfaches (Support@Domain.de) eine Mail, so wird sofort der richte Account gewählt, nämlich support@domain.de.

    Damit der Supportmitarbeiter aber nicht aus versehen mit seinem Personifizierten Mailaccount an Kunden herantreten soll, weil vom Kunden beantwortete Mails dann auch wieder in seinem Postfach landen und die anderen Supportmitarbeiter keinen Zugriff daruf haben.

    Komisch das das ganze bei anderen Leuten funktioniert?

    Gruß

    Daniel

    Mittwoch, 16. Mai 2012 06:06
  • Moin,

    Die Accounts sind folgendermaßen eingebunden. Das Primäre Postfach ist das personifizierte Postfach also M.Mustermann@domain.de. Zusätzlich hat der Benutzer über Exchange "Vollzugriff" und "Senden als..." Berechtigungen auf ein zusätzliches Konto z.B. Support@domain.de. Das Konto wird dem StandartPostfach über die Einstellung  "Zusätzlich diese Postfächer öffnen" hinzugefügt.(Warum kann man in Outlook 2010 schon vor dem hinzufügen des zusätzlichen Kontos die Ordnerstruktur sehen und aufs Postfach zugreifen? In 2007 war das anders) Aber das ist eine andere Frage)

    Nein, das ist vermutlich die ENTSCHEIDENDE Frage, die ich Dir darum auch in meiner ersten Antwort schon stellte:

    Du bindest das Postfach also per Automapping ein.

    1. Nimm das Postfach aus den zusätzlich zu öffnenden Postfächern raus
    2. Deaktiviere Automapping im Benutzerkonto
    3. Binde es als ECHTES Exchange-Postfach mit ein

    (Automapping: http://blog.icewolf.ch/archive/2010/09/24/exchange-2010-sp1-auto-mapping-feature.aspx

    Komisch das das ganze bei anderen Leuten funktioniert?

    Weil man seit Ol2010 die Konten auch als echte Exchange-Konten einbinden kann und daher zusätzliche Postfächer eigentlich gar nicht mehr braucht.

    Man bindet ein Postfach per Automapping ohne zutun des Anwender ein oder ohne Automapping manuell als weiteres Exchange-Konto.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 16. Mai 2012 06:14
  • Hi Daniel,

    hinzugefügt.(Warum kann man in Outlook 2010 schon vor dem hinzufügen des zusätzlichen Kontos die Ordnerstruktur sehen und aufs Postfach zugreifen? In 2007 war das anders) Aber das ist eine andere Frage)

    Das ist die Automappingfunktion:
    http://www.stevieg.org/2010/08/auto-mapping-shared-mailboxes-in-exchange-2010-sp1-with-outlook-2010/

    Komisch das das ganze bei anderen Leuten funktioniert?

    Wahrscheinlich gibt es die Probleme wegen dem Automapping. Teste es doch mal ohne Automapping und vielleicht mit einem POP3/SMTP-Account zum Spaß:
    http://www.msoutlook.info/question/602


    Viele Grüße
    Christian

    Mittwoch, 16. Mai 2012 06:24
    Moderator
  • Hallo Robert,

    habe es so gemacht wie du gesagt hast. Erst wenn ich das Postfach nun als ECHTES Exchange-Postfach einbinde erscheint es auch in der Ordnerliste. OK soweit.

    Leider hat sich am eigentlichen Problem, nämlich das er den Benutzer zwingen soll vor dem senden den Absender-Account auszuwählen, nichts geändert. Dort steht weiterhin der Standartaccount.

    Kann man das Automapping generell für alle Benutzer aufeinmal abstellen? Auch so das bei neuen Postfächern das erst gar nicht genutzt wird?

    Gruß

    Daniel

    Mittwoch, 16. Mai 2012 08:48
  • Moin,

    Leider hat sich am eigentlichen Problem, nämlich das er den Benutzer zwingen soll vor dem senden den Absender-Account auszuwählen, nichts geändert. Dort steht weiterhin der Standartaccount.

    eventuell braucht es zwei/drei Outlook-Neustarts, bis Outlook das Automapping-Postfach wirklich vergisst. Manchmal muss auch das Profil gelöscht und neu angelegt werden.

    Kann man das Automapping generell für alle Benutzer aufeinmal abstellen? Auch so das bei neuen Postfächern das erst gar nicht genutzt wird?

    Leider nicht so einfach. Es gibt seit dem SP2 nur einen neuen Schalte für den "add-mailboxpermission"-Befehl, der Automapping nicht einrichtet.

    Manchmal frage ich mich, ob die Entwicklung eines Extensionagenten nicht sinnvoll wäre (oder das jemand schon mal gemacht hat). Die Anforderung kommt mittlerweile öfter, weil die Leute wohl nach der anfänglichen Euphorie jetzt auf die doch immer größeren Probleme des Automappings stoßen.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 16. Mai 2012 10:08
  • Hallo Robert,

    folgendes habe ich nun rausbekommen:-)

    Fur die von mir gesuchte Funktion war es vollkommen falsch wie ich Outlook konfiguriert habe. So wie es aussieht muss Automapping aus sein, was irgendwie blöd gemacht ist. Aber egal.

    Dann darf man aber auch nicht das zusätzliche Konto über die Option "Zusätzlich diese Postfächer öffnen" hinzufügen in der eigenen Postfachkonfiguration.Hier möchte ich nochmal sagen das ich bis jetzt gar keine andere Möglichkeit kannte Postfächer hinzuzufügen!

    Man muss das zusätzliche Postfach über "Datei" -> "Informationen" -> da gibt es eine dropdownlistbox mit dem derzeitigen eigenen Postfach und darunter gibt es ein Button "Neues Konto"! Darüber muss man das "Konto hinzufügen". Dann klappt auch der Schalter mit dem Erzwingen der Auswahl des Absenderpostfaches.

    Warum hat man denn nun noch eine dritte Auswahl ein Postfach hinzu zufügen? Meinst du das mit "Ein echtes Exchange Konto" hinzufügen Robert?

    Ich dachte die ganze Zeit ein zusätzliches Postafch aufmachen reicht. Wo liegt da denn jetzt der Unterschied?

    Gruß

    Daniel

    Nachtrag: Nur so kann man auch die beiden Postfächer wie zwei getrennte Postfächer nutzen. Wenn ich jetzt im zweiten Postfach eine Mail sende, landen auch die gesendeten Mails in gesendete Objekte des zweiten Postfachs und nicht mehr immer im ersten....

    Noch ein Nachtrag: Jetzt benötige ich auch den Schalter nicht mehr, da Outlook immer automatisch den richtigen account benutzt!

    OH MANNN

    Mittwoch, 16. Mai 2012 12:45
  • Moin,

    folgendes habe ich nun rausbekommen:-)

    na ja, eigentlich wiederholst Du nur das, was Christian und ich Dir schon seit gestern (offensichtlich erfolglos) gesagt haben. :(

    Fur die von mir gesuchte Funktion war es vollkommen falsch wie ich Outlook konfiguriert habe. So wie es aussieht muss Automapping aus sein, was irgendwie blöd gemacht ist. Aber egal.

    Das habe ich schon im ersten Post vermutet-

    Dann darf man aber auch nicht das zusätzliche Konto über die Option "Zusätzlich diese Postfächer öffnen" hinzufügen in der eigenen Postfachkonfiguration.Hier möchte ich nochmal sagen das ich bis jetzt gar keine andere Möglichkeit kannte Postfächer hinzuzufügen!

    Öfter mal was neues. :)

    Man muss das zusätzliche Postfach über "Datei" -> "Informationen" -> da gibt es eine dropdownlistbox mit dem derzeitigen eigenen Postfach und darunter gibt es ein Button "Neues Konto"! Darüber muss man das "Konto hinzufügen". Dann klappt auch der Schalter mit dem Erzwingen der Auswahl des Absenderpostfaches.

    Das ist das gleiche, als wenn man ein echtes Exchange-Konto dem Profil hinzufügt (wird einen Blick in die Systemsteuer -> E-Mail und dann in das Profil und dort siehst Du plötzlich ZWEI Exchange-Konten).

    Warum hat man denn nun noch eine dritte Auswahl ein Postfach hinzu zufügen? Meinst du das mit "Ein echtes Exchange Konto" hinzufügen Robert?

    Genau.

    Ich dachte die ganze Zeit ein zusätzliches Postafch aufmachen reicht. Wo liegt da denn jetzt der Unterschied?

    Es gibt drei Möglichkeiten ein zusätzliches Postfach in Outlook zu öffnen:
    - Automapping -> ab Outlook 2010 (in Teilen schon mit Outlook 2007)
    - zusätzliches Postfach innerhalb des Hauptpostfach -> ab Outlook 2000 (mindestens, eventuell schon davor)
    - zusätzliche Exchange-Konten im Profil (das, was Du oben nur über einen anderen Weg gemacht hast - ab Outlook 2010)

    Nachtrag: Nur so kann man auch die beiden Postfächer wie zwei getrennte Postfächer nutzen. Wenn ich jetzt im zweiten Postfach eine Mail sende, landen auch die gesendeten Mails in gesendete Objekte des zweiten Postfachs und nicht mehr immer im ersten....

    Sach ich doch. ;)

    Noch ein Nachtrag: Jetzt benötige ich auch den Schalter nicht mehr, da Outlook immer automatisch den richtigen account benutzt!

    Sach ich doch auch. ;)


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 16. Mai 2012 13:47
  • Hallo,

    also ich kann mich erinnern das in Outlook 2007, wenn man einzusätzliches Exchange Postfach aufmachen wollte, das der Hinweis kann, das man immer nur ein Exchange Postfach haben kann. Aus dem Grunde kannte ich nur die Option einem vorhandenen noch eins hinzuzufügen. Das man jetzt mehrere Exchange Postfächer haben kann war mir unbekannt!

    Und aus dem Grund haben wir an einander vorbei geredet. Au mann

    Danke das ihr bei der Stange geblieben seit und mir weiter gut zugeredet habt. Deshalb von mir ein "Vielen Dank! auch an Christian!

    Grüße aus dem sonnigen NRW

    Daniel

    Mittwoch, 16. Mai 2012 14:21