none
zu verschiedenen Zeiten friert der Zugriff über Fileshare ein (evtl. auch der ganze Server) RRS feed

  • Frage

  • Hallo,

    ich habe einen Kunden (5 User) welcher hauptsächlich Programme verwendet, welche am Server auf einem freigegebenen Share liegen, leider friert der Zugriff seit kurzem ~3 mal am Tag für 10 Minuten ein.
    Ich vermute dass dabei der Server für eine kurze Zeit selbst komplett einfriert (zu lange Disk Queue oder ähnliches)

    der Server HP DL350p Gen8 ist virtualisiert mit Hyper-V auf Server 2012 R2 mit bloß 1x VM (darauf befinden sich Fileshares + ein AD)
    Festplatten sind 2x SATA Platten mit 7200rpm drin (RAID1), was nicht recht viel ist, sollte meiner Meinung nach aber trotzdem ausreichen, da sich nicht wirklich viel am Server tut und die Auslastung am Server auch gering ist, wenn die User arbeiten.

    • Server 2012 R2 Hyper-V Host mit 1x VM Server 2012 R2
    • Symantec Endpoint Protection 12.1.6 MP4 als Virenscanner auf den Clients + der VM
    • seitens HP und Windows am neuesten Stand
    • Virtual Machine Queue bereits deaktiviert (da man hier öfters über Netzwerkprobleme mit HP liest)

    das ganze hat erst angefangen als wir bei dieser Firma den Symantec Endpoint Protection (AV) installiert haben, danach war die Disk Latency dauerhaft auf ~500ms, das konnte jedoch mit dem neuesten Maintenance Pack behoben werden.
    Jetzt ist zwar das Problem nicht mehr dauerhaft vorhanden, dafür friert der Server wie oben bereits beschrieben ca. 3 mal am Tag sporadisch für ca. 10 Minuten ein.

    Wir setzen Symantec Endpoint Protection mittlerweile bei jedem unserer Kunden ein, es gab noch bei keinem Kunden Probleme damit, daher bin ich mir auch nicht mehr sicher ob SEP dafür zwingend der Auslöser ist.

    Mit dem Symantec Support habe ich bis jetzt leider nur schlechte Erfahrungen gemacht, aus Googlen werde ich auch nicht mehr schlau, da die Beträge sehr oft veraltet und somit nicht mehr relevant sind.

    Ich würde gerne mittels Perfmon oä. die Prozesse monitoren um zu sehen was zu gewissen Zeiten den Server zum einfrieren bringt, habe damit aber leider keine Erfahrung und würde mich freuen, wenn mir da jemand weiterhelfen könnte.

    Donnerstag, 28. April 2016 00:03

Antworten

  • Jop das ist einfach so. Wenn du den Cache aktivierst schreibt der RAIDController erstmal in seinen RAM. Der ist naturgemäß wesentlich schneller. Wenn der Cache aus ist, dann schreibt er direkt auf die Disks. 

    Ich würde die aber empfehlen ohne Batterie den Cache zu deaktivieren. Sollte es z.B. zu einem Stromausfall kommen und dein Server fällt aus, kann der RAIDController die Daten aus dem RAM nicht mehr auf die Disks schreiben. Das kann zu einem mittleren bis schweren Datenverlust führen (Abhängig von der Applikation). 

    Wieviel Schreibgeschwindigkeit eine Platte ohne Controller wirklich bringt kann man recht leicht ausrechen. 

    Kurzes Beispiel: 

    Eine SATA HDD mit 7.200RPM bringt ungefähr 80 IOPS. Das entspricht einer Zugriffszeit von 6 ms. In der Microsoft Welt entspricht 1 IO Prozess ca. 8Kb. Hinzu kommt der Verlust durch das RAID System. Bei RAID 1 verlieren wir 2 IOPS pro Zyklus (Penalty). Dazu kommt noch die Anzahl der Disks etc. aber eh ich zu tief einsteige. :) 

    Hier ein klasse Blog zu dem Thema: https://www.elasticsky.de/2012/06/iops-berechnung/


    Kind regards, Flo


    Mittwoch, 4. Mai 2016 14:18
  • Hi, 

    habe ich mittlerweile beheben können, habe mich leider etwas verwirren lassen, da das Problem erst seitdem der Virenscanner installiert wurde, auftrat.

    Das Problem trat aber nur deswegen auf, weil der Server allgemein eine sehr schlechte Disk Performance hatte, und Symantec das erste mal ein wenig Performance voraussetzte.

    Nachdem ich den Cache am Raid Controller testweise aktivierte (ohne Cache Battery) schaffte er auf einmal um die 80MB/s bei Kopiervorgängen, seitdem läuft der Server wieder performant.

    Kann das wirklich sein dass nur weil der Cache nicht aktiviert war, man bei Kopiervorgängen nur auf ca. 5 MB/s kommt? Kommt mir schon verdammt wenig vor...

    • Als Antwort vorgeschlagen Florian Klaffenbach Mittwoch, 4. Mai 2016 14:15
    • Als Antwort markiert maybe_ Mittwoch, 4. Mai 2016 15:08
    Mittwoch, 4. Mai 2016 13:11

Alle Antworten

  • hi, ist der fehler sporadisch oder kann man zeiten ausmachen wann es passiert? hast du bei symantec auf deinem fileserver sowas wie echtzeit datei Überwachung aktiviert? Wann laufen die scan jobs von symantec? Lg flo

    Kind regards, Flo

    Freitag, 29. April 2016 05:37
  • Hi, 

    habe ich mittlerweile beheben können, habe mich leider etwas verwirren lassen, da das Problem erst seitdem der Virenscanner installiert wurde, auftrat.

    Das Problem trat aber nur deswegen auf, weil der Server allgemein eine sehr schlechte Disk Performance hatte, und Symantec das erste mal ein wenig Performance voraussetzte.

    Nachdem ich den Cache am Raid Controller testweise aktivierte (ohne Cache Battery) schaffte er auf einmal um die 80MB/s bei Kopiervorgängen, seitdem läuft der Server wieder performant.

    Kann das wirklich sein dass nur weil der Cache nicht aktiviert war, man bei Kopiervorgängen nur auf ca. 5 MB/s kommt? Kommt mir schon verdammt wenig vor...

    • Als Antwort vorgeschlagen Florian Klaffenbach Mittwoch, 4. Mai 2016 14:15
    • Als Antwort markiert maybe_ Mittwoch, 4. Mai 2016 15:08
    Mittwoch, 4. Mai 2016 13:11
  • Jop das ist einfach so. Wenn du den Cache aktivierst schreibt der RAIDController erstmal in seinen RAM. Der ist naturgemäß wesentlich schneller. Wenn der Cache aus ist, dann schreibt er direkt auf die Disks. 

    Ich würde die aber empfehlen ohne Batterie den Cache zu deaktivieren. Sollte es z.B. zu einem Stromausfall kommen und dein Server fällt aus, kann der RAIDController die Daten aus dem RAM nicht mehr auf die Disks schreiben. Das kann zu einem mittleren bis schweren Datenverlust führen (Abhängig von der Applikation). 

    Wieviel Schreibgeschwindigkeit eine Platte ohne Controller wirklich bringt kann man recht leicht ausrechen. 

    Kurzes Beispiel: 

    Eine SATA HDD mit 7.200RPM bringt ungefähr 80 IOPS. Das entspricht einer Zugriffszeit von 6 ms. In der Microsoft Welt entspricht 1 IO Prozess ca. 8Kb. Hinzu kommt der Verlust durch das RAID System. Bei RAID 1 verlieren wir 2 IOPS pro Zyklus (Penalty). Dazu kommt noch die Anzahl der Disks etc. aber eh ich zu tief einsteige. :) 

    Hier ein klasse Blog zu dem Thema: https://www.elasticsky.de/2012/06/iops-berechnung/


    Kind regards, Flo


    Mittwoch, 4. Mai 2016 14:18
  • Okay, hat mich nur gewundert dass ohne Cache so gut wie gar kein Schreibzugriff möglich war, hat eben zwischen 2 und 6MB/s geschwankt und ist dann oft auch in ein Timeout gelaufen.

    Ja das stimmt, habe den Cache ohne Battery nur testweise aktiviert, da mir die Folgen bekannt sind.
    Eine Cache Battery ist schon bestellt und der Server hängt zusätzlich an einer USV, die den Server früh genug herunterfährt (was natürlich auch keine 100%ige Garantie ist, es könnte ja auch die USV ausfallen...)

    Danke für das Beispiel und den Artikel! So etwas habe ich schon immer mal gesucht.

    Mittwoch, 4. Mai 2016 15:13