none
Exchange 2010 - öffentliche Ordner Datenbank nach ADSI-Fehler nicht verfügbar

    Frage

  • Guten Tag,

    die Umgebung besteht aus einem Exchange 2010 auf Windows Server 2008r2 und einem Exchange 2016 auf Windows Server 2016. Der Exchange 2010 sowie 2 Windows Server2016 sind DC. Die Umgebung sollte komplett auf den 2016er wandern. Die Benutzerpostfächer und Kommunikation sind bereits migriert gewesen. Die öffentliche Ordner Datenbank liegt noch auf dem 2010er und ist (war) über ein Proxypostfach erreichbar.

    Um ein bestehendes Problem zu beheben wurde versucht nach Empfehlung eines Technet Artikels mittels ADSI-Editor der Ordner: CN=Servers msExchServersContainer CN=Servers,CN=erste administrative gruppe,CN=Administrative Groups,CN=Domain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain,DC=local zu löschen. Hierbei wurde stattdessen, nicht Fragen, der übergeordnete Ordner CN=erste administrative gruppe entfernt. Die Datenbank war natürlich durch Fehlen der Hierarchie nicht mehr erreichbar und taucht auch in GUI und Shell nicht mehr auf. Nach erkennen des Fehlers mussten CN=erste administrative gruppe und CN=Servers manuell neu angelegt werden da es keine Entsprechung im LDP gab (da Ordner leer). CN=Advanced Security, CN=Folder Hierarchies, CN=Routing Groups und CN=Legacy GWART wurden per LDP wiederhergestellt. Eine Einbindung der Datenbank scheint trotzdem nicht möglich. Eseutil /mh schließt erfolgreich für die Datenbank ab. Der Versuch eine Kopie der Datenbank als Wiederherstellungsdatenbank einzubinden scheitert beim mounten. Eine testweise erstellte neue öffentliche Ordner Datenbank kann gemountet werden. Unter Ereignisanzeige->Windows Protokolle->Anwendungen tauchen alle 2 Minuten entsprechende Fehlermeldungen zum versuchten neu einbinden auf:

    Ereignis 3154 MSExchangeRepl

     Active Manager konnte die Datenbank 'recovery' nicht auf dem Server 'SERVER.DOMAIN.local' einbinden. Fehler: Fehler bei Active Manager-Vorgang: Die Datenbank war zu keiner Zeit eingebunden.                    <--Die Wiederherstellungsdatenbank

    Ereignis 9519 MSExchangeIS

    Fehler beim Starten der Datenbank "49a45761-d449-4a8d-82c1-613d4b3d6372": 0x972. 
    Look up of DB Info failed. 

    Ereignis 3154 MSExchangeRepl

    Active Manager konnte die Datenbank 'Public Folder Database 2139936088' nicht auf dem Server 'SERVER.DOMAIN.local' einbinden. Fehler: Vorübergehender Fehler bei Active Manager-Vorgang. Wiederholen Sie den Vorgang. Fehler Vorübergehender Fehler bei Datenbankvorgang. Fehler: Vorübergehender Fehler bei einem Datenbankvorgang. Fehler: MapiExceptionADPropertyError: Unable to mount database. (hr=0x80004005, ec=2418)

    Ereignis 231 ExchangeStoreDB

    '10.04.2018 09:37:05': Bei der Kopie der Datenbank 'Public Folder Database 2139936088' ist auf diesem Server beim Einbinden ein Fehler aufgetreten. Überprüfen Sie das Ereignisprotokoll auf dem Server für 'ExchangeStoreDb'- oder 'MSExchangeRepl'-Ereignisse, um weitere Informationen zu erhalten. Der Einbindungsvorgang wird später automatisch erneut ausgeführt. 

    Demnach versucht er die öffentliche Ordner Datenbank einzubinden, bekommt es aber nicht hin. Irgendetwas übersehe ich hier offensichtlich. Hat irgendjemand eine Idee wie ich hier weiter fortfahren soll? 

    Mit freundlichen Grüßen

    Gordon Marten


    Dienstag, 10. April 2018 08:03

Antworten

  • Moin,

    das ist ja mal echt die Kategorie "extrem scheiße gelaufen". :(

    Mir ist auch nicht klar, welchen Technet-Artikel Du meinst, aber ich rate mal, dass es um einen verwaisten Exchange 2003 Eintrag und der Public Folder Hierarchie ging.

    Allerdings hat das Löschen dieses Containers (egal ob der richtige "cn=servers" oder der falsche "cn=Erste administrative Gruppe" NICHTS mit der Datenbank des Exchange 2010 zu tun. Die Daten hierzu liegen in einem anderen Container im Abschnitt "CN=Exchange Administrative Group (FYDIBOHF23SPDLT)". Die öffentlichen Ordner sind dann potentiell weg, die Datenbank ansich aber noch vorhanden und mountbar.

    In Deiner Fehlerbeschreibung fehlt also irgendwas oder es wurde noch mehr gelöscht.

    1. DC mit Windows 2016 sind von Exchange 2010 nicht supportet und machen auch immer wieder mal Probleme. Die Umstellung der DC hätte erst NACH der Abschaltung von Exchange 2010 erfolgen dürfen.

    Potentiell könnte das Problem auch hierher kommen.

    2. Prüfe mal, ob der AD-Papierkorb aktiviert wurde. Wenn ja, kannst Du den kompletten Zweig eventuell daraus wiederherstellen.

    3. Es reicht natürlich nicht aus, einfach nur den Container "Erste Administrative Gruppe" neu anzulegen. Da hängen ja noch Objekte drunter und vorallem sind da auch immer wieder spezielle Sicherheitsberechtigungen gesetzt.

    Aus meiner sich ist das ein guter Zeitpunkt, dass AD-Backup zu prüfen und aus diesem eine authorative Wiederherstellung zu machen.

    Außerdem besteht die hohe Chance, dass ihr noch mehr kaputt macht und ich würde Euch raten, einen externen Fachmann dazu zu holen.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    • Als Antwort vorgeschlagen NobbyausHBModerator Donnerstag, 12. April 2018 05:56
    • Als Antwort markiert G.Marten Samstag, 14. April 2018 00:55
    Dienstag, 10. April 2018 10:49

Alle Antworten

  • Moin,

    das ist ja mal echt die Kategorie "extrem scheiße gelaufen". :(

    Mir ist auch nicht klar, welchen Technet-Artikel Du meinst, aber ich rate mal, dass es um einen verwaisten Exchange 2003 Eintrag und der Public Folder Hierarchie ging.

    Allerdings hat das Löschen dieses Containers (egal ob der richtige "cn=servers" oder der falsche "cn=Erste administrative Gruppe" NICHTS mit der Datenbank des Exchange 2010 zu tun. Die Daten hierzu liegen in einem anderen Container im Abschnitt "CN=Exchange Administrative Group (FYDIBOHF23SPDLT)". Die öffentlichen Ordner sind dann potentiell weg, die Datenbank ansich aber noch vorhanden und mountbar.

    In Deiner Fehlerbeschreibung fehlt also irgendwas oder es wurde noch mehr gelöscht.

    1. DC mit Windows 2016 sind von Exchange 2010 nicht supportet und machen auch immer wieder mal Probleme. Die Umstellung der DC hätte erst NACH der Abschaltung von Exchange 2010 erfolgen dürfen.

    Potentiell könnte das Problem auch hierher kommen.

    2. Prüfe mal, ob der AD-Papierkorb aktiviert wurde. Wenn ja, kannst Du den kompletten Zweig eventuell daraus wiederherstellen.

    3. Es reicht natürlich nicht aus, einfach nur den Container "Erste Administrative Gruppe" neu anzulegen. Da hängen ja noch Objekte drunter und vorallem sind da auch immer wieder spezielle Sicherheitsberechtigungen gesetzt.

    Aus meiner sich ist das ein guter Zeitpunkt, dass AD-Backup zu prüfen und aus diesem eine authorative Wiederherstellung zu machen.

    Außerdem besteht die hohe Chance, dass ihr noch mehr kaputt macht und ich würde Euch raten, einen externen Fachmann dazu zu holen.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    • Als Antwort vorgeschlagen NobbyausHBModerator Donnerstag, 12. April 2018 05:56
    • Als Antwort markiert G.Marten Samstag, 14. April 2018 00:55
    Dienstag, 10. April 2018 10:49
  • Hi,

    ja es ging um verwaiste Exchangeeinträge. Der Container im Abschnitt "CN=Exchange Administrative Group (FYDIBOHF23SPDLT)" wurde nicht angerührt und im Abschnitt CN=Databases stehen auch alle korrekt aufgelistet:

    CN=Exchange2016publicDB
    CN=Exchange2016UserDB
    CN=Mailbox Database 2011010119
    CN=PFProxyDatabase
    CN=Public Folder Database 2139936088
    CN=recovery
    CN=test123

    Die Datenbank ist an ihrem Pfad vorhanden und konsistent.

    1. Deswegen war noch der 2008R2 DC und ist auch Konfigurationsdomänencontroller für den Exchange. Die Funktionsebene ist entsprechend auch noch 2008R2. Die Umgebung lief bereits 1 Monat ohne Fehlermeldung und Probleme, sodass ich es eher für unwahrscheinlich halte das hier der Fehler liegt. Ausschließen mag ich es aber nicht.

    2. Leider ist der Papierkorb nicht aktivert...

    3. Die Objekte darunter wurden mittels LDP ja wiederhergestellt, nur der Container "Erste Administrative Gruppe" hatte keinen eigenen Tombstone, und ohne den Container kann man auch die untergeordneten Objekte nicht wiederherstellen. Durch das anlegen fehlen dann natürlich andere Dinge wie du schon beschrieben hast.

    Die authorative Wiederherstellung ist wohl die beste Option. Ich hab ein Backup 14h vor dem Fehler in dem alle Objekte noch dementsprechend noch vorhanden sind. Gibt es eine entsprechende brauchbare Anleitung? Replikation geschieht hier über DFSR. Das Dokument https://docs.microsoft.com/de-de/windows-server/identity/ad-ds/manage/ad-forest-recovery-authoritative-recovery-sysvol erscheint mir unvollständig.

    Dienstag, 10. April 2018 11:27
  • Hi,

    ich wollte mich noch einmal zurückmelden, wir haben die authoritative Wiederherstellung des Subtree "CN=erste administrative gruppe,CN=Administrative Groups,CN=Domain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain,DC=local" letztendlich gewählt und konten danach die Datenbank wieder einbinden.

    Mit freundlichen Grüßen

    Samstag, 14. April 2018 00:57