none
IISExpress VS2015 Windows10 mit Client verbinden (http, lokal) RRS feed

  • Allgemeine Diskussion

  • Hallo Leute,

    ich bin neu im Forum. Ich arbeite als Programmiererin mit Visual Basic und SQL-DB mit dem VS 2015. Außerdem entwickle ich Apps im Android-Studio, also mehr oder weniger im Backend-Bereich.

    Deshalb brauche ich jetzt dringend Eure Hilfe, denn ich möchte den DB-Zugriff einer Android-App testen. Die SQL-DB ist im lokalen Server (localdb)\MSSQLLocalDB aufgebaut. Ein Website, ausgeführt aus http ://localhost:39514/, mit ASP.NET Web API 2 und Entity Framework 6 soll für den Zugriff verwendet werden. Das VS 2015 verwendet IISExpress.

    Ich versuche vergeblich, auf diese Website zuzugreifen, und habe seit Tagen viele Foren durchsucht, aber leider noch keine Lösung gefunden, was z. T. daran liegt, das Beiträge sich nicht auf IISExpress oder VS2015 oder Windows10 bezogen, und ich sie dann nicht genauso umsetzen konnte.

    Bisher habe ich:

    1. Systemsteuerung, Windows Firewall, Erweiterte Einstellungen, Eingehende Regeln -->2 neue Regeln für Port 8080 und 39514 für TCP festgelegt, die eine Verbindung zulassen für Domäne+Privat+Öffentlich zulassen.

    2. Die Internet-Anbindung erfolgt über einen privaten Netzbetreiber und wird mittels Devolo-Technik im Haus ermöglicht, d. h. Adapter nutzen das hauseigene Stromnetz, um die Verbindung herzustellen. Der PC ist als Drahtlos-LAN-Adapter WiFi mit einer festen IP-Adresse ohne DHCP eingerichtet. Die IPv4 habe ich mit cmd und ipconfig ermittelt. Das Device mit der Android-App hat im LAN ebenfalls eine feste IP, und ist ständig mit dem WLAN (mit dem gleichen Router) verbunden.

    3. Am PC im Internet-Explorer  liefert http ://localhost:39514/api/pojekts/ alle DS und http ://localhost:39514/api/pojekts/?id=1 genau einen DS der Tabelle projekt, die u. a. in der SQL-DB über die API zur Verfügung gestellt wird.

    4. Die gleiche Eingabe im Google Chrom-Browser des Handys liefert jeweils nur:

    Bad Request - Invalid Hostname

    HTTP Error 400.The request hostname is invalid.

    Im Gegensatz zu vorherigen VS-Versionen finde ich 2 applicationhost.config -Dateien:

    In C:\Users\...\Documents\IISExpress\config\ steht:

            <sites>
                <site name="WebSite1" id="1" serverAutoStart="true">
                    <application path="/">
                        <virtualDirectory path="/" physicalPath="%IIS_SITES_HOME%\WebSite1" />
                    </application>
                    <bindings>
                        <binding protocol="http" bindingInformation=":8080:localhost" />
                    </bindings>
                </site>
                <siteDefaults>
                    <logFile logFormat="W3C" directory="%IIS_USER_HOME%\Logs" />
                    <traceFailedRequestsLogging directory="%IIS_USER_HOME%\TraceLogFiles" enabled="true" maxLogFileSizeKB="1024" />
                </siteDefaults>
                <applicationDefaults applicationPool="Clr4IntegratedAppPool" />
                <virtualDirectoryDefaults allowSubDirConfig="true" />
            </sites>
    

    und in C:\Users\...\Documents\Visual Studio 2015\Projects\projektname\.vs\config\

            <sites>
                <site name="WebSite1" id="1" serverAutoStart="true">
                    <application path="/">
                        <virtualDirectory path="/" physicalPath="%IIS_SITES_HOME%\WebSite1" />
                    </application>
                    <bindings>
                        <binding protocol="http" bindingInformation=":8080:localhost" />
                    </bindings>
                </site>
                <site name="ApiSlappIntern" id="2">
                    <application path="/" applicationPool="Clr4IntegratedAppPool">
                        <virtualDirectory path="/" physicalPath="c:\users\...\documents\visual studio 2015\Projects\projektname\projektname" />
                    </application>
                    <bindings>
                      <binding protocol="http" bindingInformation="*:39514:localhost" />
                    </bindings>
                </site>
                <siteDefaults>
                    <logFile logFormat="W3C" directory="%IIS_USER_HOME%\Logs" />
                    <traceFailedRequestsLogging directory="%IIS_USER_HOME%\TraceLogFiles" enabled="true" maxLogFileSizeKB="1024" />
                </siteDefaults>
                <applicationDefaults applicationPool="Clr4IntegratedAppPool" />
                <virtualDirectoryDefaults allowSubDirConfig="true" />
            </sites>

    Ich habe bereits versucht in die 2. Datei, nachfolgendes einzufügen:

    <binding protocol="http" bindingInformation="*:39514:192.1..." />
    <binding protocol="http" bindingInformation="*:80:(Computername)"/>
    <binding protocol="http" bindingInformation="*:39514:(Computername)"/>

    --> Es kam aber beim Start des Projekt dann immer:

    Microsoft Visual Studio

    Der lIS Express-Webserver kann nicht gestartet werden.

    Failed to register URL "http ://.../" for site "projektname" application “/’. Error description: Zugriff verweigert (0x80070005).

    Könnt Ihr mir bitte sagen, was ich ändern muss und in welcher Datei? Vielen Dank im Voraus! Auch, weil ich es toll finde , das ihr diesen langen Eintrag gelesen habt!

     Viele Grüße

     Bärbel



    • Bearbeitet Bärbel_H Mittwoch, 13. Juli 2016 10:36
    • Typ geändert Bärbel_H Donnerstag, 21. Juli 2016 08:02 keine Antwort bisher
    Mittwoch, 13. Juli 2016 10:23