none
Remotedesktop "Zugriff verweigert" RRS feed

  • Allgemeine Diskussion

  • Hallo,

    Habe folgende Konstellation:

    1 x Windows 2008 SBS SP2und 2 x Remotedesktopsitzungshosts (Terminalserver) Windows 2008 R2, RDP Clients gemischt (Windows XP SP3, Vista SP 2 und Windows 7 SP1)

    Habe manchmal das Problem, dass die Remotedesktopbenutzer sich plötzlich nicht mehr beim Remotdesktopserver (Terminalserver) anmelden können. Es kommt die Fehlermeldung "Zugriff verweigert". Das passiert immer wieder mal, mal geht es wochenlang ohne Anmeldungsprobleme und plötzlich wie aus dem Nichts bekommen die Benutzer diese Meldung.Wenn ich die Server alle neu starte, dann geht es wieder.

     

    Muss man eventuell bei den Remotedesktopsitzungshosts (Terminalservern) Service Pack 1 installieren. Wäre damit der Fehler behoben?

    Kennt jemand dieses Phänomen.

     

    Mit freundlichem Gruss

    Türkay

     

     

    Donnerstag, 29. September 2011 17:58

Alle Antworten

  • Am 29.09.2011 19:58, schrieb Türkay Caglayan:

    Service Pack 1 installieren. Wäre damit der Fehler behoben?

    Keine Ahnung aber es ist sicherlich Punkt 1 auf der Liste der
    auszuschliessenden Fehlermöglichkeiten.

    Das SP ist ja nicht zum selbstzweck entwickelt worden, oder als
    Kundenbeschäftigung, damit man alle 2 Jahre ne Stunden auf den
    Fortschrittsbalken schauen kann ... wahrscheinlich wurden damit Fehler
    behoben.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Donnerstag, 29. September 2011 18:20
  • Hallo,

    welche exakte Meldung wird angezeigt?
    Wurden am Server die Sicherheitseinstellungen des RDP Protokolls evlt. irgendwann mal angepasst?
    (sollte dies der Fall sein, kommt allerdings in der Regel eine andere Meldung und vor allem IMMER)

    Welche Fehler hast du im Eventlog des Clients und Servers zu diesem Zeitpunkt?

    Verwendet ihr NLA? (Network Level Authentication)?

    http://technet.microsoft.com/en-us/library/cc732713.aspx



    Donnerstag, 29. September 2011 19:46
  • Hallo,

     

    NLA verwende ich nicht.

     

    Ich kann nicht mal über den Administratorkonto auf die Terinmalserver per RDP in dieser Situation, obwohl ich die RDP Session von einem SBS Server starte, zugreifen.

     

    Ich kann doch nicht der Einzige sein, der dieses Problem hatte.

    Mit freundlichem Gruss

    Türkay

    Freitag, 30. September 2011 04:47
  • Ich habe seit heute Morgen auf 3 Kunden Servern das selbe Problem! Habe diese vorgestern voll- durch- gepatcht.

    Freitag, 30. September 2011 06:05
  • Neustart behebt das Problem, ist aber anzunehmen, dass dies nur Temporär so bleibt...
    Freitag, 30. September 2011 06:12
  • Am 30.09.2011 06:47, schrieb Türkay Caglayan:

    Ich kann doch nicht der Einzige sein, der dieses Problem hatte.

    Klar kannst du das, warum nicht?

    Aber davon ab: Stimmen die Uhrzeiten auf allen Rechnern?

    Und:
    Verwendest du ein automatisch generiertes RDP zertifikat oder ein
    selbsterstelltes? Ersteres läuft alle 6 Monate aus ... und wenn der
    CLient die Verbindungsdaten gespeichert hast, der Server aber mit dem
    falschen Zertifikate antwortet ...

    Verwende deine PKI des SBS und erstelle ein zB 5 Jahre gültiges
    ServerZertifikat und verwende dieses.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Freitag, 30. September 2011 07:52
  • Leider fehlen mir noch die Antworten auf diese Fragen:

    >welche exakte Meldung wird angezeigt?

    >Welche Fehler hast du im Eventlog des Clients und Servers zu diesem Zeitpunkt?

    Zusätzlich würde ich einmal prüfen, welche Benutzer das Privileg "Anmelden über Remotedesktopdienste zulassen" haben.
    (per rsop.msc auf dem jeweiligen TS).

    Prüfe bitte auch diese Einstellungen am Server (bzw. setze sie auf default):

    http://blog.icewolf.ch/archive/2011/04/14/security-settings-on-remote-desktop-protocol-rdp.aspx

     

     

    Freitag, 30. September 2011 08:23
  • Hallo Matthias,

    muss ich mal die Ereignisanzeige anschauen, kann dir momentan keine exakteren Daten geben.

     

    Aber werde die Benutzer mal prüfen und die RDP Einstellungen anschauen. Bei den RDP Einstellungen habe ich aber nichts umgestellt, müssten die Default Einstellungen sein.

    Die Fehlermeldung beim RDP Verbindung bekomme ich schon:

    Die identität des remotecomputers kann nicht überprüft werden. möchten sie die verbindung dennoch herstellen.

     

    Ich klicken dann "auf die identität des remotecomputers kann nicht überprüft werden. möchten sie die verbindung dennoch herstellen" und sage Ja und danach kann man arbeiten.

    Liegt das vielliecht daran, dass die Remotedesktopclients sich deswegen irgendwann mal nicht mehr anmelden können und nur durch Serverneustarts die Verbindung wieder klappt? Wenn ja wie kann ich dieses Problem lösen.

    Danke.

     

    Mit freundlichem Gruss

    Türkay

    Samstag, 1. Oktober 2011 18:02
  • >muss ich mal die Ereignisanzeige anschauen, kann dir momentan keine exakteren Daten geben

    Ja, schau dir die Eventlogs noch einmal an.

    >Ich klicken dann "auf die identität des remotecomputers kann nicht überprüft werden. möchten sie die verbindung dennoch herstellen" und sage Ja >und danach kann man arbeiten.

    Von der Fehlermeldung her würde das ganze klar in Mark's Richtung gehen.

    Mit Zugriff verweigert hat das nichts zu tun.

    Es wird sich also vermutlich um eine Problem mit dem Zertifikat bzw. Kerberos handeln.

    PS:

    Dann wären wir doch wieder beim Thema NLA.



    Samstag, 1. Oktober 2011 18:19
  • Hallo,

    bist Du inzwischen weitergekommen?

    Gruss,
    Raul

    Dienstag, 4. Oktober 2011 14:35
    Moderator