none
Microsoft Server SQL 2012 auf 2008 RRS feed

  • Frage

  • Gibt es eine Möglichkeit meine Daten aus 2012 in eine Datenbank zu importieren die unter 2008 läuft?

    Außerdem möchte ich wissen, ob es Möglich ist mit der 2008er Version eine Verbindung von Excel (Client) auf die SQL-Datenbank (Server) herzustellen.

    Vielen Dank für Eure Antworten.

    Montag, 11. Januar 2016 07:58

Antworten

  • Hallo Hase90,

    In der Regel wird ein Wechsel (ganze Datenbank) von einer neueren SQL Server Version in eine ältere nicht unterstützt. Die reinen Daten lassen aber durchaus kopieren.

    Die Verbindung von Excel zum SQL Server kann beispielsweise über eine ODBC Schnittstelle hergestellt werden.



    Benjamin Hoch
    MCSE: Data Platform,
    MCSA: Windows Server 2012,


    Montag, 11. Januar 2016 08:09
  • Wenn ich den Datenverbindungs-Assistent öffne und eine Verbindung zu dem Server "SRV02\SQLEXPRESS" herstellen möchte, bekomme ich folgende Fehlermeldung [...]


    Hier lag der Fehler: Ich habe jetzt einfach "SRV02" eingegeben und dann hat es funktioniert. Vielen Dank für die Mithilfe!

    • Bearbeitet Hase90 Freitag, 18. März 2016 09:19
    • Als Antwort markiert Hase90 Freitag, 18. März 2016 09:19
    Freitag, 18. März 2016 09:18

Alle Antworten

  • Hallo Hase90,

    In der Regel wird ein Wechsel (ganze Datenbank) von einer neueren SQL Server Version in eine ältere nicht unterstützt. Die reinen Daten lassen aber durchaus kopieren.

    Die Verbindung von Excel zum SQL Server kann beispielsweise über eine ODBC Schnittstelle hergestellt werden.



    Benjamin Hoch
    MCSE: Data Platform,
    MCSA: Windows Server 2012,


    Montag, 11. Januar 2016 08:09
  • Hallo Hase,

    ein Beispiel für einen Downgrade findest Du unter:

    How to migrate a SQL Server database to a lower version

    Willst Du nur einige Tabellen / Daten übertragen so kannst Du mit den SQL Server Integration Services (auch komplexe) Pakete erstellen, um die Daten zu einer anderen SQL Server Instanz übertragen, die auch eine niedrigere Versionsnummer haben kann.

    Im Falle einer einmaligen Übertragung kann das auch über den Assistenten im obigen Artikel passieren.

    Wie Benjamin schon schreibt bietet Excel ein ODBC Schnittstelle

    Gruß Elmar

    Montag, 11. Januar 2016 08:35
    Beantworter
  • Hallo,

    ich habe noch eine ergänzendeFrage:

    https://www.microsoft.com/de-de/download/details.aspx?id=30438

    Kann ich diese Verison auf einem Server installieren und per Excel auf den Server zugreifen? Reicht dafür die Express-Version aus?


    • Bearbeitet Hase90 Mittwoch, 27. Januar 2016 09:05
    Mittwoch, 27. Januar 2016 09:05
  • Ja, aber warum nimmst Du keine aktuelle Version?
    https://www.microsoft.com/de-de/search/result.aspx?q=sql+server+express+2014&form=MSHOME
     Einen schönen Tag noch,
    Christoph
    --
    Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Mittwoch, 27. Januar 2016 09:12
  • Perfekt danke!
    Mittwoch, 27. Januar 2016 09:16
  • Falls Du unter "mit Excel zugreifen" meinst, einen Analysis Server zu verwenden, wird es mit Express nicht gehen.
    Hier findest Du einen Überblick über die Features der einzelnen Editionen:
    https://msdn.microsoft.com/de-de/library/cc645993(v=sql.120).aspx

    Einen schönen Tag noch,
    Christoph
    --
    Data Platform MVP - http://www.insidesql.org/blogs/cmu

    • Als Antwort vorgeschlagen Benjamin.Hoch Freitag, 19. Februar 2016 07:59
    Mittwoch, 27. Januar 2016 09:18
  • Wenn ich den Datenverbindungs-Assistent öffne und eine Verbindung zu dem Server "SRV02\SQLEXPRESS" herstellen möchte, bekomme ich folgende Fehlermeldung:

    [DBNETLIB][ConnectionOpen (Connect().]SQL Server existiert nicht oder Zugriff verweigert. 

    Der Server existiert definitiv. Ich habe auf dem Server unter "Windows-Firewall mit erweiterter Sicherheit"-> ausgehende Regeln -> SQL Server Remoteverbindung zu Webseiten -> Bereich -> Remote IP-Adresse die IP-Adresse hinterlegt. 

    Außerdem habe ich im SQL Management Studio den Benutzer hinzugefügt (Bei Benutzern und Anmeldung). Ich kann auf dem Server mich mit dem Benutzernamen anmelden. Aber nicht von Excel aus, dann erhalte ich besagte Fehlermeldung. 

    Woran kann das liegen? Unterstützt Express die Funktion, die ich nutzen möchte, nicht?

    Ich freue mich auf Eure Antworten.

    Montag, 14. März 2016 11:41
  • Hallo 

    du musst auf dem Server eine "eingehende Regel" erstellen welche den Port 1433 (Standard) öffnet.

    Gruß Benjamin


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Montag, 14. März 2016 11:50
  • Das habe ich auch gemacht. 1433 und 1434 unter lokaler Port -> Bestimmte Ports.
    • Bearbeitet Hase90 Montag, 14. März 2016 11:54
    Montag, 14. März 2016 11:54
  • Hallo Hase90

    prüfe doch bitte mal im SQL Server Konfigurations Manager welche Netzwerkprotokolle aktiviert sind.


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Montag, 14. März 2016 12:20
  • Am 14.03.2016 schrieb Hase90:

    Das habe ich auch gemacht. 1433 und 1434 unter lokaler Port -> Bestimmte Ports.

    1433 TCP eingehend. 1434 UDP eingehend. Ist der Dienst SQL Browser
    gestartet? Wenn nein, starte ihn.

    Prüfe auch ob der SQL Server auch wirklich auf Port 1433 eingestellt
    ist.
    https://alexanderzeitler.com/articles/Auf-welchem-Port-l%C3%A4uft-mein-SQL-Server-%28Express%29-2008-R2-Oder-warum-bekomme-ich-keine-Verbindung/

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Montag, 14. März 2016 17:09
  • Ich habe bei den Protokollen TCP/IP und SharedMemory jetzt auf aktiv gestellt. Ich kann aber nicht den SQL Browser aktivieren (siehe Bild). Habt ihr eine Idee woran das liegen kann?

    Außerdem habe ich bei den Eingeschafen von TCP/IP geschaut (wie in dem Link beschrieben) und dort ist bei Dynamische TCP-Ports jeweils eine 0 eingetragen. 

    Wie ändere ich, dass 1433 TCP und 1434 UDP eingestellt ist? Anbei mal ein weiteres Bild, wie es bei mir aussieht:

    • Bearbeitet Hase90 Freitag, 18. März 2016 06:29
    Freitag, 18. März 2016 06:23
  • Guten morgen,

    SQL Server Dienste sollte man generell über den Konfigurations Manager des SQL Server verwalten. Wie viele Instanzen sind auf dem Server installiert? Wenn es nur die Standard Instanz ist wird der Browser auch nicht benötigt.


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 06:28
  • Bisher nur eine Instanz, aber in naher Zukunft eine zweite. 
    Freitag, 18. März 2016 06:31
  • Poste doch bitte mal einen Screenshot der folgenden Einstellung

    SQL Konfig. Manager -> Netzwerkkonfig. -> Eigenschaften TCP/IP -> IPall


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 06:38
  • Freitag, 18. März 2016 06:41
  • Dein SQL Server arbeitet mit einem dynamischen Port. Entweder änderst du die Firewall Regel so ab dass die Anwendung SQL Server freigegeben ist (also ohne Posts) oder du ersetzt in der Konfiguration IPall die Option "dynamische TCP Ports" auf "" (leeres Feld) und den Port auf 1433.

    für Variante 1. muss aber der SQL Browser laufen.


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog


    Freitag, 18. März 2016 07:55
  • Wenn ich das Feld für dynamische TCP Ports leer lasse wird beim erneuten Öffnen wieder eine 0 angezeigt. 

    Das Problem besteht leider weiterhin.

    Schon mal vielen Dank für Eure Mühe!

    Freitag, 18. März 2016 08:08
  • War der SQL Server Dienst zu dem Zeitpunkt angehalten? Wenn nicht einfach mal versuchen sofern im Betrieb möglich. Oder aber die Firewall neu konfigurieren dass dort dynamische Posts erlaubt sind.

    https://support.microsoft.com/de-de/kb/823938


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 08:13
  • Der Dienst war zuerst nicht angehalten. Habe es dann noch einmal probiert, indem ich erst den Dienst angehalten habe, dann die Änderungen vorgenommen habe und anschließend den Dienst wieder gestartet habe. Jetzt steht auf einmal bei IPALL-> Dyanmische TCP-Ports: "51439" und ich kriege die Zahl nicht mehr weg. 

    Was genau muss ich jetzt einstellen bei den Eigenschaften von TCP/IP, damit es funktioniert? Die "Anleitung", die Du gepostet hast hilft mir irgendwie nicht weiter. 

    Freitag, 18. März 2016 08:30
  • Dann verwendest du nicht die Stndard Instanz sondern eine benannte Instanz, diese nutzen dynamische Posts. Ändere die Firewall Regel so ab dass der Dienst SQL Server auf jedem Port erreichbar ist und starte den SQL Browser.


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 08:39
  • Wenn möglich würde ich gerne noch etwas überprüfen. Führe bitte mal den folgenden TSQL Code im SSMS aus und poste das Ergebnis

    SELECT	servicename								AS	[SQL Server Service],
    		startup_type_desc						AS	[Start Type],
    		status_desc								AS	[current status], 
    		last_startup_time						AS	[last startup],
    		service_account							AS	[Service Account],
    		[filename]								AS	[start command]
    FROM	sys.dm_server_services WITH (NOLOCK);
    GO
    


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 08:53
  • SQL Server Service	Start Type	current status	last startup	Service Account	start command
    SQL Server (SQLEXPRESS)	Automatic	Running	2016-03-18 09:30:41.0369788 +01:00	NT Service\MSSQL$SQLEXPRESS	"c:\Program Files\Microsoft SQL Server\MSSQL11.SQLEXPRESS\MSSQL\Binn\sqlservr.exe" -sSQLEXPRESS
    SQL Server-Agent (SQLEXPRESS)	Disabled	Stopped	NULL	NT AUTHORITY\NETWORKSERVICE	"c:\Program Files\Microsoft SQL Server\MSSQL11.SQLEXPRESS\MSSQL\Binn\SQLAGENT.EXE" -i SQLEXPRESS
    Freitag, 18. März 2016 09:08
  • hier nochmal etwas für den SQL Express, vielleicht hilft dies ja etwas weiter

    http://support.webecs.com/kb/a868/how-do-i-configure-sql-server-express-to-allow-remote-tcp-ip-connections-on-port-1433.aspx

    https://msdn.microsoft.com/de-de/library/ms175043(v=sql.120).aspx


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Freitag, 18. März 2016 09:11
  • Wenn ich den Datenverbindungs-Assistent öffne und eine Verbindung zu dem Server "SRV02\SQLEXPRESS" herstellen möchte, bekomme ich folgende Fehlermeldung [...]


    Hier lag der Fehler: Ich habe jetzt einfach "SRV02" eingegeben und dann hat es funktioniert. Vielen Dank für die Mithilfe!

    • Bearbeitet Hase90 Freitag, 18. März 2016 09:19
    • Als Antwort markiert Hase90 Freitag, 18. März 2016 09:19
    Freitag, 18. März 2016 09:18
  • Weiter oben habe ich die Lösung gepostet. Der Fehler lag am Servernamen "SRV02\SQLEXPRESS" war falsch. Richtig ist ohne SQLEXPRESS.
    Freitag, 18. März 2016 09:20
  • Am 18.03.2016 schrieb Hase90:

    Ich habe bei den Protokollen TCP/IP und SharedMemory jetzt auf aktiv gestellt. Ich kann aber nicht den SQL Browser aktivieren (siehe Bild). Habt ihr eine Idee woran das liegen kann?



    <https://social.msdn.microsoft.com/Forums/getfile/828322>

    Benjamin hat Recht, SQL Serer Dienste solltest Du immer nur im SQL
    Server Konfigurationsmanager konfigurieren. Den SQL Server Browser
    Dienst mußt Du erst auf Automatisch stellen, Doppelklick auf den
    Dienst, umstellen auf Automatisch, jetzt kannst Du den Dienst starten.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Freitag, 18. März 2016 14:28