none
Migration E2K7 nach E2K10 RRS feed

  • Frage

  • Hallo zusammen,

    ich möchte eine Migration von E2k7 nach E2K10 machen. Nun habe ich schon die Mailboxen auf den neuen Exchange geschoben. Wenn ich allerdings auf dem Client das globale Adressbuch herunterladen will kommt ein Fehler der besagt dass der Client das Adressbuch nicht herunterladen kann. Zum anderen sind bei manchen Usern noch Verbindungen zur öffentlichen Ordner Datenbank des alten Exchange offen. Ich denke das werden die free/busy-Zeiten sein da es in dieser Organisation keine öffentlichen Ordner gibt. Mein Ziel war es eigentlich auf dem Exchange 2010 ohne öffentliche Ordner zu arbeiten. Geht das denn dann überhaupt? Oder muss ich dann jetzt auch wieder öffentliche Ordner anlegen wegen der Free/Busy-Zeiten?

    Was auch noch komisch ist, ist dass viele Benutzer eine Verbindung zum öffentlichen Ordner des alten Exchange aufbauen, aber einige User haben diese Verbindung nicht im Verbindungsstatus. Wir nutzen Outlook 2007 SP3. 

    Vielen Dank für Eure Hilfe im Voraus.

    Viele Grüße

    Andi


    Dienstag, 29. Mai 2012 06:39

Antworten

  • Hallo Timo und Robert,

    vielen Dank, Eure Antworten haben mir sehr geholfen, jetzt geht wieder alles.

    Viele Grüße

    Andi

    Freitag, 8. Juni 2012 08:45
  • Hallo Timo, hallo Robert,

    funktioniert wieder alles wunderbar, nochmals vielen Dank für Eure Hilfe.

    Viele Grüße

    Andi

    Freitag, 8. Juni 2012 08:47

Alle Antworten

  • Hallo,

    was für Clients hast du im Einsatz? Outlook 2003 braucht zwingend eine ÖO-Datenbank....

    Grüße,

    Toni

    Dienstag, 29. Mai 2012 06:44
  • Das sind zum Großteil Outlook 2007, ein oder 2 Outlook 2003 sind dabei.

    Gruß
    Andi

    Dienstag, 29. Mai 2012 06:54
  • Hallo Andi,

    wie Toni bereits geschrieben hat, wenn du Outlook älter als 2007 im Einsatz hast, brauchst du zwingend eine Public Folder DB.

    Hast du sonst keine Öffentlichen Ordner in Verwendung?

    Erzeuge eine PF-DB und repliziere die vom 2007 auf den 2010, Befehle am besten in der Shell verwenden.

    Auf dem 2010 gibt es im Scripts-Verzeichniss dazu ein paar.

    ;)


    Gruß Norbert

    Dienstag, 29. Mai 2012 07:04
    Moderator
  • Hallo Norbert,

    vielen Dank für die Antwort. Ich brauche die öffentlichen Ordner eigentlich nur wegen der Free/Busy Zeiten. Die Organisation nutzt keine öffentlichen Ordner.

    Somit muss ich "nur" die Free/Busy-Zeiten replizieren.

    Viele Grüße

    Andi

    Dienstag, 29. Mai 2012 07:31
  • Bzgl. OAB: Führ mal in der Powershell folgendes aus:

    Get-OabVirtualDirectory -Server <<CAS-Server>> | fl path

    Dann geh mal in das Verzeichniss und schaue, ob dort das OAB überhaupt schon liegt. Wenn nicht, starte mal den Dienst "Microsoft Exchange File Distribution" neu. Mehr Infos zum OAB und der Verteilung gibt es hier: http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/offline-address-book-part1.html

    Dienstag, 29. Mai 2012 08:25
  • Hallo,

    bei mir liegt das OAB in folgendem Pfad: C:\Program Files\Exchange Server\V14\ClientAccess\OAB. dort ist dann ein Ordner dessen Namen aus Zahlen und Buchstaben besteht.

    Nun habe ich auf dem E2K7 den E2K10 unter den öffentlichen Ordnern Verwaltungstolls hinzugefügt. Auf dem E2K7 sthet der E2K10 jetzt als Replikationspartner fest. Wenn ich allerdings auf den E2K1o unter den öffentlichen Ordnern Verwaltungstools schaue, dann steht bei Elemente gesamt, Größe (in kb), öffentliche Ordner Datenbank und geändert überall folgendes  drin: Nicht verfügbar auf diesem Server.

    Dauert das bis die Replikation zwischen beiden Exchange startet? Kann man die von Hand anstossen?

    Viele Grüße

    Andi

    Dienstag, 29. Mai 2012 10:14
  • Du kannst das pushen:

    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\/o=<<Orgname>>/cn=addrlists/cn=oabs/cn=Default-Offline Address Book' -Server '<<Quellserver>>'
    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\/o=<<Orgname>>/cn=addrlists/cn=oabs/cn=Default-Offline Address Book\OAB Version 2' -Server '<<Quellserver>>'
    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\/o=<<Orgname>>/cn=addrlists/cn=oabs/cn=Default-Offline Address Book\OAB Version 3a' -Server '<<Quellserver>>'
    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\/o=<<Orgname>>/cn=addrlists/cn=oabs/cn=Default-Offline Address Book\OAB Version 4'-Server '<<Quellserver>>'
    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\EX:/o=<<Orgname>>/ou=<<OU>>' -Server '<<Quellserver>>'
    Update-PublicFolder -Identity '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\EX:/o=<<Orgname>>/ou=Exchange Administrative Group (<<ID>>)' -Server '<<Quellserver>>'

    Halt die Platzhalter entsprechend anpassen. Bei uns ging das damals wegen dem Virenscanner nicht richtig. Der hat irgendwelche Sachen in die e-Mail Header mit reingeschrieben. Der Sync geht ja über Mails. Ich musste zuerst den Virenscanner abschalten (die Transportagents deaktivieren) und dann nochmal die Replicas einrichten, dann ging es.

    Dienstag, 29. Mai 2012 10:44
  • Hallo Dome,

    kann ich das denn auch für die Free/Busy-Zeiten? Ich habe heute morgen auf dem E2K10 eine PF-DB angelegt. Dann habe ich auf den PF-Verwaltungstools des E2K7 geöffnet, bin zu Free/Busy gegangen auf die Eigenschaften und dann habe ich unter Replikation den E2K10 eingetragen. Im alten sehe ich Daten, im neuen nicht. Ist das normal das es so lange dauert oder kann ich das auch manuell starten?

    Viele Grüße

    Andi

    Dienstag, 29. Mai 2012 12:52
  • Hallo Andi,

    ich habe mir den Thread gerade nochmal durchgelesen. Wenn ich das richtig verstanden habe, dann hast Du zum einen ein Problem mit dem OAB Download und zum anderen Frage bzgl. FB über Public Folder.

    Fangen wir mal mit dem OAB an:

    1. Überprüfe bitte auf welchem Server Dein OAB derzeit erstellt wird: Organization Configuration -> Mailbox -> Offline Address Book und dort die Spalte "Generation Server". Wird hier nicht Dein Exchange 2010 angezeigt, dann Rechtsklick auf das OAB und "Move".

    2. Dann überprüfst Du in den Eigenschaften des OABs unter Distribution, ob "Outlook 2003 SP2 or later" aktiviert ist und ob Dein Exchange 2010 in der Liste der Web-based Distribution Points auftaucht. Wenn nicht, bitte hinzufügen bzw. aktivieren. In Deinem Fall, da Du ja noch Outlook 2003 Clients hast, musst Du auch den Haken bei "Enable public folder distribution" setzen.

    3. Das OAB wird standardmäßig morgens um 5:00 generiert. Da wir nicht solange warten wollen, Rechtsklick auf das OAB und "Update".

    4. Jetzt überprüfen wir noch die Datenbanken. In den Eigenschaften jeder Datenbank muss unter "Client Settings" das OAB eingetragen sein. Wenn nicht bitte hinzufügen.

    5. Unter "C:\Program Files\Exchange Server\V14\ExchangeOAB\<GUID>" solltest Du nun aktuelle Dateien finden, die Dein OAB repräsentieren. Dann schaust Du auch nochmal unter "C:\Program Files\Exchange Server\V14\ClientAccess\OAB\<GUID>" ob die Dateien hier auch mit einem aktuellen Zeitstempel angekommen sind. Wenn nicht, starte wie von Dominik vorgeschlagen, den "Microsoft Exchange File Distribution" Dienst durch und schau, ob sich was ändert.

    Nun sollte Dein Outlook Client in der Lage sein das OAB herunterzuladen. Wenn nicht bitte genauen Fehlercode posten. Aktiviere dann auch mal das Logging wie unter http://office.microsoft.com/en-us/outlook-help/what-is-the-enable-logging-troubleshooting-option-HA001230421.aspx beschrieben, versuche das OAB erneut herunterzuladen und schaue anschließend in das Outlook HTTP Log unter "C:\Users\user name\AppData\Local\Temp\Outlook Logging\HTTP-someoneexamplecom-05_17_2007-10_41_24_724.log" nach Fehlern.

    Du kannst auch mal OCAT laufen lassen und schauen ob da irgendwelche Fehler oder Warnings ausgegeben werden: http://blogs.technet.com/b/exchange/archive/2012/03/05/released-outlook-configuration-analyzer-tool-ocat.aspx

    Nun zu FreeBusy:

    Wie Norbert und Toni schon geschrieben haben, braucht Outlook 2003 die Öffentlichen Ordner. Outlook 2007 und 2010 machen das etwas anders und hier bräuchtest Du für FB keine Öffentlichen Ordner mehr. Das gilt übrigens auch für das OAB. Falls Du also Deine 1-2 2003 Clients weiterhin laufen lassen möchtest, dann repliziere die Ordner für FB und OAB. Leider ärgert uns hier die Konsole und Shell dann aber etwas und zeigt in den Statistiken immer 0 Elemente an, obwohl die Items eigentlich da sind. Hier könntest Du z.B. mit Tools wie MFCMapi oder ExFolders in den Ordner schauen oder einfach mal den Test machen, indem Du die 2007 PF Datenbank zu einem unkritischen Zeitpunkt dismountest und dann mit einem 2003 Client nachschaust.


    Ich hoffe das hilft Dir nun etwas weiter. Melde Dich gerne, wenn Du noch Unterstützung brauchst.

    Viele Grüße
    Timo

     

    Dienstag, 29. Mai 2012 20:25
    Moderator
  • Hallo Timo,

    erst mal vielen Dank für Deine sehr ausführlich Anleitung. Ich habe das mit dem OAB gerade alles durchgemacht. In dem Ordner unter "C:\Program Files\Exchange Server\V14\ExchangeOAB\<GUID>" befindet sich eine Datei namens "oab.xml" und trägt den Zeitstempel vom 30.05.2012 23:22 Uhr, also von gerade. Das OAB lässt sich aber vonm Oztlook-Client aus nicht herunterladen. Ich habe es unter "Extras; Senden/Empfangen; Adressbuch herunterladen" gemacht und den Haken bei "Änderungen seit der letzten Übermittlung herunterladen" heraus genommen. Dann dauert es kurz und es kommt die Meldung: Fehler(0x8004010F) beim Ausführen der Aufgabe name@domäne.de: Fehler beim Vorgang. Ein Objekt kann nicht gefunden werden.

    Wenn ich den ExBPA laufen lasse, dann wird folgender Fehler angezeigt:

    'Administratoren' hat für den Ordner 'C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OAB\348c9d1b-0bf3-474b-909e-24a6d8434c43' auf dem Server EXCH01.domain.local nicht die Berechtigung 'Vollzugriff'. Dadurch können Clients das Offlineadressbuch nicht über HTTP(s) herunterladen. Fügen Sie dieser Gruppe die Berechtigung 'Vollzugriff' für diesen Ordner hinzu. Dies gilt für Administratoren, Authentifizierte Benutzer, Domänen Admisn und Organisationsadmins. Wenn ich aber auf dieses Verzeichnis, dann auf Sicherheit und Erweitert um die effektiven Rechte zu prüfen, dann haben alle Vollzugriff.

    Zum Thema Public Folder: Ich habe Exfolders herunter geladen und mich dann auf den E2K10 verbunden. Wenn ich dann auf "Schedule Free Busy" gehe und dann auf "Propagate Replica List" und dann den E2k7 anhake, dann kommt im Hintergrund die Meldung: Operation complete, wenn ich dann aber auf "Items" gehe dann kommt die Meldung "No replicas here".

    Hast Du da noch eine Idee?

    Viele Grüße und vielen Dank.


    Andi

    Mittwoch, 30. Mai 2012 21:51
  • Moin,

    erst mal vielen Dank für Deine sehr ausführlich Anleitung. Ich habe das mit dem OAB gerade alles durchgemacht. In dem Ordner unter "C:\Program Files\Exchange Server\V14\ExchangeOAB\<GUID>" befindet sich eine Datei namens "oab.xml" und trägt den Zeitstempel vom 30.05.2012 23:22 Uhr, also von gerade. Das OAB lässt sich aber vonm Oztlook-Client aus nicht herunterladen. Ich habe es unter "Extras; Senden/Empfangen; Adressbuch herunterladen" gemacht und den Haken bei "Änderungen seit der letzten Übermittlung herunterladen" heraus genommen. Dann dauert es kurz und es kommt die Meldung: Fehler(0x8004010F) beim Ausführen der Aufgabename@domäne.de <mailto:name@domäne.de>: Fehler beim Vorgang. Ein Objekt kann nicht gefunden werden.

    eine kurze Suche nach "0x8004010F" findet 115,000 Treffer, u.a. diese hier:
    http://support.microsoft.com/kb/905813/de
    http://support.microsoft.com/kb/939765/de

    Kurz gesagt: Das OAB wird nicht gefunden und muss von vorne bis hinten mal gecheckt werden - inkl. den URLs zur Veröffentlichung und den Zertifikaten.

    Wenn ich den ExBPA laufen lasse, dann wird folgender Fehler angezeigt:

    'Administratoren' hat für den Ordner 'C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OAB\348c9d1b-0bf3-474b-909e-24a6d8434c43' auf dem Server EXCH01.domain.local nicht die Berechtigung 'Vollzugriff'. Dadurch können Clients das Offlineadressbuch nicht über HTTP(s) herunterladen. Fügen Sie dieser Gruppe die Berechtigung 'Vollzugriff' für diesen Ordner hinzu. Dies gilt für Administratoren, Authentifizierte Benutzer, Domänen Admisn und Organisationsadmins. Wenn ich aber auf dieses Verzeichnis, dann auf Sicherheit und Erweitert um die effektiven Rechte zu prüfen, dann haben alle Vollzugriff.

    Den Fehler kannst Du ignorieren, wenn Du die Berechtigungen geprüft hast. Das ist ein Übersetzungsproblem (Administratoren <-> Administrators).

    Zum Thema Public Folder: Ich habe Exfolders herunter geladen und mich dann auf den E2K10 verbunden. Wenn ich dann auf "Schedule Free Busy" gehe und dann auf "Propagate Replica List" und dann den E2k7 anhake, dann kommt im Hintergrund die Meldung: Operation complete, wenn ich dann aber auf "Items" gehe dann kommt die Meldung "No replicas here".

    Hast Du da noch eine Idee?

    ExFolder solltest Du nur im Notfall anwenden, bitte erstmal mit den Bordmitteln ein Replikat hinzufügen. Das Befüllen kann aber danach problemlos mehrere Tage dauern.

    Und noch mal zum Üben:
    Ol2007 / Ol2010 -> Download des OAB via HTTPS -> die XML-Datei.
    Ol2003 -> Download des OAB via PublicFolder

    ;)


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Donnerstag, 31. Mai 2012 07:22
  • Hallo Robert,

    vielen Dank für Deine schnelle Antwort. Ich habe die Replikation am Montag gegen 11:00 Uhr angestossen, das sollte doch genügen zum replizieren, oder? Ich habe auf dem alten Exchange 2007 unter "Toolbox", dann "Öffentliche Ordner-Verwaltungskonsole", dann auf "Schedule+Free Busy" dann auf Replikation und dann den neuen Exchange eingetragen. Dann auf dem neuen Exchange habe ich es ebenso gemacht, nur dass ich da dann den alten Exchange eingetragen habe. Das passt doch so, oder?

    Viele Grüße
    Andi

    Donnerstag, 31. Mai 2012 08:28
  • Moin,

    vielen Dank für Deine schnelle Antwort. Ich habe die Replikation am Montag gegen 11:00 Uhr angestossen, das sollte doch genügen zum replizieren, oder?

    Normalerweise schon.

    Ich habe auf dem alten Exchange 2007 unter "Toolbox", dann "Öffentliche Ordner-Verwaltungskonsole", dann auf "Schedule+Free Busy" dann auf Replikation und dann den neuen Exchange eingetragen. Dann auf dem neuen Exchange habe ich es ebenso gemacht, nur dass ich da dann den alten Exchange eingetragen habe. Das passt doch so, oder?

    Das verstehe ich nicht. Was wurde wo eingetragen?


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Donnerstag, 31. Mai 2012 08:35
  • Hallo Timo und Robert,

    vielen Dank, Eure Antworten haben mir sehr geholfen, jetzt geht wieder alles.

    Viele Grüße

    Andi

    Freitag, 8. Juni 2012 08:45
  • Hallo Timo, hallo Robert,

    funktioniert wieder alles wunderbar, nochmals vielen Dank für Eure Hilfe.

    Viele Grüße

    Andi

    Freitag, 8. Juni 2012 08:47