none
Nicht Gelöst: Berechtigungen für Windows Search-Datenverzeichnis: Emails nicht vollständig indexiert.

    Frage

  • Hallo,

    habe jetzt lange im Internet und diversen Foren gesucht: es gibt eine Menge ähnlicher Postings aber scheinbar keine (bekannte) Lösung für das Problem.

    Das Problem: die Suche in Outlook funktioniert a) langsam und b) unzuverlässig (nicht alle Emails/Kontakte werden gefunden)

    Habe den Index schon mal neu aufgebaut (Systemsteuerung) aber es half nicht. Wenn ich nun auf Problemhilfe (im Indexierungseintrag in der Systemsteuerung) klicke, erhalte ich folgende Meldung:


    Suche und Indizierung
    Herausgeberdetails
    Gefundene Probleme
    Nicht behoben
    Nicht behoben
    Korrekte Berechtigungen für Windows Search-Verzeichnisse wiederherstellen
    Abgeschlossen
    Überprüfte, potenzielle Probleme
    Thema nicht vorhanden
     
    Thema nicht vorhanden
     
    Thema nicht vorhanden
     
    Thema nicht vorhanden
     
    Thema nicht vorhanden
     
    Thema nicht vorhanden
     
    Gefundene Probleme
    Erkennungsdetails
    5
    Falsche Berechtigungen für Windows Search-Verzeichnisse
    Nicht behoben
    Nicht behoben
    Wenn in den Datenverzeichnissen von Windows Search falsche Berechtigungen gesetzt sind, kann der Suchindex des Computers möglicherweise nicht vom Suchdienst abgerufen oder aktualisiert werden. Dies kann zu langsamen Suchvorgängen oder unvollständigen Suchergebnissen führen.
    Fehler
    Datenverzeichnisberechtigungen
    Berechtigungen für Windows Search-Datenverzeichnis
    NT-AUTORITÄT\SYSTEM
    Korrekte Berechtigungen für Windows Search-Verzeichnisse wiederherstellen
    Abgeschlossen
    Stellen Sie die richtigen Berechtigungen für die Datenverzeichnisse von Windows Search wieder her.
    Überprüfte, potenzielle Probleme
    Erkennungsdetails
      Fehler beim Suchfilterhost-Prozess
    Thema nicht vorhanden
     
    Probleme beim Suchfilterhost können auf Fehler im Windows Search-Dienst hinweisen, die bei Suchvorgängen zu Fehlern oder zur Rückgabe unvollständiger Suchergebnisse führen können.
     
      Windows Search wurde unerwartet heruntergefahren.
    Thema nicht vorhanden
     
    Wird das Herunterfahren von Windows Search bei laufender Wartung erzwungen, kann es bei Suchvorgängen zu Fehlern oder zur Rückgabe unvollständiger Suchergebnisse kommen.
     
      Windows Search wurde unerwartet heruntergefahren.
    Thema nicht vorhanden
     
    Wird das Herunterfahren von Windows Search erzwungen, kann es bei Suchvorgängen zu Fehlern oder zur Rückgabe unvollständiger Suchergebnisse kommen.
     
      Windows Search wird nicht ausgeführt.
    Thema nicht vorhanden
     
    Ohne Windows Search nehmen die Suchvorgänge möglicherweise mehr Zeit in Anspruch, und es werden möglicherweise nicht alle Elemente gefunden.
     
      Fehler bei Windows Search
    Thema nicht vorhanden
     
    Aufgrund von Problemen beim Windows Search-Dienst kann es bei Suchvorgängen zu Fehlern oder zur Rückgabe unvollständiger Suchergebnisse kommen.
     
      Fehler beim Suchprotokollhost-Prozess
    Thema nicht vorhanden
     
    Probleme beim Suchprotokollhost können auf Fehler im Windows Search-Dienst hinweisen, die bei Suchvorgängen zu Fehlern oder zur Rückgabe unvollständiger Suchergebnisse führen können.
     
    Erkennungsdetails
    Erweitern
    Informationen
    Verzeichnis
    Datenverzeichnis von Windows Search
    Verzeichnis: C:\ProgramData\Microsoft\Search\Data\
    Informationen
    Vom Benutzer gemeldete Probleme
    Problemtyp: EmailMissingProblem
    Sammlungsinformationen
    Computername: MICHAEL-PC
    Windows-Version:
    6.1
    Architektur:
    amd64
    Zeit:
    Samstag, 13. März 2010 15:46:28
    Herausgeberdetails
    Erweitern
    Suche und Indizierung
    Dient zum Suchen von Elementen auf dem Computer mithilfe von Windows Search.
    Paketversion:
    1.0
    Herausgeber:
    Microsoft Windows
    Suche und Indizierung
    Dient zum Suchen von Elementen auf dem Computer mithilfe von Windows Search.
    Paketversion:
    1.0
    Herausgeber:
    Microsoft Corporation


    ..........................................................


    Ich habe nun keine Ahnung, was man da machen kann. Ein wichtiges Detail noch: ich hatte von Vista auf Windows 7 64bit Ultimate upgegradet.

    Danke für jede Hilfestellung.

    Michael
    • Bearbeitet Kahn39 Donnerstag, 25. März 2010 09:26
    Samstag, 13. März 2010 15:33

Alle Antworten

  • Hallo Michael,

    Wir haben ebenfalls dieses Problem in Windows 7 64bit mit Outlook 2007. Ergänzend möchte ich aber hinzufügen, dass wir keine Vista-Upgrades gemacht haben, sondern Windows 7 wirklich neu installiert haben (mit einem Rechner wirklich händisch, mit anderen aus Image) und trotzdem haben wir diesen Fehler.

    Ich warte mit Dir gespannt auf eine Lösung!

    Liebe Grüße!
    Rudi
    Montag, 15. März 2010 08:33
  • Hi Michael

    versuch bitte den Index per folgenden Anweisungen neuzuerstellen:

    1. Im Registry Editor folgenden Pfad öffnen:

    HKLM\Software\Microsoft\Windows Search

    2. Per Rechtsklick - Exportieren eine Sicherung speichern.

    3. Den Wert SetupCompletedSuccessfully von 1 auf 0 anpassen.

    4. Folgende Registry Einträge entfernen:

    HKLM\Software\Microsoft\Windows Search\Applications\windows
    HKLM\Software\Microsoft\Windows Search\CatalogNames\windows
    HKLM\Software\Microsoft\Windows Search\Databases\windows
    HKLM\Software\Microsoft\Windows Search\Gather\windows
    HKLM\Software\Microsoft\Windows Search\Gathering Manager\Applications\windows
    HKLM\Software\Microsoft\Windows Search\UsnNotifier\windows 

    Hinweis: Falls die Rechte für das Löschen/Bearbeiten der o.g. Werte fehlen, per Berechtigungen - Erweitert - Besitzer den angemeldeten Benutzer eingeben. Zusätzlich überprüfen dass der angemeldete Benutzer über Vollzugriffberechtigungen für die entsprechenden Keys und Unter-Keys verfügt.

    5. In einer Als Administrator ausgeführte Eingaubeaufforderung den Suchdienst per folgende Befehle neustarten:

    Net stop wsearch

    rd C:\programdata\microsoft\Search\Data\Applications\Windows /S /Q

    Net start wsearch

    6. Ein paar Minuten warten und überprüfen, dass der SetupCompletedSuccessfully Wert wieder auf 1 zurückgestellt wurde.

    Gruß
    Andrei
    Dienstag, 16. März 2010 11:36
    Moderator
  • Hallo Andrei,

    habe RegEdit als Admin ausgeführt. Konnte den Schlüssel a la 3. abändern. Allerdings konnte ich keinen der Einträge wie unter 4. beschrieben löschen:

    " Fehler beim Löschen des Schlüssels

    CatalogNames kann nicht gelöscht werden: Fehler beim Löschen des Schlüssels"

    Ich habe jetzt mal unter Berechtigungen für Catalogs nachgesehen: System, Administratoren und Benutzer sind zwar eingetragen, haben aber effektiv keine Rechte. Kann an den Berechtigungen dafür nichts ändern. Einzig WSearch hat einen Vollzugriff auf den Knoten.


    Michael
    Samstag, 20. März 2010 17:01
  • Kahn39:

    > habe RegEdit als Admin ausgeführt. Konnte den Schlüssel a la 3. abändern. Allerdings konnte ich keinen der
    > Einträge wie unter 4. beschrieben löschen:

    Das liegt daran, dass du nicht wie unter 4. beschrieben vorgegangen bist.
    Zuerst den Besitz des Schlüssels übernehmen und danach Rechte zuweisen.
    Dann lässt er sich auch löschen.
    (Am einfachsten geht's, wenn man regedit mit Systemrechten öffnet.)

    hpm
    Sonntag, 21. März 2010 14:50
  • Hallo Andrei,

    Hallo Hans-Peter,

    vielen Dank, es hat funktioniert!!! Nachdem ich Euren Anweisung folgte, war kurze Zeit später alles funktionierend indexiert.

    Für mich als ambitionierter Laie, war der Hinweis von Hans-Peter auf den "Erweitert"-Button der Eintritt zum Glück. Der Laie (ich) unterscheidet in der Hektik mangels Expertise nicht zwischen der Berechtigung und dem Besitz ... das war ein Fehler.

    Nochmals vielen Dank an Euch beide!

    Gruß

    Michael

    P.S.: Jetzt wüsste ich natürlich gerne noch was da genau passiert ist .... nachdem man die reg-Einträge gelöscht hat. Muss aber nicht sein wenn Ihr knapp an Zeit seid, bin schon glücklich, dass es einfach wieder funktioniert.


    Michael
    Dienstag, 23. März 2010 16:07
  • Ich habe alle Schritte durchgeführt, bekommen nun aber immer noch die Fehlermeldung "Falsche Berechtigungen für Windows Search-Verzeichnisse"
    Mittwoch, 24. März 2010 09:18
  • "Kommando zurück" - direkt nach Ausführung der Aktionen funktionierte die Suche. Mittlerweile hat sich jedoch das alte Bild wieder eingestellt: unter den Kontakten überhaupt keine Treffer .... Email nur noch teilweise ....

    Indizierung eigentlich abgeschlossen laut Statusmeldung

    Wieder das Berechtigungsthema.

    Also, nicht gelöst! Wäre dankbar für jede weitere Hilfestellung .... ist vielleicht durch den Upgrade das ganze Berechtigungswesen "messed-up"?

    Viele Grüße

    Michael


    Michael
    Donnerstag, 25. März 2010 09:25
  • Kahn39:

    > Also, nicht gelöst! Wäre dankbar für jede weitere Hilfestellung.

    Hier kommt die garantiert funktionierende Hilfestellung.
    Agent Ransack:
    http://www.mythicsoft.com/default.aspx

    hpm
    Freitag, 26. März 2010 21:46
  • Hallo Hans-Peter,

    denke, ein Drittanbieter ist wirklich die letzte Lösung - ich brauche ja keine Spezialfunktionen, sondern nur die Basics. Auch 30 Euro hier und da gehen wirklich ins Geld. ... ich habe jetzt mal im englischsprahigem Forum gepostet, vielleicht hat dort noch jemand eine Idee. Falls dort eine Lösung auftaucht, werde ich diese hier posten.

     

    VG

    Michael


    Michael
    Samstag, 27. März 2010 16:40
  • Kahn39 schrieb:

    > denke, ein Drittanbieter ist wirklich die letzte Lösung - ich
    > brauche ja keine Spezialfunktionen, sondern nur die Basics. Auch 30
    > Euro hier und da gehen wirklich ins Geld. ...

    Agent Ransack ist kostenlos: http://www.mythicsoft.com/agentransack
    Hat HPM ja auch namentlich genannt.

    Servus
    Winfried
    --
    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: www.gruppenrichtlinien.de
    Gruppenrichtlinien Mailingliste "gpupdate":
    http://frickelsoft.net/cms/index.php?page=mailingliste
    Samstag, 27. März 2010 18:23
  • Kahn39:

    > denke, ein Drittanbieter ist wirklich die letzte Lösung

    das kommt auf die Ansprüche an. Meinen Ansprüchen wird die Win-Suche nicht
    gerecht, insofern muss ich eben auf ein anderes Programm ausweichen und
    erspare mir nebenbei den Ärger, mich ein Leben lang mit Fehlern rumquälen zu
    müssen. ;-)

    > Auch 30 Euro hier und da gehen wirklich ins Geld.

    Wie schon gesacht, dat genannte Programm is für umme.

    hpm
    Sonntag, 28. März 2010 15:29
  • Hey Leute,

    hier mal die Lösung für Euer Problem:

    1. Taskmanager starten
    2. Prozesse > explorer.exe > Prozess beenden
    3. Datei > Neuer Task (Ausführen...) > regedit > Enter
    4. nach HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{EF87B4CB-F2CE-4785-8658-4CA6C63E38C6}\TopViews navigieren und den {00000000-0000-0000-0000-000000000000} Key in {00000000-0000-0000-0000-000000000000}.old umbenennen
    5. > Taskmanager > Datei > Neuer Task (Ausführen...) > explorer > Enter


    und das wars auch schon, viel Glück :)
    Donnerstag, 8. April 2010 09:09
  • Hallo Michael

    verfügt das Systemkonto (NT-AUTORITÄT\SYSTEM) über Vollzugriff Berechtigungen für den C:\ProgramData\Microsoft\Search\Data Ordner (inkl. alle Unterordner)?

    Gruß
    Andrei

    Donnerstag, 8. April 2010 12:10
    Moderator
  • Agent Rabsack ist zwar ein feines Instrument.

    Aber es ist garantiert keinen Lösung für das Problem des OP!
    Liest Du denn die threads nicht? <g&d>

    Wie soll denn, bitteschön, Dein Agent die Suche in Outlook - und darum ging es hier - bewältigen??
    Ob Du's nun magst oder nicht, es gibt Software die setzt auf WDS auf - Outlook etwa oder OneNote.

    Rainald

    Sonntag, 11. April 2010 17:17
  • Agent Ransack ist kostenlos:

    ist freilich aber für das Ptinlem des OP mit Outlook gänzloch unbegelfloch :-(

    Rainald

    Sonntag, 11. April 2010 17:19
  • Rainald schrieb:

    > Agent Ransack ist kostenlos:
    >
    > ist freilich aber für das Ptinlem des OP mit Outlook gänzloch unbegelfloch :-(

    Hab ich auch nicht geschrieben, das beim Problem hilft. Magst Du bitte
    Lesen bevor Du antwortest?

    BTW: Kannst Du endlich mal anfangen die eingebaute Rechtschreibprüfung
    zu benutzen?

    Servus
    Winfried
    --
    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: www.gruppenrichtlinien.de
    Gruppenrichtlinien Mailingliste "gpupdate":
    http://frickelsoft.net/cms/index.php?page=mailingliste
    Sonntag, 11. April 2010 18:00
  • Rainald:

    > Wie soll denn, bitteschön, Dein Agent die Suche in Outlook - und darum ging es hier - bewältigen??
    > Ob Du's nun magst oder nicht, es gibt Software die setzt auf WDS auf - Outlook etwa oder OneNote.

    Zunächst mal hätte er dann eine zuverlässige Universal-Suche. Sowas braucht
    jeder.
    Was Outlook angeht, müsste er eine Suche finden, die
    a) nicht langsam
    und
    b) nicht unzuverlässig ist.
    Also etwas anderes als die Windows-Suche. Oder eben sein Windows neu
    installieren und hoffen, dass dieser Fehler nicht zwei Wochen später erneut
    auftritt.
    Das Problem besteht seit dem 13.3., jetzt haben wir den 12.4.
    Merkste wat? Wer solch eine Suche nutzt, braucht keine Feinde mehr. ;-)

    hpm
    Montag, 12. April 2010 09:27
  • @Rainald:

     

    Das Outlook-Suchtool Lookeen sollte diese Anforderungen mit Leichtigkeit erfüllen.

    Zudem indiziert es viel schneller als die WDS.

    Sonntag, 18. April 2010 20:24
  • Hallo Leatherface,

    auf meinem Windows existieren unter dem angegeben Pfad nur die folgenden Einträge.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{631958A6-AD0F-4035-A745-28AC066DC6ED}

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{FBB3477E-C9E4-4B3B-A2BA-D3F5D3CD46F9}

    Was tun?

     

    Michael


    Michael
    • Als Antwort vorgeschlagen Rainald Donnerstag, 7. Oktober 2010 20:27
    Sonntag, 13. Juni 2010 21:15
  • Hallo Andrei,

    auf ... Microsoft\Search\Data haben

    - System

    - Adminstratoren

    Jeweils einen Vollzugriff .... nur die "Speziellen Berechtigungen" sind nicht aktiviert.

    In Sachen Berechtigungen habe ich aber den Eindruck, dass da was in der Registry nicht stimmt. Gibt es ein Tool, mit dem man das gut überprüfen und ggf. auch ändern kann? Win 7 war keine Neuinstallation sondern ein Upgrade. Und heute ist Windows 7 bei einer Durchsuchung von Win 7 sogar einmal (ohne Bluescreen) direkt abgestürtzt. - Abstürze sind ansonsten eher selten.

    VG

    Michael


    Michael
    Sonntag, 13. Juni 2010 21:20
  • Hallo allerseits,

    das Problem wird scheinbar ausgesessen ...

    Eigentlich war ich gerade dabei ein anders Problem (WMDC synchronisiert keine Kontakte und Aufgaben) zu lösen, als ich auf dieses
    "Berechtigungen für Windows Search-Datenverzeichnis" Problem gestossen bin.

    Nach einer Neuinstallation meines Office und der Anlage eines neuen Outlook Profils mit anschl. Kopieren der alten Daten in das neue Profil musste der Indexer wohl neu loslegen, was ich daran sah, dass das WMDC bei der Synchronisation mit "Der Server ist ausgelastet" leider nicht das erhoffte Ergebnis (Synchronisation aller von mir gewählten Kategorien) zeigte.

    Irgendwie ist da wohl noch ein Haufen Vista im Windows 7.

    Die Indizierung nervt richtig:
    - Es wird zwar behauptet, dass der Benutzer die Indizierungsgeschwindigkeit reduziert hat, aber kein Weg aufgezeigt, wie der Benutzer das ändern kann.
    - Die korrekten Berechtigungen (ob Registry oder Dateisystem) für das Search Verzeichnis werden nirgends dokumentiert, auch hier hat der Benutzer nicht dran gefummelt. Und das Setzen der Vollberechtigung für SYSTEM bringt mal garnichts.

    Ich kann jetzt wohl ein paar Stunden warten, bis die Mühle ihren Index aufgebaut hat, um dann festzustellen, ob meine Lösung des Syncproblems greift. Das ist mal wieder mindestens ein Tag inkl. der Syncproblematik (mehrere PDA Hardresets, Softwareinstallation und Deinstallation etc.).

    Wenn es nicht regnen würde, könnte ich jetzt raus.

    Gruß

    Jens

    Mittwoch, 18. August 2010 08:19
  • Noch einmal ein Fazit von mir.

    Merkwürdigkeiten gibt es schon:

    z. B. meldet Outlook: "Ihre Elemente werden zurzeit von Outlook indiziert", guckt man dann in die Indizierungsoptionen, wird dort vermeldet: "Die Indizierungsgeschwindigkeit wurde durch Benutzeraktivität reduziert", was whl durch das Öffnen von Outlook verursacht wurde. Schließt man nun Outlook sieht man in den Indizierungsoptionen folgende Meldung: "Die Indizierung wurde abgeschlossen", obwohl noch über 20.000 Elemente zu indizieren sind ...

    Na ja, heute Mittag war er fertig und nun habe ich eine schnelle Suche, das Problem mit den Rechten auf das Search Verzeichnis habe ich einfach auf sich beruhen lassen.

    Während dieser Aktion bin ich noch auf ein Gadget gestossen, was beim Handling helfen soll, benutzt habe ich es noch nicht (war zu spät).
    Das "Indexer Status.gadget" ist zu finden unter:
    http://gallery.live.com/liveItemDetail.aspx?li=45c441a6-edbc-454d-9262-d264728d6a3a&bt=1&pl=1

    Gruß

    Jens

    Mittwoch, 18. August 2010 17:53
  • Hallo Michael

    verfügt das Systemkonto (NT-AUTORITÄT\SYSTEM) über Vollzugriff Berechtigungen für den C:\ProgramData\Microsoft\Search\Data Ordner (inkl. alle Unterordner)?

    Gruß
    Andrei


    Hallo Andrei!

    Ich habe bei meinem Bruder dieselben Symptome wie beschrieben vorgefunden. Ich habe diesen Schritt mit dem Stoppen und Neustarten der Indizierung gemacht und danach in der Ereignnisanzeige gesehen, dass es ein Berechtigungsproblem gibt. Windows Search hat keinen Zugriff auf diese Ordner.

    - Komischerweise funktioniert die Suche via > Start > Suche (jedenfalls mindestens teilweise)

    - Aber im die Suche im Explorerfenster zeigt nicht ein Resultat an.

    Und zwar sind sämtliche Ordner, die eigentlich indiziert sein sollten betroffen.

    Deshalb denke ich, dass grundlegend die Sicherheitseinstellungen NT-Autoritätssystem nicht stimmen.

    Wie kann man dies wider "fixen". Geht bei bei Windows 7 auch mit Fix-It?

    Ich wäre froh, wenn ihr mir eine Lösung wüsstet, denn, wenn schon diese Sicherheitseinstellung nicht funktioniert, fragt man sich, was da sonst noch nicht i.O. ist.

    PS: Ich bin eigentlich durch die Meldung von TuneUp Utilities drauf gekommen, als da vorgeschlagen wurde, die Indizierung auszuschalten und nebenbei noch den Ausbalancierten Modus auf Höchstleistung zu stellen. (So ein Stuss... Ich verstehe auch nicht, wieso mein Bruder dieses Programm gekauft hat).

    Ich wollte ihm dann die Vorteile der indizierten Suche zeigen, ... er mit seinen 20'000 Dokumenten, ... und es ging net!!!

    Nach einigem Suchen, zeigten sich dann eben besagte Symptome.

     

    1a. > Kann's eventuell sein, dass "Norton Internet Security Trial" nicht vollständig deinstalliert worden ist.

    1b.> Kann es irgendwie mit McAfee (k.A., wieso er McAfee kauft. Ich zeigte ihm doch die Tests der 2010 IS's, btr. Systemleistung und Sicherheit.

    1c. > Kann es mit TuneUP zu tun haben.

    2a.   > gibt's ein ein Tool, mit welchem man grundlegende Sicherheitseinstellungen wiederherstellen kann.

    2b. Oder kann man des manuell durch Eingabe eines Befehls wiederherstellen.

     

    Besten Dank im Voraus.

    Freundliche Grüsse, Leuenberger

     

    Montag, 23. August 2010 22:41
  • Sicherheitseinstellungen geändert - Benutzer gelöscht - nur noch eingeschränkte Suche

    in den Tiefen meines Windows 7 64 bit Ultra Systems habe ich einen Nutzer entdeckt, den ich nicht zuordnen konnte - und gelöscht, bzw. ihm die Berechtigung auf Files entzogen. Ich DAU. Es handelte sich um diese Berechtigung mit der langen Zahlenkette, wahrscheinlich die, die sich auch unter HKCU/Software/Microsoft/Windows Search/ProzessedSearchRoots/... findet, bei mir: S-1-5-21-17... Vielleicht reicht diese kryptische Angabe. Da anschließend die WSuche nicht mehr funktionierte, gehe ich davon aus, dass diese Berechtigung damit zusammen hängt. (Habe den Vorgang übrigens abgebrochen, bevor er ganz durchgelaufen ist, einige wenige Files werden wohl die alten Rechte noch aufweisen).

    Habe alles mögliche probiert, der Suche wieder die vollen Rechte zuzuweisen - keine Chance. MS-Fixit sagt, auch wenn ich es mit Administratorrechten ausführe (oder kann man die einzelnen Optionen auch noch mal mit Admin-Rechten ausführen?), dass am Rechtesystem etwas nicht stimmt - aber auch, dass eine Reparatur nicht möglich ist. Eine Wiederherstellung brachte auch nicht das gewünschte Ergebnis.

    Ich weiß, ich bin der größtmögliche Idiot. Sorry für die Mühe! Ich war mit der WindowsSuche immer sehr zufrieden, speziell bei Outlook hatte ich eigentlich nie Probleme das nicht zu finden, was ich gesucht habe. Jetzt bin ich ein bischen fertig...

    Würde mich riesig freuen, wenn mir jemand helfen könnte. 
    Der Thread ist ja schon älter, mein Problem aber in eine ähnliche Richtung geht, habe ich es hier angehängt. Ich habe diese Anfrage auch bei Chip im Forum gestellt. Falls dort jemand eine Antwort postet, die mir hilft, werde ich schnell abgleichen - so dass sich niemand umsonst Mühe machen muss. 

    Auf meiner Suche, das Problem wieder zu fixen, bin ich unter anderem auch so vorgegangen, wie oben von Andrei beschrieben. Dies musste ich aber wieder rückgängig machen, da es mir nicht helfen konnte. Der Dienst lässt sich jetzt wieder starten. Er indiziert mal wieder neu - hört aber wieder viel zu früh auf - was ich mir damit erkläre, dass ihm ja für viele Files die Rechte entzogen worden sind. 

    Besten Dank für eure Hilfe!

     

    PS: Das ich im gleichen Zeitraum die neuste Officeversion installiert habe, ist wahrscheinlich irrelevant, will es aber trotzdem erwähnen.

    Dienstag, 16. November 2010 07:54
  • Dankeschön, anscheinend war ich wohl völliger Paranoia verfallen. Unterdessen hat sich der Index auch wieder aufgebaut. Ich denke, es reichte, neben dem Löschen des Index in der Registry den Wert
    HKLM\Software\Microsoft\Windows Search  SetupCompletedSuccessfully von 1 auf 0 anpassen.
    Ganz herzlichen Dank jedenfalls für die Mühe!
    Donnerstag, 18. November 2010 09:11
  • Hallo,

    ich würde das Problem gerne wieder aufnehmen, denn es ist nirgends im Netz wirklich geklärt.

    Ich habe das Problem auch und habe nun aus Verzweiflung meine Festplate platt gemacht und Windows 7 samt aller Updates komplett neu aufgespielt.

    Es ist also noch kein einziges Programm installiert, Windows ist korrekt installiert und noch völlig jungfräulich.

    Wenn ich nun spaßenshalber in Windows Search die Problembehandlung für Search nutze und dort als Problem in das freie Textfeld einfach "funktioniert nicht" eingebe, spuckt er mir nach einiger Zeit den Fehler aus, dass die Berechtigungen für Windows Search falsch wären. Diese Fehlermeldung ist also völliger Quatsch, denn es kann ja noch garnichts falsch gesetzt sein. Das führt völlig in die Irre.

    Das Problem muss also woanders liegen, die Frage ist nur wo.

    Da bleibt Microsoft eine Antwort schuldig und wenn man die 1,86 Euro Hotline anruft verplempert man nur sein Geld, dann kann ich genausogut mit meiner Oma drüber sprechen, denn die haben da keinen blassen Schimmer, kennen das Problem nicht mal....

    nun denn, wo ist der kompetente Ratschlag?!

    Dienstag, 5. April 2011 20:17
  • Hallo,

    Es geht mir genau gleich. Nachdem ich diesen Threat genau durchgelesen habe und alles ausprobiert habe, hat es bei mir auch nichts genützt. Ich habe die gleichen Sympthome mit dem Berechtigungszeug etc. Dachte ich habe es gelöst aber im Outlook 2010 passiert aber nichts, es wird nach gar nichts gesucht, weder Kalendereintrage, Kontakte, E-Mails. Aber kommischerweise wenn ich unter Windows 7 etwas suche, funktioniert es.

    Ich glaube ich habe jetzt mehr kaputt gemacht als etwas besser gemacht mit den Registryeinträgen und löschen. Wenn sich nichts mehr tut, werde mal versuchen mein Office zu deinstallieren und wieder sauber zu installieren, eine andere Möglichkeit sehe ich nicht. Es kann ja niemand wirklich helfen:-)

    Mittwoch, 6. April 2011 13:14
  • Steintier:

    ich würde das Problem gerne wieder aufnehmen, denn es ist nirgends im Netz wirklich geklärt.

    Nun ja, es ist zumindest geklärt, dass die Windows-Suche nicht ganz das Gelbe vom Ei ist.
    Insofern also hat es keinen Sinn, dass du das Problem wieder aufnehmen willst.
    Lies dir dazu auch mal das alles durch:
    Trouble mit der Windows 7-Suche
    http://www.borncity.com/blog/2010/03/12/trouble-mit-der-windows-7-suche/
    Du kannst dir die vier Wochen, die man braucht, das alles durchzuarbeiten, aber auch ersparen und gleich eine
    gute Suche benutzen.

    Mittwoch, 6. April 2011 15:01
  • Ich habe nun stundenlang alle Foren durchsucht und bin für die (teils geschilderten) Probleme:

    "Indizierungsoptionen leer", "Die Indizierung wird nicht ausgeführt", Ändern-Button ausgegraut, unter "Erweitern" neu indizieren bleibt ohne Reaktion, Dienst für Indizierung läuft (angeblich), Windows Search kann angeblich aufgrund der Benutzerrechte nicht gestartet werden, Outlook-Indizierung läuft auch nicht, Haken bei Postfach kann nicht gesetzt werden bzw. bringt Fehlermeldung etc. etc. etc.

    dort auf keine Lösung gekommen, weshalb ich jetzt kurz meine "erfolgreiche" Lösung poste:
    Unter "Windows-Funktionen aktivieren oder deaktivieren" habe ich den Haken bei Indexdienst und Windows Search entfernt. Der Rechner will dann einen Neustart und das System fährt ohne Suchfunktion hoch. Dann erneut reingehen und beide Häkchen wieder setzen, Neustart, plötzlich war alles wieder OK.

    Sonntag, 17. April 2011 11:53
  • MMayor:

    Unter "Windows-Funktionen aktivieren oder deaktivieren" habe ich den Haken bei Indexdienst und Windows Search entfernt. Der Rechner will dann einen Neustart und das System fährt ohne Suchfunktion hoch. Dann erneut reingehen und beide Häkchen wieder setzen, Neustart, plötzlich war alles wieder OK.

    Ja, das mag in gewissen Fällen helfen, siehe die Sammlung von Günter Born. Es gibt aber jede Menge Fälle, in
    denen nichts von alledem zu helfen scheint. Das ist einfach Murks. Ich hab auch noch nie eine Suche gesehen,
    die fehlende Berechtigungen für Search-Verzeichnisse anmahnt. Sowas braucht die Welt eher nicht.

    Sonntag, 17. April 2011 20:15
  • Hallo Andrei,

    Hallo Hans-Peter,

    vielen Dank, es hat funktioniert!!! Nachdem ich Euren Anweisung folgte, war kurze Zeit später alles funktionierend indexiert.

    Für mich als ambitionierter Laie, war der Hinweis von Hans-Peter auf den "Erweitert"-Button der Eintritt zum Glück. Der Laie (ich) unterscheidet in der Hektik mangels Expertise nicht zwischen der Berechtigung und dem Besitz ... das war ein Fehler.

    Nochmals vielen Dank an Euch beide!

    Gruß

    Michael

    P.S.: Jetzt wüsste ich natürlich gerne noch was da genau passiert ist .... nachdem man die reg-Einträge gelöscht hat. Muss aber nicht sein wenn Ihr knapp an Zeit seid, bin schon glücklich, dass es einfach wieder funktioniert.

    Mit freundlichen Grüßen


    Michael

    Jep ich bedanke mich auch vielmals, hat bestens funktioniert! ;-)


    Montag, 25. Juli 2011 16:07
  • Hallo Mitkämpfer,

    trotz sorgfältiger Anwendung der Empfehlungen von Talmaciu (Löschung der verschiedenen Registry-Einträge und anschließend erneutem Anstoßen der Indizierung, hatte auch ich keinen Erfolg.

    Per Zufall bin ich jetzt auf die Lösung gestoßen:

     Unter Windows 7 erreicht man über die Systemsteuerung die Indizierungsoptionen. Hier findet man "einzubeziehende Orte" und "Ausschließen".

    Der Fehler liegt - so trivial das klingt - darin, dass eine Überschrift nicht stimmt: Unter der Spalte "Ausschließen" muß man bezüglich Outlook die Ordner angeben, die man _einschließen_ will. Tut man das, was logisch klingt, wenn man alle Outlook-Archiv-Ordner und alle Outlook-Persönliche-Ordner indiziert haben möchte, und schließt dann nichts aus, dann wird NICHTS indiziert (und eben nicht ALLES).

    Trägt man dagegen in der Spalte "Ausschließen" alle Ordner ein, die man indiziert haben möchte, dann klappt es sofort!

    Unglaublich, nicht wahr?

    Konfiguration: Windows 7 Home Premium SP1 und Outlook 2007 SP2 MSO (12.0.6554.5001)

    Choc007

     

     


    B. Jopen
    • Als Antwort vorgeschlagen MarkFromSwiss Donnerstag, 5. April 2012 04:43
    Dienstag, 9. August 2011 20:07
  • Hallo!

    Das klingt ja spannend. Bin schon seit 2 Jahren mit diesm Problem konfrontiert und habe bisher leider keine Lösung gefunden - auch unser EDV-Service-Anbieter hat nix rausgefunden was mir helfen würde.

    Da wir aber alle Ausgangsmails im öffentlichen Ordner speichern, damit jeder Mitarbeiter nachsehen kann, wer mit wem was vereinbart hat, ist diese Funktion für mich wirklich wichtig. Lookout kann ich zwar installieren, aber beim Starten von Outlook sagt mir das Tool, dass es nicht funktioniert, weil irgendwelche anderen Add-Ins installiert sind (wovon ich nix weiß und welche ich auch nicht finde). bin schon am Verzweifeln.

    Habe alle Ansätze hier durchprobiert - bis auf den letzten von choc007 - wo kann ich denn die Einträge unter "Ausschließen" ändern?

    Hab ein Win7-32bit-Upgrad von Vista. Hatte das Problem auch unter Vista schon (damals mit Office 2003 + 2007 und jetzt mit O 2010)

     

    grüße

    Freitag, 7. Oktober 2011 09:34
  • Hallo Mitkämpfer,

    trotz sorgfältiger Anwendung der Empfehlungen von Talmaciu (Löschung der verschiedenen Registry-Einträge und anschließend erneutem Anstoßen der Indizierung, hatte auch ich keinen Erfolg.

    Per Zufall bin ich jetzt auf die Lösung gestoßen:

     Unter Windows 7 erreicht man über die Systemsteuerung die Indizierungsoptionen. Hier findet man "einzubeziehende Orte" und "Ausschließen".

    Der Fehler liegt - so trivial das klingt - darin, dass eine Überschrift nicht stimmt: Unter der Spalte "Ausschließen" muß man bezüglich Outlook die Ordner angeben, die man _einschließen_ will. Tut man das, was logisch klingt, wenn man alle Outlook-Archiv-Ordner und alle Outlook-Persönliche-Ordner indiziert haben möchte, und schließt dann nichts aus, dann wird NICHTS indiziert (und eben nicht ALLES).

    Trägt man dagegen in der Spalte "Ausschließen" alle Ordner ein, die man indiziert haben möchte, dann klappt es sofort!

    Unglaublich, nicht wahr?

    Konfiguration: Windows 7 Home Premium SP1 und Outlook 2007 SP2 MSO (12.0.6554.5001)

    Choc007


    B. Jopen

    Hallo zusammen

    Danke an Choc007. Nachdem ich meine Postfächer ausgeschlossen habe, kann ich darin wieder suchen. Allerdings sucht das System nun nicht mehr direkt während der Eingabe im Suchfeld von Outlook 2007 sondern nur noch nach einem Klick auf das Lupensymbol, das ist aber egal. In meinem Fall war dies die Lösung, die Suche wieder verfügbar zu bekommen. Witzigerweise meldet die Problemsuche der Indizierung weiterhin die bekannten falschen Berechtigungen für das Windows Search Verzeichnis, die Ergebnisse in der Outlook-Suche sind aber da.

    Ich weiss nicht, ob die Probleme für andere damit behoben sind und ich bin auch schon fast sicher, dass ich in Kürze mit neuen Effekten der Windows Suche rechnen darf (nach dem Motto "this is not a bug, it's a feature!") aber vielen Dank an Choc007 für den Tip mit dem Ausschluss. Auf diese Idee wäre ich bestimmt nicht selbst gekommen, etwas von der Suche auszunehmen, damit es in den Suchergebnissen wieder angezeigt wird. Man lernt nie aus!

    Danke Choc007 und Euch allen viel Glück beim Troubleshooting.

    Donnerstag, 5. April 2012 04:41
  • Ich habe einfach die Indizierung an einem neuen Ort neu erstellen lassen: Bei "Indizierungsort" unter "Neuer Ort, nachdem der Dienst neu gestartet wurde:" ein neues Verzeichnis erstellen und angeben, schon funktioniert wieder alles (bei mir zumindest).

    Dienstag, 2. Oktober 2012 20:01
  • Hallo Mitkämpfer,

    trotz sorgfältiger Anwendung der Empfehlungen von Talmaciu (Löschung der verschiedenen Registry-Einträge und anschließend erneutem Anstoßen der Indizierung, hatte auch ich keinen Erfolg.

    Per Zufall bin ich jetzt auf die Lösung gestoßen:

     Unter Windows 7 erreicht man über die Systemsteuerung die Indizierungsoptionen. Hier findet man "einzubeziehende Orte" und "Ausschließen".

    Der Fehler liegt - so trivial das klingt - darin, dass eine Überschrift nicht stimmt: Unter der Spalte "Ausschließen" muß man bezüglich Outlook die Ordner angeben, die man _einschließen_ will. Tut man das, was logisch klingt, wenn man alle Outlook-Archiv-Ordner und alle Outlook-Persönliche-Ordner indiziert haben möchte, und schließt dann nichts aus, dann wird NICHTS indiziert (und eben nicht ALLES).

    Trägt man dagegen in der Spalte "Ausschließen" alle Ordner ein, die man indiziert haben möchte, dann klappt es sofort!

    Unglaublich, nicht wahr?

    Konfiguration: Windows 7 Home Premium SP1 und Outlook 2007 SP2 MSO (12.0.6554.5001)

    Choc007


    B. Jopen

    Hallo, bei mir hats funktioniert. 2 Tage lang habe ich alles Expertenvorschläge ausprobiert - ohne Erfolg. Vielen Dank!

    Ernst Hermannsdorfer CoreNet-Consult +49 080349134

    Freitag, 12. Oktober 2012 11:36
  • Hallo Mitkämpfer,

    trotz sorgfältiger Anwendung der Empfehlungen von Talmaciu (Löschung der verschiedenen Registry-Einträge und anschließend erneutem Anstoßen der Indizierung, hatte auch ich keinen Erfolg.

    Per Zufall bin ich jetzt auf die Lösung gestoßen:

     Unter Windows 7 erreicht man über die Systemsteuerung die Indizierungsoptionen. Hier findet man "einzubeziehende Orte" und "Ausschließen".

    Der Fehler liegt - so trivial das klingt - darin, dass eine Überschrift nicht stimmt: Unter der Spalte "Ausschließen" muß man bezüglich Outlook die Ordner angeben, die man _einschließen_ will. Tut man das, was logisch klingt, wenn man alle Outlook-Archiv-Ordner und alle Outlook-Persönliche-Ordner indiziert haben möchte, und schließt dann nichts aus, dann wird NICHTS indiziert (und eben nicht ALLES).

    Trägt man dagegen in der Spalte "Ausschließen" alle Ordner ein, die man indiziert haben möchte, dann klappt es sofort!

    Unglaublich, nicht wahr?

    Konfiguration: Windows 7 Home Premium SP1 und Outlook 2007 SP2 MSO (12.0.6554.5001)

    Choc007


    B. Jopen

    Hallo Choc007,

    ich habe lange nach einer Lösung gesucht. Bis ich das hier gelesen habe. Es stimmt mich zuversichtlich.

    Leider habe ich ein Problem:

    Wenn ich die Indizierungsoptionen über die Systemsteuerung aufrufe weiß ich nicht weiter:-)

    Wie trage ich etws in die Spalte "Ausschließen" ein?

    Frank

    Freitag, 1. Februar 2013 13:32
  • Unter Windows 7 erreicht man über die Systemsteuerung die Indizierungsoptionen. Hier findet man "einzubeziehende Orte" und "Ausschließen".

    Choc007

     

     


    B. Jopen

    Hallo Choc,

    das funktioniert auch ähnlich bei Win 7 64Bit und Outlook 2013, vielen Dank Choc007!

    Das ist natürlich ein Armutszeugnis für MS, dass man ein Fehlverhalten, das schon seit so langer Zeit bekannt ist, man nicht in den Griff bekommt. Unter Outllook 2000 und Win XP kannte ich solche Probleme nicht.

    Montag, 11. Februar 2013 10:17
  • Wie trage ich etws in die Spalte "Ausschließen" ein?

    Frank

    Du deaktivierst einfach das Häkchen bei Outlook, falls es bei Dir ähnlich aussieht wie bei mir (Win 7 64 Bit Outlook 2013)
    Montag, 11. Februar 2013 10:20
  • Falls noch jemand dieses Problem hat - ich habe es gerade so lösen können:

    1. In der Systemsteuerung unter Programme bei Windows Features hinzufügen und entfernen die Windows-Suche deinstallieren dann Rechner neu starten.

    2. Ordner "C:\ProgramData\Microsoft\Search\Data\Applications\Windows nach Windows.old umbenennen

    3. In Systemsteuerung die Windows-Suche wieder einschalten - Rechner neu starten.

    4. Warten bis die Indexerstellung (Kontrolle z.B. über Systemsteuerung>Indizierungsoptionen) abgeschlossen ist - kann natürlich eine Weile dauern.

    fertig - bei mir hats geholfen.

    beste Grüße


    Sonntag, 8. September 2013 09:26
  • Hallo,

    ich hatte hier ebenfalls das Problem, allerdings in eine speziellen Situation hervorgerufen.

    Wir haben in mein Outlook 2013 ein zweites Postfach eingebunden, auf das ich Full-Access Rechte habe. Danach setzte die Indizierung meines "Haupt-Postfach" aus. Nur noch das zweite Postfach wurde indiziert. Sobald wir das zweite Postfach wieder entfernt haben, lief die Indizierung wieder an.

    Wir haben das Problem zwar so nur umgangen, zeigt aber evt. dem einen oder anderen eine zustätzliche Ursache auf.

    MfG

    Mittwoch, 9. Oktober 2013 11:13