none
Autodiscover löst immer noch alten DNS Namen auf - warum? RRS feed

  • Frage

  • Guten Morgen

    Umgebung ist Exchange 2010, DCs mit 2008R2 (und ein alter 2003)

    Der Autodiscover Name soll von (wegen Umfirmierung) von Firma.alt nach Firma.neu umgestellt werden (das offizielle Zertifikat ist auf Exchange (und Kemp) eingespielt

    Starte ich Outlook 2013 - nach ca 30 - 60 sekunen kommt eine Zertifikatswarnung, dass der Name auf dem offiziellen Zertifikat (Firma.neu) nicht der Webseite entspricht (Firma.alt)

    Das Zertifikat was ich mir dann anschauen kann, ist das neu gekaufte offizielle Zertifikat.

    Im DNS hab ich die alten Einträge unter _TCP für autodiscover gelöscht (die neuen sind ebenfalls dort), auch den alten A-Record habe ich entfernt.

    Dennoch kommt diese Meldung

    (die virtuellen Verzeichnisse auf Exchange 2010 sin auf den neuen Namen geändert)

    Eine Idee?

    Gruß

    Lutz Rahe

    Dienstag, 26. Mai 2015 07:51

Antworten

  • Moin,

    na das macht die Suche schon mal leichter.

    Unter:

    C:\Users\USERNAME\AppData\Local\Microsoft\Outlook

    liegen die Dateien von Exchange.

    Outlook schließen, alle Dateien "* Autodiscover.xml" löschen, Outlook starten

    Nun holt sich Outlook für das bestehende Profil die Autodiscover-Daten neu.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 29. Mai 2015 10:59

Alle Antworten

  • Habt ihr auch den Eintrag der AutodiscoverURL  über set-ClientAccessServer$env:computername -AutoDiscoverServiceInternalUri "Firma.Neu" geändert?
    Dienstag, 26. Mai 2015 08:23
  • Moin,

    ergänzend: Die Autodiscover-Einstellungen im vDir sind wirkungslos, die kannst Du ignorieren.

    Bei Autodiscover gibt es nur zwei Ort: Den SCP (siehe Jörg) für interne Client und DNS für externe Clients.

    Bei externen Clients kann es aber in Abhängigkeit vom TTL problemlos 24 Stunden oder mehr dauern, bis die die Änderungen mitbekommen. Das hängt vom DNS-Cache des Clients und dem Caching der DNS-Server, die die Clients benutzt, ab.

    Daher setzt man vor solchen Änderungen den TTL im DNS runter, wartet die alte TTL-Zeit ab (dann haben alle Beteiligten die neue Zeit bekommen) und ändert erst dann. Wenn alles läuft, setzt man den TTL wieder hoch.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Dienstag, 26. Mai 2015 08:57
  • Moin

    Der Befehl:

    Get-ClientAccessServer | fl Name,AutoDiscoverServiceInternalUri

    löst schon nach "Firma.neu" auf

    Das Zertifikatsproblem (mit Windows Outlooks) ist innerhalb und außerhalb der Firma.

    Kann ich Outlook anzeigen lassen, wo er den Eintrag herbekommt?

    Viele Grüße

    Lutz

    Dienstag, 26. Mai 2015 09:34
  • Moin,

    ja, im OL-Icon Taskleiste Strg + rechte Maustaste , die beiden Guess-Smart Haken raus.

    Split DNS ist sauber bei dir?

    ;)


    Gruß Norbert


    Dienstag, 26. Mai 2015 10:18
    Moderator
  • Hab ich gemacht

    Sowohl unter "Ergebnisse" als auch unter "Protokoll" steht überall der richtige "firma.neu" Name.

    Keine Ahnung, wo denn Outlook (Windows und Mac) den alten Namen herbekommt.

    Im externen DNS findet man das noch................aber Outlook sucht doch nach dem neuen Namen

    und trotzdem kommt diese blöde Fehlermeldung

    Gruß

    Lutz

    • Bearbeitet Lutz Rahe Mittwoch, 27. Mai 2015 07:00 was vergessen
    Mittwoch, 27. Mai 2015 07:00
  • Moin,

    gibt es das Problem nur bei bestehenden Profilen oder auch in einem neuen?


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Mittwoch, 27. Mai 2015 15:57
  • Moin

    Super Tipp!

    Grade versucht.

    Outlook Profil gelöscht, neues eingerichtet...............keine Meldung mehr.

    Als "nur" ein lokales Problem vom Outlookclient

    Interessant wäe nur, das zu fixen, ohne an jeden Client ran zu müssen.denn so sind alle personalisierten Enstellungen weg (ich höre jetzt schon das Gejammere)

    Grüße

    Lutz Rahe

    Freitag, 29. Mai 2015 09:41
  • Moin,

    na das macht die Suche schon mal leichter.

    Unter:

    C:\Users\USERNAME\AppData\Local\Microsoft\Outlook

    liegen die Dateien von Exchange.

    Outlook schließen, alle Dateien "* Autodiscover.xml" löschen, Outlook starten

    Nun holt sich Outlook für das bestehende Profil die Autodiscover-Daten neu.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 29. Mai 2015 10:59