none
Terminalserver Session nicht übernehmen RRS feed

  • Frage

  • Hallo,

    ich habe folgende Problem.

    Ein Benutzer meldet sich an Client_1 mit Benutzernamen z.B. Benutzer1 an. Jetzt Wechsel er den Arbeitsplatz ohne sich am Client_1 abzumelden. Er meldet sich nun an Client_2 mit dem selben Benutzernamen ( Benutzer1 ) an. Jetzt übernimmt er die Session von Client_1 und wird an Client_1 abgemeldet.

    Dieses Verhalten würde ich gerne abstelle, sodass z.B. eine Meldung erscheint, das er schon angemeldet sei und sich erst abmelden müsse. Oder das man sich einfach nicht mehr anmelden kann.

    Ist dieses möglich ??

    Mittwoch, 22. Januar 2014 18:48

Antworten

  • Nein, so direkt geht das nicht, du kannst User nur mit Zusatztools davon abhalten sich mehrmals anzumelden. Z.B. Limit Login: http://technet.microsoft.com/de-de/magazine/2005.05.utilityspotlight%28en-us%29.aspx

    Was du aber tun kannst ist die Wiederverbindungsoptionen der RDP Dienste so zu konfigurieren das er sich nur am Ursprünglichen Client wieder auf die selbe Session verbinden kann. Dann haste ihn aber im schlimmsten Fall 2x auf dem TS. Aber der Verlust von evtl. ungespeicherter Arbeit oder sonstige Ärgernisse könnten ihn zukünftig davon abhalten ;).


    freundliche Grüße Thomas

    Mittwoch, 22. Januar 2014 19:20
  • Der Link geht ins leere? Dann google mal nach "Limit Login Technet" - hab aber grad draufgeklickt, ich komm hin wo er hin soll.

    Ja, das findest du entweder im entsprechenden Benutzerkonto unter Sitzungen, oder gleichnamig in den RDP Protokolleinstellungen auf den RDP Servern.

    Hast du einen oder mehrere TS? Wenn du nur einen hast kannst du dort auch noch einstellen das der User sich nur in 1 Session anmelden kann, aber das gilt nur für die RDP Dienste.


    freundliche Grüße Thomas

    Mittwoch, 22. Januar 2014 19:58
  • Ich habe es mal an einem Benutzer getestet. Es gibt unter "Sitzung" die Option "Erneute Verbindung zulassen: nur von ursprünglichen Client". Leider greift diese Option nicht. Unter der Hilfe bekommt man den Hinweis, das dieser nur vom Citrix-Client genutzt wird.

    Ich werde mir anders Helfen. Ich habe unter "Konfiguration des Remotedesktop-Sitzungshost" / Benutzeranmeldemodus / Allgemein die Option "nur eine Anmeldung pro Benutzer zulassen" deaktiviert. Dann lebe ich damit, das der Benutzer evtl. doppelt angemeldet ist.

    Der Link geht. War wohl zu doo...

    Danke für die Hilfe.

     

    Mittwoch, 22. Januar 2014 20:17

Alle Antworten

  • Nein, so direkt geht das nicht, du kannst User nur mit Zusatztools davon abhalten sich mehrmals anzumelden. Z.B. Limit Login: http://technet.microsoft.com/de-de/magazine/2005.05.utilityspotlight%28en-us%29.aspx

    Was du aber tun kannst ist die Wiederverbindungsoptionen der RDP Dienste so zu konfigurieren das er sich nur am Ursprünglichen Client wieder auf die selbe Session verbinden kann. Dann haste ihn aber im schlimmsten Fall 2x auf dem TS. Aber der Verlust von evtl. ungespeicherter Arbeit oder sonstige Ärgernisse könnten ihn zukünftig davon abhalten ;).


    freundliche Grüße Thomas

    Mittwoch, 22. Januar 2014 19:20
  • Danke für die prompte Antwort.

    Der Link geht leider in leere.

    Ich habe mir es gerade mal auf dem TS angesehen. Die Einstellungen kann ich nicht finden. Hat du vielleicht eine Tip wo ich dieses finde?

    Danke

    Mittwoch, 22. Januar 2014 19:36
  • Der Link geht ins leere? Dann google mal nach "Limit Login Technet" - hab aber grad draufgeklickt, ich komm hin wo er hin soll.

    Ja, das findest du entweder im entsprechenden Benutzerkonto unter Sitzungen, oder gleichnamig in den RDP Protokolleinstellungen auf den RDP Servern.

    Hast du einen oder mehrere TS? Wenn du nur einen hast kannst du dort auch noch einstellen das der User sich nur in 1 Session anmelden kann, aber das gilt nur für die RDP Dienste.


    freundliche Grüße Thomas

    Mittwoch, 22. Januar 2014 19:58
  • Ich habe es mal an einem Benutzer getestet. Es gibt unter "Sitzung" die Option "Erneute Verbindung zulassen: nur von ursprünglichen Client". Leider greift diese Option nicht. Unter der Hilfe bekommt man den Hinweis, das dieser nur vom Citrix-Client genutzt wird.

    Ich werde mir anders Helfen. Ich habe unter "Konfiguration des Remotedesktop-Sitzungshost" / Benutzeranmeldemodus / Allgemein die Option "nur eine Anmeldung pro Benutzer zulassen" deaktiviert. Dann lebe ich damit, das der Benutzer evtl. doppelt angemeldet ist.

    Der Link geht. War wohl zu doo...

    Danke für die Hilfe.

     

    Mittwoch, 22. Januar 2014 20:17