none
MOSS 2007 - Ihre Lizenz für den Office Server-Suchdienst ist abgelaufen. RRS feed

  • Frage

  • Hallo,

    ich habe den MOSS 2007 frisch aufgesetzt und eine vorhandene WSS 3.0 Inhaltsdatenbank angefügt. Es funktioniert soweit alles, außer das ich bei einer Suche folgende Meldung bekomme: Ihre Lizenz für den Office Server-Suchdienst ist abgelaufen.

    Weiterhin bekomme ich in der SSP Administration bei "Benutzerprofile und Meine Websites / Benutzerprofile und Eigenschaften" die Meldung: Die Evaluierungsversion von Microsoft Office SharePoint Server 2007 für diesen Server ist abgelaufen.

    Der MOSS 2007 wurde mit den aktuellen SP2 installiert (integriert bei der Installation). Den Patch aus KB971620 ist nicht installierbar, weil der Patchlevel vom MOSS 2007 bereits höher ist. Den Lizenzschlüssel kann ich nach KB971620 nicht erneut eingeben, weil das Eingabefeld blockiert ist. Die Inhaltsdatenbank stammt von einer früheren WSS3.0 Installation und wurde beim Einrichten der Webanwendung eingebunden. Auf den personalisierten Websites der Benutzer scheint die Suche zu funktionieren.

    Wo liegt das Problem? Wie kann ich das Lizenzproblem beheben? Hat jemand eine Idee?

    Danke und Gruß,

    Uwe B.
    Montag, 1. März 2010 09:57

Antworten

  • Hallo,

    wir sind nun endlich weiter gekommen und konnten das Problem beheben bzw. umgehen (je nachdem wie man das nennen will):

    Bei installierten AVG Sharepoint Addon konnten wir im Sharepoint Log folgenden Eintrag finden:

    04/06/2010 11:06:40.77  w3wp.exe (0x06BC)                        0x1954 Office Server                  Setup and Upgrade              78ya High     Microsoft.Office.Server.Administration.LicensingException: Fehler beim Abrufen der Ablaufinformationen. ---> System.DllNotFoundException: Die DLL "OfficeServerSettings.dll": Das angegebene Modul wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E) kann nicht geladen werden.     bei Microsoft.Office.Server.Administration.Licensing.NativeMethods.GetExpirationTime(Int64& expirationTime)     bei Microsoft.Office.Server.Administration.Licensing.GetExpirationFileTimeFromRegistry()     --- Ende der internen Ausnahmestapelüberwachung ---     bei Microsoft.Office.Server.Administration.Licensing.GetExpirationFileTimeFromRegistry()     bei Microsoft.Office.Server.Administration.Licensing..cctor() 

    Die OfficeServerSettings.dll war allerdings im Ordner C:\Program Files\Microsoft Office Servers\12.0\Bin vorhanden und wurde auch vom Virenscanner nicht blockiert. Wir haben dann bei den Umgebungsvariablen/Systemvariablen bei der Variable PATH folgende Pfade hinzugefügt (Nicht direkt am Ende, sonder eher mittig. Anweisung von AVG):
    %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\12\Bin;%ProgramFiles%\Microsoft Office Servers\12.0\Bin;

    Dann noch ein IIS Reset und das Lizenzproblem war behoben. Warum der Server bei installierten AVG die OfficeServerSettings.dll nicht findet, ist mir allerdings etwas unklar.

    Gruß

     

    Uwe

    Dienstag, 6. April 2010 13:53

Alle Antworten

  • Hi Uwe

    wurde der WSS SP2 bei der Installation auch integriert?


    Gruß
    Andrei
    Dienstag, 2. März 2010 09:27
  • Hy,


    Ja, ich habe die WSS3.0 SP2 Updatedateien in den Update Ordner der MOSS2007 Installationquelle extrahiert.

    Gruß

    Uwe
    Dienstag, 2. März 2010 10:43
  • Hi Uwe

    ok, könntest du auch bitte noch per KB 971620 Anweisungen überprüfen ob die angegeben Dateien (osrvlicensing.msp and sserverx.msp) im integrierten SP2 für MOSS zu finden sind?

    Gruß
    Andrei
    Dienstag, 2. März 2010 12:42
  • Hy,

    auch die sind enthalten.

    Gruß

    Uwe
    Dienstag, 2. März 2010 12:52
  • ok, unter welchem Benutzerkonto läuft der Anwendungspool? Netzwerkdienst oder ein Domänebenutzerkonto?

    ist dieses Konto Mitglied der WSS_Admin_WPG oder WSS_WPG Gruppe?

    Könntest du auch bitte überprüfen ob die o.g. Gruppen Zugriff (WSS_WPG sollte Lese Berechtigungen und WSS_Admin_WPG sollte Vollzugriff Berechtigungen enthalten) auf den folgenden Registry Schlüssel haben:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Office Server\12.0
    Dienstag, 2. März 2010 13:17
  • Hy,

    der Anwendungspool läuft unter ein Domänenbenutzerkonto.

    Dieses Konto war nicht Mitglied in der lokalen Gruppe WSS_Admin_WPG (habe ich hinzugefügt) aber Mitglied in der lokalen Gruppe WSS_WPG.

    Die Berechtigung auf den Registry Schlüssel waren korrekt gesetzt.

    Fehler sind nach Serverneustart weiterhin vorhanden.

    Gruß

    Uwe
    Dienstag, 2. März 2010 14:46
  • Hi Uwe

    gibt es im Event Log irgendwelche DCOM Fehlermeldungen?

    läuft ein Antivirenprogramm auf dem Server?

    Gruß
    Andrei
    Mittwoch, 3. März 2010 14:32
  • Hy,

    mittlerweile bin ich schon ein Schritt weiter. Das Problem ist wirklich der AVG Virenscanner. Die Fehler tauchen auf, sobald vom AVG die MS Sharepoint Komponente installiert ist. Dabei spielt es keine Rolle, was im MOSS bei Antivirus konfiguriert ist. Deinstalliere ich die AVG Teilkomponente, sind die Fehler auch wieder weg. Dieses Verhalten ist auf ein Testsystem reproduzierbar.

    DCOM Fehlermeldungen sind im Event Log nicht vorhanden.

    Mittlerweile ist der Support von AVG und Microsoft mit an dem Thema mit dran. Infos werde ich hier natürlich rein schreiben.

    Gruß

    Uwe
    Freitag, 5. März 2010 09:19
  • Hi Uwe

    wurde das Problem inzwischen gelöst?

    Gruß
    Andrei

    Montag, 22. März 2010 10:07
  • Hi,

    nein, das problem ist leider noch immer nicht gelöst. Microsoft hat die Supportanfrage geschlossen, weil die es allein auf AVG schieben. Und von AVG kommt auch nicht wirklich ein Ansatz. Wir sind hier intern noch fleißig am testen. Wenn es Fortschritte gibt, dann schreibe ich diese gleich hier rein.

    Gruß

    Uwe

    Donnerstag, 25. März 2010 09:39
  • Hallo,

    wir sind nun endlich weiter gekommen und konnten das Problem beheben bzw. umgehen (je nachdem wie man das nennen will):

    Bei installierten AVG Sharepoint Addon konnten wir im Sharepoint Log folgenden Eintrag finden:

    04/06/2010 11:06:40.77  w3wp.exe (0x06BC)                        0x1954 Office Server                  Setup and Upgrade              78ya High     Microsoft.Office.Server.Administration.LicensingException: Fehler beim Abrufen der Ablaufinformationen. ---> System.DllNotFoundException: Die DLL "OfficeServerSettings.dll": Das angegebene Modul wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E) kann nicht geladen werden.     bei Microsoft.Office.Server.Administration.Licensing.NativeMethods.GetExpirationTime(Int64& expirationTime)     bei Microsoft.Office.Server.Administration.Licensing.GetExpirationFileTimeFromRegistry()     --- Ende der internen Ausnahmestapelüberwachung ---     bei Microsoft.Office.Server.Administration.Licensing.GetExpirationFileTimeFromRegistry()     bei Microsoft.Office.Server.Administration.Licensing..cctor() 

    Die OfficeServerSettings.dll war allerdings im Ordner C:\Program Files\Microsoft Office Servers\12.0\Bin vorhanden und wurde auch vom Virenscanner nicht blockiert. Wir haben dann bei den Umgebungsvariablen/Systemvariablen bei der Variable PATH folgende Pfade hinzugefügt (Nicht direkt am Ende, sonder eher mittig. Anweisung von AVG):
    %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\12\Bin;%ProgramFiles%\Microsoft Office Servers\12.0\Bin;

    Dann noch ein IIS Reset und das Lizenzproblem war behoben. Warum der Server bei installierten AVG die OfficeServerSettings.dll nicht findet, ist mir allerdings etwas unklar.

    Gruß

     

    Uwe

    Dienstag, 6. April 2010 13:53
  • Hi Uwe

    freut mich dass das Problem dadurch behoben wurde und Vielen Dank für dein Feedback!

    Gruß
    Andrei

    Mittwoch, 7. April 2010 06:47