none
Problem to save auditing report SharePoint 2013

    Frage

  • Hi Guys,
    I got a problem when I tried to specify <g class="gr_ gr_124 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="124" id="124">location</g> where to save the report once it has been generated. 

    When I clicked on Browse, choose a location ex.  '/myurl/Documents/Test/test.xlsx',  I got the following error message: 
    "Reports cannot be stored at '/myurl/sites/Documents/Test/test.xlsx'. Reports can only be stored in a document library in the current site", regardless of which folder I choose. 
    But when I just choose the location without naming the file, like this: 
    '/myurl/sites/Documents/Test/' I got another error message: 
    "Report contains no data." 
    What's the problem? Any idea will be <g class="gr_ gr_258 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="258" id="258">appriciated</g> :)
    Thank you in advance 
    Ashraf

    Freitag, 13. Juli 2018 10:15

Antworten

  • Hi, 

    Are you a site collection admin? Only site collection admin can view the audit report.

    For you first issue, this is by design. The auditing report can only be stored in a document library in the current site. You need to select a document library when selecting file location.

    For you second issue, you need to check below things:

    1. Make sure if you have enabled the Reporting feature on your SharePoint site collection.

    2. In the "Configure Audit Settings" page(site settings > Site collection audit settings), make sure if you have enabled "Automatically trim the audit log for this site".

    3. How many number of days you set to retain audit log? Make sure to view the report within the numbers of days of audit log.

    4. Have you select at least one event to audit?

    Besides, try to reactive the Reporting feature in the site collection features in site settings, check if the issue exists.

    Best regards,

    Allen



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    vor 12 Stunden 49 Minuten

Alle Antworten

  • Hi, 

    Are you a site collection admin? Only site collection admin can view the audit report.

    For you first issue, this is by design. The auditing report can only be stored in a document library in the current site. You need to select a document library when selecting file location.

    For you second issue, you need to check below things:

    1. Make sure if you have enabled the Reporting feature on your SharePoint site collection.

    2. In the "Configure Audit Settings" page(site settings > Site collection audit settings), make sure if you have enabled "Automatically trim the audit log for this site".

    3. How many number of days you set to retain audit log? Make sure to view the report within the numbers of days of audit log.

    4. Have you select at least one event to audit?

    Besides, try to reactive the Reporting feature in the site collection features in site settings, check if the issue exists.

    Best regards,

    Allen



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    vor 12 Stunden 49 Minuten
  • Hi Allen,

    Thank you a lot Allen. It works now. I have just missed <g class="gr_ gr_78 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="78" id="78">to choose</g> "Yes" for the "Automatically trim the audit log for this site?"
    So this is not optional!! I mean you have to trim the audit log, right? <g class="gr_ gr_277 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="277" id="277">Otherwise</g> it doesn't work.

    Once again thank you for your help
    Regards
    Ashraf

    vor 10 Stunden 32 Minuten