none
Sprache des Betriebssystems wird nicht unterstützt & Fehlercode 0x84B40000 bei SQL Server 2008 R2 (Product Key ungültig) RRS feed

  • Frage

  •  

    Hallo Cummunity,

     

    habe von der MSDN die SQL Server 2008 R2 Standard x86,x64 ISO (DE) runtergeladen, entpackt & zu installieren versucht ...

    nachdem zuerst die Installation unter Windows 7 x64 (DE) mit der Fehlermeldung abgebrochen wurde, dass die Sprache des Betriebssystems nicht unterstützt wird, hat ein Suche folgende Lösung gebracht:

    mit Regedit zum Schlüssel HKEY_CURRENT_USER\Control Panel\International\Locale

    auf 00000407 (für Deutschland - bei mir war 00000c07???) ändern und Windows neu starten.

     

    nachdem die Sprachlichen Barrieren überwunden waren, die Installation diesmal bereits zum gewohnten Auswahl-Fenster kam, eine NeuInstallation gewählt wird ist dann der folgende SQL Server-Setupfehler aufgetreten:

     

    Der Product Key für SQL Server ist ungültig. Um den Vorgang fortzusetzen, geben Sie die Product Key-Werte des Echtheitszertifikats (Certificate of Authenticity, COA) oder von der Verpackung von SQL Server erneut ein.

     

    Fehlercode 0x84B40000.

     

    hm, eine TestInstallation auf genau demselben System mit der englischen Version hat problemlos geklappt - warum sind bei der deutschsprachigen Version der 2008 R2 gleich derart ungewöhnliche Probleme, die man ohne längerer Suche nicht lösen kann - mir ist dies völlig unverständlich!

     

    gibt's ähnliche Erfahrungen bzw. hat jemand von Euch bereits eine Lösung oder eine Antwort auf meine Frage ...

     

    schöne Grüße aus Salzburg,

    Sebastian

    Montag, 8. November 2010 08:53

Antworten

  • Hallo Sebastian

    Ich hatte hier in der Schweiz soeben das selbe Problem wie du in Österreich.

    Habe das Problem jedoch so lösen können:

    Unter "Region und Sprache" habe ich bei Formate "Deutsch (Deutschland)" und unter Aufenthaltsort "Deutschland" ausgewählt.

    Nun konnte ich SQL Server installieren.

    Mal sehen was passiert, wenn ich später alles wieder auf Schweiz umstelle...

    Freundliche Grüsse aus der Schweiz
    Patrick

    • Als Antwort markiert iT-Geek Freitag, 19. November 2010 10:03
    Donnerstag, 18. November 2010 09:13

Alle Antworten

  • hm, hab zumindest mal einen Ansatz gefunden, woran es liegt & es liegt nur an der Deutschen Version...

     

    der eingetragene Product Key für die deutsche Version ist in der ISO anscheinend richtig, die Installation erkennt diesen jedoch als falsch...

    d.h. entpackt man das ISO-File (z.B. mit 7-Zip) in ein Verzeichnis und ändert im x64 bzw. x86 Unterverzeichnis die DefaultSetup.ini, ergo komentiert man die PID aus (;) läuft das Setup weiter...

    der Product Key ist dann natürlich händisch ein zu tragen - die Frage ist nur welchen, wenn der Richtige nicht funktioniert...

     

    ;SQLSERVER2008 Configuration File

    [SQLSERVER2008]

    ;PID="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX"

     

    der Hinweis 'pre-PIDded' hat mich darauf gebracht, dass der Product Key aus welchem Grund auch immer mit der Deutschen Version nicht will ...

    (beide PK's sind nämlich gleich)

     

    hoffe doch, dass dieser Fehler von Microsoft in der MSDN/TechNet bald korrigiert wird, um dem einen oder anderen die laaaaaaange Sucherei nach einer Lösung zu ersparen...

     

    schöne Grüße aus Salzburg,

    Sebastian

    • Als Antwort markiert iT-Geek Montag, 8. November 2010 14:39
    • Tag als Antwort aufgehoben iT-Geek Montag, 8. November 2010 15:05
    Montag, 8. November 2010 14:39
  • Hallo Sebastian

    Ich hatte hier in der Schweiz soeben das selbe Problem wie du in Österreich.

    Habe das Problem jedoch so lösen können:

    Unter "Region und Sprache" habe ich bei Formate "Deutsch (Deutschland)" und unter Aufenthaltsort "Deutschland" ausgewählt.

    Nun konnte ich SQL Server installieren.

    Mal sehen was passiert, wenn ich später alles wieder auf Schweiz umstelle...

    Freundliche Grüsse aus der Schweiz
    Patrick

    • Als Antwort markiert iT-Geek Freitag, 19. November 2010 10:03
    Donnerstag, 18. November 2010 09:13
  • DANKE Patrick - so simpel die Antwort auch ist - dahinterkommen sollte man ...

    d.h. das Registry editieren kann man sich durch sparen

     

    die Schweizer haben's drauf ;-)

     

    schöne Grüße aus Salzburg in die Schweiz,

    Sebastian

    Freitag, 19. November 2010 10:41
  •  

    nachdem die Sprachlichen Barrieren überwunden waren, die Installation diesmal bereits zum gewohnten Auswahl-Fenster kam, eine NeuInstallation gewählt wird ist dann der folgende SQL Server-Setupfehler aufgetreten:

     

    Der Product Key für SQL Server ist ungültig. Um den Vorgang fortzusetzen, geben Sie die Product Key-Werte des Echtheitszertifikats (Certificate of Authenticity, COA) oder von der Verpackung von SQL Server erneut ein.

     

    Fehlercode 0x84B40000.


    Hallo!

    Ich beschreite gerade den gleichen Leidensweg.

    Wir haben einen Open Vertrag mit MS und habe von der VLSC-Seite MSSQL 2008 R2 Std. (DE) heruntergeladen.

    Das Problem mit der Sprache konnte dank Google schnell gelöst werden.

    Aber auch mein Produkt Key (welcher im Installationsmedium) integriert ist, ist laut Setup nicht gültig.

    Dank dem Tipp mit der "DefaultSetup.ini" bricht das Setup nun nicht mehr ab, sobald ich eine Serverinstanz installieren möchte, jedoch ein paar Klicks später werde ich aufgefordert, den Key manuell einzugeben. Natürlich funktioniert der "extrahierte" Key aus der DefaultSetup.ini nicht.

    Da ich bei MS niemanden mehr in der VL Abteilung erreiche, aber heute den Server zu installieren habe, stehe ich vor einem Problem.

    Hat jemand dazu eine Idee/Lösung parat?

    Vielen Dank!

    Montag, 25. Juli 2011 16:04
  • Installieren mit dem ".\Administrator" also dem lokalen Admin User statt dem Domain Admin klappt!
    • Als Antwort vorgeschlagen xCue Mittwoch, 27. Juli 2011 13:15
    Mittwoch, 27. Juli 2011 13:14
  • Hallo Patrick

    warum wird kein gültiger Key für die Schweiz zur Verfügung gestellt?

    Grüsse us där Schwiz
    Samuel

    Sonntag, 16. Oktober 2011 12:05
  • Hallo besten Dank, hatte auch heute nochmals das Problem.

    Muss beides auf Deutschland umstellen, bei der REG wird bei Deutsch (Deutschland) die Nummer nicht automatisch umgestellt.

    Hier muss sich der Benutzer nur mal kurz abmelden und Anmelden, ist kein Nuestart norwendig.

    Hier sieht es eher nach einem Zufall aus, danach einen "Upgrade" und danach hat man die Evolution (Enterprise) auf Standart.

    Gruss und besten Dank

    Mike

    Donnerstag, 5. Juli 2012 15:47
  • Du bist mein Held.

    Tastatur + sämtliche Regionseinstellungen auf DE-DE setzen, mit WinRAR das .iso entpacken und als lokaler Admin installieren.

    Auf KEINE andere weise konnte ich den SQL-Server installieren!!

    Freitag, 9. Januar 2015 12:11