none
Speicherleck Server 2008 R2 SP1 RRS feed

  • Frage

  • Hallo Leute,

    auf einem der Kundenmaschinen taucht seit kurzem folgendes Phänomen auf:

    Der Arbeitsspeicher ist randvoll, obwohl z.B. der tatsächliche Speicherbedarf bei ca. 30% liegt.Sehe ich mir im Taskmanager den TAB Leistung an, sehe ich, das der fehlende Speicher im Cache liegt.

    Einzig ein Neustart behebt das Problem für kurze Zeit.

    Die Maschine hat folgende Daten:

    Server 2008R2 SP1
    Rolle: RDP (Terminalserver)
    32 GB RAM
    Dual XEON

    Wie bekomme ich heraus, wer mir hier den Speicher wegfrisst?

    Ein HowTo für jemanden, der mit so etwas noch keine Berühung hatte oder eine Empfehlung für ein Tool, das mir dabei hilft, wäre ganz toll.

    Liebe Grüße
    Dieter

    Sonntag, 22. Januar 2012 15:56

Antworten

  • Hallo Leute,

    hat tatsächlich sehr lange gedauert, bis ich dahinter gekommen bin, wo dieses Phänomen herkommt.

    Den ausschlaggebenden Hinweis zum Ziel hat Matthias mit seinem Verweis auf RAMMAP gegeben.

    Mit diesem Tool aus den Sysinternals konnte ich mir tatsächlich einen Weg für die Fehlersuche bilden.

    Der MS Support verdient an dieser Stelle ebenfalls ein dickes Lob. Viele telefonische Diskussionen zum Problem haben geholfen, den Verursacher immer weiter einzukreisen.

    Schlußendlich hat uns Kommissar Zufall auch ein wenig mitgeholfen. (und meine partielle Schlaflosigkeit bei solchen Dingen)

    Um es Kurz zu machen:

    Verursacher dieses Phänomens ist auf allen drei bei diesem Kunden laufenden Maschinen die Software Avira Server Security 2012.

    Die Software startet in der Nacht mit einem Komplettscan der jeweiligen Maschine.

    Dabei habe ich beobachtet, daß der Cache komplett vollläuft. Bis dahin wäre ja noch alles ok. Nur ist die Software insofern buggy, das dieser Cache anschließend nicht mehr freigegeben wird. Weitere Beobachtungen haben dann ergeben, das unser Backup & Recovery von Acronis zwar auch mit dem Cache exzessiv arbeitet aber nach Abschluß seines Tasks schön brav den Cache frei gibt.

    Avira hat dieses Problem untersucht und mehr oder weniger bestätigt. Die Lösung läßt noch auf sich warten.

    Wir fahren im Moment mit folgenden Workaround:

    Als erstes lassen wir den Avira Scan durchlaufen. Anschließend wird mit B&R gesichert und morgens zu Dienstbeginn ist alles fein.

    Die Maschinen laufen seit Einrichtung des Workaround sauber.

    Anhand anderer Maschinen bei anderen Kunden (auch mit W2008R2 SP1, Avira und B&R) konnte ich dieses fehlerhafte Verhalten von Avira verifizieren. Wobei das Phänomen um so ausgeprägter ist, je mehr RAM in so einem Server drin sitzt.

    Ich möchte mich bei allen, die mir bei der Fehlersuche so hilfreich zur Seite gestanden haben, ganz herzlich bedanken.

    Schöne Ostern und nochmal vielen Dank.

    LD Dieter

    Samstag, 7. April 2012 10:57

Alle Antworten