none
All Domain Controller Servers in use are not responding - Exchange 2010 CAS & HUB RRS feed

  • Frage

  • Hallo zusammen,

    auf 2 Hub-Servern, welche schon länger in betrieb sind, installierten wir am letzten Wochende zusätzlich die CAS-Rolle.
    Am selbern Tag haben wir zudem 2 alte 2003er Domänencontroller rausgenommen und die Domänengesamtstruktur anschließend von 2003 auf 2008R2 heraufgestuft.

    Im Laufe der folgenden Woche, hatte einer der beiden CAS Server nun schon 2 mal einen Fehler, wobei sich das Oulook nicht mehr verbinden lässt und auch im OWA nach der Anmeldung die Meldung erscheint: Es wurde kein Server gefunden, der Informationen zu Benutzerkonto und Postfach enthält.

    Nach einem Neustart der Exchange Dienste funktioniert wieder alles einwandfrei.

    Bin wirklich dankbar für jede Hilfe!
    Gruß, Flo

    Im Einsatz sind:
    2 Exchange 2010 SP2 RU5v2 MB Server
    2 Exchange 2010 SP2 RU5v2 HT+CA Server

    EventLogs:

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 7:18:44 AM
    Event ID:      2103
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=6004). All Global Catalog Servers in forest DC=#####,DC=de are not responding:
    DC-Server1
    DC-Server2

    --------------------------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 7:18:44 AM
    Event ID:      2114
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=6004). Topology discovery failed, error 0x80040952 (LDAP_LOCAL_ERROR (Client-side internal error or bad LDAP message)). Look up the Lightweight Directory Access Protocol (LDAP) error code specified in the event description. To do this, use Microsoft Knowledge Base article 218185, "Microsoft LDAP Error Codes." Use the information in that article to learn more about the cause and resolution to this error. Use the Ping or PathPing command-line tools to test network connectivity to local domain controllers.

    ------------------------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 7:21:44 AM
    Event ID:      2604
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process MSEXCHANGEADTOPOLOGY (PID=6004). When updating security for a remote procedure call (RPC) access for the Microsoft Exchange Active Directory Topology service, Exchange could not retrieve the security descriptor for Exchange server object ###### - Error code=80040934.
     The Microsoft Exchange Active Directory Topology service will continue starting with limited permissions.

    -------------------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 7:21:44 AM
    Event ID:      2102
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=6004). All Domain Controller Servers in use are not responding:
    DC-Server1
    DC-Server2

    ------------------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange ActiveSync
    Date:          3/8/2013 7:22:09 AM
    Event ID:      1015
    Task Category: Server
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Exchange ActiveSync experienced a transient error when it tried to access Active Directory information for user "". Exchange ActiveSync will try this operation again. If this event occurs infrequently, no user action is required. If this event occurs frequently, check network connectivity using PING or PingPath. You can also use the Test-ActiveSyncConnectivity cmdlet. More information:

    Microsoft.Exchange.Data.Directory.ADTransientException: Could not find any available Global Catalog in forest #####.
       at Microsoft.Exchange.Data.Directory.ConnectionPoolManager.GetConnection(ConnectionType connectionType, ADObjectId domain, String serverName, Int32 port, NetworkCredential credential)
       at Microsoft.Exchange.Data.Directory.ConnectionPoolManager.GetConnection(ConnectionType connectionType)
       at Microsoft.Exchange.Data.Directory.ADSession.GetConnection(String preferredServer, Boolean isWriteOperation, Boolean isNotifyOperation, String optionalBaseDN, ADObjectId& rootId, ADScope scope)
       at Microsoft.Exchange.Data.Directory.ADGenericReader.GetNextResultCollection(Type controlType, DirectoryControl& responseControl)
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.GetNextResultCollection()
       at Microsoft.Exchange.Data.Directory.ADGenericPagedReader`1.GetNextPage()
       at Microsoft.Exchange.Data.Directory.ADGenericPagedReader`1.<GetEnumerator>d__4.MoveNext()
       at Microsoft.Exchange.Data.Directory.Recipient.ADRecipientSession.FindMiniRecipientBySid[TResult](SecurityIdentifier sId, IEnumerable`1 properties)
       at Microsoft.Exchange.AirSync.ADUserCache.TryGetADUserFromSid(Byte[] sid, ProtocolLogger logger, Boolean shouldUseBudget)
       at Microsoft.Exchange.AirSync.AirSyncUser.InitializeFromLoggedOnIdentity()
       at Microsoft.Exchange.AirSync.AirSyncUser..ctor(AirSyncContext context)
       at Microsoft.Exchange.AirSyncHandler.Handler.BeginProcessRequest(HttpContext httpContext, AsyncCallback asyncCallback, Object extraData)

    ------------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 7:24:44 AM
    Event ID:      2501
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process MSEXCHANGEADTOPOLOGY (PID=6004). The site monitor API was unable to verify the site name for this Exchange computer - Call=HrSearch Error code=80040934. Make sure that Exchange server is correctly registered on the DNS server.

    ----------------------------------------------------------------------

    Log Name:      Application
    Source:        MSExchange Mailbox Replication
    Date:          3/8/2013 7:30:07 AM
    Event ID:      1005
    Task Category: Service
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    The Mailbox Replication service was unable to determine the list of mailbox databases hosted in the local Active Directory site.
    Error: Could not find any available Domain Controller.

    Freitag, 8. März 2013 13:37

Antworten

  • Hallo nochmal,

    ich komme mit erfreulichen Nachrichten.
    Das Problem ist gelöst.

    Ich bedanke mich recht herzlich bei allen Mitwirkenden!

    Das Problem lag an der Umstellung der Domänenfunktionsebene von 2003 auf 2008R2.
    Hiernach kann es zu den im ersten Post beschriebenen Fehlern im Exchange kommen.
    Die Lösung ist das Neustarten des “KERBEROS DISTRIBUTION KEY (KDC) service” auf den DCs.
    http://visualplanet.org/blog/?p=20

    Hinweis: Ein Neustart des gesamten Domänencontrollers hielf in manchen Fällen nicht.

    Mit freundlichen Grüßen
    Flo
    • Bearbeitet Flo.Rena Mittwoch, 13. März 2013 08:58
    • Als Antwort markiert Flo.Rena Mittwoch, 13. März 2013 08:59
    Mittwoch, 13. März 2013 08:55

Alle Antworten

  • Hallo

    Sind auf dem Exchange Server noch die alten DNS-Server IP-Adressen der DCs eingestellt?

    Ist evtl. ein statischer Domänen-Controller auf den Exchange Server konfiguriert?

    Gruss Andy


    Freitag, 8. März 2013 13:58
  • Danke für die schnelle Antwort!!

    Die neuen DNS Server wurden schon vor längerer Zeit eingetragen.

    Da ich nicht weiß, wie ich einen statischen DC hinterlegen kann,
    gehe ich davon aus, dass dies auch nicht der Fall ist.
    Könntest du mir trotzdem bitte sagen, wie ich das prüfen kann,
    um dies auch wirklich ausschließen zu können.

    Gruß

    Freitag, 8. März 2013 14:18
  • Natürlich. 

    Get-ExchangeServer -status | fl name, *domaincontroller*, *global*

    Der Global Catalog wurde auf den neuen DCs aktiviert? 


    Freitag, 8. März 2013 14:21
  • Da ist kein statischer DC eingetragen.
    Ja, der Globale Catalog ist auf beiden neuen Servern aktiviert.

    Hast du vielleicht noch mehr Ideen?

    Habe noch einen vielleicht interessanten Event-Eintrag gefunden,
    welcher jeden Tag einmal erscheint und indem einer der alten DCs abgefragt wird:

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          3/8/2013 2:48:58 PM
    Event ID:      2070
    Task Category: Topology
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      ######
    Description:
    Process w3wp.exe () (PID=5400).  Exchange Active Directory Provider lost contact with domain controller ##"alter DC"##.  Error was 0x51 (ServerDown) (Active directory response: The LDAP server is unavailable.).  Exchange Active Directory Provider will attempt to reconnect with this domain controller when it is reachable.

    • Bearbeitet Flo.Rena Freitag, 8. März 2013 14:33
    Freitag, 8. März 2013 14:28
  • Hast du bereits einmal geschaut, wenn der vorhanden ist, ob die Zeit synchron mit den DC's ist? Stichwort: Integration Tools -> Time Sync. 
    Freitag, 8. März 2013 14:30
  • Die Exchange Server beziehen sich die Zeit von den neuen DCs
    und diese stimmt überein.

    Freitag, 8. März 2013 14:43
  • Wenn das Problem existiert, stimmt die Zeit auch noch? Reicht ein Neustart der Services aus oder muss der Server neu gestartet werden?

    Findest du während dem Problemfall Fehler in den EventLogs? 

    Freitag, 8. März 2013 15:49
  • Ja, auch während des Problems stimmte immer die Zeit.

    Ein Neustart der Exchange-Dienste reicht aus.

    Während des Problems, werden die Einträge,
    welche ich im ersten Post erwähnte, immer wiederkehrend ins Log geschrieben.

    Danke für das weitere Interesse!

    Freitag, 8. März 2013 16:30
  • Sorry für die nicht vollständige Fragestellung. Die Frage sollte eigentlich lauten, ob du Fehler in den DC's findest und nicht im Exchange. 
    Freitag, 8. März 2013 16:42
  • Achso...
    Nein, auch da hab ich schon geschaut...
    Leider keine aufschlussreiche Einträge dabei :-(
    Freitag, 8. März 2013 17:06
  • Hi Flo.Rena,

    Achso...
    Nein, auch da hab ich schon geschaut...
    Leider keine aufschlussreiche Einträge dabei :-(

    schau dir mal folgende Seite an und pass die Netzwekeinstellung an:
    http://clintboessen.blogspot.de/2012/09/exchange-2010-randomly-loosing-access.html

    netsh int tcp set global chimney=disabled
    netsh int tcp set global rss=disabled
    netsh int tcp set global taskoffload=disabled
    netsh int tcp set global autotuninglevel=disabled
     ...oder hier...
    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/8a0fd948-d75e-4a82-b0d4-68b6b7f3ba31


    Viele Grüße
    Christian

    Freitag, 8. März 2013 19:50
    Moderator
  • Hallo zusammen,

    und danke für die Unterstützung!

    Leider breitete sich das Problem über das Wochenende aus.
    Der zweite CA-Server und einer von zweien MB-Servern,
    welche in einem DAG Verbund sind, weisen nun die gleichen Fehler auf.

    @Christian: Danke für deinen Hinweis.
    Ich habe die Einstellungen bereits vorgenommen und seitdem kam es bis jetzt noch zu keinem Problem.
    Jedoch, lief der genannte MB-Server schon seit mehreren Monaten ohne Zwischenfälle durch.
    Hätte es demnach nicht schon viel früher zu dem Fehler kommen müssen?

    Brauche wirklich dringend eure Hilfe. Danke!

    Flo

    Montag, 11. März 2013 14:56
  • Hi Flo.Rena,

    @Christian: Danke für deinen Hinweis.
    Ich habe die Einstellungen bereits vorgenommen und seitdem kam es bis jetzt noch zu keinem Problem.
    Jedoch, lief der genannte MB-Server schon seit mehreren Monaten ohne Zwischenfälle durch.
    Hätte es demnach nicht schon viel früher zu dem Fehler kommen müssen?

    Eigentlich ja, fraglich, was sich da noch geändert hat. Windows Updates optimieren auch gerne.

    Brauche wirklich dringend eure Hilfe. Danke!

    Dringenden Support bekommst du bei MS und einem Dienstleister deiner Wahl:
    http://support.microsoft.com/?ln=de


    Viele Grüße
    Christian

    Montag, 11. März 2013 18:29
    Moderator
  • Entschuldigt, dass ich mit dem Thema immer noch stören muss.

    Versteh ich das denn richtig, dass wenn ein Exchange Server für kurze Zeit die Verbindung zum AD verliert,
    die Exchange Dienste die Verbindung nicht wieder aufbauen können, obwohl das AD längst wieder zu Verfügung steht.

    Ist das ein Bug von Exchange, oder besteht da anderweitiges Problem meines Systems,
    was möglicherweise garnichts mit Exchange zu tun hat?

    Dies ist übrigens der Eintrag im Log solange der Server noch funktioniert:

    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=10896). Exchange Active Directory Provider has discovered the following servers with the following characteristics:
     (Server name | Roles | Enabled | Reachability | Synchronized | GC capable | PDC | SACL right | Critical Data | Netlogon | OS Version)
    In-site:
    dc1.domäne.de    CDG 1 7 7 1 0 1 1 7 1
    dc2.domäne.de    CDG 1 7 7 1 0 1 1 7 1
     Out-of-site:

    Danke!
    Mit freundlichem Gruß, Flo

    • Bearbeitet Flo.Rena Dienstag, 12. März 2013 11:08
    Dienstag, 12. März 2013 10:31
  • Sind denn alle Einträge der DCs im DNS korrekt. Also die _msdcs.domain.com Einträge.

    Gruß

    Jörg

    Dienstag, 12. März 2013 15:22
  • Hallo nochmal,

    ich komme mit erfreulichen Nachrichten.
    Das Problem ist gelöst.

    Ich bedanke mich recht herzlich bei allen Mitwirkenden!

    Das Problem lag an der Umstellung der Domänenfunktionsebene von 2003 auf 2008R2.
    Hiernach kann es zu den im ersten Post beschriebenen Fehlern im Exchange kommen.
    Die Lösung ist das Neustarten des “KERBEROS DISTRIBUTION KEY (KDC) service” auf den DCs.
    http://visualplanet.org/blog/?p=20

    Hinweis: Ein Neustart des gesamten Domänencontrollers hielf in manchen Fällen nicht.

    Mit freundlichen Grüßen
    Flo
    • Bearbeitet Flo.Rena Mittwoch, 13. März 2013 08:58
    • Als Antwort markiert Flo.Rena Mittwoch, 13. März 2013 08:59
    Mittwoch, 13. März 2013 08:55