none
Netzlaufwerk verbinden über GPO - "Rotes Kreuz" bei Netzlaufwerk RRS feed

  • Frage

  • Hallo,

    wir wollen unser Skript (Kixtart) umstellen und die Laufwerke in Zukunft über GPO mappen.

    Das funktioniert auch soweit, allerdings habe ich jetzt festgestellt, dass bei uns eine Fach-Anwendung auf das gemappte Laufwerk zugreifen wollte, allerdings hat das nicht richtig funktioniert.

    Als ich nachgesehen habe, war am Laufwerk ein "Rotes Kreuz". Sobald ich da wieder daraufgeklickt habe, hat auch die Anwendung funktioniert.

    Beim zuweisen des Laufwerks über das Skript hatten wir das Problem nicht. 

    Ich habe etwas über einen Wert "autodisconnect" gelesen, wäre das eine Lösung oder gibt es noch wo anders ein Problem ?

    Christian

    Montag, 11. Dezember 2017 10:30

Alle Antworten

  • Hallo Christian,

    "Sobald ich da wieder daraufgeklickt habe, hat auch die Anwendung funktioniert"

    Wird das Laufwerk sonst (d.h. ohne die Anwendung) zugegriffen? Vielleicht ein falsch positiver Fehler?

    Grüße,

    Yavor

    Montag, 11. Dezember 2017 10:49
  • Hallo,

    nein ich sehe im Explorer das Laufwerk angzeigt, allerdings mit einem roten Kreuz versehen. Wenn ich dann auf das Laufwerk klicke, dann scheint wieder eine Verbindung aufgebaut zu werden, erst dann funktioniert die Fachanwendung wieder.

    Wir könnten versuchen, ob Word oder Excel ähnlich reagiert.

    Viele Grüße

    Christian

    Montag, 11. Dezember 2017 14:11
  • Das ist leider State-of-the-Art seit Windows 10:

    Bereits beim Booten können Laufwerke gemappt werden. Dabei kann das Booten u.U. eben etwas länger dauern da ja die Netzressourcen geprüft werden müssen.
    Man kann den Bootvorgang beschleunigen, in dem man die Netzressourcen erst beim Zugriff zuordnet. Die Einstellung hierfür finde ich nicht mehr.
    Leider meint Microsoft damit nun ausschließlich den manuellen Zugriff, nicht den programmgesteuerten.
    Ist der manuelle Zugriff erfolgt, klappt auch der automatische Zugriff.

    Umgehen kann man das nur mit einem Sript in der Aufgabenplanuzng "Bei Anmeldung, 30 Sekunden Verzögerung".
    Hier im Forum gabs mal einen Beitrag.
    - Alle Laufwerke unmappen!
    - Alle benötigten Laufwerke nun mappen (mit User/Kennwort)
    Montag, 11. Dezember 2017 14:26
  • Sorry, ich habe nur die hälfte geschrieben:

    Wir setzen windows 7 ein 64-bit, das Laufwerk wird ja gemappt 

    Montag, 11. Dezember 2017 14:53
  • Auch Windows 7 unterliegt da noch Updates. Wer weiß, welches der vielen Sicherheitsupdates diese Verhalten eben auch für Windows 7 eingebracht hat.

    https://www.windowsforum.de/thema/netzlaufwerk-spaeter-verbinden-als-das-netzwerk.100899/

    Montag, 11. Dezember 2017 14:58
  • Am 11.12.2017 schrieb schwarzchr:

    Das funktioniert auch soweit, allerdings habe ich jetzt festgestellt, dass bei uns eine Fach-Anwendung auf das gemappte Laufwerk zugreifen wollte, allerdings hat das nicht richtig funktioniert.

    Als ich nachgesehen habe, war am Laufwerk ein "Rotes Kreuz". Sobald ich da wieder daraufgeklickt habe, hat auch die Anwendung funktioniert.

    Hast Du diese GPO-Einstellungen gesetzt?
    https://www.gruppenrichtlinien.de/de/artikel/fast-logon-schnelles-anmelden-asynchrones-startverhalten-ehemals-faq-36/

    Falls die o.g. Einstellungen nicht helfen, hier noch eine Erweiterung:
    https://www.gruppenrichtlinien.de/de/artikel/ssd-zu-schnell-synchroner-startvorgang-nicht-moeglich/

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Montag, 11. Dezember 2017 17:06
  • Am 11.12.2017 um 15:53 schrieb schwarzchr:
    > Wir setzen windows 7 ein 64-bit, das Laufwerk wird ja gemappt 
     
    Tausche es gegen 8.1, wenn du 10 nicht magst.
    Ab 8.1 ist GPP Drivemapping im Hintergrund möglich und dieser Fehler ist
    weg.
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Group Policy - Cloud and Datacenter Management
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    GET Privacy and DISABLE Telemetry on Windows 10 - gp-pack PaT
     
    Montag, 11. Dezember 2017 19:18
  • Windows 10 kommt nächstes Jahr.

    Ich werde mal Anmeldeskripts gleichzeitig ausführen setzen, da gab es bei uns immer Probleme,

    da muss ich mal sehen, dass wir die in den Griff bekommen.

    Wenn die Einstellung gesetzt ist, dann benötigen die Kollegen eine lange Zeit bis der Desktop aufgebaut wird, d.h. das Anmelden dauert sehr lange.

    Dienstag, 12. Dezember 2017 07:01
  • Also ich habe den Wert "Anmeldeskript gleichzeitig ausführen jetzt gesetzt" die Kollegin hat sich angemeldet, das Anmelden hat super funktioniert, allerdings ist das rote Kreuz immer noch da.

    Macht es Sinn, wenn ich als erstes Argument bei den Laufwerkszuordnungen das Laufwerk lösche ?

    Dienstag, 12. Dezember 2017 07:12
  • Hatte ich das niocht geschrieben?

    "Hier im Forum gabs mal einen Beitrag.
    - Alle Laufwerke unmappen!
    - Alle benötigten Laufwerke nun mappen (mit User/Kennwort)"

    Das Script sollte aber verzögert ausgeführt werden, da das Netz u.U. noch nicht bereit ist.
    Ggf. kann man das über eine Ping-Schleife ja prüfen.

    Dienstag, 12. Dezember 2017 07:32
  • wir wollen unser Skript (Kixtart) umstellen und die Laufwerke in Zukunft über GPO mappen.

    Mag mich auch noch einmischen :-)

    Wenn Du mit nem Skript bisher gut klarkommst: Bleib dabei. Der Mehrwert von GPP Drive Mappings tendiert gegen negativ...

    Als ich nachgesehen habe, war am Laufwerk ein "Rotes Kreuz". Sobald ich da wieder daraufgeklickt habe, hat auch die Anwendung funktioniert.

    Ja, weil Du "Verbindung automatisch wiederherstellen" gesetzt hast ("persistent:yes" beim net use). Nimm das raus, dann sollte es gehen.

    Und komm nicht auf die Idee, "Replace" statt "Update" zu verwenden :-)

    Dienstag, 12. Dezember 2017 15:47
    Beantworter
  • Am 12.12.2017 um 16:47 schrieb Martin Binder [MVP]:
    [...] Der Mehrwert
    > von GPP Drive Mappings tendiert gegen negativ...
    > Und komm nicht auf die Idee, "Replace" statt "Update" zu verwenden :-)
     
    #metoo :-)
     
    Wobei Replace in noch 7 ok ist, mach das mal in der 10 :-D
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Group Policy - Cloud and Datacenter Management
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    GET Privacy and DISABLE Telemetry on Windows 10 - gp-pack PaT
     
    Dienstag, 12. Dezember 2017 19:03
  • So jetzt habe ich mal noch ein paar Tests funktioniert.

    Ich habe zuerst das Laufwerk in der Richtlinie gelöscht und dann hinzugefügt, aber egal was ich da angebe ich muss Verbindung automatisch wiederherstellen anklicken damit es funktioniert.

    Auch wenn mich die Experten lynchen:

    Wie ist denn die Abarbeitung der Richtlinien bzw. meines Anmeldeskriptes ? Könnte es eine Möglichkeit sein, wenn ich im Anmeldeskript eine pauschale Trennung des Laufwerkes, das ich später in den Gruppenrichtlinien zuweise, eingebaut habe, dass ich da Probleme habe ?


    Donnerstag, 14. Dezember 2017 14:16
  • > Wie ist denn die Abarbeitung der Richtlinien bzw. meines Anmeldeskriptes ? Könnte es eine Möglichkeit sein, wenn ich im Anmeldeskript eine pauschale Trennung des Laufwerkes, das ich später in den Gruppenrichtlinien zuweise, eingebaut habe, dass ich da Probleme habe ?

    Jo :-) Skripts laufen immer als letztes. Also "später zuweise" ist eher falsch :D

    Donnerstag, 14. Dezember 2017 15:12
    Beantworter
  • Am 14.12.2017 schrieb schwarzchr:

    Ich habe zuerst das Laufwerk in der Richtlinie gelöscht und dann hinzugefügt, aber egal was ich da angebe ich muss Verbindung automatisch wiederherstellen anklicken damit es funktioniert.

    Dann ist etwas nicht in Ordnung. Melde dich auf einem Client an und
    lass ein einfaches net use x: \\Server\Freigabe [ENTER] laufen. Was
    passiert?

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Freitag, 15. Dezember 2017 06:03
  • Vielen Dank für Euro Tipps.

    Ich habe die Anweisung zum Löschen des Laufwerkes aus dem Skript entfernt - siehe da es funktioniert ohne "Verbindung automatisch herstellen" und das rote kreuz ist auch weg.

    Noch ein Frage:

    Wenn die Skripts nach der Verarbeitung der GPOS laufen, warum wurde das Laufwerk trotzdem zugewiesen ?


    Dienstag, 19. Dezember 2017 14:16
  • Bei der Zuweisung gibt es ein Flag "Permanent". Daher merkt sich Windows die Zuweisungen über den Login hinaus.
    Lässt du den Parameter weg, wird die Zuweisung beim Logoff automatisch entfernt.
    Dienstag, 19. Dezember 2017 15:12
  • Noch eine weitere Frage:

    Ich habe jetzt eine Abteilung 1, da wird das Laufwerk H in den Gruppenrichtlinien zugeordnet.

    Jetzt gibt es da einen berechtigten Benutzer, der aber als H das Laufwerk einer anderen Abteilung 2 zugewiesen bekommen soll und als Laufwerk R das Laufwerk der Abteilung 1 zugewiesen bekommt.

    Im Anhang das Beispiel wie ich Abteilung 1 das Laufwerk zuordne.

    Wie stelle ich denn das an ?

    Wie kann ich es anstellen, dass bei Benutzern, die in den Richtlinien das Laufwerk zugewiesen bekommen, evtl. im Anmeldeskript dann je an welchem PC sie sich anmelden, ein anderes Laufwerk H zugewiesen bekommen.

    Mein Problem ist immer noch, dass ich gedacht habe ich weiße in den GPOs die Laufwerke zu und dann erst wird das Skript abgearbeitet, wo ich dann evtl. diese Zuordnung wieder anders machen kann

    Mittwoch, 20. Dezember 2017 14:11
  • Jetzt gibt es da einen berechtigten Benutzer, der aber als H das Laufwerk einer anderen Abteilung 2 zugewiesen bekommen soll und als Laufwerk R das Laufwerk der Abteilung 1 zugewiesen bekommt.

    Jetzt bist Du an dem Punkt, wegen dem ich immer empfehle, keine GPP für Laufwerkzuordnungen zu verwenden.

    Auf dem Endgerät werden Laufwerke nicht einer Gruppe zugeordnet, sondern einem einzelnen User. Deshalb ist es technisch eigentlich Unfug, das im AD an Gruppen zu hängen... Administrativ ist es natürlich komfortabel.

    Wie kann ich es anstellen, dass bei Benutzern, die in den Richtlinien das Laufwerk zugewiesen bekommen, evtl. im Anmeldeskript dann je an welchem PC sie sich anmelden, ein anderes Laufwerk H zugewiesen bekommen.

    Das muß Dein Skript erledigen. Wenn ein Laufwerk bereits verbunden ist, aber den falschen UNC-Pfad hat, mußt Du es trennen und neu verbinden.

    Mittwoch, 20. Dezember 2017 15:27
    Beantworter