none
Keine Verbindung zu Report Server / Manager möglich RRS feed

  • Frage

  • Guten Morgen,

    Ich versuche zur Zeit den Webdienst für meinen Report Server aufzurufen. Über die im Konfigurations-Manager angegebene URL kann ich ihn aber nicht erreichen. Mittlerweile folgt dort die Fehlermeldung "The permissions granted to user 'CARD\ueberalldo' are insufficient for performing this operation. (rsAccessDenied)". Wenn ich den Report Manager über die im Internet angegebene URL (http:// [ComputerName]:80/reports) aufrufen möchte wird dieser garnicht gefunden.

    Habe ich etwas übersehen ? Oder wie kann ich mir die Zugriffsrechte holen ? Bin lokal an meinem Laptop als Administrator angemeldet.

    Danke schonmal!

    Grüße Dominic

    Donnerstag, 30. April 2015 06:28

Antworten

Alle Antworten

  • Oder wie kann ich mir die Zugriffsrechte holen ? Bin lokal an meinem Laptop als Administrator angemeldet.

    Hallo Dominic,

    übersehen hast Du da nichts, entgegen den anderen Dienste wie der Datenbank Engine, Analysis Services etc. muss man in der Tat die Berechtigungen bei SSRS nach der Installation einrichten.

    Bei den aktuellen Windows OS Versionen kannst Du als Admin angemeldet sein, Admin-Rechte hast Du deswegen noch lange nicht; nennt sie UAC. Mach mal im Startmenu Rechte-Maus Klick auf den Internet Explorer "Als Administrator ausführen" und öffne dann die Report Manager URL http://localhost/Reports , oben Rechts findest Du "Side Settings" (in DE glaube Einstellungen), dann auf Tab "Sicherheit", dort kannst Du Deinen Account hinzufügen mit der Rollenzuordnung "System Administrator". Danach solltest Du die Seite auch erreichen, wenn Du den IE nicht als Admin startest.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Donnerstag, 30. April 2015 06:45
  • Danke erstmal für die schnelle Antwort.

    Mittlerweile komm ich auf die Seite auf dem Bild. Sieht erstmal nicht nach einer Fehlermeldung aus. Aber Inhalt ist auch keiner da, liegt das daran das ich noch keine Berichte auf dem Server habe oder sollte das im Normalzustand trotzdem, auch ohne Berichte, anderes aussehen ? Habe dabei den IE mal als Admin ausgeführt.

    Auf deine URL "http://localhost/Reports" komme ich leider nicht.


    nb087/ReportServer_SQLEXPRESS - /



    Microsoft SQL Server Reporting Services, Version 12.0.2000.8

    Donnerstag, 30. April 2015 06:55
  • Du solltest zumindest oben Links ein Ordner-Icon und "Berichtsportal" sehen, sowie oben Rechts ein paar Links wie "Home", "Side Settings" und Help, darunter dann ein Icon Bar.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Donnerstag, 30. April 2015 07:03
  • Das bekomme ich leider alles nicht. Lediglich die Meldung das mir Berechtigungen fehlen ist weg. (Bei Firefox hilft das Öffnen als Administrator übrigens nichts) 

    Was für Gründe kann es denn für mein Problem geben ? Weiß momentan nicht genau in welche Richtung ich forschen soll. Und wie kann es sein das ich den Report Manager garnicht aufrufen kann also die URL "http://localhost/reports" ?


    Role Assignments kann ich anscheinend über den Report Manager machen. Aber eben diesen erreiche ich nicht. Gibt es speziell da vielleicht Tipps woran es liegen könnte ?
    Donnerstag, 30. April 2015 07:16
  • ...

    Was für Gründe kann es denn für mein Problem geben ? Weiß momentan nicht genau in welche Richtung ich forschen soll. Und wie kann es sein das ich den Report Manager garnicht aufrufen kann also die URL "http://localhost/reports" ?

    ...

    Das bei Dir auch der Instanz-Name ("SQLEXPRESS") dazugehört, ist aber klar, oder?

    Sodann wäre mal interessant, wie fertig Deine Konfiguration wirklich ist.Noch hilfreicher wäre ein Auszug des aktuellen Errorlogs von SSRS. Diese liegen im Standard hier: C:\Program Files\Microsoft SQL Server\MSRS12.<INSTANZ>\Reporting Services\LogFiles


    Andreas Wolter (Blog | Twitter)
    MCSM: Microsoft Certified Solutions Master Data Platform, MCM, MVP
    www.SarpedonQualityLab.com | www.SQL-Server-Master-Class.com

    Donnerstag, 30. April 2015 07:58
  • Ok, die Seite die ich oben angezeigt habe war die URL zum Server. Ob die im Normalfall anders aussehen sollte weiß ich grade noch nicht. Die URL zum Manager funktioniert jetzt.

    Danke schonmal für die Geduld mit mir und für die schnelle Hilfe! :)

    Einen schönen Feiertag und ein schönes Wochenende allen Helfern ;)

    Donnerstag, 30. April 2015 08:07
  • Danke. Das ist schon genau richtig so.

    Aber Achtung. In der Datei wird Dein Domain+Benutzername aufgeführt.

    Auf jeden Fall ist es immer noch ein klares Berechtigungsproblem.

    "library!ReportServer_0-3!1bb0!04/30/2015-08:17:14:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: , Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'Domain\User' are insufficient for performing this operation.;"

    UAC verwendest Du ja bereits. Und Dieser Account ist auch wirklich lokaler Admin? Kannst Du mal die Sicherheitseinstellungen des IE heruntersetzen noch?


    Andreas Wolter (Blog | Twitter)
    MCSM: Microsoft Certified Solutions Master Data Platform, MCM, MVP
    www.SarpedonQualityLab.com | www.SQL-Server-Master-Class.com

    Donnerstag, 30. April 2015 08:23
  • Bei einer benannten Instanz wie hier SQLEXPRESS solltest Du die ReportManager URL über

    http://localhost/reports_SQLEXPRESS

    erreichen. Über http://localhost/reportserver_SQLEXPRESS kommst Du auf den Service, da sollte eine Ansicht kommen wie bei FTP Server, wenn man die im Browser aufruft, also eine Art Dateiverzeichnis, die bei Dir aber leer sein wird, weil noch keine Reports vorhanden sind.

    Und die beiden URL's müssen unterschiedlich sein, wenn das in Deiner Konfiguration anderes ist, dann ist das falsch und muss korrigiert werden.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]


    Donnerstag, 30. April 2015 08:25