none
Outlook - SmartCard PIN wird beim digitalen Signieren mehrfach abgefragt RRS feed

  • Frage

  • Hallo,

    ich verwende Outlook 2016 zusammen mit einer D-Trust Signaturkarte um Mails zu signieren.

    Wenn ich eine Mail zum signieren markiert habe, kommt wie vorgesehen die PIN Abfrage. Gebe ich die PIN ein und bestätige erscheint im Display des Kartenlesegeräts die Rückmeldung "Korrekt". Im Anschluss werde ich aber bis zu 4 Mal nach der PIN gefragt, bevor die Mail tatsächlich signiert ist. Gebe ich die PIN hier einmal falsch ein bekomme ich auch eine andere Rückmeldung vom Kartenleser.

    Beim Adobe Reader funktioniert das digitale Signieren mit einfacher PIN Abfrage.

    Wie kann ich Outlook dazu bekommen nur einmal pro Mail oder noch besser nur einmal beim öffnen des Programms nach dem PIN zu fragen?


    • Bearbeitet SvenW Elp Dienstag, 1. September 2020 08:22
    Dienstag, 1. September 2020 06:51

Antworten

  • Hallo Sven,

    wenn Du die ursprüngliche CER- oder PFX-Datei mit der Signatur hast, kannst Du versuchen, dieses Problem zu beheben, indem Du das Zertifikat aus dem Windows-Kryptospeicher entfernst (mit certmgr.msc oder IE - Schnittstelle zum Kryptospeicher – Tools > Internetoptionen > Inhalt > Zertifikate), dann das Zertifikat erneut importieren und das höhere Niveau der Schlüsselsicherheit deaktivieren.

    Wenn die erste Option aktiviert ist, wirst Du bei jeder Verwendung des Zertifikats von Windows zur Eingabe des Kennworts für den privaten Schlüssel aufgefordert. Stelle sicher, dass dieses Kontrollkästchen deaktiviert ist. Stelle jedoch sicher, dass das zweite Kontrollkästchen "Diesen Schlüssel als exportierbar markieren" aktiviert ist, sodass Du Deinen privaten Schlüssel zu Sicherungszwecken exportieren kannst oder wenn Du jemals den PC änderst und die gespeicherte Datei erneut importieren musst.

    Ich hoffe, Du kommst damit ein bischen weiter.

    Gruß

    Mihaela 


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 3. September 2020 19:30
    Moderator

Alle Antworten

  • Hallo Sven,

    wenn Du die ursprüngliche CER- oder PFX-Datei mit der Signatur hast, kannst Du versuchen, dieses Problem zu beheben, indem Du das Zertifikat aus dem Windows-Kryptospeicher entfernst (mit certmgr.msc oder IE - Schnittstelle zum Kryptospeicher – Tools > Internetoptionen > Inhalt > Zertifikate), dann das Zertifikat erneut importieren und das höhere Niveau der Schlüsselsicherheit deaktivieren.

    Wenn die erste Option aktiviert ist, wirst Du bei jeder Verwendung des Zertifikats von Windows zur Eingabe des Kennworts für den privaten Schlüssel aufgefordert. Stelle sicher, dass dieses Kontrollkästchen deaktiviert ist. Stelle jedoch sicher, dass das zweite Kontrollkästchen "Diesen Schlüssel als exportierbar markieren" aktiviert ist, sodass Du Deinen privaten Schlüssel zu Sicherungszwecken exportieren kannst oder wenn Du jemals den PC änderst und die gespeicherte Datei erneut importieren musst.

    Ich hoffe, Du kommst damit ein bischen weiter.

    Gruß

    Mihaela 


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 3. September 2020 19:30
    Moderator
  • Hallo Mihaela,

    ich bin erst heute dazu gekommen das zu testen. Das Programmverhalten ist halt auch eher lästig als ein echtes Problem.

    Ändern konnte ich das Programmverhalten nicht. Mein Problem an der Stelle ist, das Outlook den Schritt an dem man die Einstellung beim Zertifikatimport vornehmen könnte einfach überspringt. Mein Zertifikat ist kein Software Zertifikat sondern liegt auf einer Smart Card. Das wird dann über Schnittstellenmagie sofort in Outlook angezeigt, sowie das Programm merkt das die Karte im USB Kartenleser gesteckt ist. Von Hand kann ich das auch nicht einlesen, da ich nicht wüsste wie man dem IE oder Outlook den Importpfad auf der Smart Card angeben kann.

    Also habe ich versucht einen Weg um dieses Problem herum zu suchen. Mir ist dabei diese Gruppenrichtlinie aufgefallen.

    Computerkonfiguration>Windows-Einstellungen>Sicherheitseinstellungen>Lokale Richtilinien>Sicherheitsoptionen> Systemkryptografie: Starken Schlüsselschutz für auf dem Computer gespeicherte Benutzerschlüssel erzwingen
    Einstellung gesetzt: "Benutzer wird zur Eingabe aufgefordert, wenn der Schlüssel zum ersten Mal verwendet wird"

    Das liest sich so als wäre es was ich suche, funktioniert aber nicht. (gpupdate /force und neustart und geprüft das die richtlinie noch gesetzt hab ich danach auch mal durchgeführt).

    Übersehe ich da was oder gibt es einen Weg von der Smart Card das Zertifikat direkt zu importieren?

    Montag, 1. März 2021 09:39