none
SCCM Deploy Windows 10 SCCM Client installiert nicht RRS feed

  • Allgemeine Diskussion

  • Moin Moin,

    wir sind gerade dabei Windows 10 zu testen. Das Upgraden via Windows vNext funktioniert gut, da haben wir keine Probleme. Als Nächstes wollten wir Windows 10 per PXE installieren. Dieses funktioniert auch, nur haben wir das Problem, dass der SCCM-Client nicht installiert wird. Im Log steht, das die Installation vom Client erfolgreich war. Die WIM die wir nutzen ist die Install.wim von Windows 10 Build 10586.


    Zur Umgebung:

    Windows Server 2012 mit einem SQL Server 2012; System Center 2012 Configuration Manager SP2 mit CU2


    LOG:

    Parsing step node: Windows und ConfigMgr einrichten	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Description: Aktionen zum Einrichten von Windows und des ConfigMgr-Clients	TSManager	29.02.2016 15:36:48	372 (0x0174)
    ContinueOnError: 	TSManager	29.02.2016 15:36:48	372 (0x0174)
    SuccessCodeList: 0	TSManager	29.02.2016 15:36:48	372 (0x0174)
    RetryCount: 0	TSManager	29.02.2016 15:36:48	372 (0x0174)
    No condition is associated with the step.	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Disable: 	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Run in attribute: WinPEandFullOS	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Timeout: 	TSManager	29.02.2016 15:36:48	372 (0x0174)
    DefaultVarlist found	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Variable name: SMSClientInstallProperties	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Variable name: _SMSClientPackageID	TSManager	29.02.2016 15:36:48	372 (0x0174)
    Action command line: OSDSetupWindows.exe	TSManager	29.02.2016 15:36:48	372 (0x0174)

    Leider weiß ich nicht weiter und ich hoffe einer von euch kann mir weiter helfen.

    Gruß,

    Umut.




    Dienstag, 1. März 2016 07:30

Alle Antworten

  • Was sagt smsts.log und ccmsetup.log?

    Simon Dettling | msitproblog.com | @SimonDettling

    Dienstag, 1. März 2016 07:44
  • Da hilft nur ccmsetup.exe auf dem Client weiter und ggfs. noch smsts.log

    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 1. März 2016 07:48
    Beantworter
  • Ich habe eben ein Rechner nochmal versucht aufzusetzen. Es gibt unter Windows keine CCMSetup Ordner oder logs. Auf dem Datenträger D gibt es unter _SMSTaskSequence\Logs eine Log-Datei:

    Log-Datei:

    http://1drv.ms/1TjL1Pb

    Was ich vergessen hatte zu schreiben ist, das über die Konsole ich den Client installieren kann.

    Dienstag, 1. März 2016 08:24
  • Gemäss dem Log scheitert DISM bei der Anwendung der Treiber in WinPE:

    Failed to provision driver. Code 0x80070032

    Failed to run the action: Treiberpaket HP 800G1 Win10 anwenden.
    The request is not supported. (Error: 80070032; Source: Windows)

    Sind die Treiber welche du verwendest vollumfänglich Windows 10 kompatibel?

    Konsultiere einmal folgendes Log-File für weiteres Troubleshooting: D:\_SMSTaskSequence\PkgMgrTemp\dism.log


    Simon Dettling | msitproblog.com | @SimonDettling

    Dienstag, 1. März 2016 10:46
  • Moin Moin,

    unter D:\_SMSTaskSequence gibt es kein Ordner mit dem Namen "PkgMgrTemp", aber im Ordner Log gibt es ein Logfile mit dem Namen dism.log. Eventuell kannst du damit was anfangen. Der Treiber ist Windows 10 kompatibel (es handelt sich um eine Netzwerkkarte die Intel i217-LM). Diesen Treiber habe ich mir von der HP Seite gezogen.

    2016-03-02 08:06:59, Info                  DISM   PID=1400 TID=1444 Scratch directory set to 'D:\_SMSTaskSequence\PkgMgrTemp\'. - CDISMManager::put_ScratchDir
    2016-03-02 08:06:59, Info                  DISM   PID=1400 TID=1444 DismCore.dll version: 6.3.9600.16384 - CDISMManager::FinalConstruct
    2016-03-02 08:06:59, Info                  DISM   PID=1400 TID=1444 Successfully loaded the ImageSession at "X:\WINDOWS\System32\Dism" - CDISMManager::LoadLocalImageSession
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Found and Initialized the DISM Logger. - CDISMProviderStore::Internal_InitializeLogger
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Failed to get and initialize the PE Provider.  Continuing by assuming that it is not a WinPE image. - CDISMProviderStore::Final_OnConnect
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Finished initializing the Provider Map. - CDISMProviderStore::Final_OnConnect
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Manager: PID=1400 TID=1444 Successfully created the local image session and provider store. - CDISMManager::CreateLocalImageSession
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: 
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: <----- Starting Dism.exe session ----->
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: 
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Host machine information: OS Version=6.3.9600, Running architecture=amd64, Number of processors=4
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Dism.exe version: 6.3.9600.16384
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Executing command line: "X:\WINDOWS\system32\dism.exe" /image:"C:" /windir:"WINDOWS" /apply-unattend:"D:\_SMSTaskSequence\PkgMgrTemp\drivers.xml" /logpath:"D:\_SMSTaskSequence\PkgMgrTemp\dism.log"
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting the collection of providers from a local provider store type. - CDISMProviderStore::GetProviderCollection
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Loading Provider from location X:\WINDOWS\System32\Dism\FolderProvider.dll - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Connecting to the provider located at X:\WINDOWS\System32\Dism\FolderProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Loading Provider from location X:\WINDOWS\System32\Dism\WimProvider.dll - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Connecting to the provider located at X:\WINDOWS\System32\Dism\WimProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Loading Provider from location X:\WINDOWS\System32\Dism\VHDProvider.dll - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Connecting to the provider located at X:\WINDOWS\System32\Dism\VHDProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Loading Provider from location X:\WINDOWS\System32\Dism\ImagingProvider.dll - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Connecting to the provider located at X:\WINDOWS\System32\Dism\ImagingProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Loading Provider from location X:\WINDOWS\System32\Dism\CompatProvider.dll - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Connecting to the provider located at X:\WINDOWS\System32\Dism\CompatProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Got the collection of providers. Now enumerating them to build the command table.
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: DISM Log Provider
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: FolderManager
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: WimManager
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: WimManager.
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: VHDManager
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: GenericImagingManager
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: GenericImagingManager.
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: Compatibility Manager
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: Compatibility Manager.
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting the collection of providers from a local provider store type. - CDISMProviderStore::GetProviderCollection
    [1400] [0x80070002] FIOReadFileIntoBuffer:(1415): The system cannot find the file specified.
    [1400] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [1400] [0xc142011c] WIMGetMountedImageHandle:(2568)
    2016-03-02 08:06:59, Info                  DISM   DISM WIM Provider: PID=1400 TID=1444 [C:\] is not a WIM mount point. - CWimMountedImageInfo::Initialize
    2016-03-02 08:06:59, Info                  DISM   DISM VHD Provider: PID=1400 TID=1444 [C:\] is not recognized by the DISM VHD provider. - CVhdImage::Initialize
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting Provider VHDManager - CDISMProviderStore::GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM VHD Provider: PID=1400 TID=1444 [C:\] is not recognized by the DISM VHD provider. - CVhdImage::Initialize
    2016-03-02 08:06:59, Info                  DISM   DISM Imaging Provider: PID=1400 TID=1444 The provider VHDManager does not support CreateDismImage on C:\ - CGenericImagingManager::CreateDismImage
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Getting Provider WimManager - CDISMProviderStore::GetProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    [1400] [0x80070002] FIOReadFileIntoBuffer:(1415): The system cannot find the file specified.
    [1400] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [1400] [0xc142011c] WIMGetMountedImageHandle:(2568)
    2016-03-02 08:06:59, Info                  DISM   DISM WIM Provider: PID=1400 TID=1444 [C:\] is not a WIM mount point. - CWimMountedImageInfo::Initialize
    2016-03-02 08:06:59, Info                  DISM   DISM Imaging Provider: PID=1400 TID=1444 The provider WimManager does not support CreateDismImage on C:\ - CGenericImagingManager::CreateDismImage
    2016-03-02 08:06:59, Info                  DISM   DISM Imaging Provider: PID=1400 TID=1444 No imaging provider supported CreateDismImage for this path - CGenericImagingManager::CreateDismImage
    2016-03-02 08:06:59, Info                  DISM   DISM Manager: PID=1400 TID=1444 physical location path: C:\ - CDISMManager::CreateImageSession
    2016-03-02 08:06:59, Error                 DISM   DISM Manager: PID=1400 TID=1444 It is an unsupported scenario to service an up level image using low level dism. - CDISMManager::CreateImageSessionFromLocation(hr:0x80070032)
    2016-03-02 08:06:59, Error                 DISM   DISM.EXE: Could not load the image session. HRESULT=80070032
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: Image session has been closed. Reboot required=no.
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: 
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: <----- Ending Dism.exe session ----->
    2016-03-02 08:06:59, Info                  DISM   DISM.EXE: 
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Found the OSServices.  Waiting to finalize it until all other providers are unloaded. - CDISMProviderStore::Final_OnDisconnect
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Disconnecting Provider: FolderManager - CDISMProviderStore::Internal_DisconnectProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Disconnecting Provider: WimManager - CDISMProviderStore::Internal_DisconnectProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Disconnecting Provider: VHDManager - CDISMProviderStore::Internal_DisconnectProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Disconnecting Provider: GenericImagingManager - CDISMProviderStore::Internal_DisconnectProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Disconnecting Provider: Compatibility Manager - CDISMProviderStore::Internal_DisconnectProvider
    2016-03-02 08:06:59, Info                  DISM   DISM Provider Store: PID=1400 TID=1444 Releasing the local reference to DISMLogger.  Stop logging. - CDISMProviderStore::Internal_DisconnectProvider
    

    Mittwoch, 2. März 2016 07:39
  • Mit D:\ sollte das spätere Laufwerk C:\ gemeint sein.

    Beinhaltet das DriverPackage sämtliche Treiberdateien?

    Hier noch ein aktueller Thread aus dem englischsprachigen Forum, wo es um etwas ähnliches geht: https://social.technet.microsoft.com/Forums/en-US/db9f265e-0291-4196-bd1a-239ea5355b3f/intel-i2178lm-network-drivers-will-not-install-during-osd-to-w10?forum=configmanagerosd


    Simon Dettling | msitproblog.com | @SimonDettling

    Mittwoch, 2. März 2016 07:46
  • HI,

    auf C:\ liegt das selbe log wie auf D:\. Im Treiber Paket befindet sich nur die Netzwerkkarte. Ich habe jetzt mal eine Installation ohne Treiber-Paket angeschmissen und der Rechner ist in der Domäne. Also brauche ich nicht das Treiber-Paket. Leider wird er SCCM-Client immer noch nicht installiert und somit auch nicht die Software. :/

    Gruß,

    Umut.
    Donnerstag, 3. März 2016 06:14
  • Hat der Client eine IP Adresse, wenn er das erste mal mit dem OS hochkommt?

    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 3. März 2016 06:43
  • Ja der Client bekommt eine IP-Adresse nach dem hochkommen. Ich komme auch per RDP rauf. Wenn ich ein Windows 7 Rechner neu aufsetzte, wird da der SCCM-Client installiert.

    EDIT:

    Wir nutzen ein Windows ADK 8.1 könnte es was damit zu tun haben ?

    • Bearbeitet Umut47 Donnerstag, 3. März 2016 07:40
    Donnerstag, 3. März 2016 07:18
  • Dann erneut smsts.log analyiseren um zu schauen wo er genau aussteigt bzw. nicht weitermacht.

    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 3. März 2016 07:44
  • Moin,

    ich hab noch einige Tests gemacht und hab es leider nicht hinbekommen, einen Rechner mit Windows 10 und dem Client aufzusetzen. Was mir aufgefallen ist, dass die Log Datei immer mit:

    [Expand a string: %_SMSTSMDataPath%\Logs]LOG]!><time="08:28:23.609-60" date="03-09-2016" component="TSManager" context="" type="0" thread="1036" file="executionenv.cxx:783">

    endet.

    In meiner virtuellen Umgebung geht die Log-Datei weiter und hört nicht ab dem Punkt auf. Wie schon erwähnt, kann ich aber Windows 7 Maschinen mit Client aufsetzen.

    Leider weiß ich nicht mehr weiter und vielleicht könnt ihr mir helfen :/ ??

    Gruß,

    Umut.


    • Bearbeitet Umut47 Freitag, 11. März 2016 12:40
    Freitag, 11. März 2016 12:40
  • Leider weiß ich nicht mehr weiter und vielleicht könnt ihr mir helfen :/ ??



    Schwierig, auf die Ferne, ohne einen expliziten Fehler zu kennen ...

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 11. März 2016 14:06
    Beantworter