none
Exchange Online SMTP Versand klappt nicht RRS feed

  • Frage

  • Hallo,

    normalerweise kann man ja mit SMTP.office365.com auch von diversen Apps, die keine Exchange unterstützen rausschicken.

    nun hätte ich das bei einem User versucht:

    TLS + 587 aktiviert smtp.office365.com als Ausgangsserver

    Authentifiziertes SMTP ist aktiviert

    das Passwort stimmt - kann mich damit bei Exchange Online anmelden

    auch mit verschiedenen PCs + Outlook getestet, klappt nicht, kommt immer wieder die Passwort Abfrage.

    der Exchange Online hat Azure Connect mit einem lokalen AD - liegts vllt. daran?

    Mittwoch, 20. Januar 2021 08:40

Alle Antworten

  • U.U. musst du dies über getrennte Profile in Outlook realisieren, da ggf. mit dem bestehenden AD nachgefragt wird ob das zulässig ist.
    Dies bedeutet dann auch, dass du vor dem Start von Outlook dann die Profilabfrage aktivieren musst.

    Auch könnte ein Firewall-Regel bestimmen, dass du mit Mails nicht direkt raus darfst.

    Mittwoch, 20. Januar 2021 09:03
  • das ist nicht wirklich hilfreich ;) die eigentlich Applikation ist eine Webapplikation - Outlook ist immer nur meine Testumgebung, ob es generell funktioniert.

    Firewall alles gut 

    Mittwoch, 20. Januar 2021 09:16
  • Moin,

    von mir kommt noch eine Antwort, die ggf. nicht weiterhilft - wende dich an den MS-Support - du bezahlst dafür!

    ;)


    Gruß Norbert

    Mittwoch, 20. Januar 2021 09:42
    Moderator
  • Ja, da habe ich die Anforderung nicht verstanden.

    Um Mails zu versenden muss man sich an einem Mail-Server ja anmelden können.
    Also kannst du zu dienem Mail-Server nur die "smtp.meinefirma.meinedomain" ansprechen.
    Wenn diese im Azure ist, ist das u.U. eben "smtp.meinefirma.onmicrosoft.com".

    Mittwoch, 20. Januar 2021 10:01
  • wäre mir now, bisher war das immer smtp.office365.com - aber ich teste ;)

    und ja, zur Not MS Support :D

    Mittwoch, 20. Januar 2021 13:37
  • Hast du denn ein Konto direkt bei Office365 oder ein Firmenkonto bei deiner Firma?
    Mittwoch, 20. Januar 2021 13:41
  • ich bin der Admin von dem Office365 Account eines Kunden.
    Mittwoch, 20. Januar 2021 14:15
  • Moin,

    das Passwort stimmt, aber was verwendest Du als Benutzernamen?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Mittwoch, 20. Januar 2021 15:24
  • ganz normale HauptMailadresse :)
    Mittwoch, 20. Januar 2021 17:12
  • Bzw. einfach genau die gleichen Benutzernamen, die ich fürs Exchange Online genommen habe
    Mittwoch, 20. Januar 2021 17:12
  • OK, ketzerischer Gedanke: Du kannst ja bei Outlook nicht einfach "nur SMTP" einrichten, sondern immer SMTP+IMAP4 oder SMTP+POP3. Was ist, wenn IMAP bzw. POP3 bei dieser Mailbox deaktiviert sind, und die Passwortabfrage kommt gar nicht vom Senden, sondern vom Empfangen?

    Rein für SMTP würde ich lieber so etwas nehmen als Outlook...


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Mittwoch, 20. Januar 2021 21:53
  • jo, aber wenns nichtmal im Outlook läuft, brauch ichs in einer Webapplikation gleich garnicht versuchen ;)
    Donnerstag, 21. Januar 2021 19:14
  • jo, aber wenns nichtmal im Outlook läuft, brauch ichs in einer Webapplikation gleich garnicht versuchen ;)

    ...aber Deine Web-Applikation wird ja vielleicht keine Mails abfragen, sondern nur versenden wollen?

    Outlook ist für POP3 und besonders für IMAP der schlechteste Client, den man nehmen kann.


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Freitag, 22. Januar 2021 20:01