none
W2K R2 - Netzübertragungsrate extrem langsam zu anderen BS Versionen RRS feed

  • Frage

  • Hallo,

     

    ich stehe grade vor folgendem mir nicht erklärbarem Problem:

    Ich habe in unserem Netzwerk 2 Windows 2008 R2 Terminalserver.

    Einer von beiden hat extreme Probleme mit der Netzwerkperformance beim Zugriff auf andere Server / Computer auf denen nicht Server 2008 R2 als Betriebssystem läuft.

    Greife ich von diesem Terminalserver bspw. auf einen Fileserver zu (Windows Server 2003) und kopiere Dateien erreiche ich nicht mehr als 400 KB/s Übertragungsrate. - Selbes Phänomen beim Zugriff auf andere Fileserver oder auf Dateien die auf einzelnen Workstations liegen.

    Greife ich allerdings auf Dateien zu die auf dem anderen W2K8 R2 Terminalserver liegen werden auch große Dateien in Sekundenbruchteilen Kopiert... Im Schnitt so 14-20 MB/s

    Der Zweite TS zeigt dieses Probem nicht. Von ihm aus kann ich normal mit akzeptabler Geschwindigkeit auf alle Fileserver zugreifen.

     

    Ich habe in verschiedenen Beiträgen bereits gelesen, dass das deaktivieren des "Auto Tunings" abhilfe schaffen könnte -

    netsh int tcp set global autotuninglevel=disabled

    Dies habe ich getestet - brachte keine Verbesserung.

    Die Server sind im Übrigen alle Per Gigabit-LAN mit einander verbunden.

    Hat jemand eine Idee die mir hier weiterhelfen kann?

    Danke und Gruß


    Dienstag, 11. Januar 2011 08:31

Antworten

  • Hi <realname please>
     
    Vorab: Es gehört zum guten Ton, sich gegenüber anderen persönlich
    vorzustellen.
     
     
    > ich stehe grade vor folgendem mir nicht erklärbarem Problem:
    >
    > Ich habe in unserem Netzwerk 2 Windows 2008 R2 Terminalserver.
    >
    > Einer von beiden hat extreme Probleme mit der Netzwerkperformance
    > beim Zugriff auf andere Server / Computer auf denen nicht Server 2008
    > R2 als Betriebssystem läuft.
    >
    > Greife ich von diesem Terminalserver bspw. auf einen Fileserver zu
    > (Windows Server 2003) und kopiere Dateien erreiche ich nicht mehr als
    > 400 KB/s Übertragungsrate. - Selbes Phänomen beim Zugriff auf andere
    > Fileserver oder auf Dateien die auf einzelnen Workstations liegen.
    >
    > Greife ich allerdings auf Dateien zu die auf dem anderen W2K8 R2
    > Terminalserver liegen werden auch große Dateien in Sekundenbruchteilen
    > Kopiert... Im Schnitt so 14-20 MB/s
     
    Kannst Du bitte testen, ob auch andere Übertragungsprotokolle (HTTP, FTP
    usw.) genauso langsam in dieser Konstellation sind (--> Problem eher in der
    Netzwerkkarte o.ä. zu suchen) oder ob es dort wesentlich schneller geht
    (Problem eher in der SMB<-->SMB2 Protokoll zu suchen)
     
     
    Hintergrundinformationen:
     
    Netzwerkprobleme:
     
    Tipp: Aktuelle Firmware und Treiber für Netzwerkkarten einspielen
     
    Workaround:
    netsh int tcp set global chimney=disabled
    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableTCPA=0
     
    Source: Information about the TCP Chimney Offload, Receive Side Scaling, and
    Network Direct Memory Access features in Windows Server 2008
    http://support.microsoft.com/kb/951037/en-us
     
     
    SMB Probleme:
     
    You encounter poor performance when you use the SMB 2.0 protocol to perform
    network-related operations
    http://support.microsoft.com/kb/950836/en-us
     
    How to Disable SMB 2.0 on Windows Vista/2008
    http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    • Als Antwort markiert mssbt Dienstag, 11. Januar 2011 17:02
    Dienstag, 11. Januar 2011 09:33

Alle Antworten

  • Hi <realname please>
     
    Vorab: Es gehört zum guten Ton, sich gegenüber anderen persönlich
    vorzustellen.
     
     
    > ich stehe grade vor folgendem mir nicht erklärbarem Problem:
    >
    > Ich habe in unserem Netzwerk 2 Windows 2008 R2 Terminalserver.
    >
    > Einer von beiden hat extreme Probleme mit der Netzwerkperformance
    > beim Zugriff auf andere Server / Computer auf denen nicht Server 2008
    > R2 als Betriebssystem läuft.
    >
    > Greife ich von diesem Terminalserver bspw. auf einen Fileserver zu
    > (Windows Server 2003) und kopiere Dateien erreiche ich nicht mehr als
    > 400 KB/s Übertragungsrate. - Selbes Phänomen beim Zugriff auf andere
    > Fileserver oder auf Dateien die auf einzelnen Workstations liegen.
    >
    > Greife ich allerdings auf Dateien zu die auf dem anderen W2K8 R2
    > Terminalserver liegen werden auch große Dateien in Sekundenbruchteilen
    > Kopiert... Im Schnitt so 14-20 MB/s
     
    Kannst Du bitte testen, ob auch andere Übertragungsprotokolle (HTTP, FTP
    usw.) genauso langsam in dieser Konstellation sind (--> Problem eher in der
    Netzwerkkarte o.ä. zu suchen) oder ob es dort wesentlich schneller geht
    (Problem eher in der SMB<-->SMB2 Protokoll zu suchen)
     
     
    Hintergrundinformationen:
     
    Netzwerkprobleme:
     
    Tipp: Aktuelle Firmware und Treiber für Netzwerkkarten einspielen
     
    Workaround:
    netsh int tcp set global chimney=disabled
    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableTCPA=0
     
    Source: Information about the TCP Chimney Offload, Receive Side Scaling, and
    Network Direct Memory Access features in Windows Server 2008
    http://support.microsoft.com/kb/951037/en-us
     
     
    SMB Probleme:
     
    You encounter poor performance when you use the SMB 2.0 protocol to perform
    network-related operations
    http://support.microsoft.com/kb/950836/en-us
     
    How to Disable SMB 2.0 on Windows Vista/2008
    http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    • Als Antwort markiert mssbt Dienstag, 11. Januar 2011 17:02
    Dienstag, 11. Januar 2011 09:33
  • Hallo Tobias,

    sorry! Ich stelle mich dann erst mal vor:

    Hallo Mein Name ist Manuel.

     

    Ich habe mal einen Test der Geschwindigkeit mit NetIO durchgeführt:

    TCP connection established.
    Packet size  1k bytes:  95.01 MByte/s Tx,  307.35 KByte/s Rx.
    Packet size  2k bytes:  100.58 MByte/s Tx,  479.36 KByte/s Rx.
    Packet size  4k bytes:  95.30 MByte/s Tx,  493.00 KByte/s Rx.
    Packet size  8k bytes:  91.74 MByte/s Tx,  4036.03 KByte/s Rx.
    Packet size 16k bytes:  98.23 MByte/s Tx,  509.60 KByte/s Rx.
    Packet size 32k bytes:  106.36 MByte/s Tx,  327.84 KByte/s Rx.
    Done.

    Nicht sehr berauschend...

    Die Punkte von dir gehe ich heute Abend durch wenn ich den Server neu starten kann.

    Eine kurze Fragen noch - wie kann ich auf die schnelle testen wie die Übertragungsrate per ftp bzw. http zwischen 2 Windows servern ist?

    Danke

    Gruß

    Manuel

    Dienstag, 11. Januar 2011 15:12
  • Hallo Tobias,

    vielen Dank noch einmal für deine Hinweise.

    Hat funktioniert. Nach setzen der weiteren Einstellungen über netsh und den RegKey ist die Performance nun gut.

     

    Danke und Gruß

    Manuel

    Dienstag, 11. Januar 2011 17:03
  • Hi Manuel,
     
    > vielen Dank noch einmal für deine Hinweise.
    >
    > Hat funktioniert. Nach setzen der weiteren Einstellungen über netsh und
    > den
    > RegKey ist die Performance nun gut.
     
    dann solltest Du jetzt die neuesten Treiber UND FIRMWARE der jeweiligen
    Netzwerkkarte(n) einspielen und die Einstellungen testweise wieder
    zurückfahren.
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    Dienstag, 11. Januar 2011 19:07
  • Hallo Forum,

    ich wollte nicht extra einen neuen Beitrag eröffnen, da mein Problem in etwa das selbe ist wie hier beschrieben. Wir haben einen Cloud Server bei 1&1.

    auf diesem läuft Windows Server 2008R2 SP1. Auf diesem liegen die Daten von 8 Webseiten ( Wamp und Zend ) inklusive der Datenbanken.

    Verwaltet und gewartet wird dieser per RDP. Angebunden ist der Server mit 100Mbit Up/Down.

    Da ich nun die Administration von diesem Server übertragen bekommen habe, wollte ich als aller erstes einmal ein Backup machen,

    das Problem hierbei ist jedoch, das ich nur eine max Downloadrate von 2-200KB/Sekunde erreiche zu meinem Win7 Rechner.

    Nun habe ich die oben geschriebene Beiträge studiert, und mir auch die Windows Seite durchgelesen.

    http://support.microsoft.com/kb/951037/de

    Nun wollte ich zuerst das von Tobias beschriebene Workaround testen.

    netsh int tcp set global chimney=disabled
    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableTCPA=0

    Diesen Reg Eintrag gibt es bei mir nicht, würde ich aber wie auf der Windows Seite angegeben erstellen.

    Meine Bedenken sind nun folgende:

    Da dieser Server nicht physisch bei uns in der Firma steht, habe ich ein paar Bedenken Netzwerkeinstellungen vorzunehmen.

    Worst Case wäre das alle Einstellungen vorgenommen wurden ( Netsh sowie Reg Eintrag ) der Server hochfährt und ich danach keinen Zugriff mehr habe.

    (Verbindungsverlust)

    Grüße Mike

     




    • Bearbeitet Tigger28 Mittwoch, 5. Juni 2013 09:53
    Mittwoch, 5. Juni 2013 09:52
  • Sprich mit Deinem 1&1 Support Ansprechpartner über Deine Möglichkeiten im Fehlerfall.

    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
    Mittwoch, 5. Juni 2013 10:02