none
DNS Server antwortet nicht mit AAAA Eintrag RRS feed

  • Frage

  • Hallo,

    wir haben ein Problem mit unserem Windows 2012R2 DNS Server. In der Forward Lookup Zone ist ein AAAA Eintrag definiert (es gibt keinen A Eintrag). Wenn ich von einem Client oder auch dem Server selbst aus versuche den Hostnamen über "ping hostname" aufzulösen, bekomme ich die Meldung das der Host nicht gefunden wurde.

    Rufe ich den Namen über "nslookup hostname" ab, wird mir die korrekte ipv6 Adresse ausgegeben.

    Muss am Client\Server noch etwas aktiviert werden damit die Auflösung von ipv6 Einträgen funktioniert?
    IPv6 ist auf den Netzwerkkarten der Server und Clients aktiviert.

    Viele Grüße

    Dienstag, 15. Dezember 2015 22:28

Antworten

  • Das Problem ist inzwischen über einen MS Case teilweise gelöst worden.
    Wenn nicht genutzte ISATAP Treiber im Gerätemanager gelöscht werden, funktioniert die Auflösung anschließend Teilweise.

    Viele Grüße

    • Als Antwort markiert Zony87 Mittwoch, 30. Dezember 2015 18:46
    Mittwoch, 30. Dezember 2015 18:46

Alle Antworten

  • also wenn nslookup dir das sauber zurückgibt, funktioniert die dns auflösung.

    Hast du es denn mal mit

    ping -6 hostname

    probiert? :)


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Mittwoch, 16. Dezember 2015 08:23
  • Habe leider vergessen zu erwähnen das wir das auch schon probiert haben.
    ping -6 hostname gibt auch keine Adresse zurück :/

    Es ist allerdings auch nicht nur der Ping der nicht funktioniert. Ich komme auch nicht per RDP auf den Rechner und auch unser Support Tool kann keine Verbindung aufbauen. Wenn ich allerdings die ipv6 Adresse direkt nutze bzw. diese in die hosts Datei eintrage funktioniert beides direkt.

    Daher die Vermutung das am DNS irgendwas falsch konfiguriert ist.

    Mittwoch, 16. Dezember 2015 09:15
  • hast du es denn mal mit der Powershell probiert?

    Test-NetConnection -ComputerName HOSTNAME -InformationLevel Detailed
    Wenn der Name aufgelöst wird, funktioniert die Kommunikation an irgendeiner anderen Stelle nicht. Vielleicht deine Dienste nicht an IPv6 gebunden. Ping per Firewall abgewiesen

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Mittwoch, 16. Dezember 2015 09:30
  • Das Problem muss irgendwo an der Namensauflösung hängen. Wenn ich direkt auf die IP gehe funktioniert ja alles.

    Hab es trotzdem mal über die Powershell probiert:

    Test-NetConnection -ComputerName PierreVM10
    You cannot call a method on a null-valued expression.
    At C:\windows\system32\windowspowershell\v1.0\Modules\NetTCPIP\Test-NetConnection.psm1:103 char:21
    + ...             $Message = "Name resolution of $TargetName failed -- Stat ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    
    Volle Fehlermeldung:
    
    Exception             : System.Management.Automation.RuntimeException: You cannot call a method on a null-valued
                            expression.
                               at System.Management.Automation.ExceptionHandlingOps.CheckActionPreference(FunctionContext
                            funcContext, Exception exception)
                               at System.Management.Automation.Interpreter.ActionCallInstruction`2.Run(InterpretedFrame
                            frame)
                               at
                            System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame
                            frame)
                               at
                            System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame
                            frame)
                               at
                            System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame
                            frame)
                               at
                            System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame
                            frame)
    TargetObject          :
    CategoryInfo          : InvalidOperation: (:) [], RuntimeException
    FullyQualifiedErrorId : InvokeMethodOnNull
    ErrorDetails          :
    InvocationInfo        : System.Management.Automation.InvocationInfo
    ScriptStackTrace      : at ResolveTargetName,
                            C:\windows\system32\windowspowershell\v1.0\Modules\NetTCPIP\Test-NetConnection.psm1: line 103
                            at Test-NetConnection<Process>,
                            C:\windows\system32\windowspowershell\v1.0\Modules\NetTCPIP\Test-NetConnection.psm1: line 272
                            at <ScriptBlock>, <No file>: line 1
    PipelineIterationInfo : {}
    PSMessageDetails      :

    Wenn ich jetzt statt dem Namen die IP nehme funktioniert der Aufruf:

    Test-NetConnection -ComputerName fd1b:43e9:b8e3:1000:49fa:1fb2:789a:9744
    
    
    ComputerName           : fd1b:43e9:b8e3:1000:49fa:1fb2:789a:9744
    RemoteAddress          : fd1b:43e9:b8e3:1000:49fa:1fb2:789a:9744
    InterfaceAlias         : isatap.{601614D1-3CE9-44C5-9B61-6737A0DACD90}
    SourceAddress          : fd1b:43e9:b8e3:1:0:5efe:10.0.3.69
    PingSucceeded          : True
    PingReplyDetails (RTT) : 17 ms

    Mittwoch, 16. Dezember 2015 09:57
  • könnt ich mal n "ipconfig /all" von dem PierreVM10, dem Rechner von dem du testest und dem DNS Server haben?

    PS: hast du schonmal versucht statt des NETBIOS namens den FQDN zu verwenden? -> PierreVM10.domain.endung

     

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)


    Mittwoch, 16. Dezember 2015 10:43
  • Hi,

    hat der Server den AAAA-Eintrag selbst registriert oder habt Ihr den manuell definiert? Ersteres ist definitiv besser, da der Server dann die Adresse automatisch aktualisiert, falls sie sich mal ändern sollte, außerdem können sich so keine Rechtschreibfehler einschleichen.


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 16. Dezember 2015 10:47
  • @Dennis Hohn: Ich habe beides probiert. FQDN und NetBios liefern beide kein Ergebnis.
    Nicht über das IPconfig wundern. Es handelt sich bei dem Client um einen DirectAccess Client. Daher auch die IPv6 Adresse. Das "normale" interne Netz arbeitet über v4.

    @Ben: Der Eintrag ist vom Client eingetragen worden. Manuell haben wir daran nichts verändert.
    Aber selbst wenn die Adresse falsch wäre, müsste der Server diese ja zumindest zurückgeben.

    Windows-IP-Konfiguration Hostname . . . . . . . . . . . . : PierreVM10 Primäres DNS-Suffix . . . . . . . : kd.local Knotentyp . . . . . . . . . . . . : Hybrid IP-Routing aktiviert . . . . . . : Nein WINS-Proxy aktiviert . . . . . . : Nein DNS-Suffixsuchliste . . . . . . . : kd.local ad.cinspiration.de Ethernet-Adapter Ethernet: Medienstatus. . . . . . . . . . . : Medium getrennt Verbindungsspezifisches DNS-Suffix: kd.local Beschreibung. . . . . . . . . . . : TAP-Windows Adapter V9 Physische Adresse . . . . . . . . : 00-FF-21-FD-4C-F1 DHCP aktiviert. . . . . . . . . . : Ja Autokonfiguration aktiviert . . . : Ja Ethernet-Adapter Ethernet0: Verbindungsspezifisches DNS-Suffix: ad.cinspiration.de Beschreibung. . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection Physische Adresse . . . . . . . . : 00-0C-29-1F-69-70 DHCP aktiviert. . . . . . . . . . : Ja Autokonfiguration aktiviert . . . : Ja Verbindungslokale IPv6-Adresse . : fe80::c080:ccdc:391d:e26f%2(Bevorzugt) IPv4-Adresse . . . . . . . . . . : 192.168.88.123(Bevorzugt) Subnetzmaske . . . . . . . . . . : 255.255.255.0 Lease erhalten. . . . . . . . . . : Mittwoch, 16. Dezember 2015 12:08:09 Lease läuft ab. . . . . . . . . . : Mittwoch, 16. Dezember 2015 22:08:09 Standardgateway . . . . . . . . . : 192.168.88.21 DHCP-Server . . . . . . . . . . . : 192.168.88.20 DHCPv6-IAID . . . . . . . . . . . : 33557545 DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1D-DF-F9-7F-00-0C-29-1F-69-70 DNS-Server . . . . . . . . . . . : 192.168.188.18 192.168.88.20 NetBIOS über TCP/IP . . . . . . . : Aktiviert Tunneladapter isatap.ad.cinspiration.de: Medienstatus. . . . . . . . . . . : Medium getrennt Verbindungsspezifisches DNS-Suffix: ad.cinspiration.de Beschreibung. . . . . . . . . . . : Microsoft ISATAP Adapter Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP aktiviert. . . . . . . . . . : Nein Autokonfiguration aktiviert . . . : Ja Tunneladapter iphttpsinterface: Verbindungsspezifisches DNS-Suffix: Beschreibung. . . . . . . . . . . : iphttpsinterface Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP aktiviert. . . . . . . . . . : Nein Autokonfiguration aktiviert . . . : Ja IPv6-Adresse. . . . . . . . . . . : fd1b:43e9:b8e3:1000:49fa:1fb2:789a:9744(Bevorzugt) Temporäre IPv6-Adresse. . . . . . : fd1b:43e9:b8e3:1000:b9c0:1733:7f22:f3e(Bevorzugt) Verbindungslokale IPv6-Adresse . : fe80::49fa:1fb2:789a:9744%3(Bevorzugt) Standardgateway . . . . . . . . . : DHCPv6-IAID . . . . . . . . . . . : 134217728 DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1D-DF-F9-7F-00-0C-29-1F-69-70 NetBIOS über TCP/IP . . . . . . . : Deaktiviert


    Mittwoch, 16. Dezember 2015 11:13
  • Hallo Zony89,

    sind Sie inzwischen weitergekommen? Wenn diese Tipps Ihnen geholfen haben, markieren Sie bitte die entsprechenden Beiträge, die zur Lösung geführt haben, als Antworten.Bitte beachten Sie, dass ich wegen keiner weiteren Aktivitäten das Thema als Diskussion verschieben werde.

    Mit freundlichen Grüßen,

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 24. Dezember 2015 10:54
    Moderator
  • Das Problem ist inzwischen über einen MS Case teilweise gelöst worden.
    Wenn nicht genutzte ISATAP Treiber im Gerätemanager gelöscht werden, funktioniert die Auflösung anschließend Teilweise.

    Viele Grüße

    • Als Antwort markiert Zony87 Mittwoch, 30. Dezember 2015 18:46
    Mittwoch, 30. Dezember 2015 18:46