none
Update: Anwenden von Informationsverwaltungsrichtlinien RRS feed

  • Frage

  • Hallo zusammen,

     

    ich habe im SharePoint Server 2010 im Term Store Management Tool (Terminologiespeicher-Verwaltungstool) eine Gruppe "Kategorie" mit verschieden Ausdrücken (Auftragsrelevante Dokumente, Projektrelevante Dokumente, Schriftverkehr, ...) angelegt, nach denen die Dokumente dann kategorisiert werden können.

    Nun soll anhand der Kategorie das Dokument in das Datenarchiv (das ist bereits als eigene Webanwendung erstellt, und das manuelle „Senden an“ funktioniert auch) nach einem bestimmten Zeitraum (zu Testzwecken 1 Tag) verschoben werden.

    Ich habe mich bereits schlau gemacht und gelesen, dass es mit den Informationsverwaltungsrichtlinien funktionieren soll.

    Ich habe mich an folgende Anleitung gehalten:

    http://office.microsoft.com/de-de/sharepoint-server-help/erstellen-und-anwenden-von-informationsverwaltungsrichtlinien-HA101631505.aspx

    Ich habe mit Punkt 1 angefangen: 1. Erstellen einer Informationsverwaltungsrichtlinie für verschiedene Inhaltstypen in einer Websitesammlung

    Soweit so gut, habe ich nun eine Richtlinie „Aufbewahrung“ erstellt und die Aufbewahrung aktiviert.

    Dann heißt es ja weiter, dass man, wenn man eine solche Richtlinie erstellt hat, bei dem Punkt „Anwenden einer Websitesammlungsrichtlinie auf einen Inhaltstypweitermachen soll.

    Dort komme ich bis Punkt 4 („…wählen Sie unter Auf dem Inhaltstyp basierende Richtlinien den Inhaltstyp aus, auf den die Richtlinie angewendet werden soll.“), wo ich allerdings meinen Inhaltstyp „Kategorie“ nicht auswählen kann, weil er dort nicht angezeigt wird. Ich sehe lediglich „Wiki-Seite“ und „Ordner“.

    Müsste dort nicht auch meine „Kategorie“ stehen?

    So, was fehlt mir, was mache ich verkehrt, was muss ich anders machen?

     

    Vielen Dank und viele Grüße

    Scouty

    • Bearbeitet Scouty Dienstag, 22. März 2011 12:12
    Dienstag, 15. März 2011 10:50

Antworten

  • Dieser Weg hat sich nun für mich erst einmal erledigt. Ich habe eine andere Lösung gefunden.

    Stichworte hier sind: Auftragsdefinitionen und  Zeitgeberaufträge

    Muss man aber selber programmieren...

    Gruß Scouty

    • Als Antwort markiert Scouty Freitag, 1. April 2011 10:07
    Freitag, 1. April 2011 10:07

Alle Antworten

  • UPDATE 22.03.2011:
    Mittlerweile habe ich es geschafft, dass meinem Inhaltstyp die Richtlinie Archivierung (so heißt sie bei mir) zugeordnet ist.

    Was ich noch nicht ganz verstanden habe: Wann wird diese Richtlinie angewendet?! Also wann wird das Dokument ins Datenarhciv verschoben?

    Meine Aufbewahrungsrichtline sieht wie folgt aus:
    Ereignis: Zeitperiode: Erstellt am + 1 Tag
    Aktion: An einen anderen Speicherort übertragen
    Art der Übertragung: Verschieben
    Ziel: Senden an Datenarchiv

    Viele Grüße
    Scouty

    Dienstag, 22. März 2011 12:11
  • Hallo Scouty

    wurde das Dokument inzwischen verschoben? Falls nicht überprüffe, ob der Timer Dienst läuft und ob der Timer Job für die Verarbeitung der Policies aktiviert und erfolgreich durchgelaufen ist.

    Gruß,
    Andrei

    Donnerstag, 24. März 2011 14:02
  • Hallo Andrei,

    das Dokument wurde noch nicht verschoben. :(

    Ich habe mir sämtliche Zeitgeberaufträge (Zentraladministration - Auftragsdefinitionen überprüfen) angeguckt, sie laufen alle. (Ich war doch an der richtigen Stelle?!)

    Ich habe nochmal ein bisschen weiter geguckt. Wenn ich im Kontextmenü des Dokumentes (welches verschoben werden soll) auf Konformitätsdetails klicke, steht dort unter Ereignis:

    "Für dieses Element gibt es keine Aufbewahrungsrichtlinie."

    Hmmm... Hat das was damit zu tun?!

    Wie kann ich denn dem Element diese Richtlinie zuweisen?! Wenn ich so überlege, habe ich doch nur dem Inhlatstyp die Richtlinie zugewiesen.

    Ideen?

    Gruß Scouty

    Freitag, 25. März 2011 10:44
  • Dieser Weg hat sich nun für mich erst einmal erledigt. Ich habe eine andere Lösung gefunden.

    Stichworte hier sind: Auftragsdefinitionen und  Zeitgeberaufträge

    Muss man aber selber programmieren...

    Gruß Scouty

    • Als Antwort markiert Scouty Freitag, 1. April 2011 10:07
    Freitag, 1. April 2011 10:07
  • Hallo Andrei,

    Ich bin schon ein Stück weiter als Scouty.

    Folgender Stand: Ich habe in der Websitesammlungsverwaltung eine Informationsverwaltungsrichtlinie für den Typ "Dokument" definiert ([Erstellt]+1Tag --> Löschen). Diese habe ich anschließend in einer Bibliothek unter "Einstellungen für die Informationsverwaltungsrichtlinie" dem Inhaltstyp "Dokument" zugeordnet. Nach dem Upload eines Dokuments wird automatisch das Ablaufdatum (wie in der Richtlinie definiert) für das Dokument vergeben. Unter "Konformitätsdetails" wird für jedes Dokument die richtige Aufbewahrungsphase angezeigt. Soweit ist alles richtig.

    Problem: Wird das Ablaufdatum überschritten passiert nichts. Das Dokument bleibt in der Bibliothek stehen und unter "Konformitätsdetails" wird nach wie vor die Richtlinie angezeigt. Es scheint, als würde die Verarbeitung nicht gestartet.

    Der Dienst "Sharepoint 2010 Timer" am Server läuft.

    Wo kann ich Deinen Hinweis "...Timer Job für die Verarbeitung der Policies aktiviert und erfolgreich durchgelaufen ist." prüfen? Was fehlt noch, damit die Verarbeitung gestartet wird?

    Vielen Dank!

    Grüße, Erzengel06

     

    Montag, 4. April 2011 08:48