none
Application installiert sofort trotz Deadline in der Zukunft RRS feed

  • Frage

  • Hallo Leute

    Ich komme bei einem Problem einfach nicht weiter. Ich habe eine Application angelegt, die 3 andere superseded. Das Deployment der Application ist Required, hat aber eine Deadline für nächste Woche. Sobald der Client das deployment aber erhält, beginnt er sofort mit der Installation.

    Ist das normal? Habe ich hier ein grundsätzliches Verständnisproblem? Mit einer Deadline sollte doch die Application bis zur Deadline nur zur Verfügung stehen, oder?

    Mfg
    Bernhard


    Donnerstag, 12. November 2015 11:25

Antworten

  • Entschuldigung. Ich war die letzten Tage sehr beschäftigt. Das einzige, was wirklich geholfen hat, war, dass man erst nach dem Erstellen des Deployments den Supersedence-Tab befüllt. Wenn ich das nicht so mache, ist das Häkchen "Automatically upgrade any superseded versions of this application" gesetzt und ausgegraut und kann nicht verändert werden.

    Dieses Verhalten besteht auch noch, seitdem ich über das Wochenende auf R2 SP1 CU2 upgedatet habe.

    Ich werde diesbezüglich wohl einen Fall bei Microsoft eröffnen müssen.

    Montag, 30. November 2015 10:56

Alle Antworten

  • Hast du beide Datumsoptionen (Available & Deadline) korrekt gesetzt, inklusive der Time based on (UTC oder Local)?

    Es gibt ein Verhalten, dass wenn du eine Applikation, welche andere Superseeded, als Available deployest diese sich wie bei einem Required Deployment verhält und die Installation automatisch geschieht. Aber auch hier sollte die Deadline / Available Time beachtet werden.

    Auf welcher ConfigMgr 2012 Version tritt dieses Problem auf?


    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 12. November 2015 12:26
  • Wir haben ConfigMgr 2012 R2 CU 3 auf einem aktuellen Server 2012 im Einsatz.

    Time based habe ich sowohl UTC als auch Client local time versucht. Ich habe erst vor kurzem das Deployment neu erstellt. Available steht daher auf 12.11.2015 11:30Uhr und die Deadline steht auf 19.11.2015 21:00 Uhr.

    Außerdem habe ich angehakt, dass er außerhalb vom maintenance window die Installation auch starten darf.

    Gerade eben wieder getestet: Deployment erscheint im Softwarecenter mit dem 19.11. als Update-Datum und beginnt kurz darauf mit Download und Installation.

    Donnerstag, 12. November 2015 12:46
  • Ist weit hergeholt, aber hast du in deinen Client Settings "Deadline randomization" aktiviert? Bei einer so grossen Zeitspanne dürfte dies jedoch eigentlich keine Rolle spielen.

    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 12. November 2015 12:50
  • War aktiviert. Ich werde es mal ohne testen.
    Donnerstag, 12. November 2015 12:55
  • Nur zu Sicherstellung, Aktiviert (Yes) = ausgeschaltet.

    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 12. November 2015 12:57
  • Haha, ja, schon klar. Vorher war es disabled, jetzt teste ich es enabled ;)
    Donnerstag, 12. November 2015 12:59
  • Gleiches Problem...

    Am Client habe ich die Software, um die es geht, deinstalliert, die vorige Version wieder installiert und dann zuerst die Computerrichtlinien aktualisiert und dann den Evaluationszyklus für Anwendungsbereitstellung ausgeführt.

    Nach einer Minute kam das Deployment wieder...

    ...und nach 3 Sekunden -> Installation


    Donnerstag, 12. November 2015 13:14
  • Haben die Supersedence Applikationen selber auch noch Deployments? Tritt das Verhalten auch auf wenn du keine Supersedence verwendest?

    Simon Dettling | msitproblog.com | @SimonDettling

    Donnerstag, 12. November 2015 13:32
  • Nein, die supersedeten Applications hatten keine Deployments.

    Ich habe jetzt aus der betroffenen Application die Supersedence komplett entfernt und es funktioniert nun. Seit ca. 2 Stunden bleibt das Deployment im Softwarecenter available. Komisch.

    Jetzt frag ich mich nur, ob dieses Verhalten normal ist. Und wenn ja, warum. Im Technet habe ich nichts dazu gefunden.

    Donnerstag, 12. November 2015 15:54
  • Wie ist "Automatically upgrade any superseded versions of this application" gesetzt?

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 12. November 2015 16:30
    Beantworter
  • Das ist ausgegraut und gesetzt. Ich werde mal den Workaround von User kvnhawkins85 aus https://social.technet.microsoft.com/Forums/en-US/1abcc581-1ee8-4929-8a2f-71c8843a257c/application-supersedence-not-working-as-i-want-and-expect?forum=configmanagerapps
    versuchen. Mal sehen ob das hilft.

    Montag, 16. November 2015 12:26
  • Hallo Bernhard,

    sind Sie inzwischen weitergekommen?  

    Wenn Sie eine Lösung gefunden haben, bitte teilen Sie sie der Community mit, sodass auch andere Benutzer als der Fragesteller davon profitieren können. Wenn diese Tipps Ihnen geholfen haben, markieren Sie bitte die entsprechenden Beiträge, die zur Lösung geführt haben, als Antworten.  

    Bitte beachten Sie, dass ich wegen keiner weiteren Aktivitäten das Thema als Diskussion verschieben werde.

    Gruß

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.


    Montag, 30. November 2015 10:42
    Moderator
  • Entschuldigung. Ich war die letzten Tage sehr beschäftigt. Das einzige, was wirklich geholfen hat, war, dass man erst nach dem Erstellen des Deployments den Supersedence-Tab befüllt. Wenn ich das nicht so mache, ist das Häkchen "Automatically upgrade any superseded versions of this application" gesetzt und ausgegraut und kann nicht verändert werden.

    Dieses Verhalten besteht auch noch, seitdem ich über das Wochenende auf R2 SP1 CU2 upgedatet habe.

    Ich werde diesbezüglich wohl einen Fall bei Microsoft eröffnen müssen.

    Montag, 30. November 2015 10:56