none
Windows 10 with 120 Hz / 60 Hz Monitors issue

    Frage

  • There is a real bad bug in Windows 10, guess it's the "new" Windows Explorer.exe!
    I nailed it down to that point with nVidia devs.
    After many hours (talking to support) I finally reached a developer.
    And he told me that's about windows 10. Because the nVidia driver have no "control" over the game / Hz values on windows desktop.
    If I play on fullscreen nVidia have the "control" and it should be stable 120 Hz.
    And he was right.


    Let me explain the issue (bug):
    When you have a 120 Hz Monitor and a 60 Hz Monitor connected to the same PC, everything seems working well.
    But with Windows 10 there's a major issue.
    When any motion happens on the 2nd 60 Hz Monitor, the 120 Hz (main) Monitor drops down to something 60-85Hz.
    I ran some tests to figure this out.


    Here is just a simple test with Testufo.com to see how the Hz values are changing:
    https://www.youtube.com/watch?v=g5s3b_ZnyF0

    Here another thing I tested:
    http://i.imgur.com/dWfQzBD.jpg


    You can simply reproduce this issue, when you do this:
    http://i.imgur.com/yM883sa.jpg
    (no encoding running, just the preview of OBS, because it "makes motion" to the 60 Hz Monitor)
    When you put the preview of OBS (Open Broadcaster Software) on the 120 Hz Monitor = everythings stable.
    When you simply move the preview (no encoding running) it starts to stutter (feel unsmooth).
    Because the 120 Hz drops down to 60-85 Hz up and down. And because it's skipping it feels terrible.
    You can do this with a video or something else, not needed to use a small preview video from OBS.
    Any motion should cause this issue.


    I was in contact with nVidia devs and they told me that's something in windows 10.
    Probably the "new" windows explorer.exe and how it handles the stuff.
    And all my tests show me the same.
    You don't realise that the 120 Hz falls down to 60-85 Hz when you're not playing a game in Windowed Mode.
    Because a normal Video with 25 FPS or even 60 FPS is still good with 60 Hz.
    When you play a game in Fullscreen (Windowed) mode, like everyone today do it, you see and feel the Hz drops.
    The only "solution" is to play a game in REAL exclusive Fullscreen mode.
    Because then nVidia drivers take over control, not windows explorer.exe.
    The game is smooth, it doesn't matter if any motion on the 2nd 60 Hz monitor happen.
    Now you could say: "Ok, then just play in fullscreen instead of windowed fullscreen mode?!".


    Well, yes and no.
    1. Many people don't like the minimize time. For me it's just 1 sec so it wouldn't hur me to play fullscreen
    BUT
    2. IF (and I do that) you duplicate your 120 Hz Monitor to HDMI (with 60 Hz for a CaptureCard) it's the same like you would connect a 60 Hz Monitor.


    I still can (and sadly I have to) play in real fullscreen mode.
    But the problem about that is, I have a 5 sec blackscreen when I tab out the Fullscreen game, because:
    - Game is 120 Hz
    - When I tab out, Monitor goes from 120 to 60 (capture card HDMI) and back to 120 Hz which my Desktop have...
    This takes like 5 sec. The stream see my desktop in 1 sec but I have a 5 sec blackscreen.
    And some games don't have a real exclusive fullscreen mode, like "Gears of War 4".
    This game is in an "app" environment. The problem about explorer.exe is, that it have to handle "apps" and normal "progams".
    This is the difference between win10 and win7.
    I have no issue with Windows 7. You can feel a liiittle change in Hz value, when motion on 60 Hz Monitor happens.
    But only a small one. And without Aero enabled, it's totally fine.


    I was talking to many people, everyone had the same issue.
    But everyone told me:
    - Just buy a second 120 Hz monitor like I did, and everythings fine ;-
    BUT like I said, IF you want to forward the game (main monitor) image to HDMI, because of a CaptureCard in the second PC.
    It's not helping you to buy a second 120 Hz Monitor.
    Because you simply duplicate your 120 Hz DVI (or whatever) to HDMI and set the HDMI Hz to 60 Hz.
    You can do that in nVidia control panel by ease. Same for ati, not a big deal.
    So basically the HDMI duplication acts like a connected 60 Hz Monitor.
    WHICH cause this issue ;-)
    And to tell me, just buy a capture card which supports 120 Hz, is just...
    I only found one, and this capture card costs ~1500€ and it only have DVI, no HDMI (which I would use sometimes for PS4 streaming).
    That's the card:
    https://datapath.co.uk/video-capture-cards/vision-range/visiondvi-dl
    This capture card is to expensive for a normal user.
    It only have DVI (not a problem for me, I use external audio mixer to bring the audio to streaming PC).
    No HDMI means, no console streaming by "ease".


    This bug, force me to use and stay on windows 7.
    90% of my friends told me, it's your fault when you use windows 10.
    No one whants to switch. I always try to bring them to win10, because I (personally) totaly like it.
    After I configurated everything. Removed a TON of stuff from Windows 10, like nearly every "app" which is installed by default...
    (which is btw. not a good thing...). The most "apps" I have to remove via registry hack, and stuff like that.
    OneDrive and everything. And that the Xbox app runs the "recording" in the background by default, is not good too.
    So my windows is totally clear and perfect. I like windows 10, and I would want to stay on Windows 10.
    I deactivated the XboxApp on Windows + GameBar (which records the game in the background).
    So nothing runs in the background which could produce that issue. I check the Taskmanager / Resourcemanager / other tools aswell. Nothing wrong there. No CPU or GPU spikes.


    For your developer, that's the way to reproduce this bug:
    1. Connect a 120 Hz Monitor as main monitor
    2. Connect a  60 Hz Monitor as second monitor
    3. Open a game in Fullscreen (Windowed) mode, for example World of Warcraft. This means Fullscreen without any borders. Like Gears of War 4 do it too... And there's no option for real exclusive fullscreen...
    4. Open some video or twitch.tv stream on the 60 Hz Monitor
    5. Walk around in the game, when the video is paused. Then play the video and walk around. You should feel that it's unsmooth.

    6. Open: http://testufo.com/#test=framerates on the 120 Hz Monitor. You should see that it's 120 Hz displayed (while the video on 60 Hz Monitor is paused).
    7. Play the video (motion happens) on the 60 Hz Monitor. Just open a twitch.tv stream in a other browser. Like use testufo on chrome, and play twitch video with firefox.
       You should see that the FPS goes below 120 FPS when the video isn't fullscreen (on 60 Hz second Monitor).
       WHen you put the twitch video on fullscreen, it's on STABLE 60 FPS...
       That's the thing you can see on my video: https://www.youtube.com/watch?v=g5s3b_ZnyF0


    For Informations:
    I'm using a BenQ XL2411Z (120 Hz) + LG FLatron W2452T (60 Hz) with a GTX 1070 and an I7-4790K.
    Windows 10 Pro 64 bit / Build: 14393.693 / Version: 1607
    (the issue was in ~v11 too so I upgraded to see if it's fixed.


    What I want:
    Playing on 120 Hz Monitor, while this Monitor is duplicated to HDMI with 60 Hz.
    So that the HDMI-output goes to the CaptureCard in my second PC.
    This PC encodes the video + audio (Open Broadcaster Software) and stream it to twitch.tv!
    On Windows 7 this works without any issue. With Windows 10 I have to play in Fullscreen, but 5 sec minimize time is to much.
    Can't write into chat for a moment, because TAB out takes to long... Same for TAB back into the game...
    Duplicated == using a second 60 Hz Monitor :-\ And "Gears of War 4" is not stream able for me, because it have NO real fullscreen mode, WTF...
    Because GOW4 runs in a "windows APP"... And those have no real fullscreen mode, like I know...



    Threads I found to the same issue: (more than 1 year old problem...)

    • https://www.reddit.com/r/nvidia/comments/3f3xhr/144hz_monitor_60hz_monitor_stutter_issues_on/
    • https://www.reddit.com/r/nvidia/comments/4i4399/dual_monitor_144hz_60hz_framerate_lock_is_a_bug/
    • https://www.reddit.com/r/nvidia/comments/3mju3k/144hz_60hz_monitor_problem/

    • Bearbeitet DedraSC2 Dienstag, 24. Januar 2017 04:19
    Montag, 3. Oktober 2016 19:59