none
Server braucht Stunden um zu starten RRS feed

  • Frage

  • Windows 2008 SBS Server SP1.

    Der Server startet eigentlich ganz normal, bis man sich als Administrator anmeldet. Diese Anmeldung dauert dann fast 2 Stunden. In dieser Zeit ist ein Arbeiten mit dem Server nicht zu denken. Exchange Verbindung scheitert. Laufwerksverbindungen gehen nicht etc.

    Danach ist alles normal.

    Meine Frage: Gibt es eine Software, mit der ich bereits vom Start weg ein Protokoll erstellen lassen kann. Also welcher Dienst, Treiber, Programm wird geladen mit welcher CPU Last und wie lange dauert das Laden etc?

    Montag, 7. November 2011 07:41

Antworten

  • Hi Peter,
     
    > Fujitsu RX300 mit 40GB RAM und 4x 1TB SAS HDD.
     
    SBS 2008 supported max. 32GB RAM
     
    Weiterer RAM kann dazu führen, dass die Performance einbricht (da das
    Memory-Management dann nicht mehr sauber funktioniert)
     
    Bitte max. 32GB nach Vorgaben von Fujitsu für RX300 einbauen und erneut
    testen.
     
     
     
    > Abgesichert fährt er ganz schnell hoch.
    >
    > Virenscanner habe ich auch schon gedacht und ihn sogar testweise
    > komplett deinstalliert.
    >
    > Ja es ging erheblich flotter. Es wurde eigentlich nichts verändert. Nach
    > einem Update musste der Server neu gestartet werden. Dachte dann, es sei
    > das Update schuld und habe eine Acronis Sicherung von VOR dem Update
    > eingespielt - bringt leider nichts.
    >
    > Ich dachte nun an eine Software die mitprotokolliert was beim Starten
    > passiert. Dann kann ich herausfinden welches Teil die Probleme macht,
    > und dort ansetzen.
     
    Aktion Plan für ein Startup/Boot time tracing mittels den Windows
    Performance Analyzer Tools
     
    Download - Microsoft Windows SDK for Windows 7 and .NET Framework 4
     
    On an administrative Workstation:
     
    1. Download the Microsoft Windows SDK for Windows 7 and .NET Framework 4
    (it’s a bootstrap setup and is only around 500KB).
     
    2. Run the file winsdk_web.exe.
     
    3. Accept all defaults until the Installation Options screen is reached.
     
    4. Deselect all components except Redistributable Packages \ Windows
    Performance Toolkit. (Depending on the client, you may not have the option
    to deselect the .NET 4 tools)
     
    5. Complete the installation.
     
    6. Browse to C:\Program Files\Microsoft SDKs\Windows\v7.1\Redist\Windows
    Performance Toolkit. Copy the wpt_x64.msi and wpt_x86.msi files.
     
    These wpt_*.msi files can now be used to install the WPT on any machine and
    should be kept in a safe place so that you don’t need to download the SDK
    each time.
     
    On the affected server:
     
    1. Install the tools from the appropriate MSI file for the target system's
    processor architecture x86 (32-bit) or x64. You can use the default
    installation path or select another path. The installer will add the
    Performance Analyzer installation path to your system's PATH environment
    variable.
     
    2. Open an elevated command prompt window.
     
     a. Click the Start button
     b. Click the right mouse button
     c. Select Command Prompt
     d. Select Run as administrator
     
    3.In the command prompt window, type the following command
     
      xbootmgr -trace boot -noPrepReboot -traceFlags
    BASE+CSWITCH+DRIVERS+POWER+DISK_IO+FILE_IO+NETWORKTRACE -resultPath
    C:\TEMP\xbootmgr
     
     
    4. Restart the server and after logon send us the output from
    "C:\TEMP\xbootmgr"
     
    After having captured the trace then one can get a graphical view of the
    boot process, by starting xperfview and browse to the trace-file (*.etl) in
    the result path.
     
     
     
    Weitere Informationen bzgl. dem Windows Performance Analyzer
     
    Windows Performance Analyzer (WPA)
     
    Windows On/Off Transitions Solutions Guide
     
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    • Als Antwort vorgeschlagen Alex Pitulice Freitag, 11. November 2011 13:53
    • Als Antwort markiert Peter Putz LGH Montag, 14. November 2011 07:52
    Montag, 7. November 2011 15:41
    Moderator

Alle Antworten

  • Was für eine Hardware nutzt du?

    Abgesichert mal getestet?

    Virenscanner? Ausgeschaltet?

     

    Ging es mal flotter? Was wurde danach verändert!

    Montag, 7. November 2011 08:28
  • Fujitsu RX300 mit 40GB RAM und 4x 1TB SAS HDD.

    Abgesichert fährt er ganz schnell hoch.

    Virenscanner habe ich auch schon gedacht und ihn sogar testweise komplett deinstalliert.

    Ja es ging erheblich flotter. Es wurde eigentlich nichts verändert. Nach einem Update musste der Server neu gestartet werden. Dachte dann, es sei das Update schuld und habe eine Acronis Sicherung von VOR dem Update eingespielt - bringt leider nichts.

    Ich dachte nun an eine Software die mitprotokolliert was beim Starten passiert. Dann kann ich herausfinden welches Teil die Probleme macht, und dort ansetzen.

    Montag, 7. November 2011 09:00
  • Wenn er mal oben ist, sind dann alle Dienste gestartet? Läuft er auch???

    Hast du die Acronis Dienste mal deaktiviert und gestartet?

     

     

    Montag, 7. November 2011 10:35
  • Hi Peter,
     
    > Fujitsu RX300 mit 40GB RAM und 4x 1TB SAS HDD.
     
    SBS 2008 supported max. 32GB RAM
     
    Weiterer RAM kann dazu führen, dass die Performance einbricht (da das
    Memory-Management dann nicht mehr sauber funktioniert)
     
    Bitte max. 32GB nach Vorgaben von Fujitsu für RX300 einbauen und erneut
    testen.
     
     
     
    > Abgesichert fährt er ganz schnell hoch.
    >
    > Virenscanner habe ich auch schon gedacht und ihn sogar testweise
    > komplett deinstalliert.
    >
    > Ja es ging erheblich flotter. Es wurde eigentlich nichts verändert. Nach
    > einem Update musste der Server neu gestartet werden. Dachte dann, es sei
    > das Update schuld und habe eine Acronis Sicherung von VOR dem Update
    > eingespielt - bringt leider nichts.
    >
    > Ich dachte nun an eine Software die mitprotokolliert was beim Starten
    > passiert. Dann kann ich herausfinden welches Teil die Probleme macht,
    > und dort ansetzen.
     
    Aktion Plan für ein Startup/Boot time tracing mittels den Windows
    Performance Analyzer Tools
     
    Download - Microsoft Windows SDK for Windows 7 and .NET Framework 4
     
    On an administrative Workstation:
     
    1. Download the Microsoft Windows SDK for Windows 7 and .NET Framework 4
    (it’s a bootstrap setup and is only around 500KB).
     
    2. Run the file winsdk_web.exe.
     
    3. Accept all defaults until the Installation Options screen is reached.
     
    4. Deselect all components except Redistributable Packages \ Windows
    Performance Toolkit. (Depending on the client, you may not have the option
    to deselect the .NET 4 tools)
     
    5. Complete the installation.
     
    6. Browse to C:\Program Files\Microsoft SDKs\Windows\v7.1\Redist\Windows
    Performance Toolkit. Copy the wpt_x64.msi and wpt_x86.msi files.
     
    These wpt_*.msi files can now be used to install the WPT on any machine and
    should be kept in a safe place so that you don’t need to download the SDK
    each time.
     
    On the affected server:
     
    1. Install the tools from the appropriate MSI file for the target system's
    processor architecture x86 (32-bit) or x64. You can use the default
    installation path or select another path. The installer will add the
    Performance Analyzer installation path to your system's PATH environment
    variable.
     
    2. Open an elevated command prompt window.
     
     a. Click the Start button
     b. Click the right mouse button
     c. Select Command Prompt
     d. Select Run as administrator
     
    3.In the command prompt window, type the following command
     
      xbootmgr -trace boot -noPrepReboot -traceFlags
    BASE+CSWITCH+DRIVERS+POWER+DISK_IO+FILE_IO+NETWORKTRACE -resultPath
    C:\TEMP\xbootmgr
     
     
    4. Restart the server and after logon send us the output from
    "C:\TEMP\xbootmgr"
     
    After having captured the trace then one can get a graphical view of the
    boot process, by starting xperfview and browse to the trace-file (*.etl) in
    the result path.
     
     
     
    Weitere Informationen bzgl. dem Windows Performance Analyzer
     
    Windows Performance Analyzer (WPA)
     
    Windows On/Off Transitions Solutions Guide
     
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    • Als Antwort vorgeschlagen Alex Pitulice Freitag, 11. November 2011 13:53
    • Als Antwort markiert Peter Putz LGH Montag, 14. November 2011 07:52
    Montag, 7. November 2011 15:41
    Moderator
  • Hallo Tobias,

    hast Du auch irgendwo was zum Nachlesen bez. Performance bei mehr als 32 GB verbautem RAM?

    Unter http://social.technet.microsoft.com/Forums/de-DE/exchange_serverde/thread/cc61d81c-1097-4916-958d-1f19b9a4262f hat "Timpetu" ja auch mehr RAM als supported verbaut.


    Volker
    Montag, 7. November 2011 16:49
  • Hallo Tobias.

    Vielen Dank für deine Hilfe und Hinweise. Werde es gleich probieren, sobald der Server "entbehrlich" wird.

    Das mit dem RAM kann ich mir aber eigentlich nicht ganz vorstellen, da der Server ja mit den 40GB auch bereits vor Monaten problemlos gestartet und gearbeitet hat - aber ein Versuch ist es Wert.

     

    Dienstag, 8. November 2011 06:37
  • Hallo Tobias.

    Ich bekomme die folgende Meldung nach Eingabe von xbootmgr ....

    "-noPrepReboot": This option can only be used with shutdown and rebootCycle traces.

     

    Muss ich das nun als Fehler interpretieren, oder ist es nur ein Hinweis, dass ich den Server halt booten muss um einen trace zu erhalten?

    Dienstag, 8. November 2011 07:33
  • Hi Volker,
     
    > hast Du auch irgendwo was zum Nachlesen bez. Performance bei mehr als 32
    > GB verbautem RAM?
    >
    > hat "Timpetu" ja auch mehr RAM als supported verbaut.
     
    Ein System, dass ausserhalb seiner Systemspezifikation betrieben wird, hat
    immer das potential Fehler zu produzieren.
     
    Hierbei handelt es sich um Erfahrungswerte aus ähnlichen Supportfällen.
     
    Mehr als 32GB ist in einem SBS 2008/2011 nicht supported. Punkt.
     
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    Dienstag, 8. November 2011 09:27
    Moderator
  • Hi Peter,
     
    > Ich bekomme die folgende Meldung nach Eingabe von xbootmgr ....
    >
    > "-noPrepReboot": This option can only be used with shutdown and
    > rebootCycle traces.
    >
    > Muss ich das nun als Fehler interpretieren, oder ist es nur ein Hinweis,
    > dass ich den Server halt booten muss um einen trace zu erhalten?
     
    Hierbei handelt es sich lediglich um eine Beispielanwendung und nicht einen
    fertigen Aktionsplan für Dein Szenario.
     
    Lies Dich also bitte in die zugehörige Dokumentation ein ohne blind einfach
    die beispielhaften Paramter zu übernehmen.
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    Dienstag, 8. November 2011 09:29
    Moderator
  • Sorry.

    Ich dachte der Script wäre fertig.

    Danke für deine Infos!!

    Dienstag, 8. November 2011 11:57
  • Hallo Peter,

     

    Hat die Antwort von Tobias Dir weitergeholfen um das Problem zu lösen?

     

    Viele Grüße,

    Alex

    • Als Antwort markiert Peter Putz LGH Montag, 14. November 2011 07:51
    • Tag als Antwort aufgehoben Peter Putz LGH Montag, 14. November 2011 07:51
    Freitag, 11. November 2011 13:53
  • Hallo Alex.

     

    Ich habe die Antwort von Tobias als Antwort markiert.

    lg

    Montag, 14. November 2011 07:52
  • Hallo Peter,

    was genau hat Dir in der Antwort von Tobias geholfen? Weniger RAM (max 32) oder die Analyse?


    Volker

    Montag, 14. November 2011 07:58
  • Ich habe beides durchgeführt.

    Durch die Analyse habe ich festgestellt, dass ein Dienst eines Drittanbieters den Server hoch belastet hat. Sicherheitshalber habe ich auch die RAM auf 32GB reduziert. - Sicher ist sicher.

    Montag, 14. November 2011 08:25
  • Hallo Peter,

    Danke Dir für die Markierung und auch für die weitere Details zur Lösung. :)

    Gruss,

    Alex

    Montag, 14. November 2011 09:03
  • Ich habe zu danken!

    Und zwar euch und dem Forum hier.

     

    lg

    Montag, 14. November 2011 09:18
  • Peter Putz LGH wrote:

    Durch die Analyse habe ich festgestellt, dass ein Dienst eines
    Drittanbieters den Server hoch belastet hat. Sicherheitshalber habe ich
    auch die RAM auf 32GB reduziert. - Sicher ist sicher.

    Verrätst du uns auch noch den Namen des Dienstes/der Software?!


    Robert Riebisch
    Bitte NUR in der Newsgroup antworten!
    Please reply to the Newsgroup ONLY!


    Robert
    Montag, 26. Dezember 2011 21:50
  • Aber sicher.

    Es handelt sich um einen Dienst der Firma Trisoft. Dieser Dienst ist dazu da um einen bestimmten Ordner nach Dokumenten zu durchsuchen und dann diese Dokus in ein DokuManagementsystem abzulegen.

    Das System heist Pro.File und der Dienst TriScan.

    Nachdem der Server gebootet hat und alle Dienste gestartet sind, kann der betroffende Dienst manuell gestartet werden. Dann läuft alles problemlos. Der SW Entwickler arbeitet bereits an der Lösung. Es hat anscheinend mit einem Windows Update zu tun.

    Dienstag, 27. Dezember 2011 08:52