none
Excel 2010 Gitterlinien in 2d Oberflächenchart RRS feed

  • Frage

  • Hallo Gemeinde,

    ich habe ein massives Problem. Wir sind grade bei der Migration von Office 2003 auf 2010. Einige unserer Produktionsauswertungen bestehen aus zweidimensionalen Oberflächencharts (xlSurfaceTopView). Das Standardeinstellung  dieses Charts ist in Excel 2010 völlig anders als bei 2003. Die Oberfläche ist mit Texturen Pseudo-3d, was sich mit der Einstellung msoMaterialFlat Gott sei Dank abschalten lässt. Jedoch ist das Zeilen.- und Spaltengitter programmatisch nicht mehr zu aktivieren. Wenn man den Makrorekorder verwendet  generiert der eine Einstellung Chart.Legend.LegendEntries(x).Format.Line.ForeColor.RGB = Color. Der vom Makrogenerator generierte Code kann schon deshalb nicht funktionieren, da das Objekt Format hier keine Line-Eigenschaft hat. Ich kann das Gitter manuell erzeugen, indem in JEDEM Legend-Eintrag die Rahmenfarbe und Rahmenart gesetzt wird (was hat MS sich dabei gedacht?), aber das Endergebnis ist grauenvoll. Während bei Excel 2003 die Gitterlinenen blitzsauber gezeichnet werden, sind sie in der 2010er Version völlig unbrauchbar. Sie ändern ihre Strichstärke mittendrin von dick bis nicht vorhanden und ist völlig verwaschen. Für professionelle Zwecke ist das völlig indiskutabel.

    Hat jemand einen Tip für mich? Möglicherweise habe ich ja nur etwas übersehen. Gibt es ein 3rd Party-Chart, das so sauber zeichnet wie die Version aus Excel 2003?

    Gruß
    Wolfgang

    Donnerstag, 14. Juni 2012 06:16

Antworten

  • Hallo Wolfgang...

    Danke für die Rückmeldung :-)

    Ich habe es mal mit einer Testdatei nachgestellt; im Kompatibilitätsmodus für XLS Dateien wird's auch bei mir unscharf dargestellt. Wenn ich ein entsprechendes Diagramm direkt unter Excel 2010 simuliere und die 3-D Effekte wegnehme sowie Rahmen hinzufüge, erhalte ich dieselbe ungenaue Darstellung. 3D-Effekt wegnehmen geht über das Formatieren der einzelnen Legendeneinträge und dort unter 3D-Format -> Material -> Spezialeffekt = Flach (3. von links) wählen. Rahmen unter Rahmenfarbe setzen. Excel 2007 verhält sich bei mir ebenfalls wie 2010.

    Eine Lösung hätte ich leider erstmal nicht. Könnte mit der internen Berechnung bzw. Rendern zusammenhängen, die in Excel ab 2007 vielleicht anders ist.

    Gruß


    Microsoft Excel MVP · Excel Soccer EM Planer · www.excel-soccer.de


    Mittwoch, 4. Juli 2012 17:35

Alle Antworten

  • Hallo Wolfgang,

    ist nur geraten. Es gibt da eine Option "Bilder nicht in Datei komprimieren" (Unter Excel-Optionen->Erweitert->Bildgröße und -qualität) die standardmässig deaktiviert ist. Vielleicht hilft das ja?

    Gruß

    Viktor

    Donnerstag, 14. Juni 2012 07:12
  • Hallo Viktor,

    danke für den Hinweis. Leider hat das aber keine Änderung am Erscheinungsbild gebracht. Auch eine verwandte Option [Drucken ]"Modus für hohe Qualität für Grafiken" brachte keine Besserung.

    Ich hänge mal den unterschied zwischen 2003 und 2010 an.

    Das ist das Ergebnis unter Excel 2003

    Das ist das Ergebnis unter Excel 2010

    Gruß
    Wolfgang

    Donnerstag, 14. Juni 2012 08:17
  • Wird die Grafik nach dem Erstellen in der Größe geändert? Ich hatte das Problem mit Word2010. Wenn ich eine Grafik in ein Dokument einfüge und "unberührt" lasse, dann war das Aussehen (und Druck) OK. Wenn ich aber die Grafik in der Größe geändert habe, hatte ich ähnliche Resultate wie oben zu sehen sind.

    Ich bin dann den Weg des geringsten Aufwand gegangen und habe die Grafik nicht mehr verändert. Ich hatte mich mit dem Problem nur oberflächlich beschäftigt. Aber es scheint wohl ein allgmeines Problem zu sein, da man einige Einträge diesbezüglich finden kann. Es ist schade, das die Verarbeitung von Grafiken in Office 2010 "verschlimmbessert" wurde.

    Gruß

    Viktor

    Donnerstag, 14. Juni 2012 08:32
  • Hallo Viktor,

    Danke für Deine Antwort.

    Nur noch mal zur Klarstellung. Es handelt sich nicht um eine importierte Grafik, sondern um ein von Excel generiertes Chart vom Typ Flächendiagramm 2D. Deshalb muss/soll/wird es intern auf Vektordaten beruhen, so das ein skalieren gar keine Auswirkung haben dürfte.
    Und es geht nicht um den Ausdruck. Auch im Excel-Blatt sieht das Chart schon so desaströs aus.
    Gruß
    Wolfgang

    Donnerstag, 14. Juni 2012 09:47
  • Hallo Wolfgang...

    ich kann Dir zwar nicht sagen, ob ich dann weiterhelfen kann, aber hast Du die Möglichkeit, eine anonymisierte Beispieldatei, z.B. auf einem Server, abzulegen?

    Gruß


    Microsoft Excel MVP · Excel Soccer EM Planer · www.excel-soccer.de

    Freitag, 15. Juni 2012 17:57
  • Hallo Mourad,

    sorry, ich hatte Deine Antwort gar nicht gesehen. Da ist wohl eine EMail-Benachrichtigung bei mir durchgeflutscht. Die Auswertung wird aus einer Oracle Datenbank gespeist. Ast also "Stand alone" nicht zu gebrauchen.

    Gruß
    Wolfgang

    Dienstag, 3. Juli 2012 17:30
  • Hallo Raul,

    ja. Die Auswertung sieht unter Excel 2010 immer noch nicht besser aus. Die Klienten haben es bisher geschluckt. Jedoch bin ich noch auf der Suche nach einer Lösung oder eine 3rd-Party Control das solche Flächendiagramme besser macht. Eigentlich schade, da es Excel ja schon besser konnte.

    Gruß
    Wolfgang

    Dienstag, 3. Juli 2012 17:33
  • Hallo Wolfgang...

    Danke für die Rückmeldung :-)

    Ich habe es mal mit einer Testdatei nachgestellt; im Kompatibilitätsmodus für XLS Dateien wird's auch bei mir unscharf dargestellt. Wenn ich ein entsprechendes Diagramm direkt unter Excel 2010 simuliere und die 3-D Effekte wegnehme sowie Rahmen hinzufüge, erhalte ich dieselbe ungenaue Darstellung. 3D-Effekt wegnehmen geht über das Formatieren der einzelnen Legendeneinträge und dort unter 3D-Format -> Material -> Spezialeffekt = Flach (3. von links) wählen. Rahmen unter Rahmenfarbe setzen. Excel 2007 verhält sich bei mir ebenfalls wie 2010.

    Eine Lösung hätte ich leider erstmal nicht. Könnte mit der internen Berechnung bzw. Rendern zusammenhängen, die in Excel ab 2007 vielleicht anders ist.

    Gruß


    Microsoft Excel MVP · Excel Soccer EM Planer · www.excel-soccer.de


    Mittwoch, 4. Juli 2012 17:35
  • Hallo Mourad,

    Danke für Deine Bemühungen. Genau die gleiche Vorgehensweise hatte ich auch.
    Ich bin ja schon froh, das jemand das Problem verifizieren kann. So ist sichergestellt, das bei mir das Problem nicht vor dem Computer sitzt. :-)

    Gruß
    Wolfgang

    Donnerstag, 5. Juli 2012 17:59