locked
Windows Remote Desktop RRS feed

  • Frage

  • I am having a problem using the remote desktop on a Windows 8 Enterprise workstation, it will not connect. For some reason the authentication fails and a popup windows states that this function is not supported although it is activated. Other W8 and W7 workstations in the same network work fine. I also have checked the settings and it looks as if all services are activated too. Perhaps there happens to be a problem with the RCP drivers and all it requires is a new installation? I would be most pleased for some help.

    Ich habe versucht Windows Remote Desktop auf ein Rechner zu aktivieren ohne Erfolg. Ich erhalte immer die Meldung „ Der Remotecomputer erfordert die Authentifizierung auf Netzwerkebene usw.“ Das Häkchen ist aber aktiviert dafür.

    Im Netzwerk sind zwei W8 Enterprise und ein W7 Enterprise Workstation und alle drei können miteinander kommunizieren und Daten austauchen.

    Nur ein W8 Rechner der Standardmäßig das Remotedesktopprotokoll Version 8 unterstützt verweigert die Verbindung zu den zwei anderen Workstations.

    Firewall, Router und die RPC Einstellungen sind überall gleichermaßen eingestellt.

    Hat vielleicht jemand eine Idee voran es liegen könnte, bzw. hat es ein Update Konflikt gegeben, muss etwas in die Registry verändert oder neuinstalliert werden?

    Vielen Dank im Voraus.


    • Bearbeitet Animal Sanctuary Mittwoch, 22. Mai 2013 12:05 English version update
    • Typ geändert Alex Pitulice Donnerstag, 30. Mai 2013 09:32 Warten auf Feedback
    • Typ geändert Alex Pitulice Freitag, 7. Juni 2013 19:55 Noch Aktiv
    Mittwoch, 22. Mai 2013 06:26

Antworten

  • Hallo Toni,

    das Problem wurde dadurch gelöst "tspkg" war in die Registry eingetragen aber unter "SecurityProviders" fehlte der Wert "credssp.dll".

    Vielen herzlichen Dank und auch an alle anderen beteiligten!!!

    Nick

    Freitag, 7. Juni 2013 10:44

Alle Antworten

  • Hallo,

    so wie es aussieht liegt es an dem alten RDP 7.0 auf deinen Windows 7 Rechnern.

    Wenn du Windows 7 SP1 hast kannst du das RDP Protokoll ganz easy auf 8.0 updaten via Windowsupdate und MS Download Center (KB2592687). Danach sollte auch RDP auf Windows 8 funktionieren!

    Gruß
    Daniel

    Mittwoch, 22. Mai 2013 12:22
  • Moin,

    teste doch die Remote Desktops ohne Authentifizierung auf Netzwerkeben (Häkchen raus!) ... :-)

    Daniels Idee ist soweit gut, aktuelle Versionen sind immer toll. Hier der Link zum Update: http://www.microsoft.com/en-us/download/details.aspx?id=35387

    Generell unterstützt Windows 7 mit RDP 7 allerdings auch bereits vollständig die Autheifizierung auf Netzwerkebene. 

    Prüfe auch die lokale Gruppenrichtlinie:

    • "Gruppenrichtlinieneinstellung Benutzerauthentifizierung für Remoteverbindungen mithilfe der Authentifizierung auf Netzwerkebene erforderlich"

    Grüße


    kind regards Jochen Reinecke // MCSA '08 '12

    Mittwoch, 22. Mai 2013 13:17
  • Hallo Daniel,

    der Windows 7 Rechner hat bereits die 8er Version drauf und kann mit den einen Windows 8 Rechner verbinden. Das Problem ist aber der zweite Windows 8 Rechner lässt sich überhaupt nicht verbinden auch nicht zum ersten W8 Rechner und ich vermute dass irgendwo der Wurm im System ist, Fehlerhafte KB Datei oder durch MS Auto-Updates passiert ist.

    LG, Nick

    Mittwoch, 22. Mai 2013 15:00
  • Hallo Jochen,

    Remote Desktop ohne Authentifizierung (Häkchen raus) ohne Erfolg. Ich werde die Gruppenrichtlinieneinstellungen genau überprüfen.

    Danke Nick

    Mittwoch, 22. Mai 2013 15:21
  • Hallo Nick,

    welche Fehlmermeldung erhälst du, wenn du dich OHNE (Haken raus) Netzwerkauthentifizierung versuchst zu verbinden. Bitte schildere doch noch einmal von welchem System (OS) du dich auf welches Verbindungen möchtest.

    Ein Systemfehler oder fehlerhaftes Update (KB) würde ich ausschließen.

    Grüße


    kind regards Jochen Reinecke // MCSA '08 '12

    Freitag, 24. Mai 2013 09:39
  • Hallo Alex, ich habe alles angesehen und bei den Gruppenrichtlinien – Policies ist alles freigegeben, läuft immer noch nicht.

    VG Nick

    Freitag, 24. Mai 2013 14:33
  • Hallo Jochen,

    hier sieht Man dass unter Info – Remote Desktop im Text „***wird nicht unterstützt“ fehlt!!!

    und das noch.

    Zur Frage (OS) Verbindungen, Windows 8 Enterprise zur Windows 8 Enterprise, bzw. Windows 8 Enterprise zur Windows 7 Enterprise und umgekehrt.

    VG, Nick

    Freitag, 24. Mai 2013 14:47
  • Guten Abend,

    und du hast die Authentifizierung auf beiden Geräten deaktiviert und es getestet? (Nicht, dass es jetzt die optimale Lösung wäre. Aber ein Anhaltspunkt dennoch sicher.)

    Ansonsten könnte Torsten Weber's Blogeintrag einige interessante Aspekte für dich bieten: http://blogs.compactframework.de/Torsten.Weber/CategoryView,category,Windows,3.aspx

    Hoffe das hilft dir noch ein wenig

    Grüße


    kind regards Jochen Reinecke // MCSA '08 '12

    Montag, 27. Mai 2013 20:35
  • Morgen Jochen,

    Ich könnte eine Verbindung ohne Authentifizierung aufbauen zu den beiden Windows 8 Workstations. Finde aber immer noch nicht wo das Problem liegt wenn es aktiviert ist und nicht funktioniert.

    Gruß Nick


    Freitag, 31. Mai 2013 06:23
  • Hallo Alex,

    ich habe Jochen mitgeteilt (siehe Beitrag unten) dass einer Verbindung hergestellt werden könnte aber ohne Authentifizierung. Mir ist damals aufgefallen bei der Installation von W8 dass der Produkt Key nicht Akzeptiert wurde und ich es manuell eingegeben müsste obwohl die Software direkt beim MLSC kam. Könnte es dadurch auch Probleme mit der SSL Zertifikate liegen?

    VG, Nick

    Donnerstag, 6. Juni 2013 13:54
  • Hallo Nick,

    hast du dir auch den von mir geposteten Link angesehen und es mit diesen Einstellungen probiert?

    Normalerweise dürfte die Windows Aktivierung nichts mit SSL zutun haben, es sei denn dein System befindet sich bereits im eingeschränkten Modus. Siehe bitte unter "System" > Windows Taste + Pause nach ob es sich um eine Originial-Kopie handelt und Windows aktiviert wurde.

    Viele Grüße


    kind regards Jochen Reinecke // MCSA '08 '12

    Freitag, 7. Juni 2013 06:24
  • Hallo Jochen,

    den Link habe ich angesehen und ausprobiert und siehe unten Windows ist aktiviert.

    Gruß Nick

    Freitag, 7. Juni 2013 06:40
  • Hallo,

    bitte geh auf dem Client in die Registry zu folgendem Pfad:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    Prüfe dort, ob bei "Security Packages" der Wert "tspkg" eingetragen ist. Wenn nicht, bitte ergänzen.

    Dann prüfe bitte noch den Pfad:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders

    Prüfe, ob dort bei "SecurityProviders" der Wert "credssp.dll" drinsteht. Wenn nicht, bitte ergänzen und anschließend den PC neu starten.

    Grüße,

    Toni

    • Als Antwort vorgeschlagen Jochen.Reinecke Donnerstag, 13. Juni 2013 06:19
    Freitag, 7. Juni 2013 09:30
  • Hallo Toni,

    das Problem wurde dadurch gelöst "tspkg" war in die Registry eingetragen aber unter "SecurityProviders" fehlte der Wert "credssp.dll".

    Vielen herzlichen Dank und auch an alle anderen beteiligten!!!

    Nick

    Freitag, 7. Juni 2013 10:44
  • Freitag, 7. Juni 2013 19:55