none
Problem mit AD-Anmeldung nach Anniversary Update und Domain Join

    Frage

  • Hallo liebe Community,

    im Windows 10 Bereich schon einen Thread gestartet, doch nach meiner Erfahrung heute, bleibt eine Frage offen, die den Windows Server 2012 R2 etwaig betreffen.

    Problem:

    Upgrade von Windows 10 Home Version 1607 auf Professional-Variante mit anschließendem Domain Join an einem Windows Server 2012 R2 mit entsprechendem AD. Beitritt verlief erfolgreich und der Neustart wird durchgeführt. Anschließend ist ein Logon mit jeglichem Benutzer (auch Dom-Admin) nicht möglich und wird mit einem "Unbekannter Benutzer oder Passwort" quittiert. Eine Prüfung erfolgt scheinbar nicht, da sobald man die Anmeldung startet, sofort dieser Fehler auftritt. Im Eventlog sind zwei Einträge zu finden:

    Quelle: User Registration, ID 307
    "Automatic registration failed. Failed to lookup the registration service information from Active Directory. Exit code: Unknown HResult Error code: 0x801c001d. See http://go.microsoft.com/fwlink/?LinkId=623042"

    Quelle: User Registration, ID 304
    "Automatic registration failed at join phase.  Exit code: Unknown HResult Error code: 0x801c001d. Server error: empty. Debug Output:\r\n joinMode: Join
    drsInstance: undefined
    registrationType: undefined
    tenantType: undefined
    tenantId: undefined
    configLocation: undefined
    errorPhase: discover
    adalCorrelationId: undefined
    adalLog: undefined
    adalLog: undefined
    adalResponseCode: 0x0"

    Stellt man das gleiche Szenario mit Windows 10 Home Version 1511, Upgrade auf Professional, Domain Join etc. nach, erfolgt der Logon erfolgreich. In allen Szenarien kommen lokale Benutzerprofile zum Tragen. Wird von 1511 auf 1607 aktualisiert, funktioniert der Anmeldeprozess immer noch.

    Hattet Ihr schon ähnliche Szenarien und Erfahrungen? Über einen Austausch würde ich mich freuen.

    Viele Grüße

    Stephan

    Samstag, 13. August 2016 22:13

Antworten

Alle Antworten

  • Hallo Stephan

    ich habe das gleiche Problem. Server erkennt den Benutzer, Zugriff funktioniert, jedoch können Benutzer sich nicht anmelden.

    Wäre schön, hier Hilfe zu bekommen

    Sonntag, 14. August 2016 16:30
  • Leider fehlt mir die Zeit, sonst würde ich es selbst testen:

    wie sieht es im Zusammenhang mit Windows Server 2016 aus? Hat jemand die aktuelle TP incl. neuer dazugehöriger AD-Umgebung mit einem frischinstallierten Windows 10 Anniversary Update getestet? Ist hier nach einem Domain Join der Logon möglich?

    Viele Grüße

    Stephan

    Sonntag, 14. August 2016 22:03
  • Ich habe das ganze nochmal durchgetestet und zwar mit

    - Windows Server 2016 Version 1511 Build 14300.1045 als Domain Controller (Modus Technical Preview)

    - Windows 10 Enterprise Version 1607 Build 14393.51 für den Domain Join

    Da ich mir noch einige der neuen Features in der Enterprise Version anschauen wollte, habe ich das auch gleich zum Testen dieses Szenarios herangezogen, sprich Anniversary Update und anschließend Domain Join, sowie einer anschließenden Benutzeranmeldung.

    Ergebnis ist, dass alles einwandfrei funktioniert und daher die Frage offen bleibt, ob es eine Unverträglichkeit zwischen DC auf Basis 2012 R2 und einem neuen Domain Member auf Basis des Anniversary Updates gibt. Mit meinen Tests kann ich dies nur vermuten - Beweise sind einzig erst einmal die Logs oben :(

    Montag, 15. August 2016 14:43
  • Problem gelöst!

    Der Grund hierfür liegt am Patch-Level des Windows Server 2012 R2. Mit folgendem Build (9600.18378) von Windows Server 2012 R2 funktioniert selbst der Logon mit Windows 10 Build 14393.0 einwandfrei in meiner Umgebung.

    Viele Grüße

    Stephan

    Sonntag, 28. August 2016 21:14
  • Hallo Stephan,

    und wie ist die KB-Nummer des fehlenden Patches? Die Buildnummer hilft hier nur bedingt weiter.

    Danke.

    Montag, 29. August 2016 12:49
  • Hallo,

    ich habe das gleiche Problem und komme absolut nicht weiter. Mein DC mit Server 2012 R2 ist laut Windows Update (sowohl über den WSUS wie auch übers Internet) up to date. Bei einer Windows 10 Pro Anniversary Test-VM funktioniert der Login mit Domänenbenutzern sofort. Auf meinem Laptop, der zuerst auf Anniversary und dann von Home auf Pro upgegraded wurde, allerdings nicht, ich habe im Eventlog die selben Meldungen und ein Login mit Domänenbenutzern ist unmöglich. Das kann doch nicht sein, dass eines der Upgrades den Login dermaßen verhaut und es noch keinen Fix dafür gibt?

    Montag, 26. September 2016 11:19
  • Am 26.09.2016 schrieb kvy_91:

    mit Domänenbenutzern sofort. Auf meinem Laptop, der zuerst auf Anniversary und dann von Home auf Pro upgegraded wurde, allerdings nicht, ich habe im Eventlog die selben Meldungen und ein Login mit Domänenbenutzern ist unmöglich. Das kann doch nicht sein, dass eines der Upgrades den Login dermaßen verhaut und es noch keinen Fix dafür gibt?

    Doch, kann sein. Am sinnvollsten wäre es sicherlich, eine neue saubere
    Installation mit dem Anniversary Upgrade durchzuführen.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos für WSUS/WPP: http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Dienstag, 27. September 2016 08:38
  • Hallo

    Ich hatte heute das gleiche Phänomen wie oben beschrieben. Interessieren würde mich, ob dies nun wirklich alleine durch das Patching des Servers behoben werden kann, ohne das Windows 10 Gerät zu modifizieren (anaolog dem Thema oben beschrieben, wurde dies zuerst mit Windows 0 Home installiert, dann Anniversary Update, dann Upgrade zu Pro und dann heute Einbindung in die Domäne).

    Wenn ja, welches KB ist hierfür relevant?

    Danke und Gruss,
    Marianne

    Mittwoch, 26. Oktober 2016 21:06
  • KB Kernel  version 
    3170377 windows-os-kernel  6.3.9600.18378 
    3172614 windows-os-kernel  6.3.9600.18340 
    3175024 windows-os-kernel  6.3.9600.18438 
    3179574 windows-os-kernel  6.3.9600.18423 
    3185331 windows-os-kernel  6.3.9600.18505 
    3192392 windows-os-kernel  6.3.9600.18505 
    3192404 windows-os-kernel  6.3.9600.18505 
    3197874 windows-os-kernel  6.3.9600.18505 
    3197875 windows-os-kernel  6.3.9600.18505 
    3205401 windows-os-kernel  6.3.9600.18505 
    4012213 windows-os-kernel  6.3.9600.18589 
    4012216 windows-os-kernel  6.3.9600.18589 
    4012219 windows-os-kernel  6.3.9600.18589 
    4015550 windows-os-kernel  6.3.9600.18589 
    Samstag, 15. April 2017 06:27