none
Restore eines Sharepoint Backups schlägt fehl RRS feed

  • Frage

  • Hallo an alle,

    ich habe ein riesen Problem mit einem Sharepoint Backup (MOSS 2007), dass sich nicht wieder restoren lässt. Das Backup ist ganz normal per STSADM -o backup Befehl erstellt worden. Besonderheit ist, dass das Backup File ca. 4,5GB groß ist.

    Wenn ich jetzt einen Restore versuche (STSDAM -o restore -url URL -filename FILENAME -overwrite) kommt folgende Fehlermeldung:

    "Die Websitesammlung konnte nicht wiederhergestellt werden. Wenn dieses Problem weiterhin besteht, stellen Sie sicher, dass die Inhaltsdatenbanken verfügbar sind und über ausreichend freien Speicherplatz verfügen."

    Es ist genügend Platz auf der Platte vorhanden (30GB frei) und online war der darunter liegende SQL Server 2008 Standard auch. Ich habe das auch auf einer VM gestestet, wo SQL Server und Sharepoint auf der gleichen Maschine installiert waren, damit ich der Netzwerkthematik aus dem weg gehe. Hat aber leider auch nicht funktioniert.

    Außerdem habe ich versucht das Backup in eine komplett frische und leere Inhaltsdatenbank zu restoren, auch ohne Erfolg.

    Hat jemand irgendeine Idee?

    Vielen Dank im Voraus.

    Viele Grüße,

    Mark

    Donnerstag, 5. August 2010 07:32

Alle Antworten

  • Hallo Mark,

    im Backup Ordner sollte auch eine sprestore.log und sprestore.xml Datei vorhanden sein. Könntest du bitte diese beiden Dateien auf SkyDrive hochladen und hier verlinken damit wir uns das Problem genauer anschauen können?

    Gruß,
    Andrei

    Donnerstag, 5. August 2010 11:12
  • Hallo Andrei,

    die Dateien gibt es nicht. Muss ich das Logging irgendwie speziell aktivieren?

    Wie gesagt, ich mache einen ganz normalen STSADM -o restore und kein Farm Restoring über die Zentraladministration.

    Gruß,
    Mark

    Donnerstag, 5. August 2010 11:16
  • Hallo Mark,

    ja, sorry, habe es erst jetzt bemerkt dass der Filename Paramater auch dabei ist. Ist aber kein Problem, da wir ja noch das ULS Log (%PROGRAMFILES%\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS) haben.

    Falls hier standardmäßig nichts bezüglich des Restores protokolliert wird, könntest du das Logging per Zentral Administration - Vorgänge - Diagnoseprotokollierung - Ereignissteuerung - für Backup und Restore die Ablaufsverfolgungs aufzuzeichnende Ereignisse auf Ausführlich hochschrauben.

    Dann bitte auf SkyDrive hochladen und hier verlinken oder die Fehlemeldung gleich hier im Thread posten (Prozessname sollte stsadm.exe sein).

    Gruß,
    Andrei

    Donnerstag, 5. August 2010 11:31
  • Hallo Andrei,

    also der Restore läuft fast bist zum Schluß durch (wenn ich mir die Datenbankgröße anschaue) und dann kommt irgendwann folgender Fehler:

    08/05/2010 21:35:11.22  STSADM.EXE (0x0E68)                      0x0E6C Windows SharePoint Services    Database                       6f8g Unexpected Unexpected query execution failure, error code 210. Additional error information from SQL Server is included below. "Fehler beim Konvertieren einer binary-/varbinary-Zeichenfolge in eine datetime-Zeichenfolge."

    Das ist das Einzige was ich finden konnte in allen LOGS. Es wird auch noch die SQL Query ausgegeben, die ausgeführt wird, die habe ich jetzt allerdings mal weggelassen.

    Heißt das, dass das Backup fehlerhaft ist? Wenn ja, kann ich dagegen etwas tun?

    Grüße,
    Mark

    Freitag, 6. August 2010 08:17
  • Hallo Mark,

    das sieht jetzt aber merkwürdig aus.

    Evtl. könnte in diesem Fall ein SQL Profiler Trace weiterhelfen um genau beobachten zu können was er da konvertieren möchte..

    Starte einen Trace und versuche nochmal das Restore per stsadm auszuführen. Anschließend Trace anhalten, auf SkyDrive hochladen und hier verlinken. Dann können wir uns das genauer anschauen.

    http://msdn.microsoft.com/en-us/library/ms187929.aspx

    Gruß,
    Andrei

    Freitag, 6. August 2010 14:06
  • Hallo Andrei,

    das mit dem Trace muss ich erst noch laufen lassen. Bis der Restore nämlich durchgelaufen ist geht fast 1 Tag ins Land.

    Hier aber schon mal das SQL Statement, das den Fehler verursacht:

    http://cid-cfafa447fe06743c.office.live.com/self.aspx/Public/1.txt

    Vielen Dank für die Hilfe.

    Grüße,
    Mark

    Montag, 9. August 2010 12:53