none
IIS7 und Web Deploy Backups RRS feed

  • Frage

  • Hey Leute,

    ich bin gerade ein bisschen am Verzweifeln. Ich habe einen Webserver am Laufen (IIS7 auf Winsows Server 2008 R2) mit ASP und PHP Webseiten.

    Ich habe ein Backup von IIS samt Konfiguration und Files mit Web Deploy gemacht. Wenn ich dieses auf dem neuen Server (gleiches OS) importieren will, kommt folgende Fehlermeldung:

    System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
       bei Microsoft.Web.Deployment.CertStoreSettingsProvider.Delete(Boolean whatIf)
       bei Microsoft.Web.Deployment.DeploymentObject.DeleteOperation(DeploymentSyncContext syncContext)
       bei Microsoft.Web.Deployment.DeploymentObject.Delete(DeploymentSyncContext syncContext)
       bei Microsoft.Web.Deployment.DeploymentSyncContext.HandleDelete(DeploymentObject destObject, DeploymentObject sourceParentObject)
       bei Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source)
       bei Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source)
       bei Microsoft.Web.Deployment.DeploymentSyncContext.ProcessSync(DeploymentObject destinationObject, DeploymentObject sourceObject)
       bei Microsoft.Web.Deployment.DeploymentObject.SyncToInternal(DeploymentObject destObject, DeploymentSyncOptions syncOptions, PayloadTable payloadTable, ContentRootTable contentRootTable, Nullable`1 syncPassId, String syncSessionId)
       bei Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentProviderOptions providerOptions, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)
       bei Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentWellKnownProvider provider, String path, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)
       bei Microsoft.Web.Deployment.UI.InstallProgressWizardPage.OnWorkerDoWork(Object sender, DoWorkEventArgs e)
       bei System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

    Jemand eine Idee wie ich das beheben kann?

    Mittwoch, 22. Januar 2014 01:13