none
Excel 2013 falsche Sortierung in einer Pivot

    Frage

  • Hallo,

    ich habe eine Excel 2013 Pivot Tabelle, in der unter anderem Nachnamen in Zeilen angezeigt werden.
    Leider gibt es hier ein Problem, für dessen Lösung ich keine Idee habe.

    In der aufsteigend sortierten Liste steht der Nachname May an oberster stelle, gefolgt von den dann korekt sortierten weiteren Namen.
    Kann es sein, das Excel hier glaubt nach Datum sortieren zu müssen oder was könnte die Ursache sein?
    Wie kann ich Excel das abgewöhnen?

    Die Daten kommen übrigens aus einer SQL-Server View. Auch die Formatierung des Namens als Char-Feld hat keine Veränderung gebracht.

    Gruß 

    cheapy


    Dienstag, 27. März 2018 10:55

Alle Antworten

  • Ähnliche Fälle hatte ich auch schon:

    Kann es sein, dass vor dem Namen "May" noch ein Leerzeichen steht?
    Das ist nur schwer zu erkennen.

    Dienstag, 27. März 2018 11:52
  • Also in habe in der View explizit auf 'May' gefiltert und bekomme trotzem ein Ergebnis für diesen Namen, daher vermute ich dass es eher nicht an Leerzeichen liegt.

    Mittwoch, 28. März 2018 06:21
  • Dann kann ich nur davon ausgehen, dass die Spalte Nachname u.U. nicht das 1. Sortierkriterium der Pivottabelle ist.
    Wenn die Daten aus einem anderen Tabellenblatt kommen, sortiere dies doch erst mal nach Nachnamen.
    Ich gehe davon aus, dass das funktioniert. Excel hat aber keine verschiedenen Sortierverfahren, so dass die Sortierung u.U. noch vom Aufbau der Pivottabelle beeinflusst wird.
    Mittwoch, 28. März 2018 09:27
  • Ich habe dann mal die Daten in der Ausgabe der View schon richtig sortiert, aber das Problem besteht immer noch.
    Und es ist auch so, das wirklich nur der May aus der Reihe tanzt.
    Donnerstag, 5. April 2018 09:04
  • Schon seltsam, da "May" ja eher ein englischer Monat ist.
    Formatiere die Spalte mal explizit als Text, wer weiß, wie doof Excel manchmal mit Autoformaten umgeht.

    Donnerstag, 5. April 2018 12:11
  • So weit ich weiß, haben wir eine englische Installation mit Deutschen Sprachpaketen. Zumindest war das früher (bis Office 2010) mal so.
    Dienstag, 10. April 2018 12:14
  • Ich habe noch mal ein wenig gespielt und den Namen May verändert, dann wird er in der korrekten Reihenfolge angezeigt. Scheint also doch ein Problem der Sortierung in der Pivot zu sein.

    Montag, 18. Juni 2018 12:28
  • Hallo,

    Einträge wie "Mai", "May", "Dec", "Dez" etc. gehören in Excel zu den Benutzerdefinierten Listen (Datei | Optionen | Erweitert | Allgemein), die man generell beim benutzerdefinierten Sortieren als Kriterium für die Reihenfolge einsetzen kann - statt nach Alphabet, Größe, Datum...

    In der PivotTable wird innerhalb eines Feldes offenbar separat nach Benutzerdefinierten Listen und sonstigen Kriterien sortiert.

    • Deaktiviere für das betreffende Feld die Option "Weitere Sortieroptionen | Weitere Optionen | AutoSortieren | Bei jeder Berichtsaktualisierung automatisch sortieren".
    • Unter "Benutzerdefinierte Sortierreihenfolge" sollte der Eintrag "Keine Berechnung" aktiviert sein.

    Allerdings musst du dann den Sortiervorgang nach Änderungen in der Datenquelle und nach Aktualisieren der PivotTable neu anstoßen.

    Viele Grüße
    Lisa

    Sonntag, 8. Juli 2018 15:49