none
Exchange mit OL 2003 -> OL2010 Migration RRS feed

  • Frage

  • Hi,

    wir haben gestern (recht) erfolgreich die OL 2003 Clienten auf OL 2010 migriert. Als Server dient ein Exchange 2007 SP3 (fullfixed).

    Bei allen 37 Nutzer alles OK, nur bei einem tritt ein Problem auf, das ich nicht klären kann und dessen Ursache ich nicht finde. Es muss ein OL2010 Problem sein, denn per OWA oder auch mit einen alten OL 2003 (Test-PC) ist alles noch OK.

    Der Effekt ist folgender. Im Postfach des betreffenden Nutzers sind zwar alle Ordner zu sehen, doch diese sind z.T. leer. Und obwohl neu eingehende Mails mit fetten Ziffern hinter den Ordnern angezeigt werden, kann man keine E-Mail sehen. Das sind vor allem die selbst angelegten Ordner. In den Systemeigenen Ordnern  wie Posteingans, Ausgang usw. klappt alles. Nun wollte ich mal die Eigenschaften des/der Ordner anzeigen und da fiel auf, das OL 2010 diese Unterordner im Postfach (!) als IMAP Ordner ansieht ?! Ich dachte erst hier ist was in den Postfacheinstellungen fehlerhaft, doch selbst wenn man das Postfach neu einrichten (Profil und ost zuvor gelöscht) passiert das gleiche. Wie gesagt in OL 2003 un OWA ist alles OK. Das Postfach ist ca. 1,3 GB groß und könnte bis 5 GB groß werden.

    Was hat das für eine Ursache? Ein Bug im OL 2010? Jemand eine Idee dazu?

    Danke an alle die helfen können.

     

     

     

     


    Oliver Richter
    Mittwoch, 16. März 2011 21:32

Antworten

  • Hi Christian,

    ich glaube wir haben die Lösung! Total verkackt, aber nun scheint alles OK zu sein. War zwar viel Schrubberei per Hand doch der Enderfolg heiligt die Mittel.

    Wie wir es gemacht haben:

    1. PST Export per OL 2003 - diese PST war ja inhaltlich vollständig und OK

    2. Postfach des Nutzers im Exchange gelöscht

    3. Postfach in Exchange neu angelegt

    4. neues Exchange Postfach in OL 2003 geöffnet und parallel dazu die alte exportierte PST Datei

    5. dann per Hand im neuen Postfach alle Ordner und Unterordner angelegt

    6. dann den Inhalt (und nur den Inhalt) jeden Ordners per Hand von der PST in das neue Postfach kopiert

    7. Parallel dazu auf einem 2. PC mit OL 2010 das Ergebnis kontrolliert.

    8. Das ganze bei 68 Ordnern und zig tausenden E-Mails gemacht

     

    Wichtig zu wissen - und was bei der Kontrolle gleich auffiel- , es funktionierte nicht komplette Ordnerstrukturen (sprich Ornder im Postfach plus mit Subordnern+) in einem Durchgang zu kopieren. Der Effekt dabei war, dass der Stammordner zwar vollständig OK war, der Subordner aber wieder leer. Daher wirklich die Reihenfolge, Inhalt des Stammordners kopieren, dann Unterordner auswählen und dort alle Inhalte (E-Mails) kopieren. Aus diesen Grund hatte unsere vorherige Idee nur Postfach killen und dann exportierte PST frisch einlesen keinen Sinn, weil der Fehler der gleiche geblieben wär.

    Zusammenfassend:

    Es muss irgendwas total verkacktes in den Ordnerrechten oder Eigenschaften oder sonst was an den Ordner gewesen sein. Aber eben so, dass OL 2003, OWA kein Problem damit hatten, OL 2010 hingegen schon.

    P,S, Die Hotfixes brachten keinerlei Lösung.

    Nun denn - Danke für Deine Idee mit dem Ordner kopieren!

     


    Danke und liebe Grüße Oliver Richter
    Freitag, 13. Mai 2011 07:51

Alle Antworten

  • Hi Oliver,

    kannst du es nochmal an einem anderen Rechner testen auf die Mailbox zuzugreifen.

    Erhöh auch mal das Exchange-Diagnostik-Logging, damit man vielleicht ein paar Fehler sieht.

    Im folgenden Thread siehst du ein paar Möglichkeiten, die bei ähnlichen Problemen halfen:

    http://social.technet.microsoft.com/Forums/de-DE/exchange_serverde/thread/ac6675be-0540-4b32-9c77-256527174659

    Es kann natürlich auch an der Mailbox liegen. Kannst du sie in eine andere Speichergruppe verschieben. Auch solltest du mal einen Export der Daten in eine neue Mailbox testen. Ist dort alles iO, deaktivier die Mailbox, erstell eine neue und importier die Outlook OST-Datei...

    Das sollten jetzt mal ein paar Möglichkeiten zum Testen sein...

    Viele Grüße
    Christian

    Donnerstag, 17. März 2011 06:30
    Moderator
  • Hi Christian,

    Danke & OK ich gehe das mal durch. Folgendes ist dazu noch aufgefallen.

    Öffne ich in OL 2010 die Eigenschaften des Postfaches und ermittle die Ordnergröße, so wir ein Wert von ca. 1,2 GB angezeigt.

    Gehe ich über OL 2010 -> Datei -> Postfach aufräumen, dann wird dort eine Postfachgröße von 2,28 GB angezeigt.

    Sehe ich im Exchange nach, dann dann hat das Postfach eine Größe von ca. 1,2 GB.

    Exportiere ich das Postfach in eine PST, dann hat diese PST eine Größe von ca. 1,2 GB, Öffne ich diese, so fehlen ebenfalls die Einträge in den betreffenden Ordnern.

    Der Effekt tritt auch auf einen sauberen Test-PC mit frischer OL 2010 Installation auf.

    Werde heute Abend mal den Loglevel hoch setzen und prüfen, ob ich was sehe.

    Zur noch werde ich halt in OL 2003 das Postfach exportieren, Postfach löschen und dann importieren und hoffe, dass es dann in OL 2010 passt. Evtl. werde ich zuvor die exportierte PST im OL 2010 öffnen um zu sehen, ob diese auch das gewünschte beinhaltet.

    Die anderen Threads sind nicht so recht richtungsweisend.

    Melde mich wieder....

     


    Oliver Richter
    Donnerstag, 17. März 2011 11:02
  • Gewissheit über die Größe bekommst du mit get-mailboxstatistics... melde dich, wenn du mehr weißt...

    Viele Grüße
    Christian 

    Donnerstag, 17. März 2011 11:21
    Moderator
  • Hi Christian,

    den Exchange würde ich nach jetzigem Erkenntnisstand außen vor lassen.

    Habe folgende ausgeführt: das Postfach mit OL 2003 in PST exportiert und in OL 2003 als Datendatei eingefügt und geöffnet. Alles is OK.

    Die Postfachgröße und die Inhalte der Ordner sind 1:1.

    Nehme ich diese PST und binde sie als Datendatei in OL 2010 ein, so wird zwar auch in OL 2010 exakt die Postfachgröße wie in OL 2003 angezeigt, auch die Inhalte sind von der Größe und Anzahl vorhanden, doch im Outlook 2010 ist von den Inhalten nichts zu sehen.

    Daher habe ich mal ein scanpst auf der PST gefahren. Obwohl das scanpst meinte nur 4 Problem gefunden zu haben, wurden seitenweise solche Meldungen geloggt.

    !!AMap page <@17408> has csFree of 4, but should have 6

    bzw.

    !!TC (nid=12E) missing required column (00390040

    oder

    !!Contents Table for 80A2, row doesnt't match sub-object: irow = 36; RowID = 2004A4

    Gesamt ist das Log ca. 300 kB groß. Die PST ist nach der "Reparatur" ca. 10 MB größer als zuvor.

    Die ge-scanpstte PST habe ich dann in OL 2010 angesehen - Stand wie vorher - keine Inhalte von Ordnern oder nur 2-3. In OL 2003 hingegen alles sichtbar OK.

    Bei nochmaligem scanpst - meldete es "Es wurden interene Fehler gefunden, die behoben werden müssen." Eine Änderung an obigen Sachverhalt stellte sich aber nicht ein.

    Hast Du dazu noch eine Idee? Mir sind die Ideen jetzt ausgegangen.

    Freitag, 18. März 2011 14:04
  • Es hat aber nur diese eine User das Problem? Move eimal die Mailbox in einen anderen Speicher und teste dann nochmal. Tritt das Problem oline und/oder cached auf?

    Exportier die Mailbox einmal direkt am Server und teste mit dieser PST: Export-Mailbox
    http://technet.microsoft.com/de-de/library/bb266964(EXCHG.80).aspx

    Viele Grüße
    Christian 

    Mittwoch, 23. März 2011 08:46
    Moderator
  • Hi Christian,

    es hat z.Z. nur dieser eine Nutzer das Problem. Tritt sowohl online wie auch cached auf, aber halt eben nur bei Outlook 2010. Bei OL2003 funktioniert es immer. Dei Box in einen anderen Speicher verschieben bringt keine Lösung - der Effekt bleibt so wie er ist.

    OK den Export am Server werde ich versuchen. Melde mich dann wieder.

     


    Oliver Richter
    Donnerstag, 24. März 2011 10:54
  • Hi Christian,

    Export in PST geht nicht, wieso verstehe ich nicht. Bin direkt an der Exchange PS (Exchange 2007 SP3) und möchte das Postfach von a.nutzer exportieren.

    [PS] C:\Windows\system32>Export-Mailbox -Identity a.nutzer -PSTFolderPath d:\
    temp\anutzer.pst
    Sie arbeiten auf einem 64-Bit-Computer. Zum Exportieren in eine oder Importiere
    n aus einer PST-Datei müssen Sie auf einem 32-Bit-Computer arbeiten, auf dem Ou
    tlook 2003 SP2 oder höher installiert ist.
    Bei Zeile:1 Zeichen:1
    +  <<<< Export-Mailbox -Identity a.nutzer -PSTFolderPath d:\temp\anutzer.pst
        + CategoryInfo          : InvalidOperation: (:) [], RecipientTaskException
        + FullyQualifiedErrorId : C33BAA72

     

    Wieso will Exchange einen 32 Bit Computer für den Export und dann auch noch mit Outlook 2003 SP2 - das verstehe ich nicht.

    Eine Idee dazu? Danke.


    Oliver Richter

    Dienstag, 5. April 2011 08:43
  • Moin,

    Wieso will Exchange einen 32 Bit Computer für den Export und dann auch noch mit Outlook 2003 SP2 - das verstehe ich nicht.

    na, was sollen wir da sagen: Weil es halt so ist.

    Bis Ex2007 geht ein Export/Import über die MAPI-Schnittstelle von Outlook,
    d.h. Du benötigst ein 32-Bit Outlook auf einem 32-Bit Rechner, mit den 32
    Bit Exchange Management Tools installiert.

    Es schadet nicht, die Hilfe zu lesen, die das genau beschreibt:
    http://technet.microsoft.com/en-us/library/bb266964%28EXCHG.80%29.aspx


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Dienstag, 5. April 2011 16:30
  • Hallo Robert,

    OK, schon mehr als putzig. Zum einen EX2007 auf 32 Bit nicht für prod. Einsatz freigegeben, aber für Export wird explizit 32 Bit auf 32 Bit Maschine benötigt. Da hatte wohl die Markting Abteilung die Development Abteilung im ungünstigsten Moment zum Cut für das RTM gezwungen. Anders ist wohl dieses Duddelmuddel nicht zu erklären.

    Also schnapp ich mir einen 32 Bit W7 installier dort Outlook 2003 drauf, dann die EX 2007 W32 MMTs.

    Die Frage bleibt aber, da mein Problem mit OL 2003 zusammen hängt, ob dann ein Export zwar von Konsole aber über OL 2003 zum Erfolg führt.

    Ich melde mich wieder...


    Danke und liebe Grüße Oliver Richter
    Mittwoch, 6. April 2011 06:29
  • Hi,

    heute hatte ich mal etwas Zeit diese Mailbox zu exportieren.

    PS] C:\Windows\system32>Export-Mailbox -Identity a.nutzer -PSTFolderPath d:\temp\anutzer.pst

    Das hat alles 1A geklappt. Die Log meldete auch 0 Fehler. Die erzeugte PST war eigenartiger Weise kleiner als eine direkt mit Outlook exportierte. Mit Outlook (wie oben stehend) ca. 1,2 GB mit dem direkten Export ca. 900 MB. OK die Anzahle der Einträge war wieder 1:1.

    Der Effekt ist und bleibt aber der gleiche. Mache ich die exportierte PST in OL2003 auf ist alles OK, Öffne ich die PST mit OL 2010 sind wieder zahlreiche Ordner einfach "leer".

    Jemand noch eine Idee dazu?

     

    Danke an alle.

     

     

     


    Danke und liebe Grüße Oliver Richter
    Mittwoch, 27. April 2011 16:23
  • Hi Oliver,

    bist hier weiter gekommen? Hast du den User mal an einam anderen Client eingerichtet und getestet?

    Ist Office 2010 auch uptodate?

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;953878

    Viele Grüße

    Christian

    Mittwoch, 11. Mai 2011 05:15
    Moderator
  • Hi Christian,

    die Hotfixes vom 26. April sind noch nicht installiert. Das werden wir machen und nochmals testen.

    Ansonsten konnten wir mit keinen Trick die Sache korrigieren. Egal wie das Postfach exportiert wird (direkt von Exchange oder aus Outlook) mit OL 2003 ist es OK mit OL 2010 fehlen Einträge. Direktes OWA ist auch OK. Für mein Empfinden ein Fall für dne MS Support. Der Kunde ist aber noch am überlegen, ob er das Geld investiert oder nicht. Da es ja um "Daten" und - ja nach Auslegung - nicht direkt um das Programm geht, vermute ich, dass der Support-Call wie das Nürnberger Vogelschießen ausgeht. Nur Kosten und keine Lösung. Was denkst du Call aufmachen Sinnvoll?


    Danke und liebe Grüße Oliver Richter
    Mittwoch, 11. Mai 2011 06:21
  • Hi Oliver,

    kannst du mal einen neuen Ordner erstellen, alles Element über OWA in diesen Ordner kopieren und schauen, ob du unter Outlook 2010 den Inhalt siehst?

    Mit anderen Mailboxen gibt es an diesem Rechner keine Probleme, oder? AV und alles dazwischen ist deaktiviert? Greift noch etwas auf die Mailbox zu (Mobile, BES) und gibt es einen Unterschied zu anderen Mailboxen?

    Ich glaube um einen Call kommst du nicht rum, denn der eigentliche Fehler lässt sich nicht richtig greifen...


    Viele Grüße
    Christian

    Donnerstag, 12. Mai 2011 06:00
    Moderator
  • Hi Christian,

    so wie derzeit Stand ist, gehe ich davon aus, dass dieses "Nicht-Sichtbar-sein" eine Eigenschaft der jeweiligen Mails bzw. Ordner ist. Ähnlich den Dateieigenschaften oder Rechten. Man könnte denken die jeweiligen E-Mails hätten ein Rechte/Attribut der Art: "nur in OL 2003 & OWA/OMA anzeigen". Es wäre aber auch denkbar, dass es eine Art Berechtigung wäre, so als wären die E-Mails quasi aus einem Postfach wo ich in dem betreffenden Ordnern z.B. keine Anzeige/Leserechte hätte. Vergleichbar mit der Freigabe eines Postfaches eines anderen Nutzers, der mir Subfolder in den Rechten gesperrt hat. Wenn dem so wäre, mit welchem Tool könnte man die Rechte dieser einzelnen E-Mails oder Ordner anzeigen und korrigieren? Aber selbst wenn es Berechtigungen wären, warum wirken diese in OL 2003 anders als in OL 2010? Das die Rechte eigentlich stimmig sind, zeigt das OWA -dort ist ja auch alles OK.

    Der Effeket ist definitiv PC unabhängig. Um es eingrenzen zu können, habe ich in eine PST exportiert (mal mit OL 2010, OL 2003 und auch direkt per Exchange). Diese Datei haben wir vom Kundensystem auf drei unabhängigen Systemen getestet, WXP SP3, W7 32 Bit SP1, W7 64 Bit SP1 (auch mal ohne SP1). Die W7 sind HYPER-V Maschinen, WXP war mal HYPER-V mal physikalisch. Die PST wurde sogar zu uns ins "Labor" übertragen und dort ebenfalls nochmals eingebunden ins OL 2010. Immer das gleiche. In OL 2003 sind die Ordner und Mails zu sehen und OL 2010 sind sie nicht nicht da. Ja und auch Verschieben/Kopieren haben wir getestet. In OL 2003 einen neuen Ordner (unter der Postfach Root) erzeugt, die Daten von einem Ordner der in OL 2010 "leer" ist einkopiert und dann die PST an ein OL 2010 ran gehangen (als Standarddatendatei). Effekt, der Ordner ist zwar da, aber er ist leer. In OL 2003 geöffnet - Ordner ist OK.

    OK -mal sehen, ob der Kunde einen Call aufmachen möchte. Danke und schon mal schönes Lena-Weekend *grins*


    Danke und liebe Grüße Oliver Richter
    Donnerstag, 12. Mai 2011 07:00
  • Hi Christian,

    ich glaube wir haben die Lösung! Total verkackt, aber nun scheint alles OK zu sein. War zwar viel Schrubberei per Hand doch der Enderfolg heiligt die Mittel.

    Wie wir es gemacht haben:

    1. PST Export per OL 2003 - diese PST war ja inhaltlich vollständig und OK

    2. Postfach des Nutzers im Exchange gelöscht

    3. Postfach in Exchange neu angelegt

    4. neues Exchange Postfach in OL 2003 geöffnet und parallel dazu die alte exportierte PST Datei

    5. dann per Hand im neuen Postfach alle Ordner und Unterordner angelegt

    6. dann den Inhalt (und nur den Inhalt) jeden Ordners per Hand von der PST in das neue Postfach kopiert

    7. Parallel dazu auf einem 2. PC mit OL 2010 das Ergebnis kontrolliert.

    8. Das ganze bei 68 Ordnern und zig tausenden E-Mails gemacht

     

    Wichtig zu wissen - und was bei der Kontrolle gleich auffiel- , es funktionierte nicht komplette Ordnerstrukturen (sprich Ornder im Postfach plus mit Subordnern+) in einem Durchgang zu kopieren. Der Effekt dabei war, dass der Stammordner zwar vollständig OK war, der Subordner aber wieder leer. Daher wirklich die Reihenfolge, Inhalt des Stammordners kopieren, dann Unterordner auswählen und dort alle Inhalte (E-Mails) kopieren. Aus diesen Grund hatte unsere vorherige Idee nur Postfach killen und dann exportierte PST frisch einlesen keinen Sinn, weil der Fehler der gleiche geblieben wär.

    Zusammenfassend:

    Es muss irgendwas total verkacktes in den Ordnerrechten oder Eigenschaften oder sonst was an den Ordner gewesen sein. Aber eben so, dass OL 2003, OWA kein Problem damit hatten, OL 2010 hingegen schon.

    P,S, Die Hotfixes brachten keinerlei Lösung.

    Nun denn - Danke für Deine Idee mit dem Ordner kopieren!

     


    Danke und liebe Grüße Oliver Richter
    Freitag, 13. Mai 2011 07:51