none
DC kann seine Zeit nicht mehr via NTP syncen RRS feed

  • Frage

  • Hallo zusammen,

    Ich habe ein riesiges Problem und weiß mittlerweile gar nicht mehr wo ich anfangen soll. Mir ist heute aufgefallen, dass mein Client eine vollkommen falsche Uhrzeit hat (aktuell 06:32 anstelle von 14:48 Uhr). Alle Clients syncen ihre Zeit erfolgreich mit dem PDC - und hier ist das Problem. Mein PDC ist eine Win2012 VM. Time Sync mit dem HV ist deaktiviert. 

    Mein PDC ist der Meinung er müsse als SOurce verwenden: "Local CMOS Clock". Ok, bringen wir ihm bei er möge bitte wieder NTP verwenden:

    w32tm.exe /config /manualpeerlist:"0.de.pool.ntp.org 1.de.pool.ntp.org 2.de.pool.ntp.org 3.de.pool.ntp.org" /syncfromflags:manual /reliable:YES /update
    net stop win32time && net start win32time

    Der NTP Client ist der Meinung die Peers nicht kontaktieren zu können. W32Time Debugging aktiviert und ich finde Logeinträge a la 

    153149 03:20:06.4972712s - AddNewPendingPeer: manual
    153149 03:20:06.4972712s - Polling peer 2.de.pool.ntp.org (ntp.m|0x0|0.0.0.0:123->213.172.105.106:123)
    153149 03:20:06.4972712s - PeerPollingThread: PeerListUpdated
    153149 03:20:06.4972712s - Sending packet to 2.de.pool.ntp.org (ntp.m|0x0|0.0.0.0:123->213.172.105.106:123) in Win2K detect mode, stage 1.
    153149 03:20:06.4972712s - PeerPollingThread: waiting 0.109s
    153149 03:20:06.4972712s - No response from peer 2.de.pool.ntp.org (ntp.m|0x0|0.0.0.0:123->213.172.105.106:123).
    153149 03:20:06.4972712s - 5 Age:0 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0096468s Dst:16.0096468s FDsp:08.0000000s
    153149 03:20:06.4972712s - 4 Age:3 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0096460s Dst:16.0096460s FDsp:12.0000000s
    153149 03:20:06.4972712s - 3 Age:2 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0096460s Dst:16.0096460s FDsp:14.0000000s
    153149 03:20:06.4972712s - 2 Age:1 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0096460s Dst:16.0096460s FDsp:15.0000000s
    153149 03:20:06.4972712s - 1 Age:4 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0089056s Dst:16.0089056s FDsp:15.5000000s
    153149 03:20:06.4972712s - 0 Age:5 Ofs:+00.0000000s Dly:+00.0000000s RDly:+00.0000000s Dsp:16.0000000s RDsp:00.0000000s Pnt:00.0044456s Dst:16.0044456s FDsp:15.7500000s
    153149 03:20:06.4972712s - Logging information: NtpClient has not received response from server 2.de.pool.ntp.org (ntp.m|0x0|0.0.0.0:123->213.172.105.106:123).
    153149 03:20:06.4972712s - Logging information: NtpClient: No response has been received from manual peer 2.de.pool.ntp.org (ntp.m|0x0|0.0.0.0:123->213.172.105.106:123) after 8 attempts to contact it. This peer will be discarded as a time source and NtpClient will attempt to discover a new peer from which to synchronize.

    Meine Konfig sieht derzeit so aus:

    C:\Windows\system32>w32tm /query /configuration /verbose
    [Configuration]
    
    EventLogFlags: 2 (Local)
    AnnounceFlags: 5 (Local)
    TimeJumpAuditOffset: 28800 (Local)
    MinPollInterval: 6 (Local)
    MaxPollInterval: 10 (Local)
    MaxNegPhaseCorrection: 172800 (Local)
    MaxPosPhaseCorrection: 172800 (Local)
    MaxAllowedPhaseOffset: 300 (Local)
    
    FrequencyCorrectRate: 4 (Local)
    PollAdjustFactor: 5 (Local)
    LargePhaseOffset: 50000000 (Local)
    SpikeWatchPeriod: 900 (Local)
    LocalClockDispersion: 10 (Local)
    HoldPeriod: 5 (Local)
    PhaseCorrectRate: 7 (Local)
    UpdateInterval: 100 (Local)
    
    FileLogName: c:\EventLogs\W32Time\w32time.log (Local)
    FileLogEntries: 0-116 (Local)
    FileLogSize: 10000000 (Local)
    FileLogFlags: 0 (Undefined or NotUsed)
    
    [TimeProviders]
    
    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    CrossSiteSyncFlags: 0 (Undefined or NotUsed)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Local)
    ResolvePeerBackoffMaxTimes: 7 (Local)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 1 (Local)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Local)
    Type: NTP (Local)
    NtpServer: 0.de.pool.ntp.org 1.de.pool.ntp.org 2.de.pool.ntp.org 3.de.pool.ntp.o
    rg (Local)
    
    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 0 (Local)
    AllowNonstandardModeCombinations: 1 (Local)
    EventLogFlags: 0 (Undefined or NotUsed)
    
    VMICTimeProvider (Local)
    DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)

    An irgendwelche Firewall-Settings kann es eigentlich nicht liegen, habe Sie auch testweise deaktiviert. 

    Die Abfrage von verschiedenen Zeitservern zeigen alle einen epischen Offset, bspw.

    C:\Windows\system32>w32tm /stripchart /computer:de.pool.ntp.org /dataonly
    Tracking de.pool.ntp.org [144.76.0.164:123].
    The current time is 23.04.2020 05:45:36.
    05:45:36, +32723.4797195s
    05:45:38, +32723.4729284s
    ...

    Das führt natürlich dazu, dass sich jetzt Probleme in meiner Windowsumgebung häufen.

    Ich hoffe irgendjemand von euch hat eine Idee wodran das liegen könnte..

    VG

    Donnerstag, 23. April 2020 12:53

Antworten

Alle Antworten

  • Ggf. hat ja nur einer an deiner Zeitzone im Server gedreht!

    Meine Abfrage zeigt korrekt die aktuelle Winterzeit meiner Zone an.
    Die Zeitserver liefern allerdings grundsätzlich nur UTC-Zeit (also GMT+00:00) da jeder für seine Zeitzone selber verantwortlich ist.

    Die obigen Anzeige wird in Localtime umgerechnet.

    Es ist 23.04.2020 14:58:24.
    14:58:24, +01.0060720s
    14:58:26, +01.0053078s

    Dein Wert " +32723.47" ist da vollkommen schräg.

    Donnerstag, 23. April 2020 13:03
  • Hatte ich auch gehofft, scheint aber zu passen:

    C:\Windows\system32>w32tm /tz
    Time zone: Current:TIME_ZONE_ID_DAYLIGHT Bias: -60min (UTC=LocalTime+Bias)
      [Standard Name:"W. Europe Standard Time" Bias:0min Date:(M:10 D:5 DoW:0)]
      [Daylight Name:"W. Europe Daylight Time" Bias:-60min Date:(M:3 D:5 DoW:0)]

    Donnerstag, 23. April 2020 13:13
  • Hatte das Problem auch mal im EN Technet gepostet und dort haben wir dann die Lösung gefunden:

    Mein Post im EN Technet

    Danke trotzdem an alle und ich wünsch ein schönes Wochenende!

    • Als Antwort markiert St_Marcel Freitag, 24. April 2020 12:38
    Freitag, 24. April 2020 12:38
  • Dein Link ist leider nicht zu verfolgen.
    Freitag, 24. April 2020 18:55
  • Nun ja, wenn ich beim Aufruf des Links einen Runtime-Error bekomme stellt sich mir halt die Frage.
    Da nützt Kreativität auch nichts;-).

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    Samstag, 25. April 2020 08:56