none
Sharepoint Server klonen RRS feed

  • Frage

  • Hallo,

    bin noch neu im Thema Sharepoint. Hab jetzt hier ein Problem, und zwar soll ich unseren bestehenden Sharepoint 2010 Foundation Server klonen, damit wir ein gleiches Entwicklungs- und Testsystem haben. Das Testsystem habe ich schon soweit aufgesetzt (Sharepoint 2010 Foundation, Search Server und SQL Server). Nur wie bekomme ich die ganzen Seiten vom bisherigen System auf das Testsystem?

    Vielen Dank schon mal

    Gruß Bastian

    Mittwoch, 12. Oktober 2011 11:56

Antworten

  • Hab die Lösung gefunden. Man muss die Datanbanken upgraden.

    Unter Zentraladministration -> Upgrade und Migration -> Datenbankupgradestatus verwalten

    Bei Status sollte stehen:Es ist keine Aktion erforderlich

    Bei mir war die aktuelle Schemaversion der Inhaltsdatenbank niedriger als die maximale Version.

    Über Upgrade-SPContentDatabase hab ich die Datenbank auf die maximale Version gebracht, danach hat alles ohne Probleme funktioniert

    Ich wunder mich nur, dass man kaum was zu dem Fehler findet.

    Vielen Dank für eure Hilfe

    Gruß Bastian

     

    Dienstag, 18. Oktober 2011 07:02

Alle Antworten

  • Hi Bastian,

    vielleicht hilft dir dieser Thread ein bisschen weiter - http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/f8571241-ee98-4904-abbf-e204f204657c/


    Best Regards. Please Mark Answered, If my solution solves your problem.
    Mittwoch, 12. Oktober 2011 12:13
  • Hi,

    wenn ich das richtig verstehe, mus sich dazu quasi die Seite offline nehmen. Gibt es da keine Möglichkeit, das am laufenden System zu bewerkstelligen?

    Oder versteh ich da was falsch?

    Gruß Bastian

    Mittwoch, 12. Oktober 2011 13:45
  • Ich würde einen SharePoint nicht unbedingt klonen - also auf
    Image-Ebene, aber ich glaube das meinst du auch nicht.
     
    Was das übertragen der Inhalte von einem System auf ein anderes geht, so
    kannst du das am besten mit einem Backup/Recovery machen. Also auf dem
    bisherigen System ein Backup der Site-Collection oder der Content-DB
    machen, und dieses dann auf dem Testsystem wiederherstellen.
     
    Das ganze kannst du auf verschiedenen Wegen machen:
    Zentraladministration, STSADM oder PowerShell. Am einfachsten ist ggf.
    die Zentraladministration.
     
    Wichtig bei der Angabe des Backup-Pfades: hier solltest du einen
    UNC-Pfad angeben, auf den sowohl der SharePoint als auch der SQL-Server
    zugreifen können (ich unterstelle, dass die auf unterschiedlichen
    Servern laufen). Das bedeutet, dass der SQL-Server als nicht mit
    Local-System laufen darf.
     
    Auf deinem Testsystem kannst du dann das UNC-Verzeichnis für die
    Wiederherstellung angeben, und dort genau auswählen was
    wiederhergestellt werden soll.
     
    Das Ganze funktioniert auf jeden Fall auch "online".
     
    Ansonsten solltest du unter
    Informationen finden können.
     
    --
     
    Henning Eiben
     
    busitec GmbH
    Consultant
     
     
    Rudolf-Diesel-Straße 59
    48157 Münster
    www.busitec.de
      
    Sitz der Gesellschaft: Münster
    HR B 55 75 - Amtsgericht Münster
    USt-IdNr. DE 204607833 - St.Nr. 336/5704/1277
    Geschäftsführer: Henning Eiben, Martin Saalmann, Simon Schwingel
     
     
    Donnerstag, 13. Oktober 2011 06:48
  • Hallo,

    mit einer Sicherung und einer Wiederherstellung über die Verwaltungsshell habe ich es auch schon versucht, bekomme da aber nur Fehlermeldungen. Endweder stimmt  die Version nicht überein, obwohl auf beiden Servern die gleiche Version installiert ist oder die Fehlermeldung besagt, dass die Seite die ich wiederherstellen will keine Top-Level Seite ist.

    Wenn ich die Sicherung von der Websitesammlung wiederherstelle und keine Fehlermeldung bekomme, laufen dann beide Systeme parallel, ohne Auswirkungen aufeinander zu haben?

    Gruß Bastian

    //edit

    Über die Backup und Wiederherstellen Funktion ist dann das Testsystem unter einer anderen Adresse erreichbar?


    • Bearbeitet maeck_bb Freitag, 14. Oktober 2011 07:50
    Freitag, 14. Oktober 2011 07:12
  • Die Adresse des Portals ist ja nicht von der Site-Collection, sondern von der Web-Application abhängig. Wenn du also nur die Site-Collection oder nur ein einzelnes Web wiederhergestellt hast, dann sind die Inhalte unter der Adresse der Web-Application/Site-Collection erreichbar, wo du die Inhalte eingespielt hast. Was ggf. passieren kann, ist dass Links auf das Live-System zeigen, wenn die irgendwo fest eingetragen sind.

    Was für einen Fehler hast du denn erhalten?

    Freitag, 14. Oktober 2011 08:29
  • Fehlermeldung:

    Restore-SPSite: Die Sicherung stammt aus einer anderen Version von Microsoft SharePoint Foundation und kann auf einem Server mit der aktuellen Verison nciht wiederhergestellt werden. Die Sicherungsdatei sollte auf einem Server mit Version 4.0.145.0 oder höher wiederhergestellt werden.

    Auf beiden Servern ist Sharepoint 2010 Foundation mit SP1 installiert

    //edit

    bzw. auch Version 14.0.0.5123

    • Bearbeitet maeck_bb Freitag, 14. Oktober 2011 11:24
    Freitag, 14. Oktober 2011 09:13
  • Das ist in der Tat merkwürdig.
     
    --
     
    Henning Eiben
     
    busitec GmbH
    Consultant
     
     
    Rudolf-Diesel-Straße 59
    48157 Münster
    www.busitec.de
      
    Sitz der Gesellschaft: Münster
    HR B 55 75 - Amtsgericht Münster
    USt-IdNr. DE 204607833 - St.Nr. 336/5704/1277
    Geschäftsführer: Henning Eiben, Martin Saalmann, Simon Schwingel
     
     
    Freitag, 14. Oktober 2011 17:09
  • Hab die Lösung gefunden. Man muss die Datanbanken upgraden.

    Unter Zentraladministration -> Upgrade und Migration -> Datenbankupgradestatus verwalten

    Bei Status sollte stehen:Es ist keine Aktion erforderlich

    Bei mir war die aktuelle Schemaversion der Inhaltsdatenbank niedriger als die maximale Version.

    Über Upgrade-SPContentDatabase hab ich die Datenbank auf die maximale Version gebracht, danach hat alles ohne Probleme funktioniert

    Ich wunder mich nur, dass man kaum was zu dem Fehler findet.

    Vielen Dank für eure Hilfe

    Gruß Bastian

     

    Dienstag, 18. Oktober 2011 07:02
  • Hallo Bastian

     

    Danke dass du hier die Lösung gepostet hast. :)

     

    Grüße,

    Alex

    Dienstag, 18. Oktober 2011 07:43
    Moderator
  • Dann kann aber die SharePoint-Version auf den beiden Systemen nicht
    identisch sein. Aber gut, dass es nun funktioniert.
     
    --
     
    Henning Eiben
     
    busitec GmbH
    Consultant
     
     
    Rudolf-Diesel-Straße 59
    48157 Münster
    www.busitec.de
      
    Sitz der Gesellschaft: Münster
    HR B 55 75 - Amtsgericht Münster
    USt-IdNr. DE 204607833 - St.Nr. 336/5704/1277
    Geschäftsführer: Henning Eiben, Martin Saalmann, Simon Schwingel
     
     
    Montag, 24. Oktober 2011 07:29